1 # Compound Storage DLL.
2 # (FIXME: some methods are commented out. Commenting them in _WILL_
3 # result in dataloss. Do it at your own risk.)
7 1 pascal StgCreateDocFileA
(str long long ptr
) StgCreateDocFile16
8 2 stub StgCreateDocFileOnILockBytes
9 3 pascal StgOpenStorage
(str ptr long ptr long ptr
) StgOpenStorage16
10 4 stub StgOpenStorageOnILockBytes
11 5 pascal StgIsStorageFile
(str
) StgIsStorageFile16
12 6 stub StgIsStorageILockBytes
16 103 stub DllGetClassObject
18 # Storage Interface functions. Starting at 500
19 # these are not exported in the real storage.dll, we use them
20 # as 16->32 relays. They use the cdecl calling convention.
23 500 cdecl IStorage16_QueryInterface
(ptr ptr ptr
) IStorage16_QueryInterface
24 501 cdecl IStorage16_AddRef
(ptr
) IStorage16_AddRef
25 502 cdecl IStorage16_Release
(ptr
) IStorage16_Release
26 #503 cdecl IStorage16_CreateStream(ptr str long long long ptr) IStorage16_CreateStream
27 503 stub IStorage16_CreateStream
29 504 cdecl IStorage16_OpenStream
(ptr str ptr long long ptr
) IStorage16_OpenStream
30 #505 cdecl IStorage16_CreateStorage(ptr str long long long ptr) IStorage16_CreateStorage
31 505 stub IStorage16_CreateStorage
32 506 cdecl IStorage16_OpenStorage
(ptr str ptr long ptr long ptr
) IStorage16_OpenStorage
33 507 cdecl IStorage16_CopyTo
(ptr long ptr ptr ptr
) IStorage16_CopyTo
34 508 stub IStorage16_MoveElementTo
35 509 cdecl IStorage16_Commit
(ptr long
) IStorage16_Commit
36 510 stub IStorage16_Revert
37 511 stub IStorage16_EnumElements
38 512 stub IStorage16_DestroyElement
39 513 stub IStorage16_RenameElement
40 514 stub IStorage16_SetElementTimes
41 515 stub IStorage16_SetClass
42 516 stub IStorage16_SetStateBits
43 517 cdecl IStorage16_Stat
(ptr ptr long
) IStorage16_Stat
46 518 cdecl IStream16_QueryInterface
(ptr ptr ptr
) IStream16_QueryInterface
47 519 cdecl IStream16_AddRef
(ptr
) IStream16_AddRef
48 520 cdecl IStream16_Release
(ptr
) IStream16_Release
49 521 cdecl IStream16_Read
(ptr ptr long ptr
) IStream16_Read
50 #522 cdecl IStream16_Write(ptr ptr long ptr) IStream16_Write
51 522 stub IStream16_Write
52 523 cdecl IStream16_Seek
(ptr long long long ptr
) IStream16_Seek
53 524 stub IStream16_SetSize
54 525 stub IStream16_CopyTo
55 526 stub IStream16_Commit
56 527 stub IStream16_Revert
57 528 stub IStream16_LockRegion
58 529 stub IStream16_UnlockRegion
59 530 stub IStream16_Stat
60 531 stub IStream16_Clone