explorer: Implement ABM_ADD and ABM_REMOVE.
[wine/multimedia.git] / dlls / iphlpapi / iphlpapi.spec
blob24c4e94f2147edb96b1b543906b9ab6b56f285c1
1 @ stdcall AddIPAddress( long long long ptr ptr )
2 @ stub AllocateAndGetArpEntTableFromStack
3 @ stdcall AllocateAndGetIfTableFromStack( ptr long long long )
4 @ stdcall AllocateAndGetIpAddrTableFromStack( ptr long long long )
5 @ stdcall AllocateAndGetIpForwardTableFromStack( ptr long long long )
6 @ stdcall AllocateAndGetIpNetTableFromStack( ptr long long long )
7 @ stdcall AllocateAndGetTcpTableFromStack( ptr long long long )
8 @ stdcall AllocateAndGetUdpTableFromStack( ptr long long long )
9 @ stdcall CreateIpForwardEntry( ptr )
10 @ stdcall CreateIpNetEntry( ptr )
11 @ stdcall CreateProxyArpEntry( long long long )
12 @ stdcall DeleteIPAddress( long )
13 @ stdcall DeleteIpForwardEntry( ptr )
14 @ stdcall DeleteIpNetEntry( ptr )
15 @ stdcall DeleteProxyArpEntry( long long long )
16 @ stdcall EnableRouter( ptr ptr )
17 @ stdcall FlushIpNetTable( long )
18 @ stub FlushIpNetTableFromStack
19 @ stdcall GetAdapterIndex( wstr ptr )
20 @ stub GetAdapterOrderMap
21 @ stdcall GetAdaptersInfo( ptr ptr )
22 @ stdcall GetBestInterface( long ptr )
23 @ stdcall GetBestInterfaceEx( ptr ptr )
24 @ stub GetBestInterfaceFromStack
25 @ stdcall GetBestRoute( long long long )
26 @ stub GetBestRouteFromStack
27 @ stdcall GetFriendlyIfIndex( long )
28 @ stdcall GetIcmpStatistics( ptr )
29 @ stub GetIcmpStatsFromStack
30 @ stdcall GetIfEntry( ptr )
31 @ stub GetIfEntryFromStack
32 @ stdcall GetIfTable( ptr ptr long )
33 @ stub GetIfTableFromStack
34 @ stub GetIgmpList
35 @ stdcall GetInterfaceInfo( ptr ptr )
36 @ stdcall GetIpAddrTable( ptr ptr long )
37 @ stub GetIpAddrTableFromStack
38 @ stdcall GetIpForwardTable( ptr ptr long )
39 @ stub GetIpForwardTableFromStack
40 @ stdcall GetIpNetTable( ptr ptr long )
41 @ stub GetIpNetTableFromStack
42 @ stdcall GetIpStatistics( ptr )
43 @ stub GetIpStatsFromStack
44 @ stdcall GetNetworkParams( ptr ptr )
45 @ stdcall GetNumberOfInterfaces( ptr )
46 @ stdcall GetPerAdapterInfo( long ptr ptr )
47 @ stdcall GetRTTAndHopCount( long ptr long ptr )
48 @ stdcall GetTcpStatistics( ptr )
49 @ stub GetTcpStatsFromStack
50 @ stdcall GetTcpTable( ptr ptr long )
51 @ stub GetTcpTableFromStack
52 @ stdcall GetUdpStatistics( ptr )
53 @ stub GetUdpStatsFromStack
54 @ stdcall GetUdpTable( ptr ptr long )
55 @ stub GetUdpTableFromStack
56 @ stdcall GetUniDirectionalAdapterInfo( ptr ptr )
57 @ stdcall IcmpCloseHandle(ptr)
58 @ stdcall IcmpCreateFile()
59 @ stub IcmpParseReplies
60 @ stdcall IcmpSendEcho2(ptr ptr ptr ptr long ptr long ptr ptr long long)
61 @ stdcall IcmpSendEcho(ptr long ptr long ptr ptr long long)
62 @ stub InternalCreateIpForwardEntry
63 @ stub InternalCreateIpNetEntry
64 @ stub InternalDeleteIpForwardEntry
65 @ stub InternalDeleteIpNetEntry
66 @ stub InternalGetIfTable
67 @ stub InternalGetIpAddrTable
68 @ stub InternalGetIpForwardTable
69 @ stub InternalGetIpNetTable
70 @ stub InternalGetTcpTable
71 @ stub InternalGetUdpTable
72 @ stub InternalSetIfEntry
73 @ stub InternalSetIpForwardEntry
74 @ stub InternalSetIpNetEntry
75 @ stub InternalSetIpStats
76 @ stub InternalSetTcpEntry
77 @ stdcall IpReleaseAddress( ptr )
78 @ stdcall IpRenewAddress( ptr )
79 @ stub IsLocalAddress
80 @ stub NTPTimeToNTFileTime
81 @ stub NTTimeToNTPTime
82 @ stub NhGetGuidFromInterfaceName
83 @ stub NhGetInterfaceNameFromGuid
84 @ stub NhpAllocateAndGetInterfaceInfoFromStack
85 @ stub NhpGetInterfaceIndexFromStack
86 @ stdcall NotifyAddrChange( ptr ptr )
87 @ stdcall NotifyRouteChange( ptr ptr )
88 @ stub NotifyRouteChangeEx
89 @ stub _PfAddFiltersToInterface@24
90 @ stub _PfAddGlobalFilterToInterface@8
91 @ stub _PfBindInterfaceToIPAddress@12
92 @ stub _PfBindInterfaceToIndex@16
93 @ stub _PfCreateInterface@24
94 @ stub _PfDeleteInterface@4
95 @ stub _PfDeleteLog@0
96 @ stub _PfGetInterfaceStatistics@16
97 @ stub _PfMakeLog@4
98 @ stub _PfRebindFilters@8
99 @ stub _PfRemoveFilterHandles@12
100 @ stub _PfRemoveFiltersFromInterface@20
101 @ stub _PfRemoveGlobalFilterFromInterface@8
102 @ stub _PfSetLogBuffer@28
103 @ stub _PfTestPacket@20
104 @ stub _PfUnBindInterface@4
105 @ stdcall SendARP( long long ptr ptr )
106 @ stub SetAdapterIpAddress
107 @ stub SetBlockRoutes
108 @ stdcall SetIfEntry( ptr )
109 @ stub SetIfEntryToStack
110 @ stdcall SetIpForwardEntry( ptr )
111 @ stub SetIpForwardEntryToStack
112 @ stub SetIpMultihopRouteEntryToStack
113 @ stdcall SetIpNetEntry( ptr )
114 @ stub SetIpNetEntryToStack
115 @ stub SetIpRouteEntryToStack
116 @ stdcall SetIpStatistics( ptr )
117 @ stub SetIpStatsToStack
118 @ stdcall SetIpTTL( long )
119 @ stub SetProxyArpEntryToStack
120 @ stub SetRouteWithRef
121 @ stdcall SetTcpEntry( ptr )
122 @ stub SetTcpEntryToStack
123 @ stdcall UnenableRouter( ptr ptr )