Use server file mapping objects.
[wine/multimedia.git] / relay32 / shell32.spec
blobf3dc7f1e245dcac6e669a501f0b0f29454a59f48
1 name shell32
2 type win32
3 init Shell32LibMain
5 # Functions exported by the Win95 shell32.dll
6 # (these need to have these exact ordinals, for some
7 # win95 and winNT dlls import shell32.dll by ordinal)
8 # This list was updated to dll version 4.72
10 2 stdcall SHChangeNotifyRegister(long long long long long long) SHChangeNotifyRegister
11 3 stub CheckEscapesA@8
12 4 stdcall SHChangeNotifyDeregister (long) SHChangeNotifyDeregister
13 5 stub SHChangeNotifyUpdateEntryList@16
14 6 stub CheckEscapesW@8
15 7 stdcall CommandLineToArgvW(wstr ptr) CommandLineToArgvW
16 8 stdcall Control_FillCache_RunDLL (long long long long) Control_FillCache_RunDLL
17 9 stub PifMgr_OpenProperties@16
18 10 stub PifMgr_GetProperties@20
19 11 stub PifMgr_SetProperties@20
20 12 stub Control_FillCache_RunDLLA@16
21 13 stub PifMgr_CloseProperties@8
22 14 stub Control_FillCache_RunDLLW@16
23 15 stdcall ILGetDisplayName(ptr ptr) ILGetDisplayName
24 16 stdcall ILFindLastID(ptr) ILFindLastID
25 17 stdcall ILRemoveLastID(ptr) ILRemoveLastID
26 18 stdcall ILClone(ptr) ILClone
27 19 stdcall ILCloneFirst (ptr) ILCloneFirst
28 20 stdcall ILGlobalClone (ptr) ILGlobalClone
29 21 stdcall ILIsEqual (ptr ptr) ILIsEqual
30 22 stdcall Control_RunDLL(long long long long) Control_RunDLL # exported by name
31 23 stdcall ILIsParent (long long long) ILIsParent
32 24 stdcall ILFindChild (long long) ILFindChild
33 25 stdcall ILCombine(ptr ptr) ILCombine
34 26 stub ILLoadFromStream@8
35 27 stub ILSaveToStream@8
36 28 stub SHILCreateFromPath@12
37 29 stdcall PathIsRoot(ptr) PathIsRoot32AW
38 30 stdcall PathBuildRoot(ptr long) PathBuildRoot
39 31 stdcall PathFindExtension(ptr) PathFindExtension32AW
40 32 stdcall PathAddBackslash(ptr) PathAddBackslash32AW
41 33 stdcall PathRemoveBlanks(str) PathRemoveBlanks32AW
42 34 stdcall PathFindFilename(ptr) PathFindFilename32AW
43 35 stdcall PathRemoveFileSpec(str) PathRemoveFileSpec
44 36 stdcall PathAppend(str str) PathAppend
45 37 stdcall PathCombine(ptr ptr ptr) PathCombine32AW
46 38 stub PathStripPath
47 39 stdcall PathIsUNC (ptr) PathIsUNC32AW
48 40 stdcall PathIsRelative (ptr) PathIsRelative32AW
49 41 stub Control_RunDLLA@16
50 42 stub Control_RunDLLW@16
51 43 stdcall PathIsExe (ptr) PathIsExe
52 44 stub DoEnvironmentSubstA@8
53 45 stdcall PathFileExists(str) PathFileExists
54 46 stdcall PathMatchSpec (str str) PathMatchSpec32AW
55 47 stub PathMakeUniqueName@20
56 48 stdcall PathSetDlgItemPath (long long ptr) PathSetDlgItemPath32AW
57 49 stub PathQualify@4
58 50 stub PathStripToRoot@4
59 51 stdcall PathResolve(str long long) PathResolve
60 52 stdcall PathGetArgs(str) PathGetArgs
61 53 stub DoEnvironmentSubstW@8
62 54 stdcall DragAcceptFiles(long long) DragAcceptFiles32
63 55 stdcall PathQuoteSpaces (ptr) PathQuoteSpaces32AW
64 56 stdcall PathUnquoteSpaces(str) PathUnquoteSpaces
65 57 stdcall PathGetDriveNumber (str) PathGetDriveNumber32
66 58 stdcall ParseField(str long ptr long) ParseField32A
67 59 stub RestartDialog@12
68 60 stdcall ExitWindowsDialog(long) ExitWindowsDialog
69 61 stdcall RunFileDlg(long long long str str long) RunFileDlg
70 62 stdcall PickIconDlg(long long long long) PickIconDlg
71 63 stdcall GetFileNameFromBrowse(long long long long str str str) GetFileNameFromBrowse
72 64 stdcall DriveType (long) DriveType32
73 65 stub InvalidateDriveType
74 66 stub IsNetDrive
75 67 stdcall Shell_MergeMenus (long long long long long long) Shell_MergeMenus32
76 68 stdcall SHGetSettings(long long long) SHGetSettings
77 69 stub SHGetNetResource
78 70 stub SHCreateDefClassObject
79 71 stdcall Shell_GetImageList(ptr ptr) Shell_GetImageList
80 72 stdcall Shell_GetCachedImageIndex(ptr ptr long) Shell_GetCachedImageIndex
81 73 stub SHShellFolderView_Message
82 74 stub SHCreateStdEnumFmtEtc
83 75 stdcall PathYetAnotherMakeUniqueName(ptr ptr) PathYetAnotherMakeUniqueName
84 76 stub DragQueryInfo
85 77 stdcall SHMapPIDLToSystemImageListIndex(long long long) SHMapPIDLToSystemImageListIndex
86 78 stdcall OleStrToStrN(str long wstr long) OleStrToStrN
87 79 stdcall StrToOleStrN(wstr long str long) StrToOleStrN
88 80 stdcall DragFinish(long) DragFinish32
89 81 stdcall DragQueryFile(long long ptr long) DragQueryFile32A
90 82 stdcall DragQueryFileA(long long ptr long) DragQueryFile32A
91 83 stub CIDLData_CreateFromIDArray
92 84 stub SHIsBadInterfacePtr
93 85 stdcall OpenRegStream(long long long long) OpenRegStream
94 86 stdcall SHRegisterDragDrop(long ptr) SHRegisterDragDrop
95 87 stdcall SHRevokeDragDrop(long) SHRevokeDragDrop
96 88 stub SHDoDragDrop
97 89 stdcall SHCloneSpecialIDList(long long long) SHCloneSpecialIDList
98 90 stub SHFindFiles
99 91 stub SHFindComputer
100 92 stub PathGetShortPath
101 93 stub Win32CreateDirectory
102 94 stub Win32RemoveDirectory
103 95 stdcall SHLogILFromFSIL (ptr) SHLogILFromFSIL
104 96 stdcall StrRetToStrN (long long long long) StrRetToStrN
105 97 stdcall SHWaitForFileToOpen (long long long) SHWaitForFileToOpen
106 98 stdcall SHGetRealIDL (long long long) SHGetRealIDL
107 99 stdcall SetAppStartingCursor (long long) SetAppStartingCursor32
108 100 stdcall SHRestricted(long) SHRestricted
109 101 stub DragQueryFileAorW # exported by name
110 102 stdcall SHCoCreateInstance(ptr ptr long ptr ptr) SHCoCreateInstance
111 103 stdcall SignalFileOpen(long) SignalFileOpen
112 104 stub FileMenu_DeleteAllItems
113 105 stub FileMenu_DrawItem
114 106 stub FileMenu_FindSubMenuByPidl
115 107 stub FileMenu_GetLastSelectedItemPidls
116 108 stub FileMenu_HandleMenuChar
117 109 stdcall FileMenu_InitMenuPopup (long) FileMenu_InitMenuPopup
118 110 stub FileMenu_InsertUsingPidl
119 111 stub FileMenu_Invalidate
120 112 stub FileMenu_MeasureItem
121 113 stub FileMenu_ReplaceUsingPidl
122 114 stdcall FileMenu_Create (long long long long long) FileMenu_Create
123 115 stub FileMenu_AppendItem
124 116 stdcall FileMenu_TrackPopupMenuEx (long long long long long long) FileMenu_TrackPopupMenuEx
125 117 stub FileMenu_DeleteItemByCmd
126 118 stdcall FileMenu_Destroy (long) FileMenu_Destroy
127 119 stdcall IsLFNDrive(str) IsLFNDrive
128 120 stub FileMenu_AbortInitMenu
129 121 stdcall SHFlushClipboard () SHFlushClipboard
130 122 stub RunDLL_CallEntry16
131 123 stdcall SHFreeUnusedLibraries () SHFreeUnusedLibraries
132 124 stub FileMenu_AppendFilesForPidl
133 125 stub FileMenu_AddFilesForPidl
134 126 stdcall SHOutOfMemoryMessageBox (long long long) SHOutOfMemoryMessageBox
135 127 stdcall SHWinHelp (long long long long) SHWinHelp
136 128 stdcall DllGetClassObject(long long ptr) SHELL32_DllGetClassObject
137 129 stub DAD_AutoScroll
138 130 stub DAD_DragEnter
139 131 stub DAD_DragEnterEx
140 132 stub DAD_DragLeave
141 133 stdcall DragQueryFileW(long long ptr long) DragQueryFile32W
142 134 stub DAD_DragMove
143 135 stdcall DragQueryPoint(long ptr) DragQueryPoint32
144 136 stub DAD_SetDragImage
145 137 stdcall DAD_ShowDragImage (long) DAD_ShowDragImage
146 138 stub DuplicateIcon # exported by name
147 139 stub Desktop_UpdateBriefcaseOnEvent
148 140 stub FileMenu_DeleteItemByIndex
149 141 stub FileMenu_DeleteItemByFirstID
150 142 stub FileMenu_DeleteSeparator
151 143 stub FileMenu_EnableItemByCmd
152 144 stub FileMenu_GetItemExtent
153 145 stdcall PathFindOnPath (ptr ptr) PathFindOnPath32AW
154 146 stub RLBuildListOfPaths
155 147 stdcall SHCLSIDFromString(long long) SHCLSIDFromString
156 148 stdcall ExtractAssociatedIconA(long ptr long) ExtractAssociatedIcon32A # exported by name
157 149 stdcall SHFind_InitMenuPopup(long long long long) SHFind_InitMenuPopup
158 150 stub ExtractAssociatedIconExA # exported by name
159 151 stdcall SHLoadOLE (long) SHLoadOLE32
160 152 stdcall ILGetSize(ptr) ILGetSize
161 153 stdcall ILGetNext(ptr) ILGetNext
162 154 stdcall ILAppend (long long long) ILAppend
163 155 stdcall ILFree (ptr) ILFree
164 156 stdcall ILGlobalFree (ptr) ILGlobalFree
165 157 stdcall ILCreateFromPath (ptr) ILCreateFromPath
166 158 stdcall PathGetExtension(str long long) PathGetExtension32AW
167 159 stub PathIsDirectory
168 160 stub SHNetConnectionDialog
169 161 stdcall SHRunControlPanel (long long) SHRunControlPanel
170 162 stdcall SHSimpleIDListFromPath (ptr) SHSimpleIDListFromPath32AW
171 163 stub StrToOleStr
172 164 stub Win32DeleteFile
173 165 stdcall SHCreateDirectory(long long) SHCreateDirectory
174 166 stub CallCPLEntry16
175 167 stub SHAddFromPropSheetExtArray
176 168 stub SHCreatePropSheetExtArray
177 169 stub SHDestroyPropSheetExtArray
178 170 stub SHReplaceFromPropSheetExtArray
179 171 stub PathCleanupSpec
180 172 stub SHCreateLinks
181 173 stub SHValidateUNC
182 174 stdcall SHCreateShellFolderViewEx (ptr ptr) SHCreateShellFolderViewEx32
183 175 stdcall SHGetSpecialFolderPath(long long long long) SHGetSpecialFolderPath
184 176 stdcall SHSetInstanceExplorer (long) SHSetInstanceExplorer
185 177 stub DAD_SetDragImageFromListView
186 178 stub SHObjectProperties
187 179 stub SHGetNewLinkInfoA
188 180 stub SHGetNewLinkInfoW
189 181 stdcall RegisterShellHook(long long) RegisterShellHook32
190 182 stub ShellMessageBoxW
191 183 cdecl ShellMessageBoxA(long long long str long long) ShellMessageBoxA
192 184 stdcall ArrangeWindows(long long long long long) ArrangeWindows
193 185 stub SHHandleDiskFull
194 186 stub ExtractAssociatedIconExW # exported by name
195 187 stub ExtractAssociatedIconW # exported by name
196 188 stdcall ExtractIconA(long str long) ExtractIcon32A # exported by name
197 189 stdcall ExtractIconEx(ptr long ptr ptr long) ExtractIconEx32AW
198 190 stdcall ExtractIconExA(str long ptr ptr long) ExtractIconEx32A
199 191 stdcall ExtractIconExW(wstr long ptr ptr long) ExtractIconEx32W
200 192 stub ExtractIconResInfoA # exported by name
201 193 stub ExtractIconResInfoW # exported by name
202 194 stdcall ExtractIconW(long wstr long) ExtractIcon32W # exported by name
203 195 stdcall SHFree(ptr) SHFree
204 196 stdcall SHAlloc(long) SHAlloc
205 197 stub SHGlobalDefect
206 198 stdcall SHAbortInvokeCommand () SHAbortInvokeCommand
207 199 stub SHGetFileIcon
208 200 stub SHLocalAlloc
209 201 stub SHLocalFree
210 202 stub SHLocalReAlloc
211 203 stub AddCommasW
212 204 stub ShortSizeFormatW
213 205 stub Printer_LoadIconsW
214 206 stub Link_AddExtraDataSection
215 207 stub Link_ReadExtraDataSection
216 208 stub Link_RemoveExtraDataSection
217 209 stub Int64ToString
218 210 stub LargeIntegerToString
219 211 stub Printers_GetPidl
220 212 stub Printer_AddPrinterPropPages
221 213 stub Printers_RegisterWindowW
222 214 stub Printers_UnregisterWindow
223 215 stub SHStartNetConnectionDialog@12
224 216 stub ExtractVersionResource16W # exported by name
225 217 stub FindExeDlgProc # exported by name
226 218 stdcall FindExecutableA(ptr ptr ptr) FindExecutable32A # exported by name
227 219 stdcall FindExecutableW(wstr wstr wstr) FindExecutable32W # exported by name
228 220 stdcall FreeIconList(long) FreeIconList # exported by name
229 221 stub InternalExtractIconListA # exported by name
230 222 stub InternalExtractIconListW # exported by name
231 223 stub OpenAs_RunDLL # exported by name
232 224 stub OpenAs_RunDLLA # exported by name
233 225 stub OpenAs_RunDLLW # exported by name
234 226 stub PrintersGetCommand_RunDLL # exported by name
235 227 stub PrintersGetCommand_RunDLLA # exported by name
236 228 stub PrintersGetCommand_RunDLLW # exported by name
237 229 stub RealShellExecuteA # exported by name
238 230 stub RealShellExecuteExA # exported by name
239 231 stub RealShellExecuteExW # exported by name
240 232 stub RealShellExecuteW # exported by name
241 233 stub RegenerateUserEnvironment # exported by name
242 234 stdcall SHAddToRecentDocs (long ptr) SHAddToRecentDocs32 # exported by name
243 235 stdcall SHAppBarMessage(long ptr) SHAppBarMessage32 # exported by name
244 236 stdcall SHBrowseForFolder(ptr) SHBrowseForFolder32A # exported by name
245 237 stdcall SHBrowseForFolderA(ptr) SHBrowseForFolder32A # exported by name
246 238 stub SHBrowseForFolderW@4 # exported by name
247 239 stdcall SHChangeNotify (long long ptr ptr) SHChangeNotify32 # exported by name
248 240 stub SHEmptyRecycleBinA@12 # exported by name
249 241 stub SHEmptyRecycleBinW@12 # exported by name
250 242 stdcall SHFileOperation (ptr) SHFileOperation32 # exported by name
251 243 stdcall SHFileOperationA (ptr) SHFileOperation32A # exported by name
252 244 stdcall SHFileOperationW (ptr) SHFileOperation32W # exported by name
253 245 stub SHFormatDrive@16 # exported by name
254 246 stub SHFreeNameMappings@4 # exported by name
255 247 stdcall SHGetDataFromIDListA (long long long long long) SHGetDataFromIDListA # exported by name
256 248 stub SHGetDataFromIDListW@20 # exported by name
257 249 stub PathParseIconLocation@4
258 250 stub PathRemoveExtension@4
259 251 stub PathRemoveArgs@4
260 252 stdcall SHGetDesktopFolder(ptr) SHGetDesktopFolder # exported by name
261 253 stdcall SHGetFileInfo(ptr long ptr long long) SHGetFileInfo32A # exported by name
262 254 stdcall SHGetFileInfoA(ptr long ptr long long) SHGetFileInfo32A # exported by name
263 255 stdcall SHGetFileInfoW(ptr long ptr long long) SHGetFileInfo32W # exported by name
264 256 stdcall SHGetInstanceExplorer (long) SHGetInstanceExplorer
265 257 stdcall SHGetMalloc(ptr) SHGetMalloc # exported by name
266 258 stub SHGetNewLinkInfo@20 # exported by name
267 259 stdcall SHGetPathFromIDList(ptr ptr) SHGetPathFromIDList32 # exported by name
268 260 stub SHGetPathFromIDList@8 # exported by name
269 261 stdcall SHGetPathFromIDListA (long long) SHGetPathFromIDList32A # exported by name
270 262 stdcall SHGetPathFromIDListW (long long) SHGetPathFromIDList32W # exported by name
271 263 stdcall SHGetSpecialFolderLocation(long long ptr) SHGetSpecialFolderLocation # exported by name
272 264 stdcall SHHelpShortcuts_RunDLL(long long long long) SHHelpShortcuts_RunDLL # exported by name
273 265 stub SHHelpShortcuts_RunDLLA@16 # exported by name
274 266 stub SHHelpShortcuts_RunDLLW@16 # exported by name
275 267 stdcall SHLoadInProc(long) SHLoadInProc # exported by name
276 268 stub SHQueryRecycleBinA@8 # exported by name
277 269 stub SHQueryRecycleBinW@8 # exported by name
278 270 stub SHUpdateRecycleBinIcon@0 # exported by name
280 271 stub SheChangeDirA
281 272 stub SheChangeDirExA
282 273 stub SheChangeDirExW
283 274 stdcall SheChangeDirW(wstr) SheChangeDir32W
284 275 stub SheConvertPathW
285 276 stub SheFullPathA
286 277 stub SheFullPathW
287 278 stub SheGetCurDrive
288 279 stub SheGetDirA@8
289 280 stub SheGetDirExW@12
290 281 stdcall SheGetDirW (long long) SheGetDir32W
291 282 stub SheGetPathOffsetW
292 283 stub SheRemoveQuotesA
293 284 stub SheRemoveQuotesW
294 285 stub SheSetCurDrive
295 286 stub SheShortenPathA
296 287 stub SheShortenPathW
297 288 stdcall ShellAboutA(long str str long) ShellAbout32A
298 289 stdcall ShellAboutW(long wstr wstr long) ShellAbout32W
299 290 stdcall ShellExecuteA(long str str str str long) ShellExecute32A
300 291 stdcall ShellExecuteEx (long) ShellExecuteEx32
301 292 stdcall ShellExecuteExA (long) ShellExecuteEx32A
302 293 stdcall ShellExecuteExW (long) ShellExecuteEx32W
303 294 stdcall ShellExecuteW (long wstr wstr wstr wstr long) ShellExecute32W
304 295 stub ShellHookProc # exported by name
305 296 stdcall Shell_NotifyIcon(long ptr) Shell_NotifyIcon
306 297 stdcall Shell_NotifyIconA(long ptr) Shell_NotifyIconA
307 298 stub Shell_NotifyIconW # exported by name
308 299 stub Shl1632_ThunkData32
309 300 stub Shl3216_ThunkData32
310 301 stub StrChrA # proper ordinal unknown
311 302 stub StrChrIA # proper ordinal unknown
312 303 stub StrChrIW # proper ordinal unknown
313 304 stdcall StrChrW (ptr ptr) StrChrW # proper ordinal unknown
314 305 stub StrCmpNA # proper ordinal unknown
315 306 stub StrCmpNIA # proper ordinal unknown
316 307 stdcall StrCmpNIW (wstr wstr long) StrCmpNIW # proper ordinal unknown
317 308 stub StrCmpNW # proper ordinal unknown
318 309 stub StrCpyNA # proper ordinal unknown
319 310 stub StrCpyNW # proper ordinal unknown
320 311 stub StrNCmpA # proper ordinal unknown
321 312 stub StrNCmpIA # proper ordinal unknown
322 313 stub StrNCmpIW # proper ordinal unknown
323 314 stub StrNCmpW # proper ordinal unknown
324 315 stub StrNCpyA # proper ordinal unknown
325 316 stub StrNCpyW # proper ordinal unknown
326 317 stub StrRChrA # proper ordinal unknown
327 318 stub StrRChrIA # proper ordinal unknown
328 319 stub StrRChrIW # proper ordinal unknown
329 320 stdcall StrRChrW (wstr wstr long) StrRChrW # proper ordinal unknown
330 321 stub StrRStrA # proper ordinal unknown
331 322 stub StrRStrIA # proper ordinal unknown
332 323 stub StrRStrIW # proper ordinal unknown
333 324 stub StrRStrW # proper ordinal unknown
334 325 stub StrStrA # proper ordinal unknown
335 326 stub StrStrIA # proper ordinal unknown
336 327 stub StrStrIW # proper ordinal unknown
337 328 stub StrStrW # proper ordinal unknown
338 329 stub WOWShellExecute # proper ordinal unknown
340 505 stdcall SHRegCloseKey (long) SHRegCloseKey32
341 506 stdcall SHRegOpenKeyA (long str long) SHRegOpenKey32A
342 507 stdcall SHRegOpenKeyW (long wstr long) SHRegOpenKey32W
343 508 stub SHRegQueryValueA@16
344 509 stdcall SHRegQueryValueExA(long str ptr ptr ptr ptr) SHRegQueryValueEx32A
345 510 stdcall SHRegQueryValueW (long long long long) SHRegQueryValue32W
346 511 stdcall SHRegQueryValueExW (long wstr ptr ptr ptr ptr) SHRegQueryValueEx32W
347 512 stub SHRegDeleteKeyW@8
349 520 stdcall SHAllocShared (long long long) SHAllocShared
350 521 stdcall SHLockShared (long long) SHLockShared
351 522 stdcall SHUnlockShared (long) SHUnlockShared
352 523 stdcall SHFreeShared (long long) SHFreeShared
353 524 stub RealDriveType@8
354 525 stub RealDriveTypeFlags@8
356 640 stub NTSHChangeNotifyRegister@24
357 641 stub NTSHChangeNotifyDeregister@4
359 643 stub SHChangeNotifyReceive@16
360 644 stub SHChangeNotification_Lock@16
361 645 stub SHChangeNotification_Unlock@4
362 646 stub SHChangeRegistrationReceive@8
363 647 stub ReceiveAddToRecentDocs@8
364 648 stub SHWaitOp_Operate@8
366 650 stub PathIsSameRoot@8
367 651 stdcall ReadCabinetState (long long) ReadCabinetState
368 652 stdcall WriteCabinetState (long) WriteCabinetState
369 653 stdcall PathProcessCommand (long long long long) PathProcessCommand
371 660 stdcall FileIconInit (long) FileIconInit
373 680 stdcall IsUserAdmin () IsUserAdmin
375 1217 stub FOOBAR1217 # no joke! This is the real name!!
377 # later additions ... FIXME: incorrect ordinals
378 1218 stdcall SHGetSpecialFolderPathA(long long long long) SHGetSpecialFolderPath
379 1219 stub DoEnvironmentSubstW