1 # C RunTime DLL. All functions use cdecl!
5 1 cdecl ??
2@YAPAXI@Z
(long
) CRTDLL_new
6 2 cdecl ??
3@YAXPAX@Z
(long
) CRTDLL_delete
7 3 cdecl ?_set_new_handler@@YAP6AHI@ZP6AHI@Z@Z
(ptr
) CRTDLL_set_new_handler
26 22 cdecl __GetMainArgs
(ptr ptr ptr long
) CRTDLL__GetMainArgs
27 23 extern __argc_dll CRTDLL_argc_dll
28 24 extern __argv_dll CRTDLL_argv_dll
29 25 cdecl __dllonexit
() CRTDLL__dllonexit
35 31 stub __mb_cur_max_dll
36 32 stub __pxcptinfoptrs
37 33 stub __threadhandle
40 36 cdecl _abnormal_termination
() CRTDLL__abnormal_termination
41 37 cdecl _access
(str long
) CRTDLL__access
42 38 extern _acmdln_dll CRTDLL_acmdln_dll
43 39 stub _aexit_rtn_dll
46 42 extern _basemajor_dll CRTDLL_basemajor_dll
47 43 extern _baseminor_dll CRTDLL_baseminor_dll
48 44 extern _baseversion_dll CRTDLL_baseversion_dll
53 49 cdecl _cexit
(long
) CRTDLL__cexit
55 51 cdecl _chdir
(str
) CRTDLL__chdir
56 52 cdecl _chdrive
(long
) CRTDLL__chdrive
61 57 cdecl _close
(long
) CRTDLL__close
63 59 extern _commode_dll CRTDLL_commode_dll
79 75 extern _environ_dll CRTDLL_environ_dll
81 77 cdecl _errno
() CRTDLL__errno
82 78 stub _except_handler2
95 91 cdecl _fdopen
(long ptr
) CRTDLL__fdopen
103 99 cdecl _findfirst
(str ptr
) CRTDLL__findfirst
104 100 cdecl _findnext
(long ptr
) CRTDLL__findnext
108 104 extern _fmode_dll CRTDLL_fmode_dll
111 107 cdecl _fpreset
() CRTDLL__fpreset
115 111 cdecl _fstat
(long ptr
) CRTDLL__fstat
117 113 cdecl _ftol
(double
) CRTDLL__ftol
118 114 cdecl _fullpath
(ptr str long
) CRTDLL__fullpath
121 117 stub _get_osfhandle
124 120 cdecl _getcwd
(ptr long
) CRTDLL__getcwd
125 121 cdecl _getdcwd
(long ptr long
) CRTDLL__getdcwd
126 122 stub _getdiskfree
127 123 stub _getdllprocaddr
128 124 cdecl _getdrive
() CRTDLL__getdrive
133 129 cdecl _global_unwind2
(ptr
) CRTDLL__global_unwind2
138 134 cdecl _hypot
(double double
) hypot
139 135 cdecl _initterm
(ptr ptr
) CRTDLL__initterm
140 136 extern _iob CRTDLL_iob
141 137 cdecl _isatty
(long
) CRTDLL__isatty
142 138 cdecl _isctype
(long long
) CRTDLL__isctype
146 142 stub _ismbbkalnum
148 144 stub _ismbbkpunct
164 160 stub _ismbcsymbol
169 165 cdecl _itoa
(long ptr long
) CRTDLL__itoa
171 167 cdecl _j0
(double
) j0
172 168 cdecl _j1
(double
) j1
173 169 cdecl _jn
(long double
) jn
177 173 cdecl _local_unwind2
(ptr long
) CRTDLL__local_unwind2
180 176 cdecl _lrotl
(long long
) CRTDLL__lrotl
184 180 cdecl _ltoa
(long str long
) CRTDLL__ltoa
191 187 stub _mbcjistojms
192 188 stub _mbcjmstojis
201 197 cdecl _mbscat
(str str
) CRTDLL__mbscat
204 200 cdecl _mbscpy
(ptr str
) CRTDLL__mbscpy
208 204 cdecl _mbsicmp
(str str
) CRTDLL__mbsicmp
209 205 cdecl _mbsinc
(str
) CRTDLL__mbsinc
227 223 cdecl _mbsrchr
(str long
) CRTDLL__mbsrchr
237 233 cdecl _memicmp
(str str long
) CRTDLL__memicmp
238 234 cdecl _mkdir
(str
) CRTDLL__mkdir
243 239 cdecl _open
(str long
) CRTDLL__open
244 240 cdecl _open_osfhandle
(long long
) CRTDLL__open_osfhandle
245 241 extern _osmajor_dll CRTDLL_osmajor_dll
246 242 extern _osminor_dll CRTDLL_osminor_dll
247 243 extern _osmode_dll CRTDLL_osmode_dll
248 244 extern _osver_dll CRTDLL_osver_dll
249 245 extern _osversion_dll CRTDLL_osversion_dll
259 255 stub _pwctype_dll
260 256 cdecl _read
(long ptr long
) CRTDLL__read
263 259 cdecl _rotl
(long long
) CRTDLL__rotl
267 263 stub _seterrormode
269 265 cdecl _setmode
(long long
) CRTDLL__setmode
271 267 cdecl _sleep
(long
) CRTDLL__sleep
283 279 cdecl _splitpath
(str ptr ptr ptr ptr
) CRTDLL__splitpath
284 280 cdecl _stat
(str ptr
) CRTDLL__stat
286 282 cdecl _strcmpi
(str str
) CRTDLL__strcmpi
287 283 cdecl _strdate
(str
) CRTDLL__strdate
289 285 cdecl _strdup
(str
) CRTDLL__strdup
291 287 cdecl _stricmp
(str str
) CRTDLL__strcmpi
294 290 cdecl _strlwr
(str
) CRTDLL__strlwr
297 293 cdecl _strnicmp
(str str long
) CRTDLL__strnicmp
303 299 cdecl _strtime
(str
) CRTDLL__strtime
304 300 cdecl _strupr
(str
) CRTDLL__strupr
306 302 stub _sys_errlist
307 303 stub _sys_nerr_dll
309 305 cdecl _tempnam
(str ptr
) CRTDLL__tempnam
310 306 stub _timezone_dll
319 315 cdecl _unlink
(str
) CRTDLL__unlink
324 320 cdecl _wcsdup
(wstr
) CRTDLL__wcsdup
325 321 cdecl _wcsicmp
(wstr wstr
) CRTDLL__wcsicmp
326 322 cdecl _wcsicoll
(wstr wstr
) CRTDLL__wcsicoll
327 323 cdecl _wcslwr
(wstr
) CRTDLL__wcslwr
328 324 cdecl _wcsnicmp
(wstr wstr long
) CRTDLL__wcsnicmp
330 326 cdecl _wcsrev
(wstr
) CRTDLL__wcsrev
332 328 cdecl _wcsupr
(wstr
) CRTDLL__wcsupr
333 329 extern _winmajor_dll CRTDLL_winmajor_dll
334 330 extern _winminor_dll CRTDLL_winminor_dll
335 331 extern _winver_dll CRTDLL_winver_dll
336 332 cdecl _write
(long ptr long
) CRTDLL__write
339 335 cdecl _y0
(double
) y0
340 336 cdecl _y1
(double
) y1
341 337 cdecl _yn
(long double
) yn
343 339 cdecl abs
(long
) abs
344 340 cdecl acos
(double
) acos
345 341 cdecl asctime
(ptr
) asctime
346 342 cdecl asin
(double
) asin
347 343 cdecl atan
(double
) atan
348 344 cdecl atan2
(double double
) atan2
349 345 cdecl atexit
(ptr
) CRTDLL_atexit
350 346 cdecl atof
(str
) atof
351 347 cdecl atoi
(str
) atoi
352 348 cdecl atol
(str
) atol
354 350 cdecl calloc
(long long
) CRTDLL_calloc
355 351 cdecl ceil
(double
) ceil
357 353 cdecl clock
() CRTDLL_clock
358 354 cdecl cos
(double
) cos
359 355 cdecl cosh
(double
) cosh
360 356 cdecl ctime
(ptr
) ctime
362 358 cdecl div
(long long
) div
363 359 cdecl
exit(long
) CRTDLL_exit
364 360 cdecl exp
(double
) exp
365 361 cdecl fabs
(double
) fabs
366 362 cdecl fclose
(ptr
) CRTDLL_fclose
367 363 cdecl feof
(ptr
) CRTDLL_feof
369 365 cdecl fflush
(ptr
) CRTDLL_fflush
370 366 cdecl fgetc
(ptr
) CRTDLL_fgetc
372 368 cdecl fgets
(ptr long ptr
) CRTDLL_fgets
374 370 cdecl floor
(double
) floor
375 371 cdecl fmod
(double double
) fmod
376 372 cdecl fopen
(str str
) CRTDLL_fopen
377 373 varargs fprintf
() CRTDLL_fprintf
378 374 cdecl fputc
(long ptr
) CRTDLL_fputc
379 375 cdecl fputs
(str ptr
) CRTDLL_fputs
381 377 cdecl fread
(ptr long long ptr
) CRTDLL_fread
382 378 cdecl free
(ptr
) CRTDLL_free
383 379 cdecl freopen
(str str ptr
) CRTDLL_freopen
384 380 cdecl frexp
(double ptr
) frexp
385 381 varargs fscanf
() CRTDLL_fscanf
386 382 cdecl fseek
(ptr long long
) CRTDLL_fseek
387 383 cdecl fsetpos
(ptr ptr
) CRTDLL_fsetpos
388 384 cdecl ftell
(ptr
) CRTDLL_ftell
390 386 cdecl fwrite
(ptr long long ptr
) CRTDLL_fwrite
392 388 cdecl getc
(ptr
) CRTDLL_getc
394 390 cdecl getenv
(str
) CRTDLL_getenv
395 391 cdecl gets
(ptr
) CRTDLL_gets
396 392 cdecl gmtime
(ptr
) gmtime
398 394 cdecl isalnum
(long
) isalnum
399 395 cdecl isalpha
(long
) isalpha
400 396 cdecl iscntrl
(long
) iscntrl
401 397 cdecl isdigit
(long
) isdigit
402 398 cdecl isgraph
(long
) isgraph
404 400 cdecl islower
(long
) islower
405 401 cdecl isprint
(long
) isprint
406 402 cdecl ispunct
(long
) ispunct
407 403 cdecl isspace
(long
) isspace
408 404 cdecl isupper
(long
) isupper
422 418 cdecl isxdigit
(long
) isxdigit
423 419 cdecl labs
(long
) labs
424 420 cdecl ldexp
(double long
) ldexp
425 421 cdecl ldiv
(long long
) ldiv
427 423 cdecl localtime
(ptr
) localtime
428 424 cdecl log
(double
) log
429 425 cdecl log10
(double
) log10
430 426 cdecl longjmp
(ptr long
) CRTDLL_longjmp
431 427 cdecl malloc
(ptr
) CRTDLL_malloc
432 428 cdecl mblen
(str long
) CRTDLL_mblen
433 429 cdecl mbstowcs
(ptr str long
) CRTDLL_mbstowcs
434 430 cdecl mbtowc
(ptr ptr long
) CRTDLL_mbtowc
435 431 cdecl memchr
(ptr long long
) memchr
436 432 cdecl memcmp
(ptr ptr long
) memcmp
437 433 cdecl memcpy
(ptr ptr long
) memcpy
438 434 cdecl memmove
(ptr ptr long
) memmove
439 435 cdecl memset
(ptr long long
) memset
440 436 cdecl mktime
(ptr
) mktime
441 437 cdecl modf
(double ptr
) modf
443 439 cdecl pow
(double double
) pow
444 440 varargs
printf() printf
445 441 cdecl putc
(long ptr
) CRTDLL_putc
446 442 cdecl putchar
(long
) CRTDLL_putchar
447 443 cdecl puts
(str
) CRTDLL_puts
448 444 cdecl qsort
(ptr long long ptr
) qsort
450 446 cdecl rand
() CRTDLL_rand
451 447 cdecl realloc
(ptr long
) CRTDLL_realloc
452 448 cdecl remove
(str
) CRTDLL_remove
453 449 cdecl rename
(str str
) CRTDLL_rename
456 452 cdecl setbuf
(ptr ptr
) CRTDLL_setbuf
457 453 cdecl setlocale
(long ptr
) CRTDLL_setlocale
459 455 cdecl signal
(long ptr
) CRTDLL_signal
460 456 cdecl sin
(double
) sin
461 457 cdecl sinh
(double
) sinh
462 458 varargs sprintf
() sprintf
463 459 cdecl sqrt
(double
) sqrt
464 460 cdecl srand
(long
) CRTDLL_srand
465 461 varargs sscanf
() sscanf
466 462 cdecl strcat
(str str
) strcat
467 463 cdecl strchr
(str long
) strchr
468 464 cdecl strcmp
(str str
) strcmp
469 465 cdecl strcoll
(str str
) strcoll
470 466 cdecl strcpy
(ptr str
) strcpy
471 467 cdecl strcspn
(str str
) strcspn
473 469 cdecl strftime
(ptr long str ptr
) strftime
474 470 cdecl strlen
(str
) strlen
475 471 cdecl strncat
(str str long
) strncat
476 472 cdecl strncmp
(str str long
) strncmp
477 473 cdecl strncpy
(ptr str long
) strncpy
478 474 cdecl strpbrk
(str str
) strpbrk
479 475 cdecl strrchr
(str long
) strrchr
480 476 cdecl strspn
(str str
) strspn
481 477 cdecl strstr
(str str
) strstr
482 478 cdecl strtod
(str ptr
) strtod
483 479 cdecl strtok
(str str
) strtok
484 480 cdecl strtol
(str ptr long
) strtol
485 481 cdecl strtoul
(str ptr long
) strtoul
486 482 cdecl strxfrm
(ptr str long
) strxfrm
487 483 varargs swprintf
() wsprintf32W
489 485 cdecl system
(str
) CRTDLL_system
490 486 cdecl tan
(double
) tan
491 487 cdecl tanh
(double
) tanh
492 488 cdecl
time(ptr
) CRTDLL_time
494 490 cdecl tmpnam
(str
) CRTDLL_tmpnam
495 491 cdecl tolower
(long
) tolower
496 492 cdecl toupper
(long
) toupper
497 493 cdecl towlower
(long
) towlower
498 494 cdecl towupper
(long
) towupper
501 497 cdecl vfprintf
(ptr str ptr
) CRTDLL_vfprintf
504 500 cdecl vsprintf
(ptr str ptr
) CRTDLL_vsprintf
505 501 cdecl vswprintf
(ptr wstr ptr
) CRTDLL_vswprintf
507 503 cdecl wcscat
(wstr wstr
) CRTDLL_wcscat
508 504 cdecl wcschr
(wstr long
) CRTDLL_wcschr
509 505 cdecl wcscmp
(wstr wstr
) CRTDLL_wcscmp
510 506 cdecl wcscoll
(wstr wstr
) CRTDLL_wcscoll
511 507 cdecl wcscpy
(ptr wstr
) CRTDLL_wcscpy
512 508 cdecl wcscspn
(wstr wstr
) CRTDLL_wcscspn
514 510 cdecl wcslen
(wstr
) CRTDLL_wcslen
515 511 cdecl wcsncat
(wstr wstr long
) CRTDLL_wcsncat
516 512 cdecl wcsncmp
(wstr wstr long
) CRTDLL_wcsncmp
517 513 cdecl wcsncpy
(ptr wstr long
) CRTDLL_wcsncpy
519 515 cdecl wcsrchr
(wstr long
) CRTDLL_wcsrchr
520 516 cdecl wcsspn
(wstr wstr
) CRTDLL_wcsspn
521 517 cdecl wcsstr
(wstr wstr
) CRTDLL_wcsstr
523 519 cdecl wcstok
(wstr wstr
) CRTDLL_wcstok
524 520 cdecl wcstol
(wstr ptr long
) CRTDLL_wcstol
525 521 cdecl wcstombs
(ptr ptr long
) CRTDLL_wcstombs