Built-in DLLs resources are now specified in spec file.
[wine/multimedia.git] / dlls / comctl32 / comctl32.spec
blobdbe440f12ac7099b5386f174492d2f1f59c817aa
1 name comctl32
2 type win32
3 init COMCTL32_LibMain
4 rsrc comctl32
6 # Functions exported by the Win95 comctl32.dll
7 # (these need to have these exact ordinals, because some win95 dlls
8 # import comctl32.dll by ordinal)
9 # This list was created from a comctl32.dll v4.72 (IE4.01).
11 2 stdcall MenuHelp(long long long long long long ptr) MenuHelp
12 3 stdcall ShowHideMenuCtl(long long ptr) ShowHideMenuCtl
13 4 stdcall GetEffectiveClientRect(long long long) GetEffectiveClientRect
14 5 stdcall DrawStatusTextA(long ptr str long) DrawStatusTextA
15 6 stdcall CreateStatusWindowA(long str long long) CreateStatusWindowA
16 7 stdcall CreateToolbar(long long long long long long ptr long) CreateToolbar
17 8 stdcall CreateMappedBitmap(long long long ptr long) CreateMappedBitmap
18 9 stdcall DPA_LoadStream(ptr ptr ptr long) DPA_LoadStream
19 10 stdcall DPA_SaveStream(ptr ptr ptr long) DPA_SaveStream
20 11 stdcall DPA_Merge(ptr ptr long ptr ptr long) DPA_Merge
21 #12 stub Cctl1632_ThunkData32
22 13 stdcall MakeDragList(long) MakeDragList
23 14 stdcall LBItemFromPt(long long long long) LBItemFromPt
24 15 stdcall DrawInsert(long long long) DrawInsert
25 16 stdcall CreateUpDownControl(long long long long long long long long long long long long) CreateUpDownControl
26 17 stdcall InitCommonControls() InitCommonControls
27 18 stdcall CreatePropertySheetPage(ptr) CreatePropertySheetPageA
28 19 stdcall CreatePropertySheetPageA(ptr) CreatePropertySheetPageA
29 20 stdcall CreatePropertySheetPageW(ptr) CreatePropertySheetPageW
30 21 stdcall CreateStatusWindow(long str long long) CreateStatusWindowA
31 22 stdcall CreateStatusWindowW(long wstr long long) CreateStatusWindowW
32 23 stdcall CreateToolbarEx(long long long long long long ptr long long long long long long) CreateToolbarEx
33 24 stdcall DestroyPropertySheetPage(long) DestroyPropertySheetPage
34 25 stdcall DllGetVersion(ptr) COMCTL32_DllGetVersion
35 26 stub DllInstall
36 27 stdcall DrawStatusText(long ptr ptr long) DrawStatusTextA
37 28 stdcall DrawStatusTextW(long ptr wstr long) DrawStatusTextW
38 29 stdcall FlatSB_EnableScrollBar (long long long) FlatSB_EnableScrollBar
39 30 stdcall FlatSB_GetScrollInfo (long long ptr) FlatSB_GetScrollInfo
40 31 stdcall FlatSB_GetScrollPos (long long) FlatSB_GetScrollPos
41 32 stdcall FlatSB_GetScrollProp (long long ptr) FlatSB_GetScrollProp
42 33 stdcall FlatSB_GetScrollRange (long long ptr ptr) FlatSB_GetScrollRange
43 34 stdcall FlatSB_SetScrollInfo (long long ptr long) FlatSB_SetScrollInfo
44 35 stdcall FlatSB_SetScrollPos (long long long long) FlatSB_SetScrollPos
45 36 stdcall FlatSB_SetScrollProp (long long long long) FlatSB_SetScrollProp
46 37 stdcall FlatSB_SetScrollRange (long long long long long) FlatSB_SetScrollRange
47 38 stdcall FlatSB_ShowScrollBar (long long long) FlatSB_ShowScrollBar
48 39 stdcall ImageList_Add(ptr long long) ImageList_Add
49 40 stdcall ImageList_AddIcon(ptr long) ImageList_AddIcon
50 41 stdcall ImageList_AddMasked(ptr long long) ImageList_AddMasked
51 42 stdcall ImageList_BeginDrag(ptr long long long) ImageList_BeginDrag
52 43 stdcall ImageList_Copy(ptr long ptr long long) ImageList_Copy
53 44 stdcall ImageList_Create(long long long long long) ImageList_Create
54 45 stdcall ImageList_Destroy(ptr) ImageList_Destroy
55 46 stdcall ImageList_DragEnter(long long long) ImageList_DragEnter
56 47 stdcall ImageList_DragLeave(long) ImageList_DragLeave
57 48 stdcall ImageList_DragMove(long long) ImageList_DragMove
58 49 stdcall ImageList_DragShowNolock(long) ImageList_DragShowNolock
59 50 stdcall ImageList_Draw(ptr long long long long long) ImageList_Draw
60 51 stdcall ImageList_DrawEx(ptr long long long long long long long long long) ImageList_DrawEx
61 52 stdcall ImageList_DrawIndirect(ptr) ImageList_DrawIndirect
62 53 stdcall ImageList_Duplicate(ptr) ImageList_Duplicate
63 54 stdcall ImageList_EndDrag() ImageList_EndDrag
64 55 stdcall ImageList_GetBkColor(ptr) ImageList_GetBkColor
65 56 stdcall ImageList_GetDragImage(ptr ptr) ImageList_GetDragImage
66 57 stdcall ImageList_GetIcon(ptr long long) ImageList_GetIcon
67 58 stdcall ImageList_GetIconSize(ptr ptr ptr) ImageList_GetIconSize
68 59 stdcall ImageList_GetImageCount(ptr) ImageList_GetImageCount
69 60 stdcall ImageList_GetImageInfo(ptr long ptr) ImageList_GetImageInfo
70 61 stdcall ImageList_GetImageRect(ptr long ptr) ImageList_GetImageRect
71 62 stdcall ImageList_LoadImage(long str long long long long long) ImageList_LoadImageA
72 63 stdcall ImageList_LoadImageA(long str long long long long long) ImageList_LoadImageA
73 64 stdcall ImageList_LoadImageW(long wstr long long long long long) ImageList_LoadImageW
74 65 stdcall ImageList_Merge(ptr long ptr long long long) ImageList_Merge
75 66 stdcall ImageList_Read(ptr) ImageList_Read
76 67 stdcall ImageList_Remove(ptr long) ImageList_Remove
77 68 stdcall ImageList_Replace(ptr long long long) ImageList_Replace
78 69 stdcall ImageList_ReplaceIcon(ptr long long) ImageList_ReplaceIcon
79 70 stdcall ImageList_SetBkColor(ptr long) ImageList_SetBkColor
80 71 stdcall Alloc(long) COMCTL32_Alloc
81 72 stdcall ReAlloc(ptr long) COMCTL32_ReAlloc
82 73 stdcall Free(ptr) COMCTL32_Free
83 74 stdcall GetSize(ptr) COMCTL32_GetSize
84 75 stdcall ImageList_SetDragCursorImage(ptr long long long) ImageList_SetDragCursorImage
85 76 stdcall ImageList_SetFilter(ptr long long) ImageList_SetFilter
86 77 stdcall ImageList_SetIconSize(ptr long long) ImageList_SetIconSize
87 78 stdcall ImageList_SetImageCount(ptr long) ImageList_SetImageCount
88 79 stdcall ImageList_SetOverlayImage(ptr long long) ImageList_SetOverlayImage
89 80 stdcall ImageList_Write(ptr ptr) ImageList_Write
90 81 stdcall InitCommonControlsEx(ptr) InitCommonControlsEx
91 82 stdcall InitializeFlatSB(long) InitializeFlatSB
92 83 stdcall PropertySheet(ptr) PropertySheetA
93 84 stdcall PropertySheetA(ptr) PropertySheetA
94 85 stdcall PropertySheetW(ptr) PropertySheetW
95 86 stdcall UninitializeFlatSB(long) UninitializeFlatSB
96 87 stdcall _TrackMouseEvent(ptr) _TrackMouseEvent
98 151 stdcall CreateMRUListA(ptr) CreateMRUListA
99 152 stdcall FreeMRUList(ptr) FreeMRUListA
100 153 stdcall AddMRUStringA(long str) AddMRUStringA
101 154 stdcall EnumMRUListA(long long ptr long) EnumMRUListA
102 155 stdcall FindMRUStringA(long str ptr) FindMRUStringA
103 156 stdcall DelMRUString(long long) DelMRUString
104 157 stdcall CreateMRUListLazyA(ptr long long long) CreateMRUListLazyA
106 163 stub CreatePage
107 164 stub CreateProxyPage
109 167 stdcall AddMRUData(long ptr long) AddMRUData
110 169 stdcall FindMRUData(long ptr long ptr) FindMRUData
112 233 stdcall Str_GetPtrA(str str long) Str_GetPtrA
113 234 stdcall Str_SetPtrA(str str) Str_SetPtrA
114 235 stdcall Str_GetPtrW(wstr wstr long) Str_GetPtrW
115 236 stdcall Str_SetPtrW(wstr wstr) Str_SetPtrW
117 320 stdcall DSA_Create(long long) DSA_Create
118 321 stdcall DSA_Destroy(ptr) DSA_Destroy
119 322 stdcall DSA_GetItem(ptr long long) DSA_GetItem
120 323 stdcall DSA_GetItemPtr(ptr long) DSA_GetItemPtr
121 324 stdcall DSA_InsertItem(ptr long long) DSA_InsertItem
122 325 stdcall DSA_SetItem (ptr long long) DSA_SetItem
123 326 stdcall DSA_DeleteItem(ptr long) DSA_DeleteItem
124 327 stdcall DSA_DeleteAllItems(ptr) DSA_DeleteAllItems
125 328 stdcall DPA_Create(long) DPA_Create
126 329 stdcall DPA_Destroy(ptr) DPA_Destroy
127 330 stdcall DPA_Grow(ptr long) DPA_Grow
128 331 stdcall DPA_Clone(ptr ptr) DPA_Clone
129 332 stdcall DPA_GetPtr(ptr long) DPA_GetPtr
130 333 stdcall DPA_GetPtrIndex(ptr ptr) DPA_GetPtrIndex
131 334 stdcall DPA_InsertPtr(ptr long ptr) DPA_InsertPtr
132 335 stdcall DPA_SetPtr(ptr long ptr) DPA_SetPtr
133 336 stdcall DPA_DeletePtr(ptr long) DPA_DeletePtr
134 337 stdcall DPA_DeleteAllPtrs(ptr) DPA_DeleteAllPtrs
135 338 stdcall DPA_Sort(ptr ptr long) DPA_Sort
136 339 stdcall DPA_Search(ptr ptr long ptr long long) DPA_Search
137 340 stdcall DPA_CreateEx(long long) DPA_CreateEx
138 341 stdcall SendNotify(long long long ptr) COMCTL32_SendNotify
139 342 stdcall SendNotifyEx(long long long ptr long) COMCTL32_SendNotifyEx
141 350 stdcall StrChrA(str str) COMCTL32_StrChrA
142 351 stdcall StrRChrA(str str long) COMCTL32_StrRChrA
143 352 stdcall StrCmpNA(str str long) COMCTL32_StrCmpNA
144 353 stdcall StrCmpNIA(str str long) COMCTL32_StrCmpNIA
145 354 stdcall StrStrA(str str) COMCTL32_StrStrA
146 355 stdcall StrStrIA(str str) COMCTL32_StrStrIA
147 356 stdcall StrCSpnA(str str) COMCTL32_StrCSpnA
148 357 stdcall StrToIntA(str) COMCTL32_StrToIntA
149 358 stdcall StrChrW(wstr long) COMCTL32_StrChrW
150 359 stdcall StrRChrW(wstr wstr long) COMCTL32_StrRChrW
151 360 stdcall StrCmpNW(wstr wstr long) COMCTL32_StrCmpNW
152 361 stdcall StrCmpNIW(wstr wstr long) COMCTL32_StrCmpNIW
153 362 stdcall StrStrW(wstr wstr) COMCTL32_StrStrW
154 363 stub StrStrIW
155 364 stdcall StrSpnW(wstr wstr) COMCTL32_StrSpnW
156 365 stub StrToIntW
157 366 stub StrChrIA
158 367 stub StrChrIW
159 368 stub StrRChrIA
160 369 stub StrRChrIW
162 372 stub StrRStrIA
163 373 stub StrRStrIW
164 374 stub StrCSpnIA
165 375 stub StrCSpnIW
166 376 stub IntlStrEqWorkerA@16
167 377 stub IntlStrEqWorkerW@16
169 382 stub SmoothScrollWindow@4
170 383 stub DoReaderMode@4
171 384 stub SetPathWordBreakProc@8
172 385 stdcall DPA_EnumCallback(long long long) DPA_EnumCallback
173 386 stdcall DPA_DestroyCallback(ptr ptr long) DPA_DestroyCallback
174 387 stdcall DSA_EnumCallback(ptr ptr long) DSA_EnumCallback
175 388 stdcall DSA_DestroyCallback(ptr ptr long) DSA_DestroyCallback
176 389 stub COMCTL32_389
177 390 stub COMCTL32_390
179 400 stub CreateMRUListW@4
180 401 stub AddMRUStringW@8
181 402 stub FindMRUStringW@12
182 403 stub EnumMRUListW@16
183 404 stub CreateMRUListLazyW@16
185 410 stdcall COMCTL32_410(long long long long) comctl32_410
186 411 stdcall COMCTL32_411(long long long) comctl32_411
187 412 stdcall COMCTL32_412(long long long) comctl32_412
188 413 stdcall COMCTL32_413(long long long long) comctl32_413
190 # this is actually ordinal 70 in COMCTL32 v5.0
191 414 stdcall InitMUILanguage(long) InitMUILanguage