1 @ stdcall A_SHAFinal
(ptr ptr
)
2 @ stdcall A_SHAInit
(ptr
)
3 @ stdcall A_SHAUpdate
(ptr ptr long
)
4 @ stdcall AbortSystemShutdownA
(ptr
)
5 @ stdcall AbortSystemShutdownW
(ptr
)
6 @ stdcall AccessCheck
(ptr long long ptr ptr ptr ptr ptr
)
7 @ stdcall AccessCheckAndAuditAlarmA
(str ptr str str ptr long ptr long ptr ptr ptr
)
8 @ stdcall AccessCheckAndAuditAlarmW
(wstr ptr wstr wstr ptr long ptr long ptr ptr ptr
)
9 @ stdcall AccessCheckByType
(ptr ptr long long ptr long ptr ptr ptr ptr ptr
)
10 # @ stub AccessCheckByTypeAndAuditAlarmA
11 # @ stub AccessCheckByTypeAndAuditAlarmW
12 # @ stub AccessCheckByTypeResultList
13 # @ stub AccessCheckByTypeResultListAndAuditAlarmA
14 # @ stub AccessCheckByTypeResultListAndAuditAlarmByHandleA
15 # @ stub AccessCheckByTypeResultListAndAuditAlarmByHandleW
16 # @ stub AccessCheckByTypeResultListAndAuditAlarmW
17 @ stdcall AddAccessAllowedAce
(ptr long long ptr
)
18 @ stdcall AddAccessAllowedAceEx
(ptr long long long ptr
)
19 # @ stub AddAccessAllowedObjectAce
20 @ stdcall AddAccessDeniedAce
(ptr long long ptr
)
21 @ stdcall AddAccessDeniedAceEx
(ptr long long long ptr
)
22 # @ stub AddAccessDeniedObjectAce
23 @ stdcall AddAce
(ptr long long ptr long
)
24 @ stdcall AddAuditAccessAce
(ptr long long ptr long long
)
25 @ stdcall AddAuditAccessAceEx
(ptr long long long ptr long long
)
26 # @ stub AddAuditAccessObjectAce
27 # @ stub AddUsersToEncryptedFile
28 @ stdcall AdjustTokenGroups
(long long ptr long ptr ptr
)
29 @ stdcall AdjustTokenPrivileges
(long long ptr long ptr ptr
)
30 @ stdcall AllocateAndInitializeSid
(ptr long long long long long long long long long ptr
)
31 @ stdcall AllocateLocallyUniqueId
(ptr
)
32 @ stdcall AreAllAccessesGranted
(long long
)
33 @ stdcall AreAnyAccessesGranted
(long long
)
34 @ stdcall BackupEventLogA
(long str
)
35 @ stdcall BackupEventLogW
(long wstr
)
36 @ stdcall BuildExplicitAccessWithNameA
(ptr str long long long
)
37 @ stdcall BuildExplicitAccessWithNameW
(ptr wstr long long long
)
38 # @ stub BuildImpersonateExplicitAccessWithNameA
39 # @ stub BuildImpersonateExplicitAccessWithNameW
40 # @ stub BuildImpersonateTrusteeA
41 # @ stub BuildImpersonateTrusteeW
42 @ stdcall BuildSecurityDescriptorA
(ptr ptr long ptr long ptr ptr ptr ptr
)
43 @ stdcall BuildSecurityDescriptorW
(ptr ptr long ptr long ptr ptr ptr ptr
)
44 @ stdcall BuildTrusteeWithNameA
(ptr str
)
45 @ stdcall BuildTrusteeWithNameW
(ptr wstr
)
46 @ stdcall BuildTrusteeWithObjectsAndNameA
(ptr ptr long str str str
)
47 @ stdcall BuildTrusteeWithObjectsAndNameW
(ptr ptr long wstr wstr wstr
)
48 @ stdcall BuildTrusteeWithObjectsAndSidA
(ptr ptr ptr ptr ptr
)
49 @ stdcall BuildTrusteeWithObjectsAndSidW
(ptr ptr ptr ptr ptr
)
50 @ stdcall BuildTrusteeWithSidA
(ptr ptr
)
51 @ stdcall BuildTrusteeWithSidW
(ptr ptr
)
52 # @ stub CancelOverlappedAccess
53 @ stdcall ChangeServiceConfig2A
(long long ptr
)
54 @ stdcall ChangeServiceConfig2W
(long long ptr
)
55 @ stdcall ChangeServiceConfigA
(long long long long wstr str ptr str str str str
)
56 @ stdcall ChangeServiceConfigW
(long long long long wstr wstr ptr wstr wstr wstr wstr
)
57 @ stdcall CheckTokenMembership
(long ptr ptr
)
58 @ stdcall ClearEventLogA
(long str
)
59 @ stdcall ClearEventLogW
(long wstr
)
60 # @ stub CloseCodeAuthzLevel
61 # @ stub CloseEncryptedFileRaw
62 @ stdcall CloseEventLog
(long
)
63 @ stdcall CloseServiceHandle
(long
)
65 @ stdcall CommandLineFromMsiDescriptor
(wstr ptr ptr
)
66 # @ stub ComputeAccessTokenFromCodeAuthzLevel
67 @ stdcall ControlService
(long long ptr
)
68 @ stdcall ControlTraceA
(int64 str ptr long
)
69 @ stdcall ControlTraceW
(int64 wstr ptr long
)
70 # @ stub ConvertAccessToSecurityDescriptorA
71 # @ stub ConvertAccessToSecurityDescriptorW
72 # @ stub ConvertSDToStringSDRootDomainA
73 # @ stub ConvertSDToStringSDRootDomainW
74 # @ stub ConvertSecurityDescriptorToAccessA
75 # @ stub ConvertSecurityDescriptorToAccessNamedA
76 # @ stub ConvertSecurityDescriptorToAccessNamedW
77 # @ stub ConvertSecurityDescriptorToAccessW
78 @ stdcall ConvertSecurityDescriptorToStringSecurityDescriptorA
(ptr long long ptr ptr
)
79 @ stdcall ConvertSecurityDescriptorToStringSecurityDescriptorW
(ptr long long ptr ptr
)
80 @ stdcall ConvertSidToStringSidA
(ptr ptr
)
81 @ stdcall ConvertSidToStringSidW
(ptr ptr
)
82 # @ stub ConvertStringSDToSDDomainA
83 # @ stub ConvertStringSDToSDDomainW
84 # @ stub ConvertStringSDToSDRootDomainA
85 # @ stub ConvertStringSDToSDRootDomainW
86 @ stdcall ConvertStringSecurityDescriptorToSecurityDescriptorA
(str long ptr ptr
)
87 @ stdcall ConvertStringSecurityDescriptorToSecurityDescriptorW
(wstr long ptr ptr
)
88 @ stdcall ConvertStringSidToSidA
(ptr ptr
)
89 @ stdcall ConvertStringSidToSidW
(ptr ptr
)
90 @ stdcall ConvertToAutoInheritPrivateObjectSecurity
(ptr ptr ptr ptr long ptr
)
91 @ stdcall CopySid
(long ptr ptr
)
92 # @ stub CreateCodeAuthzLevel
93 @ stdcall CreatePrivateObjectSecurity
(ptr ptr ptr long long ptr
)
94 # @ stub CreatePrivateObjectSecurityEx
95 # @ stub CreatePrivateObjectSecurityWithMultipleInheritance
96 @ stdcall CreateProcessAsUserA
(long str str ptr ptr long long ptr str ptr ptr
)
97 # @ stub CreateProcessAsUserSecure
98 @ stdcall CreateProcessAsUserW
(long wstr wstr ptr ptr long long ptr wstr ptr ptr
)
99 @ stdcall CreateProcessWithLogonW
(wstr wstr wstr long wstr wstr long ptr wstr ptr ptr
)
100 @ stdcall CreateRestrictedToken
(long long long ptr long ptr long ptr ptr
)
101 @ stdcall CreateServiceA
(long str str long long long long str str ptr str str str
)
102 @ stdcall CreateServiceW
(long wstr wstr long long long long wstr wstr ptr wstr wstr wstr
)
103 # @ stub CreateTraceInstanceId
104 @ stdcall CreateWellKnownSid
(long ptr ptr ptr
)
105 @ stdcall CredDeleteA
(str long long
)
106 @ stdcall CredDeleteW
(wstr long long
)
107 @ stdcall CredEnumerateA
(str long ptr ptr
)
108 @ stdcall CredEnumerateW
(wstr long ptr ptr
)
109 @ stdcall CredFree
(ptr
)
110 @ stdcall CredGetSessionTypes
(long ptr
)
111 # @ stub CredGetTargetInfoA
112 # @ stub CredGetTargetInfoW
113 # @ stub CredIsMarshaledCredentialA
114 # @ stub CredIsMarshaledCredentialW
115 # @ stub CredMarshalCredentialA
116 # @ stub CredMarshalCredentialW
117 @ stub CredProfileLoaded
118 @ stdcall CredReadA
(str long long ptr
)
119 @ stdcall CredReadDomainCredentialsA
(ptr long ptr ptr
)
120 @ stdcall CredReadDomainCredentialsW
(ptr long ptr ptr
)
121 @ stdcall CredReadW
(wstr long long ptr
)
124 # @ stub CredUnmarshalCredentialA
125 # @ stub CredUnmarshalCredentialW
126 @ stdcall CredWriteA
(ptr long
)
127 # @ stub CredWriteDomainCredentialsA
128 # @ stub CredWriteDomainCredentialsW
129 @ stdcall CredWriteW
(ptr long
)
130 # @ stub CredpConvertCredential
131 # @ stub CredpConvertTargetInfo
132 # @ stub CredpDecodeCredential
133 # @ stub CredpEncodeCredential
134 @ stdcall CryptAcquireContextA
(ptr str str long long
)
135 @ stdcall CryptAcquireContextW
(ptr wstr wstr long long
)
136 @ stdcall CryptContextAddRef
(long ptr long
)
137 @ stdcall CryptCreateHash
(long long long long ptr
)
138 @ stdcall CryptDecrypt
(long long long long ptr ptr
)
139 @ stdcall CryptDeriveKey
(long long long long ptr
)
140 @ stdcall CryptDestroyHash
(long
)
141 @ stdcall CryptDestroyKey
(long
)
142 @ stdcall CryptDuplicateHash
(long ptr long ptr
)
143 @ stdcall CryptDuplicateKey
(long ptr long ptr
)
144 @ stdcall CryptEncrypt
(long long long long ptr ptr long
)
145 @ stdcall CryptEnumProviderTypesA
(long ptr long ptr ptr ptr
)
146 @ stdcall CryptEnumProviderTypesW
(long ptr long ptr ptr ptr
)
147 @ stdcall CryptEnumProvidersA
(long ptr long ptr ptr ptr
)
148 @ stdcall CryptEnumProvidersW
(long ptr long ptr ptr ptr
)
149 @ stdcall CryptExportKey
(long long long long ptr ptr
)
150 @ stdcall CryptGenKey
(long long long ptr
)
151 @ stdcall CryptGenRandom
(long long ptr
)
152 @ stdcall CryptGetDefaultProviderA
(long ptr long ptr ptr
)
153 @ stdcall CryptGetDefaultProviderW
(long ptr long ptr ptr
)
154 @ stdcall CryptGetHashParam
(long long ptr ptr long
)
155 @ stdcall CryptGetKeyParam
(long long ptr ptr long
)
156 @ stdcall CryptGetProvParam
(long long ptr ptr long
)
157 @ stdcall CryptGetUserKey
(long long ptr
)
158 @ stdcall CryptHashData
(long ptr long long
)
159 @ stdcall CryptHashSessionKey
(long long long
)
160 @ stdcall CryptImportKey
(long ptr long long long ptr
)
161 @ stdcall CryptReleaseContext
(long long
)
162 @ stdcall CryptSetHashParam
(long long ptr long
)
163 @ stdcall CryptSetKeyParam
(long long ptr long
)
164 @ stdcall CryptSetProvParam
(long long ptr long
)
165 @ stdcall CryptSetProviderA
(str long
)
166 @ stdcall CryptSetProviderExA
(str long ptr long
)
167 @ stdcall CryptSetProviderExW
(wstr long ptr long
)
168 @ stdcall CryptSetProviderW
(wstr long
)
169 @ stdcall CryptSignHashA
(long long ptr long ptr ptr
)
170 @ stdcall CryptSignHashW
(long long ptr long ptr ptr
)
171 @ stdcall CryptVerifySignatureA
(long ptr long long ptr long
)
172 @ stdcall CryptVerifySignatureW
(long ptr long long ptr long
)
173 @ stdcall DecryptFileA
(str long
)
174 @ stdcall DecryptFileW
(wstr long
)
175 @ stdcall DeleteAce
(ptr long
)
176 @ stdcall DeleteService
(long
)
177 @ stdcall DeregisterEventSource
(long
)
178 @ stdcall DestroyPrivateObjectSecurity
(ptr
)
179 # @ stub DuplicateEncryptionInfoFile
180 @ stdcall DuplicateToken
(long long ptr
)
181 @ stdcall DuplicateTokenEx
(long long ptr long long ptr
)
182 # @ stub ElfBackupEventLogFileA
183 # @ stub ElfBackupEventLogFileW
184 # @ stub ElfChangeNotify
185 # @ stub ElfClearEventLogFileA
186 # @ stub ElfClearEventLogFileW
187 # @ stub ElfCloseEventLog
188 @ stub ElfDeregisterEventSource
189 @ stub ElfDeregisterEventSourceW
190 # @ stub ElfFlushEventLog
191 # @ stub ElfNumberOfRecords
192 # @ stub ElfOldestRecord
193 # @ stub ElfOpenBackupEventLogA
194 # @ stub ElfOpenBackupEventLogW
195 # @ stub ElfOpenEventLogA
196 # @ stub ElfOpenEventLogW
197 # @ stub ElfReadEventLogA
198 # @ stub ElfReadEventLogW
199 # @ stub ElfRegisterEventSourceA
200 @ stub ElfRegisterEventSourceW
201 # @ stub ElfReportEventA
202 @ stub ElfReportEventW
203 @ stdcall EnableTrace
(long long long ptr int64
)
204 @ stdcall EncryptFileA
(str
)
205 @ stdcall EncryptFileW
(wstr
)
206 # @ stub EncryptedFileKeyInfo
207 # @ stub EncryptionDisable
208 @ stdcall EnumDependentServicesA
(long long ptr long ptr ptr
)
209 @ stdcall EnumDependentServicesW
(long long ptr long ptr ptr
)
210 @ stub EnumServiceGroupA
211 @ stub EnumServiceGroupW
212 @ stdcall EnumServicesStatusA
(long long long ptr long ptr ptr ptr
)
213 @ stdcall EnumServicesStatusExA
(long long long long ptr long ptr ptr ptr str
)
214 @ stdcall EnumServicesStatusExW
(long long long long ptr long ptr ptr ptr wstr
)
215 @ stdcall EnumServicesStatusW
(long long long ptr long ptr ptr ptr
)
216 # @ stub EnumerateTraceGuids
217 # @ stub EqualDomainSid
218 @ stdcall EqualPrefixSid
(ptr ptr
)
219 @ stdcall EqualSid
(ptr ptr
)
220 @ stdcall EventEnabled
(int64 ptr
)
221 @ stdcall EventRegister
(ptr ptr ptr ptr
)
222 @ stdcall FileEncryptionStatusA
(str ptr
)
223 @ stdcall FileEncryptionStatusW
(wstr ptr
)
224 @ stdcall FindFirstFreeAce
(ptr ptr
)
225 @ stdcall FlushTraceA
(int64 str ptr
)
226 @ stdcall FlushTraceW
(int64 wstr ptr
)
227 # @ stub FreeEncryptedFileKeyInfo
228 # @ stub FreeEncryptionCertificateHashList
229 # @ stub FreeInheritedFromArray
230 @ stdcall FreeSid
(ptr
)
231 # @ stub GetAccessPermissionsForObjectA
232 # @ stub GetAccessPermissionsForObjectW
233 @ stdcall GetAce
(ptr long ptr
)
234 @ stdcall GetAclInformation
(ptr ptr long long
)
235 @ stdcall GetAuditedPermissionsFromAclA
(ptr ptr ptr ptr
)
236 @ stdcall GetAuditedPermissionsFromAclW
(ptr ptr ptr ptr
)
237 @ stdcall GetCurrentHwProfileA
(ptr
)
238 @ stdcall GetCurrentHwProfileW
(ptr
)
239 @ stdcall GetEffectiveRightsFromAclA
(ptr ptr ptr
)
240 @ stdcall GetEffectiveRightsFromAclW
(ptr ptr ptr
)
241 @ stdcall GetEventLogInformation
(long long ptr long ptr
)
242 @ stdcall GetExplicitEntriesFromAclA
(ptr ptr ptr
)
243 @ stdcall GetExplicitEntriesFromAclW
(ptr ptr ptr
)
244 @ stdcall GetFileSecurityA
(str long ptr long ptr
)
245 @ stdcall GetFileSecurityW
(wstr long ptr long ptr
)
246 # @ stub GetInformationCodeAuthzLevelW
247 # @ stub GetInformationCodeAuthzPolicyW
248 # @ stub GetInheritanceSourceA
249 # @ stub GetInheritanceSourceW
250 @ stdcall GetKernelObjectSecurity
(long long ptr long ptr
)
251 @ stdcall GetLengthSid
(ptr
)
252 # @ stub GetLocalManagedApplicationData
253 # @ stub GetLocalManagedApplications
254 # @ stub GetManagedApplicationCategories
255 # @ stub GetManagedApplications
256 @ stub GetMangledSiteSid
257 # @ stub GetMultipleTrusteeA
258 # @ stub GetMultipleTrusteeOperationA
259 # @ stub GetMultipleTrusteeOperationW
260 # @ stub GetMultipleTrusteeW
261 @ stdcall GetNamedSecurityInfoA
(str long long ptr ptr ptr ptr ptr
)
262 # @ stub GetNamedSecurityInfoExA
263 # @ stub GetNamedSecurityInfoExW
264 @ stdcall GetNamedSecurityInfoW
(wstr long long ptr ptr ptr ptr ptr
)
265 @ stdcall GetNumberOfEventLogRecords
(long ptr
)
266 @ stdcall GetOldestEventLogRecord
(long ptr
)
267 # @ stub GetOverlappedAccessResults
268 @ stdcall GetPrivateObjectSecurity
(ptr long ptr long ptr
)
269 @ stdcall GetSecurityDescriptorControl
(ptr ptr ptr
)
270 @ stdcall GetSecurityDescriptorDacl
(ptr ptr ptr ptr
)
271 @ stdcall GetSecurityDescriptorGroup
(ptr ptr ptr
)
272 @ stdcall GetSecurityDescriptorLength
(ptr
)
273 @ stdcall GetSecurityDescriptorOwner
(ptr ptr ptr
)
274 # @ stub GetSecurityDescriptorRMControl
275 @ stdcall GetSecurityDescriptorSacl
(ptr ptr ptr ptr
)
276 @ stdcall GetSecurityInfo
(long long long ptr ptr ptr ptr ptr
)
277 @ stdcall GetSecurityInfoExA
(long long long str str ptr ptr ptr ptr
)
278 @ stdcall GetSecurityInfoExW
(long long long wstr wstr ptr ptr ptr ptr
)
279 @ stdcall GetServiceDisplayNameA
(ptr str ptr ptr
)
280 @ stdcall GetServiceDisplayNameW
(ptr wstr ptr ptr
)
281 @ stdcall GetServiceKeyNameA
(long str ptr ptr
)
282 @ stdcall GetServiceKeyNameW
(long wstr ptr ptr
)
283 @ stdcall GetSidIdentifierAuthority
(ptr
)
284 @ stdcall GetSidLengthRequired
(long
)
285 @ stdcall GetSidSubAuthority
(ptr long
)
286 @ stdcall GetSidSubAuthorityCount
(ptr
)
287 @ stub GetSiteSidFromToken
288 @ stdcall GetTokenInformation
(long long ptr long ptr
)
289 # @ stub GetTraceEnableFlags
290 # @ stub GetTraceEnableLevel
291 # @ stub GetTraceLoggerHandle
292 @ stdcall GetTrusteeFormA
(ptr
)
293 @ stdcall GetTrusteeFormW
(ptr
)
294 @ stdcall GetTrusteeNameA
(ptr
)
295 @ stdcall GetTrusteeNameW
(ptr
)
296 @ stdcall GetTrusteeTypeA
(ptr
)
297 @ stdcall GetTrusteeTypeW
(ptr
)
298 @ stdcall GetUserNameA
(ptr ptr
)
299 @ stdcall GetUserNameW
(ptr ptr
)
300 # @ stub GetWindowsAccountDomainSid
301 # @ stub I_ScGetCurrentGroupStateW
302 # @ stub I_ScIsSecurityProcess
303 # @ stub I_ScPnPGetServiceName
304 # @ stub I_ScSendTSMessage
305 @ stub I_ScSetServiceBit
306 @ stub I_ScSetServiceBitsA
307 # @ stub I_ScSetServiceBitsW
308 # @ stub IdentifyCodeAuthzLevelW
309 # @ stub ImpersonateAnonymousToken
310 @ stdcall ImpersonateLoggedOnUser
(long
)
311 @ stdcall ImpersonateNamedPipeClient
(long
)
312 @ stdcall ImpersonateSelf
(long
)
313 @ stdcall InitializeAcl
(ptr long long
)
314 @ stdcall InitializeSecurityDescriptor
(ptr long
)
315 @ stdcall InitializeSid
(ptr ptr long
)
316 @ stdcall InitiateSystemShutdownA
(str str long long long
)
317 @ stdcall InitiateSystemShutdownExA
(str str long long long long
)
318 @ stdcall InitiateSystemShutdownExW
(wstr wstr long long long long
)
319 @ stdcall InitiateSystemShutdownW
(wstr wstr long long long
)
320 @ stub InstallApplication
321 @ stub IsProcessRestricted
322 @ stdcall IsTextUnicode
(ptr long ptr
)
323 @ stdcall IsTokenRestricted
(long
)
324 # @ stub IsTokenUntrusted
325 @ stdcall IsValidAcl
(ptr
)
326 @ stdcall IsValidSecurityDescriptor
(ptr
)
327 @ stdcall IsValidSid
(ptr
)
328 @ stdcall IsWellKnownSid
(ptr long
)
329 @ stdcall LockServiceDatabase
(ptr
)
330 @ stdcall LogonUserA
(str str str long long ptr
)
331 # @ stub LogonUserExA
332 # @ stub LogonUserExW
333 @ stdcall LogonUserW
(wstr wstr wstr long long ptr
)
334 @ stdcall LookupAccountNameA
(str str ptr ptr ptr ptr ptr
)
335 @ stdcall LookupAccountNameW
(wstr wstr ptr ptr ptr ptr ptr
)
336 @ stdcall LookupAccountSidA
(ptr ptr ptr ptr ptr ptr ptr
)
337 @ stdcall LookupAccountSidW
(ptr ptr ptr ptr ptr ptr ptr
)
338 @ stdcall LookupPrivilegeDisplayNameA
(str str str ptr ptr
)
339 @ stdcall LookupPrivilegeDisplayNameW
(wstr wstr wstr ptr ptr
)
340 @ stdcall LookupPrivilegeNameA
(str ptr ptr long
)
341 @ stdcall LookupPrivilegeNameW
(wstr ptr ptr long
)
342 @ stdcall LookupPrivilegeValueA
(ptr ptr ptr
)
343 @ stdcall LookupPrivilegeValueW
(ptr ptr ptr
)
344 # @ stub LookupSecurityDescriptorPartsA
345 # @ stub LookupSecurityDescriptorPartsW
346 @ stdcall LsaAddAccountRights
(ptr ptr ptr long
)
347 @ stub LsaAddPrivilegesToAccount
348 # @ stub LsaClearAuditLog
349 @ stdcall LsaClose
(ptr
)
350 @ stub LsaCreateAccount
351 @ stub LsaCreateSecret
352 @ stub LsaCreateTrustedDomain
353 @ stdcall LsaCreateTrustedDomainEx
(ptr ptr ptr long ptr
)
355 @ stdcall LsaDeleteTrustedDomain
(ptr ptr
)
356 @ stdcall LsaEnumerateAccountRights
(ptr ptr ptr ptr
)
357 @ stub LsaEnumerateAccounts
358 @ stdcall LsaEnumerateAccountsWithUserRight
(ptr ptr ptr ptr
)
359 @ stub LsaEnumeratePrivileges
360 @ stub LsaEnumeratePrivilegesOfAccount
361 @ stdcall LsaEnumerateTrustedDomains
(ptr ptr ptr long ptr
)
362 @ stdcall LsaEnumerateTrustedDomainsEx
(ptr ptr ptr long ptr
)
363 @ stdcall LsaFreeMemory
(ptr
)
364 # @ stub LsaGetQuotasForAccount
365 # @ stub LsaGetRemoteUserName
366 @ stub LsaGetSystemAccessAccount
367 # @ stub LsaGetUserName
368 @ stub LsaICLookupNames
369 # @ stub LsaICLookupNamesWithCreds
370 @ stub LsaICLookupSids
371 # @ stub LsaICLookupSidsWithCreds
372 @ stdcall LsaLookupNames2
(ptr long long ptr ptr ptr
)
373 @ stdcall LsaLookupNames
(long long ptr ptr ptr
)
374 @ stub LsaLookupPrivilegeDisplayName
375 # @ stub LsaLookupPrivilegeName
376 # @ stub LsaLookupPrivilegeValue
377 @ stdcall LsaLookupSids
(ptr long ptr ptr ptr
)
378 @ stdcall LsaNtStatusToWinError
(long
)
379 @ stub LsaOpenAccount
380 @ stdcall LsaOpenPolicy
(long long long long
)
381 # @ stub LsaOpenPolicySce
383 @ stub LsaOpenTrustedDomain
384 @ stdcall LsaOpenTrustedDomainByName
(ptr ptr long ptr
)
385 # @ stub LsaQueryDomainInformationPolicy
386 # @ stub LsaQueryForestTrustInformation
387 @ stub LsaQueryInfoTrustedDomain
388 @ stdcall LsaQueryInformationPolicy
(ptr long ptr
)
389 @ stub LsaQuerySecret
390 # @ stub LsaQuerySecurityObject
391 @ stdcall LsaQueryTrustedDomainInfo
(ptr ptr long ptr
)
392 @ stdcall LsaQueryTrustedDomainInfoByName
(ptr ptr long ptr
)
393 @ stdcall LsaRegisterPolicyChangeNotification
(long long
)
394 @ stdcall LsaRemoveAccountRights
(ptr ptr long ptr long
)
395 @ stub LsaRemovePrivilegesFromAccount
396 @ stdcall LsaRetrievePrivateData
(ptr ptr ptr
)
397 # @ stub LsaSetDomainInformationPolicy
398 # @ stub LsaSetForestTrustInformation
399 @ stdcall LsaSetInformationPolicy
(long long ptr
)
400 @ stub LsaSetInformationTrustedDomain
401 # @ stub LsaSetQuotasForAccount
402 @ stdcall LsaSetSecret
(ptr ptr ptr
)
403 # @ stub LsaSetSecurityObject
404 @ stub LsaSetSystemAccessAccount
405 @ stdcall LsaSetTrustedDomainInfoByName
(ptr ptr long ptr
)
406 @ stdcall LsaSetTrustedDomainInformation
(ptr ptr long ptr
)
407 @ stdcall LsaStorePrivateData
(ptr ptr ptr
)
408 @ stdcall LsaUnregisterPolicyChangeNotification
(long long
)
409 @ stdcall MD4Final
(ptr
)
410 @ stdcall MD4Init
(ptr
)
411 @ stdcall MD4Update
(ptr ptr long
)
412 @ stdcall MD5Final
(ptr
)
413 @ stdcall MD5Init
(ptr
)
414 @ stdcall MD5Update
(ptr ptr long
)
415 # @ stub MSChapSrvChangePassword2
416 # @ stub MSChapSrvChangePassword
417 # @ stub MakeAbsoluteSD2
418 @ stdcall MakeAbsoluteSD
(ptr ptr ptr ptr ptr ptr ptr ptr ptr ptr ptr
)
419 @ stdcall MakeSelfRelativeSD
(ptr ptr ptr
)
420 @ stdcall MapGenericMask
(ptr ptr
)
421 @ stdcall NotifyBootConfigStatus
(long
)
422 @ stdcall NotifyChangeEventLog
(long long
)
423 @ stdcall ObjectCloseAuditAlarmA
(str ptr long
)
424 @ stdcall ObjectCloseAuditAlarmW
(wstr ptr long
)
425 # @ stub ObjectDeleteAuditAlarmA
426 @ stdcall ObjectDeleteAuditAlarmW
(wstr ptr long
)
427 @ stdcall ObjectOpenAuditAlarmA
(str ptr str str ptr long long long ptr long long ptr
)
428 @ stdcall ObjectOpenAuditAlarmW
(wstr ptr wstr wstr ptr long long long ptr long long ptr
)
429 @ stdcall ObjectPrivilegeAuditAlarmA
(str ptr long long ptr long
)
430 @ stdcall ObjectPrivilegeAuditAlarmW
(wstr ptr long long ptr long
)
431 @ stdcall OpenBackupEventLogA
(str str
)
432 @ stdcall OpenBackupEventLogW
(wstr wstr
)
433 # @ stub OpenEncryptedFileRawA
434 # @ stub OpenEncryptedFileRawW
435 @ stdcall OpenEventLogA
(str str
)
436 @ stdcall OpenEventLogW
(wstr wstr
)
437 @ stdcall OpenProcessToken
(long long ptr
)
438 @ stdcall OpenSCManagerA
(str str long
)
439 @ stdcall OpenSCManagerW
(wstr wstr long
)
440 @ stdcall OpenServiceA
(long str long
)
441 @ stdcall OpenServiceW
(long wstr long
)
442 @ stdcall OpenThreadToken
(long long long ptr
)
445 @ stdcall PrivilegeCheck
(ptr ptr ptr
)
446 @ stdcall PrivilegedServiceAuditAlarmA
(str str long ptr long
)
447 @ stdcall PrivilegedServiceAuditAlarmW
(wstr wstr long ptr long
)
448 # @ stub ProcessIdleTasks
449 # @ stub ProcessTrace
450 @ stdcall QueryAllTracesA
(ptr long ptr
)
451 @ stdcall QueryAllTracesW
(ptr long ptr
)
452 # @ stub QueryRecoveryAgentsOnEncryptedFile
453 @ stdcall QueryServiceConfig2A
(long long ptr long ptr
)
454 @ stdcall QueryServiceConfig2W
(long long ptr long ptr
)
455 @ stdcall QueryServiceConfigA
(long ptr long ptr
)
456 @ stdcall QueryServiceConfigW
(long ptr long ptr
)
457 @ stdcall QueryServiceLockStatusA
(long ptr long ptr
)
458 @ stdcall QueryServiceLockStatusW
(long ptr long ptr
)
459 @ stdcall QueryServiceObjectSecurity
(long long ptr long ptr
)
460 @ stdcall QueryServiceStatus
(long ptr
)
461 @ stdcall QueryServiceStatusEx
(long long ptr long ptr
)
463 @ stdcall QueryTraceW
(int64 wstr ptr
)
464 # @ stub QueryUsersOnEncryptedFile
465 @ stdcall QueryWindows31FilesMigration
(long
)
466 # @ stub ReadEncryptedFileRaw
467 @ stdcall ReadEventLogA
(long long long ptr long ptr ptr
)
468 @ stdcall ReadEventLogW
(long long long ptr long ptr ptr
)
469 @ stdcall RegCloseKey
(long
)
470 @ stdcall RegConnectRegistryA
(str long ptr
)
471 @ stdcall RegConnectRegistryW
(wstr long ptr
)
472 @ stdcall RegCreateKeyA
(long str ptr
)
473 @ stdcall RegCreateKeyExA
(long str long ptr long long ptr ptr ptr
)
474 @ stdcall RegCreateKeyExW
(long wstr long ptr long long ptr ptr ptr
)
475 @ stdcall RegCreateKeyW
(long wstr ptr
)
476 @ stdcall RegDeleteKeyA
(long str
)
477 @ stdcall RegDeleteKeyExA
(long str long long
)
478 @ stdcall RegDeleteKeyExW
(long wstr long long
)
479 @ stdcall RegDeleteKeyW
(long wstr
)
480 @ stdcall RegDeleteTreeA
(long str
)
481 @ stdcall RegDeleteTreeW
(long wstr
)
482 @ stdcall RegDeleteValueA
(long str
)
483 @ stdcall RegDeleteValueW
(long wstr
)
484 @ stdcall RegDisablePredefinedCache
()
485 @ stdcall RegEnumKeyA
(long long ptr long
)
486 @ stdcall RegEnumKeyExA
(long long ptr ptr ptr ptr ptr ptr
)
487 @ stdcall RegEnumKeyExW
(long long ptr ptr ptr ptr ptr ptr
)
488 @ stdcall RegEnumKeyW
(long long ptr long
)
489 @ stdcall RegEnumValueA
(long long ptr ptr ptr ptr ptr ptr
)
490 @ stdcall RegEnumValueW
(long long ptr ptr ptr ptr ptr ptr
)
491 @ stdcall RegFlushKey
(long
)
492 @ stdcall RegGetKeySecurity
(long long ptr ptr
)
493 @ stdcall RegGetValueA
(long str str long ptr ptr ptr
)
494 @ stdcall RegGetValueW
(long wstr wstr long ptr ptr ptr
)
495 @ stdcall RegLoadKeyA
(long str str
)
496 @ stdcall RegLoadKeyW
(long wstr wstr
)
497 @ stdcall RegLoadMUIStringA
(long str str long ptr long str
)
498 @ stdcall RegLoadMUIStringW
(long wstr wstr long ptr long wstr
)
499 @ stdcall RegNotifyChangeKeyValue
(long long long long long
)
500 @ stdcall RegOpenCurrentUser
(long ptr
)
501 @ stdcall RegOpenKeyA
(long str ptr
)
502 @ stdcall RegOpenKeyExA
(long str long long ptr
)
503 @ stdcall RegOpenKeyExW
(long wstr long long ptr
)
504 @ stdcall RegOpenKeyW
(long wstr ptr
)
505 @ stdcall RegOpenUserClassesRoot
(ptr long long ptr
)
506 @ stdcall RegOverridePredefKey
(long long
)
507 @ stdcall RegQueryInfoKeyA
(long ptr ptr ptr ptr ptr ptr ptr ptr ptr ptr ptr
)
508 @ stdcall RegQueryInfoKeyW
(long ptr ptr ptr ptr ptr ptr ptr ptr ptr ptr ptr
)
509 @ stdcall RegQueryMultipleValuesA
(long ptr long ptr ptr
)
510 @ stdcall RegQueryMultipleValuesW
(long ptr long ptr ptr
)
511 @ stdcall RegQueryValueA
(long str ptr ptr
)
512 @ stdcall RegQueryValueExA
(long str ptr ptr ptr ptr
)
513 @ stdcall RegQueryValueExW
(long wstr ptr ptr ptr ptr
)
514 @ stdcall RegQueryValueW
(long wstr ptr ptr
)
515 @ stub RegRemapPreDefKey
516 @ stdcall RegReplaceKeyA
(long str str str
)
517 @ stdcall RegReplaceKeyW
(long wstr wstr wstr
)
518 @ stdcall RegRestoreKeyA
(long str long
)
519 @ stdcall RegRestoreKeyW
(long wstr long
)
520 @ stdcall RegSaveKeyA
(long ptr ptr
)
521 # @ stub RegSaveKeyExA
522 # @ stub RegSaveKeyExW
523 @ stdcall RegSaveKeyW
(long ptr ptr
)
524 @ stdcall RegSetKeySecurity
(long long ptr
)
525 @ stdcall RegSetValueA
(long str long ptr long
)
526 @ stdcall RegSetValueExA
(long str long long ptr long
)
527 @ stdcall RegSetValueExW
(long wstr long long ptr long
)
528 @ stdcall RegSetValueW
(long wstr long ptr long
)
529 @ stdcall RegUnLoadKeyA
(long str
)
530 @ stdcall RegUnLoadKeyW
(long wstr
)
531 @ stdcall RegisterEventSourceA
(ptr ptr
)
532 @ stdcall RegisterEventSourceW
(ptr ptr
)
533 # @ stub RegisterIdleTask
534 @ stdcall RegisterServiceCtrlHandlerA
(str ptr
)
535 @ stdcall RegisterServiceCtrlHandlerExA
(str ptr ptr
)
536 @ stdcall RegisterServiceCtrlHandlerExW
(wstr ptr ptr
)
537 @ stdcall RegisterServiceCtrlHandlerW
(wstr ptr
)
538 @ stdcall RegisterTraceGuidsA
(ptr ptr ptr long ptr str str ptr
)
539 @ stdcall RegisterTraceGuidsW
(ptr ptr ptr long ptr wstr wstr ptr
)
540 # @ stub RemoveTraceCallback
541 # @ stub RemoveUsersFromEncryptedFile
542 @ stdcall ReportEventA
(long long long long ptr long long str ptr
)
543 @ stdcall ReportEventW
(long long long long ptr long long wstr ptr
)
544 @ stdcall RevertToSelf
()
545 @ stdcall SaferCloseLevel
(ptr
)
546 @ stdcall SaferComputeTokenFromLevel
(ptr ptr ptr long ptr
)
547 @ stdcall SaferCreateLevel
(long long long ptr ptr
)
548 # @ stub SaferGetLevelInformation
549 @ stdcall SaferGetPolicyInformation
(long long long ptr ptr ptr
)
550 # @ stub SaferIdentifyLevel
551 # @ stub SaferRecordEventLogEntry
552 # @ stub SaferSetLevelInformation
553 # @ stub SaferSetPolicyInformation
554 # @ stub SaferiChangeRegistryScope
555 # @ stub SaferiCompareTokenLevels
556 # @ stub SaferiIsExecutableFileType
557 # @ stub SaferiPopulateDefaultsInRegistry
558 # @ stub SaferiRecordEventLogEntry
559 # @ stub SaferiReplaceProcessThreadTokens
560 # @ stub SaferiSearchMatchingHashRules
561 @ stdcall SetAclInformation
(ptr ptr long long
)
562 # @ stub SetEntriesInAccessListA
563 # @ stub SetEntriesInAccessListW
564 @ stdcall SetEntriesInAclA
(long ptr ptr ptr
)
565 @ stdcall SetEntriesInAclW
(long ptr ptr ptr
)
566 # @ stub SetEntriesInAuditListA
567 # @ stub SetEntriesInAuditListW
568 @ stdcall SetFileSecurityA
(str long ptr
)
569 @ stdcall SetFileSecurityW
(wstr long ptr
)
570 # @ stub SetInformationCodeAuthzLevelW
571 # @ stub SetInformationCodeAuthzPolicyW
572 @ stdcall SetKernelObjectSecurity
(long long ptr
)
573 @ stdcall SetNamedSecurityInfoA
(str long ptr ptr ptr ptr ptr
)
574 # @ stub SetNamedSecurityInfoExA
575 # @ stub SetNamedSecurityInfoExW
576 @ stdcall SetNamedSecurityInfoW
(wstr long ptr ptr ptr ptr ptr
)
577 @ stdcall SetPrivateObjectSecurity
(long ptr ptr ptr long
)
578 # @ stub SetPrivateObjectSecurityEx
579 @ stdcall SetSecurityDescriptorControl
(ptr long long
)
580 @ stdcall SetSecurityDescriptorDacl
(ptr long ptr long
)
581 @ stdcall SetSecurityDescriptorGroup
(ptr ptr long
)
582 @ stdcall SetSecurityDescriptorOwner
(ptr ptr long
)
583 # @ stub SetSecurityDescriptorRMControl
584 @ stdcall SetSecurityDescriptorSacl
(ptr long ptr long
)
585 @ stdcall SetSecurityInfo
(long long long ptr ptr ptr ptr
)
586 # @ stub SetSecurityInfoExA
587 # @ stub SetSecurityInfoExW
588 @ stdcall SetServiceBits
(long long long long
)
589 @ stdcall SetServiceObjectSecurity
(long long ptr
)
590 @ stdcall SetServiceStatus
(long long
)
591 @ stdcall SetThreadToken
(ptr ptr
)
592 @ stdcall SetTokenInformation
(long long ptr long
)
593 # @ stub SetTraceCallback
594 # @ stub SetUserFileEncryptionKey
595 @ stdcall StartServiceA
(long long ptr
)
596 @ stdcall StartServiceCtrlDispatcherA
(ptr
)
597 @ stdcall StartServiceCtrlDispatcherW
(ptr
)
598 @ stdcall StartServiceW
(long long ptr
)
599 @ stdcall StartTraceA
(ptr str ptr
)
600 @ stdcall StartTraceW
(ptr wstr ptr
)
603 @ stdcall SynchronizeWindows31FilesAndWindowsNTRegistry
(long long long long
)
604 @ stdcall SystemFunction001
(ptr ptr ptr
)
605 @ stdcall SystemFunction002
(ptr ptr ptr
)
606 @ stdcall SystemFunction003
(ptr ptr
)
607 @ stdcall SystemFunction004
(ptr ptr ptr
)
608 @ stdcall SystemFunction005
(ptr ptr ptr
)
609 @ stdcall SystemFunction006
(ptr ptr
)
610 @ stdcall SystemFunction007
(ptr ptr
)
611 @ stdcall SystemFunction008
(ptr ptr ptr
)
612 @ stdcall SystemFunction009
(ptr ptr ptr
)
613 @ stdcall SystemFunction010
(ptr ptr ptr
)
614 @ stdcall SystemFunction011
(ptr ptr ptr
) SystemFunction010
615 @ stdcall SystemFunction012
(ptr ptr ptr
)
616 @ stdcall SystemFunction013
(ptr ptr ptr
)
617 @ stdcall SystemFunction014
(ptr ptr ptr
) SystemFunction012
618 @ stdcall SystemFunction015
(ptr ptr ptr
) SystemFunction013
619 @ stdcall SystemFunction016
(ptr ptr ptr
) SystemFunction012
620 @ stdcall SystemFunction017
(ptr ptr ptr
) SystemFunction013
621 @ stdcall SystemFunction018
(ptr ptr ptr
) SystemFunction012
622 @ stdcall SystemFunction019
(ptr ptr ptr
) SystemFunction013
623 @ stdcall SystemFunction020
(ptr ptr ptr
) SystemFunction012
624 @ stdcall SystemFunction021
(ptr ptr ptr
) SystemFunction013
625 @ stdcall SystemFunction022
(ptr ptr ptr
) SystemFunction012
626 @ stdcall SystemFunction023
(ptr ptr ptr
) SystemFunction013
627 @ stdcall SystemFunction024
(ptr ptr ptr
)
628 @ stdcall SystemFunction025
(ptr ptr ptr
)
629 @ stdcall SystemFunction026
(ptr ptr ptr
) SystemFunction024
630 @ stdcall SystemFunction027
(ptr ptr ptr
) SystemFunction025
631 @ stub SystemFunction028
632 @ stub SystemFunction029
633 @ stdcall SystemFunction030
(ptr ptr
)
634 @ stdcall SystemFunction031
(ptr ptr
) SystemFunction030
635 @ stdcall SystemFunction032
(ptr ptr
)
636 @ stub SystemFunction033
637 @ stub SystemFunction034
638 @ stdcall SystemFunction035
(str
)
639 @ stdcall SystemFunction036
(ptr long
) # RtlGenRandom
640 @ stdcall SystemFunction040
(ptr long long
) # RtlEncryptMemory
641 @ stdcall SystemFunction041
(ptr long long
) # RtlDecryptMemory
642 @ stdcall TraceEvent
(int64 ptr
)
643 @ stub TraceEventInstance
645 @ stub TraceMessageVa
646 # @ stub TreeResetNamedSecurityInfoA
647 @ stdcall TreeResetNamedSecurityInfoW
(wstr long long ptr ptr ptr ptr long ptr long ptr
)
648 # @ stub TrusteeAccessToObjectA
649 # @ stub TrusteeAccessToObjectW
650 # @ stub UninstallApplication
651 @ stdcall UnlockServiceDatabase
(ptr
)
652 # @ stub UnregisterIdleTask
653 @ stdcall UnregisterTraceGuids
(int64
)
656 @ stub WdmWmiServiceMain
658 # @ stub WmiCloseTraceWithCursor
659 # @ stub WmiConvertTimestamp
660 # @ stub WmiDevInstToInstanceNameA
661 # @ stub WmiDevInstToInstanceNameW
662 # @ stub WmiEnumerateGuids
663 # @ stub WmiExecuteMethodA
664 # @ stub WmiExecuteMethodW
665 # @ stub WmiFileHandleToInstanceNameA
666 # @ stub WmiFileHandleToInstanceNameW
667 # @ stub WmiFreeBuffer
668 # @ stub WmiGetFirstTraceOffset
669 # @ stub WmiGetNextEvent
670 # @ stub WmiGetTraceHeader
671 # @ stub WmiMofEnumerateResourcesA
672 # @ stub WmiMofEnumerateResourcesW
673 # @ stub WmiNotificationRegistrationA
674 # @ stub WmiNotificationRegistrationW
676 # @ stub WmiOpenTraceWithCursor
677 # @ stub WmiParseTraceEvent
678 # @ stub WmiQueryAllDataA
679 # @ stub WmiQueryAllDataMultipleA
680 # @ stub WmiQueryAllDataMultipleW
681 # @ stub WmiQueryAllDataW
682 # @ stub WmiQueryGuidInformation
683 # @ stub WmiQuerySingleInstanceA
684 # @ stub WmiQuerySingleInstanceMultipleA
685 # @ stub WmiQuerySingleInstanceMultipleW
686 @ stub WmiQuerySingleInstanceW
687 # @ stub WmiReceiveNotificationsA
688 # @ stub WmiReceiveNotificationsW
689 # @ stub WmiSetSingleInstanceA
690 @ stub WmiSetSingleInstanceW
691 # @ stub WmiSetSingleItemA
692 # @ stub WmiSetSingleItemW
693 # @ stub Wow64Win32ApiEntry
694 # @ stub WriteEncryptedFileRaw