Finished separation of shell32 and wsock32.
[wine/multimedia.git] / dlls / shell32 / shell.spec
blobd91cd1b4360cc2be19c1bfe968b80b60c5fd3552
1 name shell
2 type win16
3 owner shell32
5 1 pascal RegOpenKey(long str ptr) RegOpenKey16
6 2 pascal RegCreateKey(long str ptr) RegCreateKey16
7 3 pascal RegCloseKey(long) RegCloseKey16
8 4 pascal RegDeleteKey(long str) RegDeleteKey16
9 5 pascal RegSetValue(long str long str long) RegSetValue16
10 6 pascal RegQueryValue(long str ptr ptr) RegQueryValue16
11 7 pascal RegEnumKey(long long ptr long) RegEnumKey16
12 9 pascal16 DragAcceptFiles(word word) DragAcceptFiles16
13 11 pascal16 DragQueryFile(word s_word ptr s_word) DragQueryFile16
14 12 pascal16 DragFinish(word) DragFinish16
15 13 pascal16 DragQueryPoint(word ptr) DragQueryPoint16
16 20 pascal16 ShellExecute(word str str str str s_word) ShellExecute16
17 21 pascal16 FindExecutable(str str ptr) FindExecutable16
18 22 pascal16 ShellAbout(word ptr ptr word) ShellAbout16
19 33 pascal16 AboutDlgProc(word word word long) AboutDlgProc16
20 34 pascal16 ExtractIcon(word str s_word) ExtractIcon16
21 36 pascal16 ExtractAssociatedIcon(word ptr ptr) ExtractAssociatedIcon16
22 37 pascal DoEnvironmentSubst(ptr word) DoEnvironmentSubst16
23 38 pascal FindEnvironmentString(ptr) FindEnvironmentString16
24 39 pascal16 InternalExtractIcon(word ptr s_word word) InternalExtractIcon16
25 40 pascal16 ExtractIconEx(str word ptr ptr word) ExtractIconEx16
26 # 98 stub SHL3216_THUNKDATA16
27 # 99 stub SHL1632_THUNKDATA16
29 #100 4 0550 HERETHARBETYGARS exported, shared data
30 #101 8 010e FINDEXEDLGPROC exported, shared data
31 101 pascal DllEntryPoint(long word word word long word) SHELL_DllEntryPoint
33 102 pascal16 RegisterShellHook(word word) RegisterShellHook16
34 103 pascal ShellHookProc(word word long) ShellHookProc16
36 157 stub RESTARTDIALOG
37 # 166 PICKICONDLG
39 262 pascal16 DriveType(long) DriveType16
41 # 263 SH16TO32DRIVEIOCTL
42 # 264 SH16TO32INT2526
43 # 300 SHGETFILEINFO
44 # 400 SHFORMATDRIVE
45 401 stub SHCHECKDRIVE
46 # 402 _RUNDLLCHECKDRIVE
48 # 8 WEP
49 #32 WCI