5 # Functions exported by the Win95 comctl32.dll
6 # (these need to have these exact ordinals, because some win95 dlls
7 # import comctl32.dll by ordinal)
8 # This list was created from a comctl32.dll v4.72 (IE4.01).
10 2 stdcall MenuHelp
(long long long long long long ptr
) MenuHelp
11 3 stdcall ShowHideMenuCtl
(long long ptr
) ShowHideMenuCtl
12 4 stdcall GetEffectiveClientRect
(long long long
) GetEffectiveClientRect
13 5 stdcall DrawStatusTextA
(long ptr str long
) DrawStatusText32A
14 6 stdcall CreateStatusWindowA
(long str long long
) CreateStatusWindow32A
15 7 stdcall CreateToolbar
(long long long long long long ptr long
) CreateToolbar
16 8 stdcall CreateMappedBitmap
(long long long ptr long
) CreateMappedBitmap
19 11 stdcall DPA_Merge
(ptr ptr long ptr ptr long
) DPA_Merge
20 #12 stub Cctl1632_ThunkData32
24 16 stdcall CreateUpDownControl
(long long long long long long long long long long long long
) CreateUpDownControl
25 17 stdcall InitCommonControls
() InitCommonControls
26 18 stub CreatePropertySheetPage
27 19 stdcall CreatePropertySheetPageA
(ptr
) CreatePropertySheetPage32A
28 20 stdcall CreatePropertySheetPageW
(ptr
) CreatePropertySheetPage32W
29 21 stdcall CreateStatusWindow
(long str long long
) CreateStatusWindow32AW
30 22 stdcall CreateStatusWindowW
(long wstr long long
) CreateStatusWindow32W
31 23 stdcall CreateToolbarEx
(long long long long long long ptr long long long long long long
) CreateToolbarEx
32 24 stdcall DestroyPropertySheetPage
(long
) DestroyPropertySheetPage32
33 25 stdcall DllGetVersion
(ptr
) COMCTL32_DllGetVersion
35 27 stdcall DrawStatusText
(long ptr ptr long
) DrawStatusText32AW
36 28 stdcall DrawStatusTextW
(long ptr wstr long
) DrawStatusText32W
37 29 stub FlatSB_EnableScrollBar
38 30 stub FlatSB_GetScrollInfo
39 31 stub FlatSB_GetScrollPos
40 32 stub FlatSB_GetScrollProp
41 33 stub FlatSB_GetScrollRange
42 34 stub FlatSB_SetScrollInfo
43 35 stub FlatSB_SetScrollPos
44 36 stub FlatSB_SetScrollProp
45 37 stub FlatSB_SetScrollRange
46 38 stub FlatSB_ShowScrollBar
47 39 stdcall ImageList_Add
(ptr long long
) ImageList_Add
48 40 stdcall ImageList_AddIcon
(ptr long
) ImageList_AddIcon
49 41 stdcall ImageList_AddMasked
(ptr long long
) ImageList_AddMasked
50 42 stdcall ImageList_BeginDrag
(ptr long long long
) ImageList_BeginDrag
51 43 stdcall ImageList_Copy
(ptr long ptr long long
) ImageList_Copy
52 44 stdcall ImageList_Create
(long long long long long
) ImageList_Create
53 45 stdcall ImageList_Destroy
(ptr
) ImageList_Destroy
54 46 stdcall ImageList_DragEnter
(long long long
) ImageList_DragEnter
55 47 stdcall ImageList_DragLeave
(long
) ImageList_DragLeave
56 48 stdcall ImageList_DragMove
(long long
) ImageList_DragMove
57 49 stdcall ImageList_DragShowNolock
(long
) ImageList_DragShowNolock
58 50 stdcall ImageList_Draw
(ptr long long long long long
) ImageList_Draw
59 51 stdcall ImageList_DrawEx
(ptr long long long long long long long long long
) ImageList_DrawEx
60 52 stdcall ImageList_DrawIndirect
(ptr
) ImageList_DrawIndirect
61 53 stdcall ImageList_Duplicate
(ptr
) ImageList_Duplicate
62 54 stdcall ImageList_EndDrag
() ImageList_EndDrag
63 55 stdcall ImageList_GetBkColor
(ptr
) ImageList_GetBkColor
64 56 stdcall ImageList_GetDragImage
(ptr ptr
) ImageList_GetDragImage
65 57 stdcall ImageList_GetIcon
(ptr long long
) ImageList_GetIcon
66 58 stdcall ImageList_GetIconSize
(ptr ptr ptr
) ImageList_GetIconSize
67 59 stdcall ImageList_GetImageCount
(ptr
) ImageList_GetImageCount
68 60 stdcall ImageList_GetImageInfo
(ptr long ptr
) ImageList_GetImageInfo
69 61 stdcall ImageList_GetImageRect
(ptr long ptr
) ImageList_GetImageRect
70 62 stdcall ImageList_LoadImage
(long str long long long long long
) ImageList_LoadImage32AW
71 63 stdcall ImageList_LoadImageA
(long str long long long long long
) ImageList_LoadImage32A
72 64 stdcall ImageList_LoadImageW
(long wstr long long long long long
) ImageList_LoadImage32W
73 65 stdcall ImageList_Merge
(ptr long ptr long long long
) ImageList_Merge
74 66 stdcall ImageList_Read
(ptr
) ImageList_Read
75 67 stdcall ImageList_Remove
(ptr long
) ImageList_Remove
76 68 stdcall ImageList_Replace
(ptr long long long
) ImageList_Replace
77 69 stdcall ImageList_ReplaceIcon
(ptr long long
) ImageList_ReplaceIcon
78 70 stdcall ImageList_SetBkColor
(ptr long
) ImageList_SetBkColor
79 71 stdcall Alloc
(long
) COMCTL32_Alloc
80 72 stdcall ReAlloc
(ptr long
) COMCTL32_ReAlloc
81 73 stdcall Free
(ptr
) COMCTL32_Free
82 74 stdcall GetSize
(ptr
) COMCTL32_GetSize
83 75 stdcall ImageList_SetDragCursorImage
(ptr long long long
) ImageList_SetDragCursorImage
84 76 stdcall ImageList_SetFilter
(ptr long long
) ImageList_SetFilter
85 77 stdcall ImageList_SetIconSize
(ptr long long
) ImageList_SetIconSize
86 78 stdcall ImageList_SetImageCount
(ptr long
) ImageList_SetImageCount
87 79 stdcall ImageList_SetOverlayImage
(ptr long long
) ImageList_SetOverlayImage
88 80 stdcall ImageList_Write
(ptr ptr
) ImageList_Write
89 81 stdcall InitCommonControlsEx
(ptr
) InitCommonControlsEx
90 82 stub InitializeFlatSB
92 84 stdcall PropertySheetA
(ptr
) PropertySheet32A
93 85 stdcall PropertySheetW
(ptr
) PropertySheet32W
94 86 stub UninitializeFlatSB
95 87 stub _TrackMouseEvent
97 151 stdcall CreateMRUListA
(ptr
) CreateMRUList32A
98 152 stdcall FreeMRUList
(ptr
) FreeMRUList32A
99 153 stub AddMRUStringA@
8
100 154 stub EnumMRUListA@
16
101 155 stub FindMRUStringA@
12
102 156 stub DelMRUString@
8
103 157 stdcall CreateMRUListLazyA
(ptr long long long
) CreateMRUListLazy32A
106 164 stub CreateProxyPage
108 167 stdcall AddMRUData
(ptr long long
) AddMRUData
109 169 stdcall FindMRUData
(ptr long long long
) FindMRUData
111 233 stdcall Str_GetPtrA
(str str long
) Str_GetPtr32A
112 234 stdcall Str_SetPtrA
(str str
) Str_SetPtr32A
113 235 stdcall Str_GetPtrW
(wstr wstr long
) Str_GetPtr32W
114 236 stdcall Str_SetPtrW
(wstr wstr
) Str_SetPtr32W
116 320 stdcall DSA_Create
(long long
) DSA_Create
117 321 stdcall DSA_Destroy
(ptr
) DSA_Destroy
118 322 stdcall DSA_GetItem
(ptr long long
) DSA_GetItem
119 323 stdcall DSA_GetItemPtr
(ptr long
) DSA_GetItemPtr
120 324 stdcall DSA_InsertItem
(ptr long long
) DSA_InsertItem
121 325 stdcall DSA_SetItem
(ptr long long
) DSA_SetItem
122 326 stdcall DSA_DeleteItem
(ptr long
) DSA_DeleteItem
123 327 stdcall DSA_DeleteAllItems
(ptr
) DSA_DeleteAllItems
124 328 stdcall DPA_Create
(long
) DPA_Create
125 329 stdcall DPA_Destroy
(ptr
) DPA_Destroy
126 330 stdcall DPA_Grow
(ptr long
) DPA_Grow
127 331 stdcall DPA_Clone
(ptr ptr
) DPA_Clone
128 332 stdcall DPA_GetPtr
(ptr long
) DPA_GetPtr
129 333 stdcall DPA_GetPtrIndex
(ptr ptr
) DPA_GetPtrIndex
130 334 stdcall DPA_InsertPtr
(ptr long ptr
) DPA_InsertPtr
131 335 stdcall DPA_SetPtr
(ptr long ptr
) DPA_SetPtr
132 336 stdcall DPA_DeletePtr
(ptr long
) DPA_DeletePtr
133 337 stdcall DPA_DeleteAllPtrs
(ptr
) DPA_DeleteAllPtrs
134 338 stdcall DPA_Sort
(ptr ptr long
) DPA_Sort
135 339 stdcall DPA_Search
(ptr ptr long ptr long long
) DPA_Search
136 340 stdcall DPA_CreateEx
(long long
) DPA_CreateEx
137 341 stdcall SendNotify
(long long long ptr
) COMCTL32_SendNotify
138 342 stdcall SendNotifyEx
(long long long ptr long
) COMCTL32_SendNotifyEx
140 350 stdcall StrChrA
(str str
) COMCTL32_StrChrA
141 351 stdcall StrRChrA
(str str long
) COMCTL32_StrRChrA
142 352 stdcall StrCmpNA
(str str long
) COMCTL32_StrCmpNA
144 354 stdcall StrStrA
(str str
) COMCTL32_StrStrA
145 355 stdcall StrStrIA
(str str
) COMCTL32_StrStrIA
146 356 stdcall StrCSpnA
(str str
) COMCTL32_StrCSpnA
147 357 stdcall StrToIntA
(str
) COMCTL32_StrToIntA
148 358 stdcall StrChrW
(wstr long
) COMCTL32_StrChrW
149 359 stdcall StrRChrW
(wstr wstr long
) COMCTL32_StrRChrW
150 360 stdcall StrCmpNW
(wstr wstr long
) COMCTL32_StrCmpNW
152 362 stdcall StrStrW
(wstr wstr
) COMCTL32_StrStrW
154 364 stdcall StrSpnW
(wstr wstr
) COMCTL32_StrSpnW
165 376 stub IntlStrEqWorkerA@
16
166 377 stub IntlStrEqWorkerW@
16
168 382 stub SmoothScrollWindow@
4
169 383 stub DoReaderMode@
4
170 384 stub SetPathWordBreakProc@
8
171 385 stdcall DPA_EnumCallback
(long long long
) DPA_EnumCallback
172 386 stdcall DPA_DestroyCallback
(ptr ptr long
) DPA_DestroyCallback
173 387 stdcall DSA_EnumCallback
(ptr ptr long
) DSA_EnumCallback
174 388 stdcall DSA_DestroyCallback
(ptr ptr long
) DSA_DestroyCallback
175 389 stub COMCTL32_389
176 390 stub COMCTL32_390
178 400 stub CreateMRUListW@
4
179 401 stub AddMRUStringW@
8
180 402 stub FindMRUStringW@
12
181 403 stub EnumMRUListW@
16
182 404 stub CreateMRUListLazyW@
16
184 410 stub COMCTL32_410
185 411 stub COMCTL32_411
186 412 stub COMCTL32_412
187 413 stub COMCTL32_413