1 # C RunTime DLL. All functions use cdecl!
6 001 cdecl ??
2@YAPAXI@Z
(long
) CRTDLL_new
7 002 cdecl ??
3@YAXPAX@Z
(long
) CRTDLL_delete
8 003 cdecl ?_set_new_handler@@YAP6AHI@ZP6AHI@Z@Z
(ptr
) CRTDLL_set_new_handler
27 022 cdecl __GetMainArgs
(ptr ptr ptr long
) CRTDLL__GetMainArgs
28 023 extern __argc_dll CRTDLL_argc_dll
29 024 extern __argv_dll CRTDLL_argv_dll
36 031 stub __mb_cur_max_dll
37 032 stub __pxcptinfoptrs
38 033 stub __threadhandle
41 036 stub _abnormal_termination
43 038 extern _acmdln_dll CRTDLL_acmdln_dll
44 039 stub _aexit_rtn_dll
47 042 extern _basemajor_dll CRTDLL_basemajor_dll
48 043 extern _baseminor_dll CRTDLL_baseminor_dll
49 044 extern _baseversion_dll CRTDLL_baseversion_dll
56 051 cdecl _chdir
(ptr
) CRTDLL__chdir
57 052 cdecl _chdrive
(long
) CRTDLL__chdrive
64 059 long _commode_dll
(0)
75 070 stub _daylight_dll
80 075 extern _environ_dll CRTDLL_environ_dll
82 077 cdecl _errno
() CRTDLL__errno
83 078 stub _except_handler2
100 095 stub _fileinfo_dll
109 104 long _fmode_dll
(0)
122 117 stub _get_osfhandle
127 122 stub _getdiskfree
128 123 stub _getdllprocaddr
134 129 stub _global_unwind2
140 135 cdecl _initterm
(ptr ptr
) CRTDLL__initterm
142 137 cdecl _isatty
(long
) CRTDLL__isatty
143 138 cdecl _isctype
(long long
) CRTDLL__isctype
147 142 stub _ismbbkalnum
149 144 stub _ismbbkpunct
165 160 stub _ismbcsymbol
178 173 stub _local_unwind2
192 187 stub _mbcjistojms
193 188 stub _mbcjmstojis
202 197 cdecl _mbscat
(ptr ptr
) CRTDLL__mbscat
205 200 cdecl _mbscpy
(ptr ptr
) CRTDLL__mbscpy
209 204 cdecl _mbsicmp
(ptr ptr
) CRTDLL__mbsicmp
210 205 cdecl _mbsinc
(ptr
) CRTDLL__mbsinc
239 234 cdecl _mkdir
(ptr
) CRTDLL__mkdir
245 240 stub _open_osfhandle
246 241 extern _osmajor_dll CRTDLL_osmajor_dll
247 242 extern _osminor_dll CRTDLL_osminor_dll
248 243 long _osmode_dll
(0)
249 244 extern _osver_dll CRTDLL_osver_dll
250 245 extern _osversion_dll CRTDLL_osversion_dll
260 255 stub _pwctype_dll
268 263 stub _seterrormode
270 265 cdecl _setmode
(long long
) CRTDLL__setmode
287 282 cdecl _strcmpi
(ptr ptr
) lstrcmpi32A
290 285 cdecl _strdup
(ptr
) CRTDLL__strdup
292 287 cdecl _stricmp
(ptr ptr
) lstrcmpi32A
298 293 cdecl _strnicmp
(ptr ptr long
) lstrncmpi32A
305 300 cdecl _strupr
(ptr
) CRTDLL__strupr
307 302 stub _sys_errlist
308 303 stub _sys_nerr_dll
311 306 stub _timezone_dll
326 321 cdecl _wcsicmp
(ptr ptr
) lstrcmpi32W
327 322 cdecl _wcsicoll
(ptr ptr
) CRTDLL__wcsicoll
328 323 cdecl _wcslwr
(ptr
) CRTDLL__wcslwr
331 326 cdecl _wcsrev
(ptr
) CRTDLL__wcsrev
333 328 cdecl _wcsupr
(ptr
) CRTDLL__wcsupr
334 329 extern _winmajor_dll CRTDLL_winmajor_dll
335 330 extern _winminor_dll CRTDLL_winminor_dll
336 331 extern _winver_dll CRTDLL_winver_dll
337 332 cdecl _write
(long ptr long
) CRTDLL__write
344 339 cdecl abs
(long
) CRTDLL_abs
345 340 cdecl acos
(long
) CRTDLL_acos
346 341 cdecl asctime
(ptr
) asctime
347 342 cdecl asin
(long
) CRTDLL_asin
348 343 cdecl atan
(long
) CRTDLL_atan
349 344 cdecl atan2
(long long
) CRTDLL_atan2
350 345 cdecl atexit
(ptr
) CRTDLL_atexit
351 346 cdecl atof
(ptr
) CRTDLL_atof
352 347 cdecl atoi
(ptr
) CRTDLL_atoi
353 348 cdecl atol
(ptr
) CRTDLL_atol
355 350 cdecl calloc
(long long
) CRTDLL_calloc
358 353 cdecl clock
() clock
359 354 cdecl cos
(long
) CRTDLL_cos
360 355 cdecl cosh
(long
) CRTDLL_cosh
361 356 cdecl ctime
(ptr
) ctime
363 358 cdecl div
(long long
) div
364 359 cdecl
exit(long
) CRTDLL_exit
365 360 cdecl exp
(long
) CRTDLL_exp
366 361 cdecl fabs
(long
) CRTDLL_fabs
367 362 cdecl fclose
(ptr
) CRTDLL_fclose
370 365 cdecl fflush
(ptr
) CRTDLL_fflush
378 373 cdecl fprintf
() CRTDLL_fprintf
383 378 cdecl free
(ptr
) CRTDLL_free
396 391 cdecl gets
(ptr
) CRTDLL_gets
397 392 cdecl gmtime
(ptr
) gmtime
399 394 cdecl isalnum
(long
) CRTDLL_isalnum
400 395 cdecl isalpha
(long
) CRTDLL_isalpha
401 396 cdecl iscntrl
(long
) CRTDLL_iscntrl
402 397 cdecl isdigit
(long
) CRTDLL_isdigit
403 398 cdecl isgraph
(long
) CRTDLL_isgraph
405 400 cdecl islower
(long
) CRTDLL_islower
406 401 cdecl isprint
(long
) CRTDLL_isprint
407 402 cdecl ispunct
(long
) CRTDLL_ispunct
408 403 cdecl isspace
(long
) CRTDLL_isspace
409 404 cdecl isupper
(long
) CRTDLL_isupper
423 418 cdecl isxdigit
(long
) CRTDLL_isxdigit
424 419 cdecl labs
(long
) CRTDLL_labs
426 421 cdecl ldiv
(long long
) ldiv
428 423 cdecl localtime
(ptr
) localtime
429 424 cdecl log
(long
) CRTDLL_log
430 425 cdecl log10
(long
) CRTDLL_log10
432 427 cdecl malloc
(ptr
) CRTDLL_malloc
434 429 cdecl mbstowcs
(ptr ptr long
) CRTDLL_mbstowcs
435 430 cdecl mbtowc
(long
) CRTDLL_mbtowc
436 431 cdecl memchr
(ptr long long
) memchr
437 432 cdecl memcmp
(ptr ptr long
) memcmp
438 433 cdecl memcpy
(ptr ptr long
) memcpy
439 434 cdecl memmove
(ptr ptr long
) memmove
440 435 cdecl memset
(ptr long long
) memset
441 436 cdecl mktime
(ptr
) mktime
444 439 cdecl pow
(long long
) CRTDLL_pow
445 440 cdecl
printf() CRTDLL_printf
447 442 cdecl putchar
(long
) CRTDLL_putchar
449 444 cdecl qsort
(ptr long long ptr
) qsort
451 446 cdecl rand
() CRTDLL_rand
452 447 cdecl realloc
(ptr long
) CRTDLL_realloc
458 453 cdecl setlocale
(long ptr
) CRTDLL_setlocale
461 456 cdecl sin
(long
) CRTDLL_sin
462 457 cdecl sinh
(long
) CRTDLL_sinh
463 458 cdecl sprintf
() CRTDLL_sprintf
464 459 cdecl sqrt
(long
) CRTDLL_sqrt
465 460 cdecl srand
(long
) CRTDLL_srand
466 461 cdecl sscanf
() CRTDLL_sscanf
467 462 cdecl strcat
(ptr ptr
) strcat
468 463 cdecl strchr
(ptr long
) strchr
469 464 cdecl strcmp
(ptr ptr
) strcmp
470 465 cdecl strcoll
(ptr ptr
) strcoll
471 466 cdecl strcpy
(ptr ptr
) strcpy
472 467 cdecl strcspn
(ptr ptr
) strcspn
474 469 cdecl strftime
(ptr long ptr ptr
) strftime
475 470 cdecl strlen
(ptr
) strlen
476 471 cdecl strncat
(ptr ptr long
) strncat
477 472 cdecl strncmp
(ptr ptr long
) strncmp
478 473 cdecl strncpy
(ptr ptr long
) strncpy
479 474 cdecl strpbrk
(ptr ptr
) strpbrk
480 475 cdecl strrchr
(ptr long
) strrchr
481 476 cdecl strspn
(ptr ptr
) strspn
482 477 cdecl strstr
(ptr ptr
) strstr
484 479 cdecl strtok
(ptr ptr
) strtok
485 480 cdecl strtol
(ptr ptr long
) strtol
486 481 cdecl strtoul
(ptr ptr long
) strtoul
487 482 cdecl strxfrm
(ptr ptr long
) strxfrm
488 483 cdecl swprintf
() CRTDLL_swprintf
491 486 cdecl tan
(long
) CRTDLL_tan
492 487 cdecl tanh
(long
) CRTDLL_tanh
493 488 cdecl
time(ptr
) CRTDLL_time
496 491 cdecl tolower
(long
) CRTDLL_tolower
497 492 cdecl toupper
(long
) CRTDLL_toupper
499 494 cdecl towupper
(long
) CRTDLL_towupper
505 500 cdecl vsprintf
() CRTDLL_vsprintf
508 503 cdecl wcscat
(ptr ptr
) lstrcat32W
509 504 cdecl wcschr
(ptr long
) CRTDLL_wcschr
511 506 cdecl wcscoll
(ptr ptr
) CRTDLL_wcscoll
512 507 cdecl wcscpy
(ptr ptr
) lstrcpy32W
513 508 cdecl wcscspn
(ptr ptr
) CRTDLL_wcscspn
515 510 cdecl wcslen
(ptr
) lstrlen32W
516 511 cdecl wcsncat
(ptr ptr long
) lstrcatn32W
517 512 cdecl wcsncmp
(ptr ptr long
) lstrncmp32W
518 513 cdecl wcsncpy
(ptr ptr long
) lstrcpyn32W
520 515 cdecl wcsrchr
(ptr long
) CRTDLL_wcsrchr
521 516 cdecl wcsspn
(ptr ptr
) CRTDLL_wcsspn
522 517 cdecl wcsstr
(ptr ptr
) CRTDLL_wcsstr