Remove remnants of the old code.
[wine/multimedia.git] / dlls / wininet / wininet.spec
bloba29676ecc321c7e54e7c8ad55ca799c973ead231
1 @ stdcall InternetInitializeAutoProxyDll(long)
2 @ stub ShowCertificate
3 @ stdcall CommitUrlCacheEntryA(str str double double long str long str str)
4 @ stub CommitUrlCacheEntryW
5 @ stub CreateUrlCacheContainerA
6 @ stub CreateUrlCacheContainerW
7 @ stdcall CreateUrlCacheEntryA(str long str ptr long)
8 @ stub CreateUrlCacheEntryW
9 @ stdcall CreateUrlCacheGroup(long ptr)
10 @ stub DeleteIE3Cache
11 @ stub DeleteUrlCacheContainerA
12 @ stub DeleteUrlCacheContainerW
13 @ stdcall DeleteUrlCacheEntry(str)
14 @ stdcall DeleteUrlCacheGroup(double long ptr)
15 @ stdcall DetectAutoProxyUrl(str long long)
16 @ stdcall DllInstall(long ptr) WININET_DllInstall
17 @ stub FindCloseUrlCache
18 @ stub FindFirstUrlCacheContainerA
19 @ stub FindFirstUrlCacheContainerW
20 @ stdcall FindFirstUrlCacheEntryA(str ptr ptr)
21 @ stub FindFirstUrlCacheEntryExA
22 @ stub FindFirstUrlCacheEntryExW
23 @ stdcall FindFirstUrlCacheEntryW(wstr ptr ptr)
24 @ stub FindNextUrlCacheContainerA
25 @ stub FindNextUrlCacheContainerW
26 @ stub FindNextUrlCacheEntryA
27 @ stub FindNextUrlCacheEntryExA
28 @ stub FindNextUrlCacheEntryExW
29 @ stub FindNextUrlCacheEntryW
30 @ stub FreeUrlCacheSpaceA
31 @ stub FreeUrlCacheSpaceW
32 @ stub FtpCommandA
33 @ stub FtpCommandW
34 @ stdcall FtpCreateDirectoryA(ptr str)
35 @ stdcall FtpCreateDirectoryW(ptr wstr)
36 @ stdcall FtpDeleteFileA(ptr str)
37 @ stub FtpDeleteFileW
38 @ stdcall FtpFindFirstFileA(ptr str ptr long long)
39 @ stdcall FtpFindFirstFileW(ptr wstr ptr long long)
40 @ stdcall FtpGetCurrentDirectoryA(ptr str ptr)
41 @ stdcall FtpGetCurrentDirectoryW(ptr wstr ptr)
42 @ stdcall FtpGetFileA(ptr str str long long long long)
43 @ stdcall FtpGetFileW(ptr wstr wstr long long long long)
44 @ stdcall FtpOpenFileA(ptr str long long long)
45 @ stdcall FtpOpenFileW(ptr wstr long long long)
46 @ stdcall FtpPutFileA(ptr str str long long)
47 @ stub FtpPutFileW
48 @ stdcall FtpRemoveDirectoryA(ptr str)
49 @ stub FtpRemoveDirectoryW
50 @ stdcall FtpRenameFileA(ptr str str)
51 @ stub FtpRenameFileW
52 @ stdcall FtpSetCurrentDirectoryA(ptr str)
53 @ stdcall FtpSetCurrentDirectoryW(ptr wstr)
54 @ stdcall GetUrlCacheConfigInfoA(ptr ptr long)
55 @ stdcall GetUrlCacheConfigInfoW(ptr ptr long)
56 @ stdcall GetUrlCacheEntryInfoA(str ptr long)
57 @ stdcall GetUrlCacheEntryInfoExA(str ptr ptr str ptr ptr long)
58 @ stdcall GetUrlCacheEntryInfoExW(wstr ptr ptr wstr ptr ptr long)
59 @ stdcall GetUrlCacheEntryInfoW(wstr ptr long)
60 @ stub GetUrlCacheHeaderData
61 @ stub GopherCreateLocatorA
62 @ stub GopherCreateLocatorW
63 @ stub GopherFindFirstFileA
64 @ stub GopherFindFirstFileW
65 @ stub GopherGetAttributeA
66 @ stub GopherGetAttributeW
67 @ stub GopherGetLocatorTypeA
68 @ stub GopherGetLocatorTypeW
69 @ stub GopherOpenFileA
70 @ stub GopherOpenFileW
71 @ stdcall HttpAddRequestHeadersA(ptr str long long)
72 @ stub HttpAddRequestHeadersW
73 @ stdcall HttpEndRequestA(ptr ptr long long)
74 @ stdcall HttpEndRequestW(ptr ptr long long)
75 @ stdcall HttpOpenRequestA(ptr str str str str ptr long long)
76 @ stdcall HttpOpenRequestW(ptr wstr wstr wstr wstr ptr long long)
77 @ stdcall HttpQueryInfoA(ptr long ptr ptr ptr)
78 @ stdcall HttpQueryInfoW(ptr long ptr ptr ptr)
79 @ stdcall HttpSendRequestA(ptr str long ptr long)
80 @ stdcall HttpSendRequestExA(long ptr ptr long long)
81 @ stub HttpSendRequestExW
82 @ stdcall HttpSendRequestW(ptr wstr long ptr long)
83 @ stub IncrementUrlCacheHeaderData
84 @ stdcall InternetAttemptConnect(long)
85 @ stdcall InternetAutodial(long ptr)
86 @ stub InternetAutodialCallback
87 @ stdcall InternetAutodialHangup(long)
88 @ stdcall InternetCanonicalizeUrlA(str str ptr long)
89 @ stdcall InternetCanonicalizeUrlW(wstr wstr ptr long)
90 @ stdcall InternetCheckConnectionA(ptr long long)
91 @ stdcall InternetCheckConnectionW(ptr long long)
92 @ stdcall InternetCloseHandle(long)
93 @ stdcall InternetCombineUrlA(str str str ptr long)
94 @ stdcall InternetCombineUrlW(wstr wstr wstr ptr long)
95 @ stub InternetConfirmZoneCrossing
96 @ stdcall InternetConnectA(ptr str long str str long long long)
97 @ stdcall InternetConnectW(ptr wstr long wstr wstr long long long)
98 @ stdcall InternetCrackUrlA(str long long ptr)
99 @ stdcall InternetCrackUrlW(wstr long long ptr)
100 @ stdcall InternetCreateUrlA(ptr long ptr ptr)
101 @ stdcall InternetCreateUrlW(ptr long ptr ptr)
102 @ stub InternetDebugGetLocalTime
103 @ stub InternetDial
104 @ stdcall InternetErrorDlg(long long long long ptr)
105 @ stdcall InternetFindNextFileA(ptr ptr)
106 @ stub InternetFindNextFileW
107 @ stub InternetGetCertByURL
108 @ stdcall InternetGetConnectedState(ptr long)
109 @ stdcall InternetGetConnectedStateExW(ptr ptr long long)
110 @ stdcall InternetGetCookieA(str str ptr long)
111 @ stdcall InternetGetCookieW(wstr wstr ptr long)
112 @ stdcall InternetGetLastResponseInfoA(ptr str ptr)
113 @ stub InternetGetLastResponseInfoW
114 @ stub InternetGoOnline
115 @ stub InternetHangUp
116 @ stdcall InternetLockRequestFile(ptr ptr)
117 @ stdcall InternetOpenA(str long str str long)
118 @ stdcall InternetOpenW(wstr long wstr wstr long)
119 @ stub InternetOpenServerPushParse
120 @ stdcall InternetOpenUrlA(ptr str str long long long)
121 @ stdcall InternetOpenUrlW(ptr wstr wstr long long long)
122 @ stdcall InternetQueryDataAvailable(ptr ptr long long)
123 @ stdcall InternetQueryOptionA(ptr long ptr ptr)
124 @ stdcall InternetQueryOptionW(ptr long ptr ptr)
125 @ stdcall InternetReadFile(ptr ptr long ptr)
126 @ stdcall InternetReadFileExA(ptr ptr long long)
127 @ stdcall InternetReadFileExW(ptr ptr long long)
128 @ stub InternetServerPushParse
129 @ stdcall InternetSetCookieA(str str str)
130 @ stdcall InternetSetCookieW(wstr wstr wstr)
131 @ stub InternetSetDialState
132 @ stub InternetSetFilePointer
133 @ stdcall InternetSetOptionA(ptr long ptr long)
134 @ stdcall InternetSetOptionW(ptr long ptr long)
135 @ stdcall InternetSetOptionExA(ptr long ptr long long)
136 @ stdcall InternetSetOptionExW(ptr long ptr long long)
137 @ stdcall InternetSetStatusCallback(ptr ptr) InternetSetStatusCallbackA
138 @ stdcall InternetSetStatusCallbackA(ptr ptr)
139 @ stub InternetSetStatusCallbackW
140 @ stub InternetShowSecurityInfoByURL
141 @ stub InternetTimeFromSystemTime
142 @ stub InternetTimeToSystemTime
143 @ stdcall InternetUnlockRequestFile(ptr)
144 @ stdcall InternetWriteFile(ptr ptr long ptr)
145 @ stub InternetWriteFileExA
146 @ stub InternetWriteFileExW
147 @ stdcall IsHostInProxyBypassList(long str long)
148 @ stub LoadUrlCacheContent
149 @ stub ParseX509EncodedCertificateForListBoxEntry
150 @ stub ReadUrlCacheEntryStream
151 @ stdcall RetrieveUrlCacheEntryFileA(str ptr ptr long)
152 @ stub RetrieveUrlCacheEntryFileW
153 @ stub RetrieveUrlCacheEntryStreamA
154 @ stub RetrieveUrlCacheEntryStreamW
155 @ stub RunOnceUrlCache
156 @ stub SetUrlCacheConfigInfoA
157 @ stub SetUrlCacheConfigInfoW
158 @ stdcall SetUrlCacheEntryGroup(str long double ptr long ptr)
159 @ stdcall SetUrlCacheEntryInfoA(str ptr long)
160 @ stdcall SetUrlCacheEntryInfoW(wstr ptr long)
161 @ stub SetUrlCacheHeaderData
162 @ stub ShowClientAuthCerts
163 @ stub ShowSecurityInfo
164 @ stub ShowX509EncodedCertificate
165 @ stub UnlockUrlCacheEntryFile
166 @ stub UnlockUrlCacheEntryStream
167 @ stub UpdateUrlCacheContentPath