1 # $Id: gdi.spec,v 1.3 1993/07/04 04:04:21 root Exp root $
7 1 pascal SetBkColor
(word long
) SetBkColor
(1 2)
8 2 pascal16 SetBkMode
(word word
) SetBkMode
(1 2)
9 3 pascal16 SetMapMode
(word word
) SetMapMode
(1 2)
10 4 pascal16 SetROP2
(word word
) SetROP2
(1 2)
11 5 pascal16 SetRelAbs
(word word
) SetRelAbs
(1 2)
12 6 pascal16 SetPolyFillMode
(word word
) SetPolyFillMode
(1 2)
13 7 pascal16 SetStretchBltMode
(word word
) SetStretchBltMode
(1 2)
14 8 pascal16 SetTextCharacterExtra
(word s_word
) SetTextCharacterExtra
(1 2)
15 9 pascal SetTextColor
(word long
) SetTextColor
(1 2)
16 10 pascal16 SetTextJustification
(word s_word s_word
) SetTextJustification
(1 2 3)
17 11 pascal SetWindowOrg
(word s_word s_word
) SetWindowOrg
(1 2 3)
18 12 pascal SetWindowExt
(word s_word s_word
) SetWindowExt
(1 2 3)
19 13 pascal SetViewportOrg
(word s_word s_word
) SetViewportOrg
(1 2 3)
20 14 pascal SetViewportExt
(word s_word s_word
) SetViewportExt
(1 2 3)
21 15 pascal OffsetWindowOrg
(word s_word s_word
) OffsetWindowOrg
(1 2 3)
22 16 pascal ScaleWindowExt
(word s_word s_word s_word s_word
)
23 ScaleWindowExt
(1 2 3 4 5)
24 17 pascal OffsetViewportOrg
(word s_word s_word
) OffsetViewportOrg
(1 2 3)
25 18 pascal ScaleViewportExt
(word s_word s_word s_word s_word
)
26 ScaleViewportExt
(1 2 3 4 5)
27 19 pascal16 LineTo
(word s_word s_word
) LineTo
(1 2 3)
28 20 pascal MoveTo
(word s_word s_word
) MoveTo
(1 2 3)
29 21 pascal16 ExcludeClipRect
(word s_word s_word s_word s_word
)
30 ExcludeClipRect
(1 2 3 4 5)
31 22 pascal16 IntersectClipRect
(word s_word s_word s_word s_word
)
32 IntersectClipRect
(1 2 3 4 5)
33 23 pascal16 Arc
(word s_word s_word s_word s_word s_word s_word s_word s_word
)
34 Arc
(1 2 3 4 5 6 7 8 9)
35 24 pascal16 Ellipse
(word s_word s_word s_word s_word
) Ellipse
(1 2 3 4 5)
36 25 pascal16 FloodFill
(word s_word s_word long
) FloodFill
(1 2 3 4)
37 26 pascal16 Pie
(word s_word s_word s_word s_word s_word s_word s_word s_word
)
38 Pie
(1 2 3 4 5 6 7 8 9)
39 27 pascal16 Rectangle
(word s_word s_word s_word s_word
) Rectangle
(1 2 3 4 5)
40 28 pascal16 RoundRect
(word s_word s_word s_word s_word s_word s_word
)
41 RoundRect
(1 2 3 4 5 6 7)
42 29 pascal16 PatBlt
(word s_word s_word s_word s_word long
) PatBlt
(1 2 3 4 5 6)
43 30 pascal16 SaveDC
(word
) SaveDC
(1)
44 31 pascal SetPixel
(word s_word s_word long
) SetPixel
(1 2 3 4)
45 32 pascal16 OffsetClipRgn
(word s_word s_word
) OffsetClipRgn
(1 2 3)
46 33 pascal16 TextOut
(word s_word s_word ptr word
) TextOut
(1 2 3 4 5)
47 34 pascal16 BitBlt
( word s_word s_word s_word s_word word s_word s_word long
)
48 BitBlt
(1 2 3 4 5 6 7 8 9)
49 35 pascal16 StretchBlt
( word s_word s_word s_word s_word word s_word s_word s_word s_word long
)
50 StretchBlt
(1 2 3 4 5 6 7 8 9 10 11)
51 36 pascal16 Polygon
(word ptr word
) Polygon
(1 2 3)
52 37 pascal16 Polyline
(word ptr word
) Polyline
(1 2 3)
53 38 pascal Escape
(word word word ptr ptr
) Escape
(1 2 3 4 5)
54 39 pascal16 RestoreDC
(word s_word
) RestoreDC
(1 2)
55 40 pascal16 FillRgn
(word word word
) FillRgn
(1 2 3)
57 42 pascal16 InvertRgn
(word word
) InvertRgn
(1 2)
58 43 pascal16 PaintRgn
(word word
) PaintRgn
(1 2)
59 44 pascal16 SelectClipRgn
(word word
) SelectClipRgn
(1 2)
60 45 pascal16 SelectObject
(word word
) SelectObject
(1 2)
62 47 pascal16 CombineRgn
(word word word word
) CombineRgn
(1 2 3 4)
63 48 pascal16 CreateBitmap
(word word word word ptr
) CreateBitmap
(1 2 3 4 5)
64 49 pascal16 CreateBitmapIndirect
(ptr
) CreateBitmapIndirect
(1)
65 50 pascal16 CreateBrushIndirect
(ptr
) CreateBrushIndirect
(1)
66 51 pascal16 CreateCompatibleBitmap
(word word word
) CreateCompatibleBitmap
(1 2 3)
67 52 pascal16 CreateCompatibleDC
(word
) CreateCompatibleDC
(1)
68 53 pascal16 CreateDC
(ptr ptr ptr ptr
) CreateDC
(1 2 3 4)
69 54 pascal16 CreateEllipticRgn
(s_word s_word s_word s_word
)
70 CreateEllipticRgn
(1 2 3 4)
71 55 pascal16 CreateEllipticRgnIndirect
(ptr
) CreateEllipticRgnIndirect
(1)
72 56 pascal16 CreateFont
(s_word s_word s_word s_word s_word word word word
73 word word word word word ptr
)
74 CreateFont
(1 2 3 4 5 6 7 8 9 10 11 12 13 14)
75 57 pascal16 CreateFontIndirect
(ptr
) CreateFontIndirect
(1)
76 58 pascal16 CreateHatchBrush
(word long
) CreateHatchBrush
(1 2)
77 60 pascal16 CreatePatternBrush
(word
) CreatePatternBrush
(1)
78 61 pascal16 CreatePen
(s_word s_word long
) CreatePen
(1 2 3)
79 62 pascal16 CreatePenIndirect
(ptr
) CreatePenIndirect
(1)
80 63 pascal16 CreatePolygonRgn
(ptr word word
) CreatePolygonRgn
(1 2 3)
81 64 pascal16 CreateRectRgn
(s_word s_word s_word s_word
) CreateRectRgn
(1 2 3 4)
82 65 pascal16 CreateRectRgnIndirect
(ptr
) CreateRectRgnIndirect
(1)
83 66 pascal16 CreateSolidBrush
(long
) CreateSolidBrush
(1)
84 67 pascal16 DPtoLP
(word ptr s_word
) DPtoLP
(1 2 3)
85 68 pascal16 DeleteDC
(word
) DeleteDC
(1)
86 69 pascal16 DeleteObject
(word
) DeleteObject
(1)
87 70 pascal16 EnumFonts
(word ptr ptr ptr
) EnumFonts
(1 2 3 4)
88 71 pascal16 EnumObjects
(word word ptr ptr
) EnumObjects
(1 2 3 4)
89 72 pascal16 EqualRgn
(word word
) EqualRgn
(1 2)
90 73 pascal16 ExcludeVisRect
(word s_word s_word s_word s_word
)
91 ExcludeVisRect
(1 2 3 4 5)
92 74 pascal GetBitmapBits
(word long ptr
) GetBitmapBits
(1 2 3)
93 75 pascal GetBkColor
(word
) GetBkColor
(1)
94 76 pascal16 GetBkMode
(word
) GetBkMode
(1)
95 77 pascal16 GetClipBox
(word ptr
) GetClipBox
(1 2)
96 78 pascal GetCurrentPosition
(word
) GetCurrentPosition
(1)
97 79 pascal GetDCOrg
(word
) GetDCOrg
(1)
98 80 pascal16 GetDeviceCaps
(word s_word
) GetDeviceCaps
(1 2)
99 81 pascal16 GetMapMode
(word
) GetMapMode
(1)
100 82 pascal16 GetObject
(word word ptr
) GetObject
(1 2 3)
101 83 pascal GetPixel
(word s_word s_word
) GetPixel
(1 2 3)
102 84 pascal16 GetPolyFillMode
(word
) GetPolyFillMode
(1)
103 85 pascal16 GetROP2
(word
) GetROP2
(1)
104 86 pascal16 GetRelAbs
(word
) GetRelAbs
(1)
105 87 pascal16 GetStockObject
(word
) GetStockObject
(1)
106 88 pascal16 GetStretchBltMode
(word
) GetStretchBltMode
(1)
107 89 pascal16 GetTextCharacterExtra
(word
) GetTextCharacterExtra
(1)
108 90 pascal GetTextColor
(word
) GetTextColor
(1)
109 91 pascal GetTextExtent
(word ptr s_word
) GetTextExtent
(1 2 3)
110 92 pascal16 GetTextFace
(word s_word ptr
) GetTextFace
(1 2 3)
111 93 pascal16 GetTextMetrics
(word ptr
) GetTextMetrics
(1 2)
112 94 pascal GetViewportExt
(word
) GetViewportExt
(1)
113 95 pascal GetViewportOrg
(word
) GetViewportOrg
(1)
114 96 pascal GetWindowExt
(word
) GetWindowExt
(1)
115 97 pascal GetWindowOrg
(word
) GetWindowOrg
(1)
116 98 pascal16 IntersectVisRect
(word s_word s_word s_word s_word
)
117 IntersectVisRect
(1 2 3 4 5)
118 99 pascal16 LPtoDP
(word ptr s_word
) LPtoDP
(1 2 3)
119 100 pascal16 LineDDA
(s_word s_word s_word s_word ptr long
)
121 101 pascal16 OffsetRgn
(word s_word s_word
) OffsetRgn
(1 2 3)
122 102 pascal16 OffsetVisRgn
(word s_word s_word
) OffsetVisRgn
(1 2 3)
123 103 pascal16 PtVisible
(word s_word s_word
) PtVisible
(1 2 3)
124 104 pascal16 RectVisibleOld
(word ptr
) RectVisible
(1 2)
125 105 pascal16 SelectVisRgn
(word word
) SelectVisRgn
(1 2)
126 106 pascal SetBitmapBits
(word long ptr
) SetBitmapBits
(1 2 3)
127 117 pascal SetDCOrg
(word s_word s_word
) SetDCOrg
(1 2 3)
128 119 pascal16 AddFontResource
(ptr
) AddFontResource
(1)
130 #122 pascal ReSurRection
131 123 pascal16 PlayMetaFile
(word word
) PlayMetaFile
(1 2)
132 124 pascal16 GetMetaFile
(ptr
) GetMetaFile
(1)
133 125 pascal16 CreateMetaFile
(ptr
) CreateMetaFile
(1)
134 126 pascal16 CloseMetaFile
(word
) CloseMetaFile
(1)
135 127 pascal16 DeleteMetaFile
(word
) DeleteMetaFile
(1)
136 128 pascal MulDiv
(s_word s_word s_word
) MulDiv
(1 2 3)
137 129 pascal16 SaveVisRgn
(word
) SaveVisRgn
(1)
138 130 pascal16 RestoreVisRgn
(word
) RestoreVisRgn
(1)
139 131 pascal16 InquireVisRgn
(word
) InquireVisRgn
(1)
140 132 pascal16 SetEnvironment
(ptr ptr word
) SetEnvironment
(1 2 3)
141 133 pascal16 GetEnvironment
(ptr ptr word
) GetEnvironment
(1 2 3)
142 134 pascal16 GetRgnBox
(word ptr
) GetRgnBox
(1 2)
144 136 pascal16 RemoveFontResource
(ptr
) RemoveFontResource
(1)
145 148 pascal SetBrushOrg
(word s_word s_word
) SetBrushOrg
(1 2 3)
146 149 pascal GetBrushOrg
(word
) GetBrushOrg
(1)
147 150 pascal16 UnrealizeObject
(word
) UnrealizeObject
(1)
148 #151 pascal CopyMetaFile
149 153 pascal16 CreateIC
(ptr ptr ptr ptr
) CreateIC
(1 2 3 4)
150 154 pascal GetNearestColor
(word long
) GetNearestColor
(1 2)
151 #155 pascal QueryAbort
152 156 pascal16 CreateDiscardableBitmap
(word word word
)
153 CreateDiscardableBitmap
(1 2 3)
154 #159 pascal GetMetaFileBits
155 #160 pascal SetMetaFileBits
156 161 pascal16 PtInRegion
(word s_word s_word
) PtInRegion
(1 2 3)
157 162 pascal GetBitmapDimension
(word
) GetBitmapDimension
(1)
158 163 pascal SetBitmapDimension
(word s_word s_word
) SetBitmapDimension
(1 2 3)
159 #169 pascal IsDCDirty
160 #170 pascal SetDCStatus
161 172 pascal16 SetRectRgn
(word s_word s_word s_word s_word
) SetRectRgn
(1 2 3 4 5)
162 173 pascal16 GetClipRgn
(word
) GetClipRgn
(1)
163 #175 pascal EnumMetaFile
164 176 pascal16 PlayMetaFileRecord
(word ptr ptr word
) PlayMetaFileRecord
(1 2 3 4)
165 179 pascal16 GetDCState
(word
) GetDCState
(1)
166 180 pascal16 SetDCState
(word word
) SetDCState
(1 2)
167 181 pascal16 RectInRegionOld
(word ptr
) RectInRegion
(1 2)
168 #190 pascal SetDCHook
169 #191 pascal GetDCHook
170 #192 pascal SetHookFlags
171 #193 pascal SetBoundsRect
172 #194 pascal GetBoundsRect
173 #195 pascal SelectBitmap
174 #196 pascal SetMetaFileBitsBetter
176 #202 pascal DMCOLORINFO
177 #206 pascal DMENUMDFONTS
178 #207 pascal DMENUMOBJ
181 #210 pascal DMREALIZEOBJECT
185 #214 pascal DMEXTTEXTOUT
186 #215 pascal DMGETCHARWIDTH
187 #216 pascal DMSTRETCHBLT
188 #217 pascal DMDIBBITS
189 #218 pascal DMSTRETCHDIBITS
190 #219 pascal DMSETDIBTODEV
191 #220 pascal DMTRANSPOSE
194 #232 pascal EXTRACTPQ
199 #241 pascal WRITESPOOL
200 #242 pascal WRITEDIALOG
202 #244 pascal DELETEJOB
203 #245 pascal GETSPOOLJOB
204 #246 pascal STARTSPOOLPAGE
205 #247 pascal ENDSPOOLPAGE
207 250 pascal16 Copy
(ptr ptr word
) Copy
(1 2 3)
208 #253 pascal DeleteSpoolPage
209 #254 pascal SpoolFile
210 #300 pascal ENGINEENUMERATEFONT
211 #301 pascal ENGINEDELETEFONT
212 #302 pascal ENGINEREALIZEFONT
213 #303 pascal ENGINEGETCHARWIDTH
214 #304 pascal ENGINESETFONTCONTEXT
215 #305 pascal ENGINEGETGLYPHBMP
216 #306 pascal ENGINEMAKEFONTDIR
217 #307 pascal GETCHARABCWIDTHS
218 #308 pascal GETOUTLINETEXTMETRICS
219 #309 pascal GETGLYPHOUTLINE
220 #310 pascal CREATESCALABLEFONTRESOURCE
221 #311 pascal GETFONTDATA
222 #312 pascal CONVERTOUTLINEFONTFILE
223 #313 pascal GETRASTERIZERCAPS
224 #314 pascal ENGINEEXTTEXTOUT
225 330 pascal16 EnumFontFamilies
(word ptr ptr ptr
) EnumFontFamilies
(1 2 3 4)
226 #332 pascal GETKERNINGPAIRS
227 345 pascal16 GetTextAlign
(word
) GetTextAlign
(1)
228 346 pascal16 SetTextAlign
(word word
) SetTextAlign
(1 2)
229 348 pascal16 Chord
(word s_word s_word s_word s_word s_word s_word s_word s_word
)
230 Chord
(1 2 3 4 5 6 7 8 9)
231 349 pascal SetMapperFlags
(word word
) SetMapperFlags
(1 2)
232 350 pascal16 GetCharWidth
(word word word ptr
) GetCharWidth
(1 2 3 4)
233 351 pascal16 ExtTextOut
(word s_word s_word word ptr ptr s_word ptr
)
234 ExtTextOut
(1 2 3 4 5 6 7 8)
235 #352 pascal GETPHYSICALFONTHANDLE
236 #353 pascal GETASPECTRATIOFILTER
237 #354 pascal SHRINKGDIHEAP
238 360 pascal16 CreatePalette
(ptr
) CreatePalette
(1)
239 361 pascal16 GDISelectPalette
(word word
) GDISelectPalette
(1 2)
240 362 pascal16 GDIRealizePalette
(word
) GDIRealizePalette
(1)
241 363 pascal16 GetPaletteEntries
(word word word ptr
) GetPaletteEntries
(1 2 3 4)
242 364 pascal16 SetPaletteEntries
(word word word ptr
) SetPaletteEntries
(1 2 3 4)
243 365 pascal16 RealizeDefaultPalette
(word
) RealizeDefaultPalette
(1)
244 #366 pascal UPDATECOLORS
245 #367 pascal ANIMATEPALETTE
246 #368 pascal RESIZEPALETTE
247 370 pascal16 GetNearestPaletteIndex
(word long
) GetNearestPaletteIndex
(1 2)
248 372 pascal16 ExtFloodFill
(word s_word s_word long word
) ExtFloodFill
(1 2 3 4)
249 375 pascal16 GetSystemPaletteEntries
(word word word ptr
)
250 GetSystemPaletteEntries
(1 2 3 4)
254 #379 pascal STARTPAGE
256 #381 pascal SETABORTPROC
258 #400 pascal FASTWINDOWFRAME
259 #401 pascal GDIMOVEBITMAP
261 #405 pascal FINALGDIINIT
262 #407 pascal CREATEUSERBITMAP
263 #409 pascal CREATEUSERDISCARDABLEBITMAP
264 #410 pascal ISVALIDMETAFILE
265 411 pascal16 GetCurLogFont
(word
) GetCurLogFont
(1)
266 #412 pascal ISDCCURRENTPALETTE
267 #439 pascal STRETCHDIBITS
268 440 pascal16 SetDIBits
(word word word word ptr ptr word
) SetDIBits
(1 2 3 4 5 6 7)
269 441 pascal16 GetDIBits
(word word word word ptr ptr word
) GetDIBits
(1 2 3 4 5 6 7)
270 442 pascal16 CreateDIBitmap
(word ptr long ptr ptr word
)
271 CreateDIBitmap
(1 2 3 4 5 6)
272 443 pascal16 SetDIBitsToDevice
(word s_word s_word word word word word word
274 SetDIBitsToDevice
(1 2 3 4 5 6 7 8 9 10 11 12)
275 444 pascal16 CreateRoundRectRgn
(s_word s_word s_word s_word s_word s_word
)
276 CreateRoundRectRgn
(1 2 3 4 5 6)
277 445 pascal16 CreateDIBPatternBrush
(word word
) CreateDIBPatternBrush
(1 2)
278 #449 pascal DEVICECOLORMATCH
279 450 pascal16 PolyPolygon
(word ptr ptr word
) PolyPolygon
(1 2 3 4)
280 451 pascal16 CreatePolyPolygonRgn
(ptr ptr word word
)
281 CreatePolyPolygonRgn
(1 2 3 4)
282 #452 pascal GDISEEGDIDO
283 #460 pascal GDITASKTERMINATION
284 461 return SetObjectOwner
4 0
285 462 pascal16 IsGDIObject
(word
) IsGDIObject
(1)
286 #463 pascal MAKEOBJECTPRIVATE
287 #464 pascal FIXUPBOGUSPUBLISHERMETAFILE
288 465 pascal16 RectVisible
(word ptr
) RectVisible
(1 2)
289 466 pascal16 RectInRegion
(word ptr
) RectInRegion
(1 2)
290 #467 pascal UNICODETOANSI
291 468 pascal16 GetBitmapDimensionEx
(word ptr
) GetBitmapDimensionEx
(1 2)
292 469 pascal16 GetBrushOrgEx
(word ptr
) GetBrushOrgEx
(1 2)
293 470 pascal16 GetCurrentPositionEx
(word ptr
) GetCurrentPositionEx
(1 2)
294 471 pascal16 GetTextExtentPoint
(word ptr s_word ptr
) GetTextExtentPoint
(1 2 3 4)
295 472 pascal16 GetViewportExtEx
(word ptr
) GetViewportExtEx
(1 2)
296 473 pascal16 GetViewportOrgEx
(word ptr
) GetViewportOrgEx
(1 2)
297 474 pascal16 GetWindowExtEx
(word ptr
) GetWindowExtEx
(1 2)
298 475 pascal16 GetWindowOrgEx
(word ptr
) GetWindowOrgEx
(1 2)
299 476 pascal16 OffsetViewportOrgEx
(word s_word s_word ptr
)
300 OffsetViewportOrgEx
(1 2 3 4)
301 477 pascal16 OffsetWindowOrgEx
(word s_word s_word ptr
)
302 OffsetWindowOrgEx
(1 2 3 4)
303 478 pascal16 SetBitmapDimensionEx
(word s_word s_word ptr
)
304 SetBitmapDimensionEx
(1 2 3 4)
305 479 pascal16 SetViewportExtEx
(word s_word s_word ptr
) SetViewportExtEx
(1 2 3 4)
306 480 pascal16 SetViewportOrgEx
(word s_word s_word ptr
) SetViewportOrgEx
(1 2 3 4)
307 481 pascal16 SetWindowExtEx
(word s_word s_word ptr
) SetWindowExtEx
(1 2 3 4)
308 482 pascal16 SetWindowOrgEx
(word s_word s_word ptr
) SetWindowOrgEx
(1 2 3 4)
309 483 pascal16 MoveToEx
(word s_word s_word ptr
) MoveToEx
(1 2 3 4)
310 484 pascal16 ScaleViewportExtEx
(word s_word s_word s_word s_word ptr
)
311 ScaleViewportExtEx
(1 2 3 4 5 6)
312 485 pascal16 ScaleWindowExtEx
(word s_word s_word s_word s_word ptr
)
313 ScaleWindowExtEx
(1 2 3 4 5 6)
314 #486 pascal GETASPECTRATIOFILEREX