Added some missing definitions.
[wine/multimedia.git] / dlls / wsock32 / wsock32.spec
blobed3dc93f51c834274966795008fa62c640ef58ce
1 name wsock32
2 type win32
4 import ws2_32.dll
5 import ntdll.dll
7 debug_channels (winsock)
9 1 forward accept ws2_32.accept
10 2 forward bind ws2_32.bind
11 3 forward closesocket ws2_32.closesocket
12 4 forward connect ws2_32.connect
13 5 forward getpeername ws2_32.getpeername
14 6 forward getsockname ws2_32.getsockname
15 7 forward getsockopt ws2_32.getsockopt
16 8 forward htonl ws2_32.htonl
17 9 forward htons ws2_32.htons
18 10 forward inet_addr ws2_32.inet_addr
19 11 forward inet_ntoa ws2_32.inet_ntoa
20 12 forward ioctlsocket ws2_32.ioctlsocket
21 13 forward listen ws2_32.listen
22 14 forward ntohl ws2_32.ntohl
23 15 forward ntohs ws2_32.ntohs
24 16 forward recv ws2_32.recv
25 17 forward recvfrom ws2_32.recvfrom
26 18 forward select ws2_32.select
27 19 forward send ws2_32.send
28 20 forward sendto ws2_32.sendto
29 21 forward setsockopt ws2_32.setsockopt
30 22 forward shutdown ws2_32.shutdown
31 23 forward socket ws2_32.socket
32 51 forward gethostbyaddr ws2_32.gethostbyaddr
33 52 forward gethostbyname ws2_32.gethostbyname
34 53 forward getprotobyname ws2_32.getprotobyname
35 54 forward getprotobynumber ws2_32.getprotobynumber
36 55 forward getservbyname ws2_32.getservbyname
37 56 forward getservbyport ws2_32.getservbyport
38 57 forward gethostname ws2_32.gethostname
39 101 forward WSAAsyncSelect ws2_32.WSAAsyncSelect
40 102 forward WSAAsyncGetHostByAddr ws2_32.WSAAsyncGetHostByAddr
41 103 forward WSAAsyncGetHostByName ws2_32.WSAAsyncGetHostByName
42 104 forward WSAAsyncGetProtoByNumber ws2_32.WSAAsyncGetProtoByNumber
43 105 forward WSAAsyncGetProtoByName ws2_32.WSAAsyncGetProtoByName
44 106 forward WSAAsyncGetServByPort ws2_32.WSAAsyncGetServByPort
45 107 forward WSAAsyncGetServByName ws2_32.WSAAsyncGetServByName
46 108 forward WSACancelAsyncRequest ws2_32.WSACancelAsyncRequest
47 109 forward WSASetBlockingHook ws2_32.WSASetBlockingHook
48 110 forward WSAUnhookBlockingHook ws2_32.WSAUnhookBlockingHook
49 111 forward WSAGetLastError ws2_32.WSAGetLastError
50 112 forward WSASetLastError ws2_32.WSASetLastError
51 113 forward WSACancelBlockingCall ws2_32.WSACancelBlockingCall
52 114 forward WSAIsBlocking ws2_32.WSAIsBlocking
53 115 forward WSAStartup ws2_32.WSAStartup
54 116 forward WSACleanup ws2_32.WSACleanup
55 151 forward __WSAFDIsSet ws2_32.__WSAFDIsSet
56 500 forward WEP ws2_32.WEP
58 # applications *should* 'degrade gracefully if these are not present
59 # ... as it is, they don't
60 #1000 stub WSApSetPostRoutine
61 1001 stdcall WsControl(long long ptr ptr ptr ptr) WsControl
62 1100 stdcall inet_network(str) inet_network
63 1101 stdcall getnetbyname(str) getnetbyname
64 #1102 stub rcmd
65 #1103 stub rexec
66 #1104 stub rresvport
67 #1105 stub sethostname
68 #1106 stub dn_expand
69 1107 stdcall WSARecvEx(long ptr long ptr) WSARecvEx
70 1108 stdcall s_perror(str) WS_s_perror
71 1109 stub GetAddressByNameA
72 1110 stub GetAddressByNameW
73 #1111 stub EnumProtocolsA
74 #1112 stub EnumProtocolsW
75 #1113 stub GetTypeByNameA
76 #1114 stub GetTypeByNameW
77 #1115 stub GetNameByTypeA
78 #1116 stub GetNameByTypeW
79 #1117 stub SetServiceA
80 #1118 stub SetServiceW
81 #1119 stub GetServiceA
82 #1120 stub GetServiceW
83 #1130 stub NPLoadNameSpaces
84 #1140 stub TransmitFile
85 #1141 stub AcceptEx
86 #1142 stub GetAcceptExSockaddrs