1 @ stdcall A_SHAFinal
(ptr ptr
)
2 @ stdcall A_SHAInit
(ptr
)
3 @ stdcall A_SHAUpdate
(ptr ptr long
)
4 @ stdcall AbortSystemShutdownA
(ptr
)
5 @ stdcall AbortSystemShutdownW
(ptr
)
6 @ stdcall AccessCheck
(ptr long long ptr ptr ptr ptr ptr
)
7 @ stdcall AccessCheckAndAuditAlarmA
(str ptr str str ptr long ptr long ptr ptr ptr
)
8 @ stdcall AccessCheckAndAuditAlarmW
(wstr ptr wstr wstr ptr long ptr long ptr ptr ptr
)
9 @ stdcall AccessCheckByType
(ptr ptr long long ptr long ptr ptr ptr ptr ptr
)
10 # @ stub AccessCheckByTypeAndAuditAlarmA
11 # @ stub AccessCheckByTypeAndAuditAlarmW
12 # @ stub AccessCheckByTypeResultList
13 # @ stub AccessCheckByTypeResultListAndAuditAlarmA
14 # @ stub AccessCheckByTypeResultListAndAuditAlarmByHandleA
15 # @ stub AccessCheckByTypeResultListAndAuditAlarmByHandleW
16 # @ stub AccessCheckByTypeResultListAndAuditAlarmW
17 @ stdcall AddAccessAllowedAce
(ptr long long ptr
)
18 @ stdcall AddAccessAllowedAceEx
(ptr long long long ptr
)
19 # @ stub AddAccessAllowedObjectAce
20 @ stdcall AddAccessDeniedAce
(ptr long long ptr
)
21 @ stdcall AddAccessDeniedAceEx
(ptr long long long ptr
)
22 # @ stub AddAccessDeniedObjectAce
23 @ stdcall AddAce
(ptr long long ptr long
)
24 @ stdcall AddAuditAccessAce
(ptr long long ptr long long
)
25 @ stdcall AddAuditAccessAceEx
(ptr long long long ptr long long
)
26 # @ stub AddAuditAccessObjectAce
27 # @ stub AddUsersToEncryptedFile
28 @ stdcall AdjustTokenGroups
(long long ptr long ptr ptr
)
29 @ stdcall AdjustTokenPrivileges
(long long ptr long ptr ptr
)
30 @ stdcall AllocateAndInitializeSid
(ptr long long long long long long long long long ptr
)
31 @ stdcall AllocateLocallyUniqueId
(ptr
)
32 @ stdcall AreAllAccessesGranted
(long long
)
33 @ stdcall AreAnyAccessesGranted
(long long
)
34 @ stdcall BackupEventLogA
(long str
)
35 @ stdcall BackupEventLogW
(long wstr
)
36 @ stdcall BuildExplicitAccessWithNameA
(ptr str long long long
)
37 @ stdcall BuildExplicitAccessWithNameW
(ptr wstr long long long
)
38 # @ stub BuildImpersonateExplicitAccessWithNameA
39 # @ stub BuildImpersonateExplicitAccessWithNameW
40 # @ stub BuildImpersonateTrusteeA
41 # @ stub BuildImpersonateTrusteeW
42 @ stdcall BuildSecurityDescriptorA
(ptr ptr long ptr long ptr ptr ptr ptr
)
43 @ stdcall BuildSecurityDescriptorW
(ptr ptr long ptr long ptr ptr ptr ptr
)
44 @ stdcall BuildTrusteeWithNameA
(ptr str
)
45 @ stdcall BuildTrusteeWithNameW
(ptr wstr
)
46 @ stdcall BuildTrusteeWithObjectsAndNameA
(ptr ptr long str str str
)
47 @ stdcall BuildTrusteeWithObjectsAndNameW
(ptr ptr long wstr wstr wstr
)
48 @ stdcall BuildTrusteeWithObjectsAndSidA
(ptr ptr ptr ptr ptr
)
49 @ stdcall BuildTrusteeWithObjectsAndSidW
(ptr ptr ptr ptr ptr
)
50 @ stdcall BuildTrusteeWithSidA
(ptr ptr
)
51 @ stdcall BuildTrusteeWithSidW
(ptr ptr
)
52 # @ stub CancelOverlappedAccess
53 @ stdcall ChangeServiceConfig2A
(long long ptr
)
54 @ stdcall ChangeServiceConfig2W
(long long ptr
)
55 @ stdcall ChangeServiceConfigA
(long long long long wstr str ptr str str str str
)
56 @ stdcall ChangeServiceConfigW
(long long long long wstr wstr ptr wstr wstr wstr wstr
)
57 @ stdcall CheckTokenMembership
(long ptr ptr
)
58 @ stdcall ClearEventLogA
(long str
)
59 @ stdcall ClearEventLogW
(long wstr
)
60 # @ stub CloseCodeAuthzLevel
61 # @ stub CloseEncryptedFileRaw
62 @ stdcall CloseEventLog
(long
)
63 @ stdcall CloseServiceHandle
(long
)
65 @ stdcall CommandLineFromMsiDescriptor
(wstr ptr ptr
)
66 # @ stub ComputeAccessTokenFromCodeAuthzLevel
67 @ stdcall ControlService
(long long ptr
)
68 @ stdcall ControlTraceA
(int64 str ptr long
)
69 @ stdcall ControlTraceW
(int64 wstr ptr long
)
70 # @ stub ConvertAccessToSecurityDescriptorA
71 # @ stub ConvertAccessToSecurityDescriptorW
72 # @ stub ConvertSDToStringSDRootDomainA
73 # @ stub ConvertSDToStringSDRootDomainW
74 # @ stub ConvertSecurityDescriptorToAccessA
75 # @ stub ConvertSecurityDescriptorToAccessNamedA
76 # @ stub ConvertSecurityDescriptorToAccessNamedW
77 # @ stub ConvertSecurityDescriptorToAccessW
78 @ stdcall ConvertSecurityDescriptorToStringSecurityDescriptorA
(ptr long long ptr ptr
)
79 @ stdcall ConvertSecurityDescriptorToStringSecurityDescriptorW
(ptr long long ptr ptr
)
80 @ stdcall ConvertSidToStringSidA
(ptr ptr
)
81 @ stdcall ConvertSidToStringSidW
(ptr ptr
)
82 # @ stub ConvertStringSDToSDDomainA
83 # @ stub ConvertStringSDToSDDomainW
84 # @ stub ConvertStringSDToSDRootDomainA
85 # @ stub ConvertStringSDToSDRootDomainW
86 @ stdcall ConvertStringSecurityDescriptorToSecurityDescriptorA
(str long ptr ptr
)
87 @ stdcall ConvertStringSecurityDescriptorToSecurityDescriptorW
(wstr long ptr ptr
)
88 @ stdcall ConvertStringSidToSidA
(ptr ptr
)
89 @ stdcall ConvertStringSidToSidW
(ptr ptr
)
90 @ stdcall ConvertToAutoInheritPrivateObjectSecurity
(ptr ptr ptr ptr long ptr
)
91 @ stdcall CopySid
(long ptr ptr
)
92 # @ stub CreateCodeAuthzLevel
93 @ stdcall CreatePrivateObjectSecurity
(ptr ptr ptr long long ptr
)
94 # @ stub CreatePrivateObjectSecurityEx
95 # @ stub CreatePrivateObjectSecurityWithMultipleInheritance
96 @ stdcall CreateProcessAsUserA
(long str str ptr ptr long long ptr str ptr ptr
)
97 # @ stub CreateProcessAsUserSecure
98 @ stdcall CreateProcessAsUserW
(long wstr wstr ptr ptr long long ptr wstr ptr ptr
)
99 @ stdcall CreateProcessWithLogonW
(wstr wstr wstr long wstr wstr long ptr wstr ptr ptr
)
100 @ stdcall CreateRestrictedToken
(long long long ptr long ptr long ptr ptr
)
101 @ stdcall CreateServiceA
(long str str long long long long str str ptr str str str
)
102 @ stdcall CreateServiceW
(long wstr wstr long long long long wstr wstr ptr wstr wstr wstr
)
103 # @ stub CreateTraceInstanceId
104 @ stdcall CreateWellKnownSid
(long ptr ptr ptr
)
105 @ stdcall CredDeleteA
(str long long
)
106 @ stdcall CredDeleteW
(wstr long long
)
107 @ stdcall CredEnumerateA
(str long ptr ptr
)
108 @ stdcall CredEnumerateW
(wstr long ptr ptr
)
109 @ stdcall CredFree
(ptr
)
110 @ stdcall CredGetSessionTypes
(long ptr
)
111 # @ stub CredGetTargetInfoA
112 # @ stub CredGetTargetInfoW
113 # @ stub CredIsMarshaledCredentialA
114 # @ stub CredIsMarshaledCredentialW
115 # @ stub CredMarshalCredentialA
116 # @ stub CredMarshalCredentialW
117 @ stub CredProfileLoaded
118 @ stdcall CredReadA
(str long long ptr
)
119 @ stdcall CredReadDomainCredentialsA
(ptr long ptr ptr
)
120 @ stdcall CredReadDomainCredentialsW
(ptr long ptr ptr
)
121 @ stdcall CredReadW
(wstr long long ptr
)
124 # @ stub CredUnmarshalCredentialA
125 # @ stub CredUnmarshalCredentialW
126 @ stdcall CredWriteA
(ptr long
)
127 # @ stub CredWriteDomainCredentialsA
128 # @ stub CredWriteDomainCredentialsW
129 @ stdcall CredWriteW
(ptr long
)
130 # @ stub CredpConvertCredential
131 # @ stub CredpConvertTargetInfo
132 # @ stub CredpDecodeCredential
133 # @ stub CredpEncodeCredential
134 @ stdcall CryptAcquireContextA
(ptr str str long long
)
135 @ stdcall CryptAcquireContextW
(ptr wstr wstr long long
)
136 @ stdcall CryptContextAddRef
(long ptr long
)
137 @ stdcall CryptCreateHash
(long long long long ptr
)
138 @ stdcall CryptDecrypt
(long long long long ptr ptr
)
139 @ stdcall CryptDeriveKey
(long long long long ptr
)
140 @ stdcall CryptDestroyHash
(long
)
141 @ stdcall CryptDestroyKey
(long
)
142 @ stdcall CryptDuplicateHash
(long ptr long ptr
)
143 @ stdcall CryptDuplicateKey
(long ptr long ptr
)
144 @ stdcall CryptEncrypt
(long long long long ptr ptr long
)
145 @ stdcall CryptEnumProviderTypesA
(long ptr long ptr ptr ptr
)
146 @ stdcall CryptEnumProviderTypesW
(long ptr long ptr ptr ptr
)
147 @ stdcall CryptEnumProvidersA
(long ptr long ptr ptr ptr
)
148 @ stdcall CryptEnumProvidersW
(long ptr long ptr ptr ptr
)
149 @ stdcall CryptExportKey
(long long long long ptr ptr
)
150 @ stdcall CryptGenKey
(long long long ptr
)
151 @ stdcall CryptGenRandom
(long long ptr
)
152 @ stdcall CryptGetDefaultProviderA
(long ptr long ptr ptr
)
153 @ stdcall CryptGetDefaultProviderW
(long ptr long ptr ptr
)
154 @ stdcall CryptGetHashParam
(long long ptr ptr long
)
155 @ stdcall CryptGetKeyParam
(long long ptr ptr long
)
156 @ stdcall CryptGetProvParam
(long long ptr ptr long
)
157 @ stdcall CryptGetUserKey
(long long ptr
)
158 @ stdcall CryptHashData
(long ptr long long
)
159 @ stdcall CryptHashSessionKey
(long long long
)
160 @ stdcall CryptImportKey
(long ptr long long long ptr
)
161 @ stdcall CryptReleaseContext
(long long
)
162 @ stdcall CryptSetHashParam
(long long ptr long
)
163 @ stdcall CryptSetKeyParam
(long long ptr long
)
164 @ stdcall CryptSetProvParam
(long long ptr long
)
165 @ stdcall CryptSetProviderA
(str long
)
166 @ stdcall CryptSetProviderExA
(str long ptr long
)
167 @ stdcall CryptSetProviderExW
(wstr long ptr long
)
168 @ stdcall CryptSetProviderW
(wstr long
)
169 @ stdcall CryptSignHashA
(long long ptr long ptr ptr
)
170 @ stdcall CryptSignHashW
(long long ptr long ptr ptr
)
171 @ stdcall CryptVerifySignatureA
(long ptr long long ptr long
)
172 @ stdcall CryptVerifySignatureW
(long ptr long long ptr long
)
173 @ stdcall DecryptFileA
(str long
)
174 @ stdcall DecryptFileW
(wstr long
)
175 @ stdcall DeleteAce
(ptr long
)
176 @ stdcall DeleteService
(long
)
177 @ stdcall DeregisterEventSource
(long
)
178 @ stdcall DestroyPrivateObjectSecurity
(ptr
)
179 # @ stub DuplicateEncryptionInfoFile
180 @ stdcall DuplicateToken
(long long ptr
)
181 @ stdcall DuplicateTokenEx
(long long ptr long long ptr
)
182 # @ stub ElfBackupEventLogFileA
183 # @ stub ElfBackupEventLogFileW
184 # @ stub ElfChangeNotify
185 # @ stub ElfClearEventLogFileA
186 # @ stub ElfClearEventLogFileW
187 # @ stub ElfCloseEventLog
188 @ stub ElfDeregisterEventSource
189 @ stub ElfDeregisterEventSourceW
190 # @ stub ElfFlushEventLog
191 # @ stub ElfNumberOfRecords
192 # @ stub ElfOldestRecord
193 # @ stub ElfOpenBackupEventLogA
194 # @ stub ElfOpenBackupEventLogW
195 # @ stub ElfOpenEventLogA
196 # @ stub ElfOpenEventLogW
197 # @ stub ElfReadEventLogA
198 # @ stub ElfReadEventLogW
199 # @ stub ElfRegisterEventSourceA
200 @ stub ElfRegisterEventSourceW
201 # @ stub ElfReportEventA
202 @ stub ElfReportEventW
203 @ stdcall EnableTrace
(long long long ptr int64
)
204 @ stdcall EnableTraceEx
(ptr ptr int64 long long int64 int64 long ptr
)
205 @ stdcall EncryptFileA
(str
)
206 @ stdcall EncryptFileW
(wstr
)
207 # @ stub EncryptedFileKeyInfo
208 # @ stub EncryptionDisable
209 @ stdcall EnumDependentServicesA
(long long ptr long ptr ptr
)
210 @ stdcall EnumDependentServicesW
(long long ptr long ptr ptr
)
211 @ stub EnumServiceGroupA
212 @ stub EnumServiceGroupW
213 @ stdcall EnumServicesStatusA
(long long long ptr long ptr ptr ptr
)
214 @ stdcall EnumServicesStatusExA
(long long long long ptr long ptr ptr ptr str
)
215 @ stdcall EnumServicesStatusExW
(long long long long ptr long ptr ptr ptr wstr
)
216 @ stdcall EnumServicesStatusW
(long long long ptr long ptr ptr ptr
)
217 # @ stub EnumerateTraceGuids
218 # @ stub EqualDomainSid
219 @ stdcall EqualPrefixSid
(ptr ptr
)
220 @ stdcall EqualSid
(ptr ptr
)
221 @ stdcall EventEnabled
(int64 ptr
)
222 @ stdcall EventRegister
(ptr ptr ptr ptr
)
223 @ stdcall FileEncryptionStatusA
(str ptr
)
224 @ stdcall FileEncryptionStatusW
(wstr ptr
)
225 @ stdcall FindFirstFreeAce
(ptr ptr
)
226 @ stdcall FlushTraceA
(int64 str ptr
)
227 @ stdcall FlushTraceW
(int64 wstr ptr
)
228 # @ stub FreeEncryptedFileKeyInfo
229 # @ stub FreeEncryptionCertificateHashList
230 # @ stub FreeInheritedFromArray
231 @ stdcall FreeSid
(ptr
)
232 # @ stub GetAccessPermissionsForObjectA
233 # @ stub GetAccessPermissionsForObjectW
234 @ stdcall GetAce
(ptr long ptr
)
235 @ stdcall GetAclInformation
(ptr ptr long long
)
236 @ stdcall GetAuditedPermissionsFromAclA
(ptr ptr ptr ptr
)
237 @ stdcall GetAuditedPermissionsFromAclW
(ptr ptr ptr ptr
)
238 @ stdcall GetCurrentHwProfileA
(ptr
)
239 @ stdcall GetCurrentHwProfileW
(ptr
)
240 @ stdcall GetEffectiveRightsFromAclA
(ptr ptr ptr
)
241 @ stdcall GetEffectiveRightsFromAclW
(ptr ptr ptr
)
242 @ stdcall GetEventLogInformation
(long long ptr long ptr
)
243 @ stdcall GetExplicitEntriesFromAclA
(ptr ptr ptr
)
244 @ stdcall GetExplicitEntriesFromAclW
(ptr ptr ptr
)
245 @ stdcall GetFileSecurityA
(str long ptr long ptr
)
246 @ stdcall GetFileSecurityW
(wstr long ptr long ptr
)
247 # @ stub GetInformationCodeAuthzLevelW
248 # @ stub GetInformationCodeAuthzPolicyW
249 # @ stub GetInheritanceSourceA
250 # @ stub GetInheritanceSourceW
251 @ stdcall GetKernelObjectSecurity
(long long ptr long ptr
)
252 @ stdcall GetLengthSid
(ptr
)
253 # @ stub GetLocalManagedApplicationData
254 # @ stub GetLocalManagedApplications
255 # @ stub GetManagedApplicationCategories
256 # @ stub GetManagedApplications
257 @ stub GetMangledSiteSid
258 # @ stub GetMultipleTrusteeA
259 # @ stub GetMultipleTrusteeOperationA
260 # @ stub GetMultipleTrusteeOperationW
261 # @ stub GetMultipleTrusteeW
262 @ stdcall GetNamedSecurityInfoA
(str long long ptr ptr ptr ptr ptr
)
263 @ stdcall GetNamedSecurityInfoExA
(str long long str str ptr ptr ptr ptr
)
264 @ stdcall GetNamedSecurityInfoExW
(wstr long long wstr wstr ptr ptr ptr ptr
)
265 @ stdcall GetNamedSecurityInfoW
(wstr long long ptr ptr ptr ptr ptr
)
266 @ stdcall GetNumberOfEventLogRecords
(long ptr
)
267 @ stdcall GetOldestEventLogRecord
(long ptr
)
268 # @ stub GetOverlappedAccessResults
269 @ stdcall GetPrivateObjectSecurity
(ptr long ptr long ptr
)
270 @ stdcall GetSecurityDescriptorControl
(ptr ptr ptr
)
271 @ stdcall GetSecurityDescriptorDacl
(ptr ptr ptr ptr
)
272 @ stdcall GetSecurityDescriptorGroup
(ptr ptr ptr
)
273 @ stdcall GetSecurityDescriptorLength
(ptr
)
274 @ stdcall GetSecurityDescriptorOwner
(ptr ptr ptr
)
275 # @ stub GetSecurityDescriptorRMControl
276 @ stdcall GetSecurityDescriptorSacl
(ptr ptr ptr ptr
)
277 @ stdcall GetSecurityInfo
(long long long ptr ptr ptr ptr ptr
)
278 @ stdcall GetSecurityInfoExA
(long long long str str ptr ptr ptr ptr
)
279 @ stdcall GetSecurityInfoExW
(long long long wstr wstr ptr ptr ptr ptr
)
280 @ stdcall GetServiceDisplayNameA
(ptr str ptr ptr
)
281 @ stdcall GetServiceDisplayNameW
(ptr wstr ptr ptr
)
282 @ stdcall GetServiceKeyNameA
(long str ptr ptr
)
283 @ stdcall GetServiceKeyNameW
(long wstr ptr ptr
)
284 @ stdcall GetSidIdentifierAuthority
(ptr
)
285 @ stdcall GetSidLengthRequired
(long
)
286 @ stdcall GetSidSubAuthority
(ptr long
)
287 @ stdcall GetSidSubAuthorityCount
(ptr
)
288 @ stub GetSiteSidFromToken
289 @ stdcall GetTokenInformation
(long long ptr long ptr
)
290 # @ stub GetTraceEnableFlags
291 # @ stub GetTraceEnableLevel
292 # @ stub GetTraceLoggerHandle
293 @ stdcall GetTrusteeFormA
(ptr
)
294 @ stdcall GetTrusteeFormW
(ptr
)
295 @ stdcall GetTrusteeNameA
(ptr
)
296 @ stdcall GetTrusteeNameW
(ptr
)
297 @ stdcall GetTrusteeTypeA
(ptr
)
298 @ stdcall GetTrusteeTypeW
(ptr
)
299 @ stdcall GetUserNameA
(ptr ptr
)
300 @ stdcall GetUserNameW
(ptr ptr
)
301 # @ stub GetWindowsAccountDomainSid
302 # @ stub I_ScGetCurrentGroupStateW
303 # @ stub I_ScIsSecurityProcess
304 # @ stub I_ScPnPGetServiceName
305 # @ stub I_ScSendTSMessage
306 @ stub I_ScSetServiceBit
307 @ stub I_ScSetServiceBitsA
308 # @ stub I_ScSetServiceBitsW
309 # @ stub IdentifyCodeAuthzLevelW
310 # @ stub ImpersonateAnonymousToken
311 @ stdcall ImpersonateLoggedOnUser
(long
)
312 @ stdcall ImpersonateNamedPipeClient
(long
)
313 @ stdcall ImpersonateSelf
(long
)
314 @ stdcall InitializeAcl
(ptr long long
)
315 @ stdcall InitializeSecurityDescriptor
(ptr long
)
316 @ stdcall InitializeSid
(ptr ptr long
)
317 @ stdcall InitiateSystemShutdownA
(str str long long long
)
318 @ stdcall InitiateSystemShutdownExA
(str str long long long long
)
319 @ stdcall InitiateSystemShutdownExW
(wstr wstr long long long long
)
320 @ stdcall InitiateSystemShutdownW
(wstr wstr long long long
)
321 @ stub InstallApplication
322 @ stub IsProcessRestricted
323 @ stdcall IsTextUnicode
(ptr long ptr
)
324 @ stdcall IsTokenRestricted
(long
)
325 # @ stub IsTokenUntrusted
326 @ stdcall IsValidAcl
(ptr
)
327 @ stdcall IsValidSecurityDescriptor
(ptr
)
328 @ stdcall IsValidSid
(ptr
)
329 @ stdcall IsWellKnownSid
(ptr long
)
330 @ stdcall LockServiceDatabase
(ptr
)
331 @ stdcall LogonUserA
(str str str long long ptr
)
332 # @ stub LogonUserExA
333 # @ stub LogonUserExW
334 @ stdcall LogonUserW
(wstr wstr wstr long long ptr
)
335 @ stdcall LookupAccountNameA
(str str ptr ptr ptr ptr ptr
)
336 @ stdcall LookupAccountNameW
(wstr wstr ptr ptr ptr ptr ptr
)
337 @ stdcall LookupAccountSidA
(ptr ptr ptr ptr ptr ptr ptr
)
338 @ stdcall LookupAccountSidW
(ptr ptr ptr ptr ptr ptr ptr
)
339 @ stdcall LookupPrivilegeDisplayNameA
(str str str ptr ptr
)
340 @ stdcall LookupPrivilegeDisplayNameW
(wstr wstr wstr ptr ptr
)
341 @ stdcall LookupPrivilegeNameA
(str ptr ptr long
)
342 @ stdcall LookupPrivilegeNameW
(wstr ptr ptr long
)
343 @ stdcall LookupPrivilegeValueA
(ptr ptr ptr
)
344 @ stdcall LookupPrivilegeValueW
(ptr ptr ptr
)
345 # @ stub LookupSecurityDescriptorPartsA
346 # @ stub LookupSecurityDescriptorPartsW
347 @ stdcall LsaAddAccountRights
(ptr ptr ptr long
)
348 @ stub LsaAddPrivilegesToAccount
349 # @ stub LsaClearAuditLog
350 @ stdcall LsaClose
(ptr
)
351 @ stub LsaCreateAccount
352 @ stub LsaCreateSecret
353 @ stub LsaCreateTrustedDomain
354 @ stdcall LsaCreateTrustedDomainEx
(ptr ptr ptr long ptr
)
356 @ stdcall LsaDeleteTrustedDomain
(ptr ptr
)
357 @ stdcall LsaEnumerateAccountRights
(ptr ptr ptr ptr
)
358 @ stub LsaEnumerateAccounts
359 @ stdcall LsaEnumerateAccountsWithUserRight
(ptr ptr ptr ptr
)
360 @ stub LsaEnumeratePrivileges
361 @ stub LsaEnumeratePrivilegesOfAccount
362 @ stdcall LsaEnumerateTrustedDomains
(ptr ptr ptr long ptr
)
363 @ stdcall LsaEnumerateTrustedDomainsEx
(ptr ptr ptr long ptr
)
364 @ stdcall LsaFreeMemory
(ptr
)
365 # @ stub LsaGetQuotasForAccount
366 # @ stub LsaGetRemoteUserName
367 @ stub LsaGetSystemAccessAccount
368 # @ stub LsaGetUserName
369 @ stub LsaICLookupNames
370 # @ stub LsaICLookupNamesWithCreds
371 @ stub LsaICLookupSids
372 # @ stub LsaICLookupSidsWithCreds
373 @ stdcall LsaLookupNames2
(ptr long long ptr ptr ptr
)
374 @ stdcall LsaLookupNames
(long long ptr ptr ptr
)
375 @ stub LsaLookupPrivilegeDisplayName
376 # @ stub LsaLookupPrivilegeName
377 # @ stub LsaLookupPrivilegeValue
378 @ stdcall LsaLookupSids
(ptr long ptr ptr ptr
)
379 @ stdcall LsaNtStatusToWinError
(long
)
380 @ stub LsaOpenAccount
381 @ stdcall LsaOpenPolicy
(long long long long
)
382 # @ stub LsaOpenPolicySce
384 @ stub LsaOpenTrustedDomain
385 @ stdcall LsaOpenTrustedDomainByName
(ptr ptr long ptr
)
386 # @ stub LsaQueryDomainInformationPolicy
387 # @ stub LsaQueryForestTrustInformation
388 @ stub LsaQueryInfoTrustedDomain
389 @ stdcall LsaQueryInformationPolicy
(ptr long ptr
)
390 @ stub LsaQuerySecret
391 # @ stub LsaQuerySecurityObject
392 @ stdcall LsaQueryTrustedDomainInfo
(ptr ptr long ptr
)
393 @ stdcall LsaQueryTrustedDomainInfoByName
(ptr ptr long ptr
)
394 @ stdcall LsaRegisterPolicyChangeNotification
(long long
)
395 @ stdcall LsaRemoveAccountRights
(ptr ptr long ptr long
)
396 @ stub LsaRemovePrivilegesFromAccount
397 @ stdcall LsaRetrievePrivateData
(ptr ptr ptr
)
398 # @ stub LsaSetDomainInformationPolicy
399 # @ stub LsaSetForestTrustInformation
400 @ stdcall LsaSetInformationPolicy
(long long ptr
)
401 @ stub LsaSetInformationTrustedDomain
402 # @ stub LsaSetQuotasForAccount
403 @ stdcall LsaSetSecret
(ptr ptr ptr
)
404 # @ stub LsaSetSecurityObject
405 @ stub LsaSetSystemAccessAccount
406 @ stdcall LsaSetTrustedDomainInfoByName
(ptr ptr long ptr
)
407 @ stdcall LsaSetTrustedDomainInformation
(ptr ptr long ptr
)
408 @ stdcall LsaStorePrivateData
(ptr ptr ptr
)
409 @ stdcall LsaUnregisterPolicyChangeNotification
(long long
)
410 @ stdcall MD4Final
(ptr
)
411 @ stdcall MD4Init
(ptr
)
412 @ stdcall MD4Update
(ptr ptr long
)
413 @ stdcall MD5Final
(ptr
)
414 @ stdcall MD5Init
(ptr
)
415 @ stdcall MD5Update
(ptr ptr long
)
416 # @ stub MSChapSrvChangePassword2
417 # @ stub MSChapSrvChangePassword
418 # @ stub MakeAbsoluteSD2
419 @ stdcall MakeAbsoluteSD
(ptr ptr ptr ptr ptr ptr ptr ptr ptr ptr ptr
)
420 @ stdcall MakeSelfRelativeSD
(ptr ptr ptr
)
421 @ stdcall MapGenericMask
(ptr ptr
)
422 @ stdcall NotifyBootConfigStatus
(long
)
423 @ stdcall NotifyChangeEventLog
(long long
)
424 @ stdcall ObjectCloseAuditAlarmA
(str ptr long
)
425 @ stdcall ObjectCloseAuditAlarmW
(wstr ptr long
)
426 # @ stub ObjectDeleteAuditAlarmA
427 @ stdcall ObjectDeleteAuditAlarmW
(wstr ptr long
)
428 @ stdcall ObjectOpenAuditAlarmA
(str ptr str str ptr long long long ptr long long ptr
)
429 @ stdcall ObjectOpenAuditAlarmW
(wstr ptr wstr wstr ptr long long long ptr long long ptr
)
430 @ stdcall ObjectPrivilegeAuditAlarmA
(str ptr long long ptr long
)
431 @ stdcall ObjectPrivilegeAuditAlarmW
(wstr ptr long long ptr long
)
432 @ stdcall OpenBackupEventLogA
(str str
)
433 @ stdcall OpenBackupEventLogW
(wstr wstr
)
434 # @ stub OpenEncryptedFileRawA
435 # @ stub OpenEncryptedFileRawW
436 @ stdcall OpenEventLogA
(str str
)
437 @ stdcall OpenEventLogW
(wstr wstr
)
438 @ stdcall OpenProcessToken
(long long ptr
)
439 @ stdcall OpenSCManagerA
(str str long
)
440 @ stdcall OpenSCManagerW
(wstr wstr long
)
441 @ stdcall OpenServiceA
(long str long
)
442 @ stdcall OpenServiceW
(long wstr long
)
443 @ stdcall OpenThreadToken
(long long long ptr
)
444 @ stdcall
-ret64 OpenTraceA
(ptr
)
445 @ stdcall
-ret64 OpenTraceW
(ptr
)
446 @ stdcall PrivilegeCheck
(ptr ptr ptr
)
447 @ stdcall PrivilegedServiceAuditAlarmA
(str str long ptr long
)
448 @ stdcall PrivilegedServiceAuditAlarmW
(wstr wstr long ptr long
)
449 # @ stub ProcessIdleTasks
450 @ stdcall ProcessTrace
(ptr long ptr ptr
)
451 @ stdcall QueryAllTracesA
(ptr long ptr
)
452 @ stdcall QueryAllTracesW
(ptr long ptr
)
453 # @ stub QueryRecoveryAgentsOnEncryptedFile
454 @ stdcall QueryServiceConfig2A
(long long ptr long ptr
)
455 @ stdcall QueryServiceConfig2W
(long long ptr long ptr
)
456 @ stdcall QueryServiceConfigA
(long ptr long ptr
)
457 @ stdcall QueryServiceConfigW
(long ptr long ptr
)
458 @ stdcall QueryServiceLockStatusA
(long ptr long ptr
)
459 @ stdcall QueryServiceLockStatusW
(long ptr long ptr
)
460 @ stdcall QueryServiceObjectSecurity
(long long ptr long ptr
)
461 @ stdcall QueryServiceStatus
(long ptr
)
462 @ stdcall QueryServiceStatusEx
(long long ptr long ptr
)
464 @ stdcall QueryTraceW
(int64 wstr ptr
)
465 # @ stub QueryUsersOnEncryptedFile
466 @ stdcall QueryWindows31FilesMigration
(long
)
467 # @ stub ReadEncryptedFileRaw
468 @ stdcall ReadEventLogA
(long long long ptr long ptr ptr
)
469 @ stdcall ReadEventLogW
(long long long ptr long ptr ptr
)
470 @ stdcall RegCloseKey
(long
)
471 @ stdcall RegConnectRegistryA
(str long ptr
)
472 @ stdcall RegConnectRegistryW
(wstr long ptr
)
473 @ stdcall RegCreateKeyA
(long str ptr
)
474 @ stdcall RegCreateKeyExA
(long str long ptr long long ptr ptr ptr
)
475 @ stdcall RegCreateKeyExW
(long wstr long ptr long long ptr ptr ptr
)
476 @ stdcall RegCreateKeyW
(long wstr ptr
)
477 @ stdcall RegDeleteKeyA
(long str
)
478 @ stdcall RegDeleteKeyExA
(long str long long
)
479 @ stdcall RegDeleteKeyExW
(long wstr long long
)
480 @ stdcall RegDeleteKeyW
(long wstr
)
481 @ stdcall RegDeleteTreeA
(long str
)
482 @ stdcall RegDeleteTreeW
(long wstr
)
483 @ stdcall RegDeleteValueA
(long str
)
484 @ stdcall RegDeleteValueW
(long wstr
)
485 @ stdcall RegDisablePredefinedCache
()
486 @ stdcall RegEnumKeyA
(long long ptr long
)
487 @ stdcall RegEnumKeyExA
(long long ptr ptr ptr ptr ptr ptr
)
488 @ stdcall RegEnumKeyExW
(long long ptr ptr ptr ptr ptr ptr
)
489 @ stdcall RegEnumKeyW
(long long ptr long
)
490 @ stdcall RegEnumValueA
(long long ptr ptr ptr ptr ptr ptr
)
491 @ stdcall RegEnumValueW
(long long ptr ptr ptr ptr ptr ptr
)
492 @ stdcall RegFlushKey
(long
)
493 @ stdcall RegGetKeySecurity
(long long ptr ptr
)
494 @ stdcall RegGetValueA
(long str str long ptr ptr ptr
)
495 @ stdcall RegGetValueW
(long wstr wstr long ptr ptr ptr
)
496 @ stdcall RegLoadKeyA
(long str str
)
497 @ stdcall RegLoadKeyW
(long wstr wstr
)
498 @ stdcall RegLoadMUIStringA
(long str str long ptr long str
)
499 @ stdcall RegLoadMUIStringW
(long wstr wstr long ptr long wstr
)
500 @ stdcall RegNotifyChangeKeyValue
(long long long long long
)
501 @ stdcall RegOpenCurrentUser
(long ptr
)
502 @ stdcall RegOpenKeyA
(long str ptr
)
503 @ stdcall RegOpenKeyExA
(long str long long ptr
)
504 @ stdcall RegOpenKeyExW
(long wstr long long ptr
)
505 @ stdcall RegOpenKeyW
(long wstr ptr
)
506 @ stdcall RegOpenUserClassesRoot
(ptr long long ptr
)
507 @ stdcall RegOverridePredefKey
(long long
)
508 @ stdcall RegQueryInfoKeyA
(long ptr ptr ptr ptr ptr ptr ptr ptr ptr ptr ptr
)
509 @ stdcall RegQueryInfoKeyW
(long ptr ptr ptr ptr ptr ptr ptr ptr ptr ptr ptr
)
510 @ stdcall RegQueryMultipleValuesA
(long ptr long ptr ptr
)
511 @ stdcall RegQueryMultipleValuesW
(long ptr long ptr ptr
)
512 @ stdcall RegQueryValueA
(long str ptr ptr
)
513 @ stdcall RegQueryValueExA
(long str ptr ptr ptr ptr
)
514 @ stdcall RegQueryValueExW
(long wstr ptr ptr ptr ptr
)
515 @ stdcall RegQueryValueW
(long wstr ptr ptr
)
516 @ stub RegRemapPreDefKey
517 @ stdcall RegReplaceKeyA
(long str str str
)
518 @ stdcall RegReplaceKeyW
(long wstr wstr wstr
)
519 @ stdcall RegRestoreKeyA
(long str long
)
520 @ stdcall RegRestoreKeyW
(long wstr long
)
521 @ stdcall RegSaveKeyA
(long ptr ptr
)
522 # @ stub RegSaveKeyExA
523 # @ stub RegSaveKeyExW
524 @ stdcall RegSaveKeyW
(long ptr ptr
)
525 @ stdcall RegSetKeySecurity
(long long ptr
)
526 @ stdcall RegSetValueA
(long str long ptr long
)
527 @ stdcall RegSetValueExA
(long str long long ptr long
)
528 @ stdcall RegSetValueExW
(long wstr long long ptr long
)
529 @ stdcall RegSetValueW
(long wstr long ptr long
)
530 @ stdcall RegUnLoadKeyA
(long str
)
531 @ stdcall RegUnLoadKeyW
(long wstr
)
532 @ stdcall RegisterEventSourceA
(ptr ptr
)
533 @ stdcall RegisterEventSourceW
(ptr ptr
)
534 # @ stub RegisterIdleTask
535 @ stdcall RegisterServiceCtrlHandlerA
(str ptr
)
536 @ stdcall RegisterServiceCtrlHandlerExA
(str ptr ptr
)
537 @ stdcall RegisterServiceCtrlHandlerExW
(wstr ptr ptr
)
538 @ stdcall RegisterServiceCtrlHandlerW
(wstr ptr
)
539 @ stdcall RegisterTraceGuidsA
(ptr ptr ptr long ptr str str ptr
)
540 @ stdcall RegisterTraceGuidsW
(ptr ptr ptr long ptr wstr wstr ptr
)
541 # @ stub RemoveTraceCallback
542 # @ stub RemoveUsersFromEncryptedFile
543 @ stdcall ReportEventA
(long long long long ptr long long str ptr
)
544 @ stdcall ReportEventW
(long long long long ptr long long wstr ptr
)
545 @ stdcall RevertToSelf
()
546 @ stdcall SaferCloseLevel
(ptr
)
547 @ stdcall SaferComputeTokenFromLevel
(ptr ptr ptr long ptr
)
548 @ stdcall SaferCreateLevel
(long long long ptr ptr
)
549 # @ stub SaferGetLevelInformation
550 @ stdcall SaferGetPolicyInformation
(long long long ptr ptr ptr
)
551 # @ stub SaferIdentifyLevel
552 # @ stub SaferRecordEventLogEntry
553 @ stdcall SaferSetLevelInformation
(ptr long ptr long
)
554 # @ stub SaferSetPolicyInformation
555 # @ stub SaferiChangeRegistryScope
556 # @ stub SaferiCompareTokenLevels
557 # @ stub SaferiIsExecutableFileType
558 # @ stub SaferiPopulateDefaultsInRegistry
559 # @ stub SaferiRecordEventLogEntry
560 # @ stub SaferiReplaceProcessThreadTokens
561 # @ stub SaferiSearchMatchingHashRules
562 @ stdcall SetAclInformation
(ptr ptr long long
)
563 # @ stub SetEntriesInAccessListA
564 # @ stub SetEntriesInAccessListW
565 @ stdcall SetEntriesInAclA
(long ptr ptr ptr
)
566 @ stdcall SetEntriesInAclW
(long ptr ptr ptr
)
567 # @ stub SetEntriesInAuditListA
568 # @ stub SetEntriesInAuditListW
569 @ stdcall SetFileSecurityA
(str long ptr
)
570 @ stdcall SetFileSecurityW
(wstr long ptr
)
571 # @ stub SetInformationCodeAuthzLevelW
572 # @ stub SetInformationCodeAuthzPolicyW
573 @ stdcall SetKernelObjectSecurity
(long long ptr
)
574 @ stdcall SetNamedSecurityInfoA
(str long ptr ptr ptr ptr ptr
)
575 # @ stub SetNamedSecurityInfoExA
576 # @ stub SetNamedSecurityInfoExW
577 @ stdcall SetNamedSecurityInfoW
(wstr long ptr ptr ptr ptr ptr
)
578 @ stdcall SetPrivateObjectSecurity
(long ptr ptr ptr long
)
579 # @ stub SetPrivateObjectSecurityEx
580 @ stdcall SetSecurityDescriptorControl
(ptr long long
)
581 @ stdcall SetSecurityDescriptorDacl
(ptr long ptr long
)
582 @ stdcall SetSecurityDescriptorGroup
(ptr ptr long
)
583 @ stdcall SetSecurityDescriptorOwner
(ptr ptr long
)
584 # @ stub SetSecurityDescriptorRMControl
585 @ stdcall SetSecurityDescriptorSacl
(ptr long ptr long
)
586 @ stdcall SetSecurityInfo
(long long long ptr ptr ptr ptr
)
587 # @ stub SetSecurityInfoExA
588 # @ stub SetSecurityInfoExW
589 @ stdcall SetServiceBits
(long long long long
)
590 @ stdcall SetServiceObjectSecurity
(long long ptr
)
591 @ stdcall SetServiceStatus
(long long
)
592 @ stdcall SetThreadToken
(ptr ptr
)
593 @ stdcall SetTokenInformation
(long long ptr long
)
594 # @ stub SetTraceCallback
595 # @ stub SetUserFileEncryptionKey
596 @ stdcall StartServiceA
(long long ptr
)
597 @ stdcall StartServiceCtrlDispatcherA
(ptr
)
598 @ stdcall StartServiceCtrlDispatcherW
(ptr
)
599 @ stdcall StartServiceW
(long long ptr
)
600 @ stdcall StartTraceA
(ptr str ptr
)
601 @ stdcall StartTraceW
(ptr wstr ptr
)
604 @ stdcall SynchronizeWindows31FilesAndWindowsNTRegistry
(long long long long
)
605 @ stdcall SystemFunction001
(ptr ptr ptr
)
606 @ stdcall SystemFunction002
(ptr ptr ptr
)
607 @ stdcall SystemFunction003
(ptr ptr
)
608 @ stdcall SystemFunction004
(ptr ptr ptr
)
609 @ stdcall SystemFunction005
(ptr ptr ptr
)
610 @ stdcall SystemFunction006
(ptr ptr
)
611 @ stdcall SystemFunction007
(ptr ptr
)
612 @ stdcall SystemFunction008
(ptr ptr ptr
)
613 @ stdcall SystemFunction009
(ptr ptr ptr
)
614 @ stdcall SystemFunction010
(ptr ptr ptr
)
615 @ stdcall SystemFunction011
(ptr ptr ptr
) SystemFunction010
616 @ stdcall SystemFunction012
(ptr ptr ptr
)
617 @ stdcall SystemFunction013
(ptr ptr ptr
)
618 @ stdcall SystemFunction014
(ptr ptr ptr
) SystemFunction012
619 @ stdcall SystemFunction015
(ptr ptr ptr
) SystemFunction013
620 @ stdcall SystemFunction016
(ptr ptr ptr
) SystemFunction012
621 @ stdcall SystemFunction017
(ptr ptr ptr
) SystemFunction013
622 @ stdcall SystemFunction018
(ptr ptr ptr
) SystemFunction012
623 @ stdcall SystemFunction019
(ptr ptr ptr
) SystemFunction013
624 @ stdcall SystemFunction020
(ptr ptr ptr
) SystemFunction012
625 @ stdcall SystemFunction021
(ptr ptr ptr
) SystemFunction013
626 @ stdcall SystemFunction022
(ptr ptr ptr
) SystemFunction012
627 @ stdcall SystemFunction023
(ptr ptr ptr
) SystemFunction013
628 @ stdcall SystemFunction024
(ptr ptr ptr
)
629 @ stdcall SystemFunction025
(ptr ptr ptr
)
630 @ stdcall SystemFunction026
(ptr ptr ptr
) SystemFunction024
631 @ stdcall SystemFunction027
(ptr ptr ptr
) SystemFunction025
632 @ stub SystemFunction028
633 @ stub SystemFunction029
634 @ stdcall SystemFunction030
(ptr ptr
)
635 @ stdcall SystemFunction031
(ptr ptr
) SystemFunction030
636 @ stdcall SystemFunction032
(ptr ptr
)
637 @ stub SystemFunction033
638 @ stub SystemFunction034
639 @ stdcall SystemFunction035
(str
)
640 @ stdcall SystemFunction036
(ptr long
) # RtlGenRandom
641 @ stdcall SystemFunction040
(ptr long long
) # RtlEncryptMemory
642 @ stdcall SystemFunction041
(ptr long long
) # RtlDecryptMemory
643 @ stdcall TraceEvent
(int64 ptr
)
644 @ stub TraceEventInstance
645 @ varargs TraceMessage
(int64 long ptr long
)
646 @ stdcall TraceMessageVa
(int64 long ptr long ptr
)
647 # @ stub TreeResetNamedSecurityInfoA
648 @ stdcall TreeResetNamedSecurityInfoW
(wstr long long ptr ptr ptr ptr long ptr long ptr
)
649 # @ stub TrusteeAccessToObjectA
650 # @ stub TrusteeAccessToObjectW
651 # @ stub UninstallApplication
652 @ stdcall UnlockServiceDatabase
(ptr
)
653 # @ stub UnregisterIdleTask
654 @ stdcall UnregisterTraceGuids
(int64
)
657 @ stub WdmWmiServiceMain
659 # @ stub WmiCloseTraceWithCursor
660 # @ stub WmiConvertTimestamp
661 # @ stub WmiDevInstToInstanceNameA
662 # @ stub WmiDevInstToInstanceNameW
663 # @ stub WmiEnumerateGuids
664 # @ stub WmiExecuteMethodA
665 # @ stub WmiExecuteMethodW
666 # @ stub WmiFileHandleToInstanceNameA
667 # @ stub WmiFileHandleToInstanceNameW
668 # @ stub WmiFreeBuffer
669 # @ stub WmiGetFirstTraceOffset
670 # @ stub WmiGetNextEvent
671 # @ stub WmiGetTraceHeader
672 # @ stub WmiMofEnumerateResourcesA
673 # @ stub WmiMofEnumerateResourcesW
674 # @ stub WmiNotificationRegistrationA
675 # @ stub WmiNotificationRegistrationW
677 # @ stub WmiOpenTraceWithCursor
678 # @ stub WmiParseTraceEvent
679 # @ stub WmiQueryAllDataA
680 # @ stub WmiQueryAllDataMultipleA
681 # @ stub WmiQueryAllDataMultipleW
682 # @ stub WmiQueryAllDataW
683 # @ stub WmiQueryGuidInformation
684 # @ stub WmiQuerySingleInstanceA
685 # @ stub WmiQuerySingleInstanceMultipleA
686 # @ stub WmiQuerySingleInstanceMultipleW
687 @ stub WmiQuerySingleInstanceW
688 # @ stub WmiReceiveNotificationsA
689 # @ stub WmiReceiveNotificationsW
690 # @ stub WmiSetSingleInstanceA
691 @ stub WmiSetSingleInstanceW
692 # @ stub WmiSetSingleItemA
693 # @ stub WmiSetSingleItemW
694 # @ stub Wow64Win32ApiEntry
695 # @ stub WriteEncryptedFileRaw