1 # Functions exported by the Win95 shell32.dll
2 # (these need to have these exact ordinals, for some
3 # win95 and winNT dlls import shell32.dll by ordinal)
4 # This list was updated to dll version 4.72
6 2 stdcall
-noname SHChangeNotifyRegister
(long long long long long ptr
)
7 3 stdcall SHDefExtractIconA
(str long long ptr ptr long
)
8 4 stdcall
-noname SHChangeNotifyDeregister
(long
)
9 5 stdcall
-noname SHChangeNotifyUpdateEntryList
(long long long long
)
10 6 stdcall SHDefExtractIconW
(wstr long long ptr ptr long
)
11 9 stub
-noname PifMgr_OpenProperties
12 10 stub
-noname PifMgr_GetProperties
13 11 stub
-noname PifMgr_SetProperties
14 13 stub
-noname PifMgr_CloseProperties
15 15 stdcall
-noname ILGetDisplayName
(ptr ptr
)
16 16 stdcall
-noname ILFindLastID
(ptr
)
17 17 stdcall
-noname ILRemoveLastID
(ptr
)
18 18 stdcall
-noname ILClone
(ptr
)
19 19 stdcall
-noname ILCloneFirst
(ptr
)
20 20 stdcall
-noname ILGlobalClone
(ptr
)
21 21 stdcall
-noname ILIsEqual
(ptr ptr
)
22 23 stdcall
-noname ILIsParent
(ptr ptr long
)
23 24 stdcall
-noname ILFindChild
(ptr ptr
)
24 25 stdcall
-noname ILCombine
(ptr ptr
)
25 26 stdcall
-noname ILLoadFromStream
(ptr ptr
)
26 27 stdcall
-noname ILSaveToStream
(ptr ptr
)
27 28 stdcall
-noname SHILCreateFromPath
(ptr ptr ptr
) SHILCreateFromPathAW
28 29 stdcall
-noname PathIsRoot
(ptr
) PathIsRootAW
29 30 stdcall
-noname PathBuildRoot
(ptr long
) PathBuildRootAW
30 31 stdcall
-noname PathFindExtension
(ptr
) PathFindExtensionAW
31 32 stdcall
-noname PathAddBackslash
(ptr
) PathAddBackslashAW
32 33 stdcall
-noname PathRemoveBlanks
(ptr
) PathRemoveBlanksAW
33 34 stdcall
-noname PathFindFileName
(ptr
) PathFindFileNameAW
34 35 stdcall
-noname PathRemoveFileSpec
(ptr
) PathRemoveFileSpecAW
35 36 stdcall
-noname PathAppend
(ptr ptr
) PathAppendAW
36 37 stdcall
-noname PathCombine
(ptr ptr ptr
) PathCombineAW
37 38 stdcall
-noname PathStripPath
(ptr
)PathStripPathAW
38 39 stdcall
-noname PathIsUNC
(ptr
) PathIsUNCAW
39 40 stdcall
-noname PathIsRelative
(ptr
) PathIsRelativeAW
40 41 stdcall
-noname IsLFNDriveA
(str
)
41 42 stdcall
-noname IsLFNDriveW
(wstr
)
42 43 stdcall
-noname PathIsExe
(ptr
) PathIsExeAW
43 45 stdcall
-noname PathFileExists
(ptr
) PathFileExistsAW
44 46 stdcall
-noname PathMatchSpec
(ptr ptr
) PathMatchSpecAW
45 47 stdcall
-noname PathMakeUniqueName
(ptr long ptr ptr ptr
)PathMakeUniqueNameAW
46 48 stdcall
-noname PathSetDlgItemPath
(long long ptr
) PathSetDlgItemPathAW
47 49 stdcall
-noname PathQualify
(ptr
) PathQualifyAW
48 50 stdcall
-noname PathStripToRoot
(ptr
) PathStripToRootAW
49 51 stdcall PathResolve
(str long long
) PathResolveAW
50 52 stdcall
-noname PathGetArgs
(str
) PathGetArgsAW
51 53 stdcall DoEnvironmentSubst
(long long
) DoEnvironmentSubstAW
52 55 stdcall
-noname PathQuoteSpaces
(ptr
) PathQuoteSpacesAW
53 56 stdcall
-noname PathUnquoteSpaces
(str
) PathUnquoteSpacesAW
54 57 stdcall
-noname PathGetDriveNumber
(str
) PathGetDriveNumberAW
55 58 stdcall
-noname ParseField
(str long ptr long
) ParseFieldAW
56 59 stdcall
-noname RestartDialog
(long wstr long
)
57 60 stdcall
-noname ExitWindowsDialog
(long
)
58 61 stdcall
-noname RunFileDlg
(long long long str str long
)
59 62 stdcall
-noname PickIconDlg
(long long long long
)
60 63 stdcall
-noname GetFileNameFromBrowse
(long long long long str str str
)
61 64 stdcall
-noname DriveType
(long
)
62 65 stdcall
-noname InvalidateDriveType
(long
)
63 66 stdcall
-noname IsNetDrive
(long
)
64 67 stdcall
-noname Shell_MergeMenus
(long long long long long long
)
65 68 stdcall
-noname SHGetSetSettings
(ptr long long
)
66 69 stub
-noname SHGetNetResource
67 70 stdcall
-noname SHCreateDefClassObject
(long long long long long
)
68 71 stdcall
-noname Shell_GetImageList
(ptr ptr
)
69 72 stdcall
-noname Shell_GetCachedImageIndex
(ptr ptr long
) Shell_GetCachedImageIndexAW
70 73 stdcall
-noname SHShellFolderView_Message
(long long long
)
71 74 stdcall
-noname SHCreateStdEnumFmtEtc
(long ptr ptr
)
72 75 stdcall
-noname PathYetAnotherMakeUniqueName
(ptr wstr wstr wstr
)
74 77 stdcall
-noname SHMapPIDLToSystemImageListIndex
(ptr ptr ptr
)
75 78 stdcall
-noname OleStrToStrN
(str long wstr long
) OleStrToStrNAW
76 79 stdcall
-noname StrToOleStrN
(wstr long str long
) StrToOleStrNAW
77 83 stdcall
-noname CIDLData_CreateFromIDArray
(ptr long ptr ptr
)
78 84 stub SHIsBadInterfacePtr
79 85 stdcall
-noname OpenRegStream
(long str str long
) shlwapi.SHOpenRegStreamA
80 86 stdcall
-noname SHRegisterDragDrop
(long ptr
)
81 87 stdcall
-noname SHRevokeDragDrop
(long
)
82 88 stdcall
-noname SHDoDragDrop
(long ptr ptr long ptr
)
83 89 stdcall
-noname SHCloneSpecialIDList
(long long long
)
84 90 stdcall
-noname SHFindFiles
(ptr ptr
)
85 91 stub SHFindComputer
86 92 stdcall
-noname PathGetShortPath
(ptr
) PathGetShortPathAW
87 93 stdcall
-noname Win32CreateDirectory
(wstr ptr
) Win32CreateDirectoryAW
88 94 stdcall
-noname Win32RemoveDirectory
(wstr
) Win32RemoveDirectoryAW
89 95 stdcall
-noname SHLogILFromFSIL
(ptr
)
90 96 stdcall
-noname StrRetToStrN
(ptr long ptr ptr
) StrRetToStrNAW
91 97 stdcall
-noname SHWaitForFileToOpen
(long long long
)
92 98 stdcall
-noname SHGetRealIDL
(ptr ptr ptr
)
93 99 stdcall
-noname SetAppStartingCursor
(long long
)
94 100 stdcall
-noname SHRestricted
(long
)
96 102 stdcall
-noname SHCoCreateInstance
(wstr ptr long ptr ptr
)
97 103 stdcall
-noname SignalFileOpen
(long
)
98 104 stdcall
-noname FileMenu_DeleteAllItems
(long
)
99 105 stdcall
-noname FileMenu_DrawItem
(long ptr
)
100 106 stdcall
-noname FileMenu_FindSubMenuByPidl
(long ptr
)
101 107 stdcall
-noname FileMenu_GetLastSelectedItemPidls
(long ptr ptr
)
102 108 stdcall
-noname FileMenu_HandleMenuChar
(long long
)
103 109 stdcall
-noname FileMenu_InitMenuPopup
(long
)
104 110 stdcall
-noname FileMenu_InsertUsingPidl
(long long ptr long long ptr
)
105 111 stdcall
-noname FileMenu_Invalidate
(long
)
106 112 stdcall
-noname FileMenu_MeasureItem
(long ptr
)
107 113 stdcall
-noname FileMenu_ReplaceUsingPidl
(long long ptr long ptr
)
108 114 stdcall
-noname FileMenu_Create
(long long long long long
)
109 115 stdcall
-noname FileMenu_AppendItem
(long ptr long long long long
) FileMenu_AppendItemAW
110 116 stdcall
-noname FileMenu_TrackPopupMenuEx
(long long long long long long
)
111 117 stdcall
-noname FileMenu_DeleteItemByCmd
(long long
)
112 118 stdcall
-noname FileMenu_Destroy
(long
)
113 119 stdcall
-noname IsLFNDrive
(ptr
) IsLFNDriveAW
114 120 stdcall
-noname FileMenu_AbortInitMenu
()
115 121 stdcall
-noname SHFlushClipboard
()
116 122 stdcall
-noname RunDLL_CallEntry16
(long long long str long
) #name wrong?
117 123 stdcall
-noname SHFreeUnusedLibraries
()
118 124 stdcall
-noname FileMenu_AppendFilesForPidl
(long ptr long
)
119 125 stdcall
-noname FileMenu_AddFilesForPidl
(long long long ptr long long ptr
)
120 126 stdcall
-noname SHOutOfMemoryMessageBox
(long long long
)
121 127 stdcall
-noname SHWinHelp
(long long long long
)
122 128 stdcall
-noname SHDllGetClassObject
(ptr ptr ptr
) DllGetClassObject
123 129 stdcall
-noname DAD_AutoScroll
(long ptr ptr
)
124 130 stdcall
-noname DAD_DragEnter
(long
)
125 131 stdcall
-noname DAD_DragEnterEx
(long double
)
126 132 stdcall
-noname DAD_DragLeave
()
127 134 stdcall
-noname DAD_DragMove
(double
)
128 136 stdcall
-noname DAD_SetDragImage
(long long
)
129 137 stdcall
-noname DAD_ShowDragImage
(long
)
130 139 stub Desktop_UpdateBriefcaseOnEvent
131 140 stdcall
-noname FileMenu_DeleteItemByIndex
(long long
)
132 141 stdcall
-noname FileMenu_DeleteItemByFirstID
(long long
)
133 142 stdcall
-noname FileMenu_DeleteSeparator
(long
)
134 143 stdcall
-noname FileMenu_EnableItemByCmd
(long long long
)
135 144 stdcall
-noname FileMenu_GetItemExtent
(long long
)
136 145 stdcall
-noname PathFindOnPath
(ptr ptr
) PathFindOnPathAW
137 146 stdcall
-noname RLBuildListOfPaths
()
138 147 stdcall
-noname SHCLSIDFromString
(long long
) SHCLSIDFromStringAW
139 149 stdcall
-noname SHFind_InitMenuPopup
(long long long long
)
141 151 stdcall
-noname SHLoadOLE
(long
)
142 152 stdcall
-noname ILGetSize
(ptr
)
143 153 stdcall
-noname ILGetNext
(ptr
)
144 154 stdcall
-noname ILAppend
(long long long
)
145 155 stdcall
-noname ILFree
(ptr
)
146 156 stdcall
-noname ILGlobalFree
(ptr
)
147 157 stdcall
-noname ILCreateFromPath
(ptr
) ILCreateFromPathAW
148 158 stdcall
-noname PathGetExtension
(str long long
) PathGetExtensionAW
149 159 stdcall
-noname PathIsDirectory
(ptr
) PathIsDirectoryAW
150 160 stub SHNetConnectionDialog
151 161 stdcall
-noname SHRunControlPanel
(long long
)
152 162 stdcall
-noname SHSimpleIDListFromPath
(ptr
) SHSimpleIDListFromPathAW
153 163 stdcall
-noname StrToOleStr
(wstr str
) StrToOleStrAW
154 164 stdcall
-noname Win32DeleteFile
(str
) Win32DeleteFileAW
155 165 stdcall
-noname SHCreateDirectory
(long ptr
)
156 166 stdcall
-noname CallCPLEntry16
(long long long long long long
)
157 167 stdcall
-noname SHAddFromPropSheetExtArray
(long long long
)
158 168 stdcall
-noname SHCreatePropSheetExtArray
(long str long
)
159 169 stdcall
-noname SHDestroyPropSheetExtArray
(long
)
160 170 stdcall
-noname SHReplaceFromPropSheetExtArray
(long long long long
)
161 171 stdcall
-noname PathCleanupSpec
(ptr ptr
)
162 172 stdcall
-noname SHCreateLinks
(long str ptr long ptr
)
163 173 stdcall
-noname SHValidateUNC
(long long long
)
164 174 stdcall
-noname SHCreateShellFolderViewEx
(ptr ptr
)
165 175 stdcall
-noname SHGetSpecialFolderPath
(long long long long
) SHGetSpecialFolderPathAW
166 176 stdcall
-noname SHSetInstanceExplorer
(long
)
167 177 stub DAD_SetDragImageFromListView
168 178 stdcall
-noname SHObjectProperties
(long long wstr wstr
)
169 179 stdcall
-noname SHGetNewLinkInfoA
(str str ptr long long
)
170 180 stdcall
-noname SHGetNewLinkInfoW
(wstr wstr ptr long long
)
171 181 stdcall
-noname RegisterShellHook
(long long
)
172 182 varargs
-noname ShellMessageBoxW
(long long long str long
)
173 183 varargs
-noname ShellMessageBoxA
(long long long str long
)
174 184 stdcall
-noname ArrangeWindows
(long long long long long
)
175 185 stub SHHandleDiskFull
176 186 stdcall
-noname ILGetDisplayNameEx
(ptr ptr ptr long
)
177 187 stub ILGetPseudoNameW
178 188 stdcall
-noname ShellDDEInit
(long
)
179 189 stdcall
-noname ILCreateFromPathA
(str
)
180 190 stdcall
-noname ILCreateFromPathW
(wstr
)
181 191 stdcall
-noname SHUpdateImageA
(str long long long
)
182 192 stdcall
-noname SHUpdateImageW
(wstr long long long
)
183 193 stdcall
-noname SHHandleUpdateImage
(ptr
)
184 194 stub SHCreatePropSheetExtArrayEx
185 195 stdcall
-noname SHFree
(ptr
)
186 196 stdcall
-noname SHAlloc
(long
)
187 197 stub SHGlobalDefect
188 198 stdcall
-noname SHAbortInvokeCommand
()
189 199 stub SHGetFileIcon
190 200 stub SHLocalAlloc
192 202 stub SHLocalReAlloc
194 204 stub ShortSizeFormatW
195 205 stdcall Printer_LoadIconsW
(wstr ptr ptr
)
196 206 stub Link_AddExtraDataSection
197 207 stub Link_ReadExtraDataSection
198 208 stub Link_RemoveExtraDataSection
199 209 stub Int64ToString
200 210 stub LargeIntegerToString
201 211 stub Printers_GetPidl
202 212 stub Printers_AddPrinterPropPages
203 213 stdcall Printers_RegisterWindowW
(wstr long ptr ptr
)
204 214 stdcall Printers_UnregisterWindow
(long long
)
205 215 stdcall
-noname SHStartNetConnectionDialog
(long str long
)
206 243 stdcall @
(long long
) shell32_243
207 244 stdcall
-noname SHInitRestricted
(ptr ptr
)
208 249 stdcall
-noname PathParseIconLocation
(ptr
) PathParseIconLocationAW
209 250 stdcall
-noname PathRemoveExtension
(ptr
) PathRemoveExtensionAW
210 251 stdcall
-noname PathRemoveArgs
(ptr
) PathRemoveArgsAW
211 256 stdcall @
(ptr ptr
) SHELL32_256
212 #299 stub Shl1632_ThunkData32
213 #300 stub Shl3216_ThunkData32
215 505 stdcall SHRegCloseKey
(long
)
216 506 stdcall SHRegOpenKeyA
(long str long
)
217 507 stdcall SHRegOpenKeyW
(long wstr long
)
218 508 stdcall SHRegQueryValueA
(long str ptr ptr
)
219 509 stdcall SHRegQueryValueExA
(long str ptr ptr ptr ptr
)
220 510 stdcall SHRegQueryValueW
(long long long long
)
221 511 stdcall SHRegQueryValueExW
(long wstr ptr ptr ptr ptr
)
222 512 stdcall SHRegDeleteKeyW
(long wstr
)
224 520 stdcall
-noname SHAllocShared
(ptr long long
)
225 521 stdcall
-noname SHLockShared
(long long
)
226 522 stdcall
-noname SHUnlockShared
(ptr
)
227 523 stdcall
-noname SHFreeShared
(long long
)
228 524 stdcall
-noname RealDriveType
(long long
)
229 525 stub RealDriveTypeFlags
231 640 stdcall
-noname NTSHChangeNotifyRegister
(long long long long long long
)
232 641 stdcall
-noname NTSHChangeNotifyDeregister
(long
)
234 643 stub SHChangeNotifyReceive
235 644 stdcall
-noname SHChangeNotification_Lock
(long long ptr ptr
)
236 645 stdcall
-noname SHChangeNotification_Unlock
(long
)
237 646 stub SHChangeRegistrationReceive
238 647 stub ReceiveAddToRecentDocs
239 648 stub SHWaitOp_Operate
241 650 stdcall
-noname PathIsSameRoot
(ptr ptr
) PathIsSameRootAW
243 651 stdcall
-noname ReadCabinetState
(long long
) # OldReadCabinetState
244 652 stdcall
-noname WriteCabinetState
(long
)
245 653 stdcall
-noname PathProcessCommand
(long long long long
) PathProcessCommandAW
246 654 stdcall @
(long long
) shell32_654
# ReadCabinetState@8
248 660 stdcall
-noname FileIconInit
(long
)
249 680 stdcall
-noname IsUserAdmin
()
251 714 stdcall @
(ptr
) SHELL32_714
# PathIsTemporaryW
252 730 stdcall
-noname RestartDialogEx
(long wstr long long
)
254 1217 stub FOOBAR1217
# no joke! This is the real name!!
256 @ stdcall CheckEscapesA
(str long
)
257 @ stdcall CheckEscapesW
(wstr long
)
258 @ stdcall CommandLineToArgvW
(wstr ptr
)
259 @ stdcall Control_FillCache_RunDLL
(long long long long
) Control_FillCache_RunDLLA
260 @ stdcall Control_FillCache_RunDLLA
(long long long long
)
261 @ stdcall Control_FillCache_RunDLLW
(long long long long
)
262 @ stdcall Control_RunDLL
(ptr ptr str long
) Control_RunDLLA
263 @ stdcall Control_RunDLLA
(ptr ptr str long
)
264 @ stub Control_RunDLLAsUserW
265 @ stdcall Control_RunDLLW
(ptr ptr wstr long
)
266 @ stdcall
-private DllCanUnloadNow
()
267 @ stdcall
-private DllGetClassObject
(ptr ptr ptr
)
268 @ stdcall
-private DllGetVersion
(ptr
)
269 @ stdcall
-private DllInstall
(long wstr
)
270 @ stdcall
-private DllRegisterServer
()
271 @ stdcall
-private DllUnregisterServer
()
272 @ stdcall DoEnvironmentSubstA
(str str
)
273 @ stdcall DoEnvironmentSubstW
(wstr wstr
)
274 @ stdcall DragAcceptFiles
(long long
)
275 @ stdcall DragFinish
(long
)
276 @ stdcall DragQueryFile
(long long ptr long
) DragQueryFileA
277 @ stdcall DragQueryFileA
(long long ptr long
)
278 @ stub DragQueryFileAorW
279 @ stdcall DragQueryFileW
(long long ptr long
)
280 @ stdcall DragQueryPoint
(long ptr
)
281 @ stdcall DuplicateIcon
(long long
)
282 @ stdcall ExtractAssociatedIconA
(long str ptr
)
283 @ stdcall ExtractAssociatedIconExA
(long str long long
)
284 @ stdcall ExtractAssociatedIconExW
(long wstr long long
)
285 @ stdcall ExtractAssociatedIconW
(long wstr ptr
)
286 @ stdcall ExtractIconA
(long str long
)
287 @ stdcall ExtractIconEx
(ptr long ptr ptr long
) ExtractIconExA
288 @ stdcall ExtractIconExA
(str long ptr ptr long
)
289 @ stdcall ExtractIconExW
(wstr long ptr ptr long
)
290 @ stub ExtractIconResInfoA
291 @ stub ExtractIconResInfoW
292 @ stdcall ExtractIconW
(long wstr long
)
293 @ stub ExtractVersionResource16W
294 @ stub FindExeDlgProc
295 @ stdcall FindExecutableA
(str str ptr
)
296 @ stdcall FindExecutableW
(wstr wstr ptr
)
297 @ stub FixupOptionalComponents
298 @ stdcall FreeIconList
(long
)
299 @ stub InternalExtractIconListA
300 @ stub InternalExtractIconListW
303 @ stub OpenAs_RunDLLA
304 @ stub OpenAs_RunDLLW
305 @ stub PrintersGetCommand_RunDLL
306 @ stub PrintersGetCommand_RunDLLA
307 @ stub PrintersGetCommand_RunDLLW
308 @ stub RealShellExecuteA
309 @ stub RealShellExecuteExA
310 @ stub RealShellExecuteExW
311 @ stub RealShellExecuteW
312 @ stub RegenerateUserEnvironment
313 @ stdcall SHAddToRecentDocs
(long ptr
)
314 @ stdcall SHAppBarMessage
(long ptr
)
315 @ stdcall SHBindToParent
(ptr ptr ptr ptr
)
316 @ stdcall SHBrowseForFolder
(ptr
) SHBrowseForFolderA
317 @ stdcall SHBrowseForFolderA
(ptr
)
318 @ stdcall SHBrowseForFolderW
(ptr
)
319 @ stdcall SHChangeNotify
(long long ptr ptr
)
320 @ stub SHChangeNotifySuspendResume
321 @ stdcall SHCreateDirectoryExA
(long str ptr
)
322 @ stdcall SHCreateDirectoryExW
(long wstr ptr
)
323 @ stub SHCreateProcessAsUserW
324 @ stdcall SHEmptyRecycleBinA
(long str long
)
325 @ stdcall SHEmptyRecycleBinW
(long wstr long
)
326 @ stub SHExtractIconsW
327 @ stdcall SHFileOperation
(ptr
) SHFileOperationA
328 @ stdcall SHFileOperationA
(ptr
)
329 @ stdcall SHFileOperationW
(ptr
)
330 @ stdcall SHFormatDrive
(long long long long
)
331 @ stdcall SHFreeNameMappings
(ptr
)
332 @ stdcall SHGetDataFromIDListA
(ptr ptr long ptr long
)
333 @ stdcall SHGetDataFromIDListW
(ptr ptr long ptr long
)
334 @ stdcall SHGetDesktopFolder
(ptr
)
335 @ stdcall SHGetDiskFreeSpaceA
(str ptr ptr ptr
) kernel32.GetDiskFreeSpaceExA
336 @ stdcall SHGetDiskFreeSpaceExA
(str ptr ptr ptr
) kernel32.GetDiskFreeSpaceExA
337 @ stdcall SHGetDiskFreeSpaceExW
(wstr ptr ptr ptr
) kernel32.GetDiskFreeSpaceExW
338 @ stdcall SHGetFileInfo
(ptr long ptr long long
) SHGetFileInfoA
339 @ stdcall SHGetFileInfoA
(ptr long ptr long long
)
340 @ stdcall SHGetFileInfoW
(ptr long ptr long long
)
341 @ stdcall SHGetFolderLocation
(long long long long ptr
)
342 @ stdcall SHGetFolderPathA
(long long long long ptr
)
343 @ stdcall SHGetFolderPathW
(long long long long ptr
)
344 @ stub SHGetFreeDiskSpace
345 @ stub SHGetIconOverlayIndexA
346 @ stub SHGetIconOverlayIndexW
347 @ stdcall SHGetInstanceExplorer
(long
)
348 @ stdcall SHGetMalloc
(ptr
)
349 @ stdcall SHGetNewLinkInfo
(str str ptr long long
) SHGetNewLinkInfoA
350 @ stdcall SHGetPathFromIDList
(ptr ptr
) SHGetPathFromIDListA
351 @ stdcall SHGetPathFromIDListA
(ptr ptr
)
352 @ stdcall SHGetPathFromIDListW
(ptr ptr
)
353 @ stdcall SHGetSettings
(ptr long
)
354 @ stdcall SHGetSpecialFolderLocation
(long long ptr
)
355 @ stdcall SHGetSpecialFolderPathA
(long ptr long long
)
356 @ stdcall SHGetSpecialFolderPathW
(long ptr long long
)
357 @ stdcall SHHelpShortcuts_RunDLL
(long long long long
) SHHelpShortcuts_RunDLLA
358 @ stdcall SHHelpShortcuts_RunDLLA
(long long long long
)
359 @ stdcall SHHelpShortcuts_RunDLLW
(long long long long
)
360 @ stub SHInvokePrinterCommandA
361 @ stub SHInvokePrinterCommandW
362 @ stdcall SHIsFileAvailableOffline
(wstr ptr
)
363 @ stdcall SHLoadInProc
(long
)
364 @ stdcall SHLoadNonloadedIconOverlayIdentifiers
()
365 @ stdcall SHPathPrepareForWriteA
(long ptr str long
)
366 @ stdcall SHPathPrepareForWriteW
(long ptr wstr long
)
367 @ stdcall SHQueryRecycleBinA
(str ptr
)
368 @ stdcall SHQueryRecycleBinW
(wstr ptr
)
369 @ stdcall SHSetLocalizedName
(wstr wstr long
)
370 @ stub SHUpdateRecycleBinIcon
371 @ stdcall SheChangeDirA
(str
)
372 @ stub SheChangeDirExA
373 @ stub SheChangeDirExW
374 @ stdcall SheChangeDirW
(wstr
)
375 @ stub SheConvertPathW
378 @ stub SheGetCurDrive
379 @ stdcall SheGetDirA
(long long
)
381 @ stdcall SheGetDirW
(long long
)
382 @ stub SheGetPathOffsetW
383 @ stub SheRemoveQuotesA
384 @ stub SheRemoveQuotesW
385 @ stub SheSetCurDrive
386 @ stub SheShortenPathA
387 @ stub SheShortenPathW
388 @ stdcall ShellAboutA
(long str str long
)
389 @ stdcall ShellAboutW
(long wstr wstr long
)
390 @ stub ShellExec_RunDLL
391 @ stub ShellExec_RunDLLA
392 @ stub ShellExec_RunDLLW
393 @ stdcall ShellExecuteA
(long str str str str long
)
394 @ stdcall ShellExecuteEx
(long
) ShellExecuteExA
395 @ stdcall ShellExecuteExA
(long
)
396 @ stdcall ShellExecuteExW
(long
)
397 @ stdcall ShellExecuteW
(long wstr wstr wstr wstr long
)
399 @ stdcall Shell_NotifyIcon
(long ptr
) Shell_NotifyIconA
400 @ stdcall Shell_NotifyIconA
(long ptr
)
401 @ stdcall Shell_NotifyIconW
(long ptr
)
402 @ stdcall StrChrA
(str long
) shlwapi.StrChrA
403 @ stdcall StrChrIA
(str long
) shlwapi.StrChrIA
404 @ stdcall StrChrIW
(wstr long
) shlwapi.StrChrIW
405 @ stdcall StrChrW
(wstr long
) shlwapi.StrChrW
406 @ stdcall StrCmpNA
(str str long
) shlwapi.StrCmpNA
407 @ stdcall StrCmpNIA
(str str long
) shlwapi.StrCmpNIA
408 @ stdcall StrCmpNIW
(wstr wstr long
) shlwapi.StrCmpNIW
409 @ stdcall StrCmpNW
(wstr wstr long
) shlwapi.StrCmpNW
410 @ stdcall StrCpyNA
(ptr str long
) kernel32.lstrcpynA
411 @ stdcall StrCpyNW
(wstr wstr long
) shlwapi.StrCpyNW
412 @ stdcall StrNCmpA
(str str long
) shlwapi.StrCmpNA
413 @ stdcall StrNCmpIA
(str str long
) shlwapi.StrCmpNIA
414 @ stdcall StrNCmpIW
(wstr wstr long
) shlwapi.StrCmpNIW
415 @ stdcall StrNCmpW
(wstr wstr long
) shlwapi.StrCmpNW
416 @ stdcall StrNCpyA
(ptr str long
) kernel32.lstrcpynA
417 @ stdcall StrNCpyW
(wstr wstr long
) shlwapi.StrCpyNW
418 @ stdcall StrRChrA
(str str long
) shlwapi.StrRChrA
419 @ stdcall StrRChrIA
(str str long
) shlwapi.StrRChrIA
420 @ stdcall StrRChrIW
(str str long
) shlwapi.StrRChrIW
421 @ stdcall StrRChrW
(wstr wstr long
) shlwapi.StrRChrW
423 @ stdcall StrRStrIA
(str str str
) shlwapi.StrRStrIA
424 @ stdcall StrRStrIW
(wstr wstr wstr
) shlwapi.StrRStrIW
426 @ stdcall StrStrA
(str str
) shlwapi.StrStrA
427 @ stdcall StrStrIA
(str str
) shlwapi.StrStrIA
428 @ stdcall StrStrIW
(wstr wstr
) shlwapi.StrStrIW
429 @ stdcall StrStrW
(wstr wstr
) shlwapi.StrStrW
430 @ stub WOWShellExecute