1 # Compound Storage DLL.
2 # (FIXME: some methods are commented out. Commenting them in _WILL_
3 # result in dataloss. Do it at your own risk.)
5 1 pascal StgCreateDocFileA
(str long long ptr
) StgCreateDocFile16
6 2 stub StgCreateDocFileOnILockBytes
7 # 2 pascal StgCreateDocFileOnILockBytes(ptr long long ptr) StgCreateDocFileOnILockBytes16
8 3 pascal StgOpenStorage
(str ptr long ptr long ptr
) StgOpenStorage16
9 4 pascal StgOpenStorageOnILockBytes
(segptr ptr long long long ptr
) StgOpenStorageOnILockBytes16
10 5 pascal StgIsStorageFile
(str
) StgIsStorageFile16
11 6 pascal StgIsStorageILockBytes
(segptr
) StgIsStorageILockBytes16
15 103 stub DllGetClassObject
17 # Storage Interface functions. Starting at 500
18 # these are not exported in the real storage.dll, we use them
19 # as 16->32 relays. They use the cdecl calling convention.
22 500 cdecl IStorage16_QueryInterface
(ptr ptr ptr
) IStorage16_fnQueryInterface
23 501 cdecl IStorage16_AddRef
(ptr
) IStorage16_fnAddRef
24 502 cdecl IStorage16_Release
(ptr
) IStorage16_fnRelease
25 #503 cdecl IStorage16_CreateStream(ptr str long long long ptr) IStorage16_fnCreateStream
26 503 stub IStorage16_CreateStream
28 504 cdecl IStorage16_OpenStream
(ptr str ptr long long ptr
) IStorage16_fnOpenStream
29 #505 cdecl IStorage16_CreateStorage(ptr str long long long ptr) IStorage16_fnCreateStorage
30 505 stub IStorage16_CreateStorage
31 506 cdecl IStorage16_OpenStorage
(ptr str ptr long ptr long ptr
) IStorage16_fnOpenStorage
32 507 cdecl IStorage16_CopyTo
(ptr long ptr ptr ptr
) IStorage16_fnCopyTo
33 508 stub IStorage16_MoveElementTo
34 509 cdecl IStorage16_Commit
(ptr long
) IStorage16_fnCommit
35 510 stub IStorage16_Revert
36 511 stub IStorage16_EnumElements
37 512 stub IStorage16_DestroyElement
38 513 stub IStorage16_RenameElement
39 514 stub IStorage16_SetElementTimes
40 515 stub IStorage16_SetClass
41 516 stub IStorage16_SetStateBits
42 517 cdecl IStorage16_Stat
(ptr ptr long
) IStorage16_fnStat
45 518 cdecl IStream16_QueryInterface
(ptr ptr ptr
) IStream16_fnQueryInterface
46 519 cdecl IStream16_AddRef
(ptr
) IStream16_fnAddRef
47 520 cdecl IStream16_Release
(ptr
) IStream16_fnRelease
48 521 cdecl IStream16_Read
(ptr ptr long ptr
) IStream16_fnRead
49 #522 cdecl IStream16_Write(ptr ptr long ptr) IStream16_fnWrite
50 522 stub IStream16_Write
51 523 cdecl IStream16_Seek
(ptr double long ptr
) IStream16_fnSeek
52 524 stub IStream16_SetSize
53 525 stub IStream16_CopyTo
54 526 stub IStream16_Commit
55 527 stub IStream16_Revert
56 528 stub IStream16_LockRegion
57 529 stub IStream16_UnlockRegion
58 530 stub IStream16_Stat
59 531 stub IStream16_Clone