Added tests for GetSystemDirectoryA/W and GetWindowsDirectoryA/W.
[wine/hacks.git] / dlls / avifil32 / avifile.spec
bloba3b9f5183cff07c11e4618cb70596e471e5dd9f3
1 name avifile
2 type win16
3 owner avifil32
5 # I'm just using "long" instead of "ptr" for the interface pointers,
6 # because they are 32-bit pointers, not converted to 16-bit format,
7 # but the app doesn't really need to know, it should never need to
8 # dereference the interface pointer itself (if we're lucky)...
10 1 stub WEP
11 2 stub DLLGETCLASSOBJECT
12 3 stub DLLCANUNLOADNOW
13 4 stub ___EXPORTEDSTUB
14 10 stub _IID_IAVISTREAM
15 11 stub _IID_IAVIFILE
16 12 stub _IID_IAVIEDITSTREAM
17 13 stub _IID_IGETFRAME
18 14 stub _CLSID_AVISIMPLEUNMARSHAL
19 100 pascal AVIFileInit() AVIFileInit
20 101 pascal AVIFileExit() AVIFileExit
21 102 pascal AVIFileOpen(ptr str word ptr) AVIFileOpenA
22 103 stub AVISTREAMOPENFROMFILE
23 104 stub AVISTREAMCREATE
24 105 stub AVIMAKECOMPRESSEDSTREAM
25 106 stub AVIMAKEFILEFROMSTREAMS
26 107 stub AVIMAKESTREAMFROMCLIPBOARD
27 110 stub AVISTREAMGETFRAME
28 111 stub AVISTREAMGETFRAMECLOSE
29 112 stub AVISTREAMGETFRAMEOPEN
30 120 stub _AVISAVE
31 121 stub AVISAVEV
32 122 stub AVISAVEOPTIONS
33 123 stub AVIBUILDFILTER
34 124 stub AVISAVEOPTIONSFREE
35 130 stub AVISTREAMSTART
36 131 stub AVISTREAMLENGTH
37 132 stub AVISTREAMTIMETOSAMPLE
38 133 stub AVISTREAMSAMPLETOTIME
39 140 stub AVIFILEADDREF
40 141 pascal AVIFileRelease(long) AVIFileRelease
41 142 stub AVIFILEINFO
42 143 pascal AVIFileGetStream(long ptr long long) AVIFileGetStream
43 144 stub AVIFILECREATESTREAM
44 146 stub AVIFILEWRITEDATA
45 147 stub AVIFILEREADDATA
46 148 stub AVIFILEENDRECORD
47 160 stub AVISTREAMADDREF
48 161 stub AVISTREAMRELEASE
49 162 stub AVISTREAMINFO
50 163 stub AVISTREAMFINDSAMPLE
51 164 stub AVISTREAMREADFORMAT
52 165 stub AVISTREAMREADDATA
53 166 stub AVISTREAMWRITEDATA
54 167 stub AVISTREAMREAD
55 168 stub AVISTREAMWRITE
56 169 stub AVISTREAMSETFORMAT
57 180 stub EDITSTREAMCOPY
58 181 stub EDITSTREAMCUT
59 182 stub EDITSTREAMPASTE
60 184 stub CREATEEDITABLESTREAM
61 185 stub AVIPUTFILEONCLIPBOARD
62 187 stub AVIGETFROMCLIPBOARD
63 188 stub AVICLEARCLIPBOARD
64 190 stub EDITSTREAMCLONE
65 191 stub EDITSTREAMSETNAME
66 192 stub EDITSTREAMSETINFO
67 200 stub AVISTREAMBEGINSTREAMING
68 201 stub AVISTREAMENDSTREAMING