Merged the two serializer and unserializer functions into one, cleaned
[wine.git] / dlls / shell32 / shell.spec
blob3fb13b81c02b1f5f2ad68578fb3041efc7f9ace3
1 name shell
2 type win16
3 owner shell32
4 rsrc version16.res
6 1 pascal RegOpenKey(long str ptr) RegOpenKey16
7 2 pascal RegCreateKey(long str ptr) RegCreateKey16
8 3 pascal RegCloseKey(long) RegCloseKey16
9 4 pascal RegDeleteKey(long str) RegDeleteKey16
10 5 pascal RegSetValue(long str long str long) RegSetValue16
11 6 pascal RegQueryValue(long str ptr ptr) RegQueryValue16
12 7 pascal RegEnumKey(long long ptr long) RegEnumKey16
13 9 pascal16 DragAcceptFiles(word word) DragAcceptFiles16
14 11 pascal16 DragQueryFile(word s_word ptr s_word) DragQueryFile16
15 12 pascal16 DragFinish(word) DragFinish16
16 13 pascal16 DragQueryPoint(word ptr) DragQueryPoint16
17 20 pascal16 ShellExecute(word str str str str s_word) ShellExecute16
18 21 pascal16 FindExecutable(str str ptr) FindExecutable16
19 22 pascal16 ShellAbout(word ptr ptr word) ShellAbout16
20 33 pascal16 AboutDlgProc(word word word long) AboutDlgProc16
21 34 pascal16 ExtractIcon(word str s_word) ExtractIcon16
22 36 pascal16 ExtractAssociatedIcon(word ptr ptr) ExtractAssociatedIcon16
23 37 pascal DoEnvironmentSubst(ptr word) DoEnvironmentSubst16
24 38 pascal FindEnvironmentString(ptr) FindEnvironmentString16
25 39 pascal16 InternalExtractIcon(word ptr s_word word) InternalExtractIcon16
26 40 pascal16 ExtractIconEx(str word ptr ptr word) ExtractIconEx16
27 # 98 stub SHL3216_THUNKDATA16
28 # 99 stub SHL1632_THUNKDATA16
30 #100 4 0550 HERETHARBETYGARS exported, shared data
31 #101 8 010e FINDEXEDLGPROC exported, shared data
32 101 pascal DllEntryPoint(long word word word long word) SHELL_DllEntryPoint
34 102 pascal16 RegisterShellHook(word word) RegisterShellHook16
35 103 pascal ShellHookProc(word word long) ShellHookProc16
37 157 stub RESTARTDIALOG
38 # 166 PICKICONDLG
40 262 pascal16 DriveType(long) DriveType16
42 # 263 SH16TO32DRIVEIOCTL
43 # 264 SH16TO32INT2526
44 # 300 SHGETFILEINFO
45 # 400 SHFORMATDRIVE
46 401 stub SHCHECKDRIVE
47 # 402 _RUNDLLCHECKDRIVE
49 # 8 WEP
50 #32 WCI