1 # Functions exported by the Win95 shell32.dll
2 # (these need to have these exact ordinals, for some
3 # win95 and winNT dlls import shell32.dll by ordinal)
4 # This list was updated to dll version 4.72
6 2 stdcall
-noname SHChangeNotifyRegister
(long long long long long ptr
)
7 3 stdcall SHDefExtractIconA
(str long long ptr ptr long
)
8 4 stdcall
-noname SHChangeNotifyDeregister
(long
)
9 5 stdcall
-noname SHChangeNotifyUpdateEntryList
(long long long long
)
10 6 stdcall SHDefExtractIconW
(wstr long long ptr ptr long
)
11 9 stub
-noname PifMgr_OpenProperties
12 10 stub
-noname PifMgr_GetProperties
13 11 stub
-noname PifMgr_SetProperties
14 13 stub
-noname PifMgr_CloseProperties
15 15 stdcall
-noname ILGetDisplayName
(ptr ptr
)
16 16 stdcall
-noname ILFindLastID
(ptr
)
17 17 stdcall
-noname ILRemoveLastID
(ptr
)
18 18 stdcall
-noname ILClone
(ptr
)
19 19 stdcall
-noname ILCloneFirst
(ptr
)
20 20 stdcall
-noname ILGlobalClone
(ptr
)
21 21 stdcall
-noname ILIsEqual
(ptr ptr
)
22 23 stdcall
-noname ILIsParent
(ptr ptr long
)
23 24 stdcall
-noname ILFindChild
(ptr ptr
)
24 25 stdcall
-noname ILCombine
(ptr ptr
)
25 26 stdcall
-noname ILLoadFromStream
(ptr ptr
)
26 27 stdcall
-noname ILSaveToStream
(ptr ptr
)
27 28 stdcall
-noname SHILCreateFromPath
(ptr ptr ptr
) SHILCreateFromPathAW
28 29 stdcall
-noname PathIsRoot
(ptr
) PathIsRootAW
29 30 stdcall
-noname PathBuildRoot
(ptr long
) PathBuildRootAW
30 31 stdcall
-noname PathFindExtension
(ptr
) PathFindExtensionAW
31 32 stdcall
-noname PathAddBackslash
(ptr
) PathAddBackslashAW
32 33 stdcall
-noname PathRemoveBlanks
(ptr
) PathRemoveBlanksAW
33 34 stdcall
-noname PathFindFileName
(ptr
) PathFindFileNameAW
34 35 stdcall
-noname PathRemoveFileSpec
(ptr
) PathRemoveFileSpecAW
35 36 stdcall
-noname PathAppend
(ptr ptr
) PathAppendAW
36 37 stdcall
-noname PathCombine
(ptr ptr ptr
) PathCombineAW
37 38 stdcall
-noname PathStripPath
(ptr
)PathStripPathAW
38 39 stdcall
-noname PathIsUNC
(ptr
) PathIsUNCAW
39 40 stdcall
-noname PathIsRelative
(ptr
) PathIsRelativeAW
40 41 stdcall
-noname IsLFNDriveA
(str
)
41 42 stdcall
-noname IsLFNDriveW
(wstr
)
42 43 stdcall
-noname PathIsExe
(ptr
) PathIsExeAW
43 45 stdcall
-noname PathFileExists
(ptr
) PathFileExistsAW
44 46 stdcall
-noname PathMatchSpec
(ptr ptr
) PathMatchSpecAW
45 47 stdcall
-noname PathMakeUniqueName
(ptr long ptr ptr ptr
)PathMakeUniqueNameAW
46 48 stdcall
-noname PathSetDlgItemPath
(long long ptr
) PathSetDlgItemPathAW
47 49 stdcall
-noname PathQualify
(ptr
) PathQualifyAW
48 50 stdcall
-noname PathStripToRoot
(ptr
) PathStripToRootAW
49 51 stdcall PathResolve
(str long long
) PathResolveAW
50 52 stdcall
-noname PathGetArgs
(str
) PathGetArgsAW
51 53 stdcall DoEnvironmentSubst
(long long
) DoEnvironmentSubstAW
52 54 stub LogoffWindowsDialog
53 55 stdcall
-noname PathQuoteSpaces
(ptr
) PathQuoteSpacesAW
54 56 stdcall
-noname PathUnquoteSpaces
(str
) PathUnquoteSpacesAW
55 57 stdcall
-noname PathGetDriveNumber
(str
) PathGetDriveNumberAW
56 58 stdcall
-noname ParseField
(str long ptr long
) ParseFieldAW
57 59 stdcall
-noname RestartDialog
(long wstr long
)
58 60 stdcall
-noname ExitWindowsDialog
(long
)
59 61 stdcall
-noname RunFileDlg
(long long long str str long
)
60 62 stdcall
-noname PickIconDlg
(long long long long
)
61 63 stdcall
-noname GetFileNameFromBrowse
(long long long long str str str
)
62 64 stdcall
-noname DriveType
(long
)
63 65 stdcall
-noname InvalidateDriveType
(long
)
64 66 stdcall
-noname IsNetDrive
(long
)
65 67 stdcall
-noname Shell_MergeMenus
(long long long long long long
)
66 68 stdcall
-noname SHGetSetSettings
(ptr long long
)
67 69 stub
-noname SHGetNetResource
68 70 stdcall
-noname SHCreateDefClassObject
(long long long long long
)
69 71 stdcall
-noname Shell_GetImageList
(ptr ptr
)
70 72 stdcall
-noname Shell_GetCachedImageIndex
(ptr ptr long
) Shell_GetCachedImageIndexAW
71 73 stdcall
-noname SHShellFolderView_Message
(long long long
)
72 74 stdcall
-noname SHCreateStdEnumFmtEtc
(long ptr ptr
)
73 75 stdcall
-noname PathYetAnotherMakeUniqueName
(ptr wstr wstr wstr
)
75 77 stdcall
-noname SHMapPIDLToSystemImageListIndex
(ptr ptr ptr
)
76 78 stdcall
-noname OleStrToStrN
(str long wstr long
) OleStrToStrNAW
77 79 stdcall
-noname StrToOleStrN
(wstr long str long
) StrToOleStrNAW
78 83 stdcall
-noname CIDLData_CreateFromIDArray
(ptr long ptr ptr
)
79 84 stub SHIsBadInterfacePtr
80 85 stdcall
-noname OpenRegStream
(long str str long
) shlwapi.SHOpenRegStreamA
81 86 stdcall
-noname SHRegisterDragDrop
(long ptr
)
82 87 stdcall
-noname SHRevokeDragDrop
(long
)
83 88 stdcall
-noname SHDoDragDrop
(long ptr ptr long ptr
)
84 89 stdcall
-noname SHCloneSpecialIDList
(long long long
)
85 90 stdcall
-noname SHFindFiles
(ptr ptr
)
86 91 stub SHFindComputer
87 92 stdcall
-noname PathGetShortPath
(ptr
) PathGetShortPathAW
88 93 stdcall
-noname Win32CreateDirectory
(wstr ptr
) Win32CreateDirectoryAW
89 94 stdcall
-noname Win32RemoveDirectory
(wstr
) Win32RemoveDirectoryAW
90 95 stdcall
-noname SHLogILFromFSIL
(ptr
)
91 96 stdcall
-noname StrRetToStrN
(ptr long ptr ptr
) StrRetToStrNAW
92 97 stdcall
-noname SHWaitForFileToOpen
(long long long
)
93 98 stdcall
-noname SHGetRealIDL
(ptr ptr ptr
)
94 99 stdcall
-noname SetAppStartingCursor
(long long
)
95 100 stdcall
-noname SHRestricted
(long
)
97 102 stdcall
-noname SHCoCreateInstance
(wstr ptr long ptr ptr
)
98 103 stdcall
-noname SignalFileOpen
(long
)
99 104 stdcall
-noname FileMenu_DeleteAllItems
(long
)
100 105 stdcall
-noname FileMenu_DrawItem
(long ptr
)
101 106 stdcall
-noname FileMenu_FindSubMenuByPidl
(long ptr
)
102 107 stdcall
-noname FileMenu_GetLastSelectedItemPidls
(long ptr ptr
)
103 108 stdcall
-noname FileMenu_HandleMenuChar
(long long
)
104 109 stdcall
-noname FileMenu_InitMenuPopup
(long
)
105 110 stdcall
-noname FileMenu_InsertUsingPidl
(long long ptr long long ptr
)
106 111 stdcall
-noname FileMenu_Invalidate
(long
)
107 112 stdcall
-noname FileMenu_MeasureItem
(long ptr
)
108 113 stdcall
-noname FileMenu_ReplaceUsingPidl
(long long ptr long ptr
)
109 114 stdcall
-noname FileMenu_Create
(long long long long long
)
110 115 stdcall
-noname FileMenu_AppendItem
(long ptr long long long long
) FileMenu_AppendItemAW
111 116 stdcall
-noname FileMenu_TrackPopupMenuEx
(long long long long long long
)
112 117 stdcall
-noname FileMenu_DeleteItemByCmd
(long long
)
113 118 stdcall
-noname FileMenu_Destroy
(long
)
114 119 stdcall
-noname IsLFNDrive
(ptr
) IsLFNDriveAW
115 120 stdcall
-noname FileMenu_AbortInitMenu
()
116 121 stdcall
-noname SHFlushClipboard
()
117 122 stdcall
-noname RunDLL_CallEntry16
(long long long str long
) #name wrong?
118 123 stdcall
-noname SHFreeUnusedLibraries
()
119 124 stdcall
-noname FileMenu_AppendFilesForPidl
(long ptr long
)
120 125 stdcall
-noname FileMenu_AddFilesForPidl
(long long long ptr long long ptr
)
121 126 stdcall
-noname SHOutOfMemoryMessageBox
(long long long
)
122 127 stdcall
-noname SHWinHelp
(long long long long
)
123 128 stdcall
-noname SHDllGetClassObject
(ptr ptr ptr
) DllGetClassObject
124 129 stdcall
-noname DAD_AutoScroll
(long ptr ptr
)
125 130 stdcall
-noname DAD_DragEnter
(long
)
126 131 stdcall
-noname DAD_DragEnterEx
(long double
)
127 132 stdcall
-noname DAD_DragLeave
()
128 134 stdcall
-noname DAD_DragMove
(double
)
129 136 stdcall
-noname DAD_SetDragImage
(long long
)
130 137 stdcall
-noname DAD_ShowDragImage
(long
)
131 139 stub Desktop_UpdateBriefcaseOnEvent
132 140 stdcall
-noname FileMenu_DeleteItemByIndex
(long long
)
133 141 stdcall
-noname FileMenu_DeleteItemByFirstID
(long long
)
134 142 stdcall
-noname FileMenu_DeleteSeparator
(long
)
135 143 stdcall
-noname FileMenu_EnableItemByCmd
(long long long
)
136 144 stdcall
-noname FileMenu_GetItemExtent
(long long
)
137 145 stdcall
-noname PathFindOnPath
(ptr ptr
) PathFindOnPathAW
138 146 stdcall
-noname RLBuildListOfPaths
()
139 147 stdcall
-noname SHCLSIDFromString
(long long
) SHCLSIDFromStringAW
140 148 stdcall
-noname SHMapIDListToImageListIndexAsync
(ptr ptr ptr long ptr ptr ptr ptr ptr
)
141 149 stdcall
-noname SHFind_InitMenuPopup
(long long long long
)
143 151 stdcall
-noname SHLoadOLE
(long
)
144 152 stdcall
-noname ILGetSize
(ptr
)
145 153 stdcall
-noname ILGetNext
(ptr
)
146 154 stdcall
-noname ILAppend
(long long long
)
147 155 stdcall
-noname ILFree
(ptr
)
148 156 stdcall
-noname ILGlobalFree
(ptr
)
149 157 stdcall
-noname ILCreateFromPath
(ptr
) ILCreateFromPathAW
150 158 stdcall
-noname PathGetExtension
(str long long
) PathGetExtensionAW
151 159 stdcall
-noname PathIsDirectory
(ptr
) PathIsDirectoryAW
152 160 stub SHNetConnectionDialog
153 161 stdcall
-noname SHRunControlPanel
(long long
)
154 162 stdcall
-noname SHSimpleIDListFromPath
(ptr
) SHSimpleIDListFromPathAW
155 163 stdcall
-noname StrToOleStr
(wstr str
) StrToOleStrAW
156 164 stdcall
-noname Win32DeleteFile
(str
) Win32DeleteFileAW
157 165 stdcall
-noname SHCreateDirectory
(long ptr
)
158 166 stdcall
-noname CallCPLEntry16
(long long long long long long
)
159 167 stdcall
-noname SHAddFromPropSheetExtArray
(long long long
)
160 168 stdcall
-noname SHCreatePropSheetExtArray
(long wstr long
)
161 169 stdcall
-noname SHDestroyPropSheetExtArray
(long
)
162 170 stdcall
-noname SHReplaceFromPropSheetExtArray
(long long long long
)
163 171 stdcall
-noname PathCleanupSpec
(ptr ptr
)
164 172 stdcall
-noname SHCreateLinks
(long str ptr long ptr
)
165 173 stdcall
-noname SHValidateUNC
(long long long
)
166 174 stdcall
-noname SHCreateShellFolderViewEx
(ptr ptr
)
167 175 stdcall
-noname SHGetSpecialFolderPath
(long long long long
) SHGetSpecialFolderPathAW
168 176 stdcall
-noname SHSetInstanceExplorer
(long
)
169 177 stub DAD_SetDragImageFromListView
170 178 stdcall
-noname SHObjectProperties
(long long wstr wstr
)
171 179 stdcall
-noname SHGetNewLinkInfoA
(str str ptr long long
)
172 180 stdcall
-noname SHGetNewLinkInfoW
(wstr wstr ptr long long
)
173 181 stdcall
-noname RegisterShellHook
(long long
)
174 182 varargs
-noname ShellMessageBoxW
(long long wstr wstr long
)
175 183 varargs
-noname ShellMessageBoxA
(long long str str long
)
176 184 stdcall
-noname ArrangeWindows
(long long long long long
)
177 185 stub SHHandleDiskFull
178 186 stdcall
-noname ILGetDisplayNameEx
(ptr ptr ptr long
)
179 187 stub ILGetPseudoNameW
180 188 stdcall
-noname ShellDDEInit
(long
)
181 189 stdcall
-noname ILCreateFromPathA
(str
)
182 190 stdcall
-noname ILCreateFromPathW
(wstr
)
183 191 stdcall
-noname SHUpdateImageA
(str long long long
)
184 192 stdcall
-noname SHUpdateImageW
(wstr long long long
)
185 193 stdcall
-noname SHHandleUpdateImage
(ptr
)
186 194 stdcall
-noname SHCreatePropSheetExtArrayEx
(long wstr long ptr
)
187 195 stdcall
-noname SHFree
(ptr
)
188 196 stdcall
-noname SHAlloc
(long
)
189 197 stub SHGlobalDefect
190 198 stdcall
-noname SHAbortInvokeCommand
()
191 199 stub SHGetFileIcon
192 200 stub SHLocalAlloc
194 202 stub SHLocalReAlloc
196 204 stub ShortSizeFormatW
197 205 stdcall Printer_LoadIconsW
(wstr ptr ptr
)
198 206 stub Link_AddExtraDataSection
199 207 stub Link_ReadExtraDataSection
200 208 stub Link_RemoveExtraDataSection
201 209 stub Int64ToString
202 210 stub LargeIntegerToString
203 211 stub Printers_GetPidl
204 212 stub Printers_AddPrinterPropPages
205 213 stdcall Printers_RegisterWindowW
(wstr long ptr ptr
)
206 214 stdcall Printers_UnregisterWindow
(long long
)
207 215 stdcall
-noname SHStartNetConnectionDialog
(long str long
)
208 243 stdcall @
(long long
) shell32_243
209 244 stdcall
-noname SHInitRestricted
(ptr ptr
)
210 249 stdcall
-noname PathParseIconLocation
(ptr
) PathParseIconLocationAW
211 250 stdcall
-noname PathRemoveExtension
(ptr
) PathRemoveExtensionAW
212 251 stdcall
-noname PathRemoveArgs
(ptr
) PathRemoveArgsAW
213 256 stdcall @
(ptr ptr
) SHELL32_256
214 258 stdcall
-noname LinkWindow_RegisterClass
()
215 259 stdcall
-noname LinkWindow_UnregisterClass
()
216 #299 stub Shl1632_ThunkData32
217 #300 stub Shl3216_ThunkData32
219 505 stdcall SHRegCloseKey
(long
)
220 506 stdcall SHRegOpenKeyA
(long str long
)
221 507 stdcall SHRegOpenKeyW
(long wstr long
)
222 508 stdcall SHRegQueryValueA
(long str ptr ptr
)
223 509 stdcall SHRegQueryValueExA
(long str ptr ptr ptr ptr
)
224 510 stdcall SHRegQueryValueW
(long long long long
)
225 511 stdcall SHRegQueryValueExW
(long wstr ptr ptr ptr ptr
)
226 512 stdcall SHRegDeleteKeyW
(long wstr
)
228 520 stdcall
-noname SHAllocShared
(ptr long long
)
229 521 stdcall
-noname SHLockShared
(long long
)
230 522 stdcall
-noname SHUnlockShared
(ptr
)
231 523 stdcall
-noname SHFreeShared
(long long
)
232 524 stdcall
-noname RealDriveType
(long long
)
233 525 stub RealDriveTypeFlags
235 640 stdcall
-noname NTSHChangeNotifyRegister
(long long long long long long
)
236 641 stdcall
-noname NTSHChangeNotifyDeregister
(long
)
238 643 stub SHChangeNotifyReceive
239 644 stdcall
-noname SHChangeNotification_Lock
(long long ptr ptr
)
240 645 stdcall
-noname SHChangeNotification_Unlock
(long
)
241 646 stub SHChangeRegistrationReceive
242 647 stub ReceiveAddToRecentDocs
243 648 stub SHWaitOp_Operate
245 650 stdcall
-noname PathIsSameRoot
(ptr ptr
) PathIsSameRootAW
247 651 stdcall
-noname ReadCabinetState
(long long
) # OldReadCabinetState
248 652 stdcall
-noname WriteCabinetState
(long
)
249 653 stdcall
-noname PathProcessCommand
(long long long long
) PathProcessCommandAW
250 654 stdcall @
(long long
) shell32_654
# ReadCabinetState@8
252 660 stdcall
-noname FileIconInit
(long
)
253 680 stdcall
-noname IsUserAdmin
()
255 714 stdcall @
(ptr
) SHELL32_714
# PathIsTemporaryW
256 730 stdcall
-noname RestartDialogEx
(long wstr long long
)
258 1217 stub FOOBAR1217
# no joke! This is the real name!!
260 @ stdcall CheckEscapesA
(str long
)
261 @ stdcall CheckEscapesW
(wstr long
)
262 @ stdcall CommandLineToArgvW
(wstr ptr
)
263 @ stdcall Control_FillCache_RunDLL
(long long long long
) Control_FillCache_RunDLLA
264 @ stdcall Control_FillCache_RunDLLA
(long long long long
)
265 @ stdcall Control_FillCache_RunDLLW
(long long long long
)
266 @ stdcall Control_RunDLL
(ptr ptr str long
) Control_RunDLLA
267 @ stdcall Control_RunDLLA
(ptr ptr str long
)
268 @ stub Control_RunDLLAsUserW
269 @ stdcall Control_RunDLLW
(ptr ptr wstr long
)
270 @ stdcall
-private DllCanUnloadNow
()
271 @ stdcall
-private DllGetClassObject
(ptr ptr ptr
)
272 @ stdcall
-private DllGetVersion
(ptr
)
273 @ stdcall
-private DllInstall
(long wstr
)
274 @ stdcall
-private DllRegisterServer
()
275 @ stdcall
-private DllUnregisterServer
()
276 @ stdcall DoEnvironmentSubstA
(str str
)
277 @ stdcall DoEnvironmentSubstW
(wstr wstr
)
278 @ stdcall DragAcceptFiles
(long long
)
279 @ stdcall DragFinish
(long
)
280 @ stdcall DragQueryFile
(long long ptr long
) DragQueryFileA
281 @ stdcall DragQueryFileA
(long long ptr long
)
282 @ stub DragQueryFileAorW
283 @ stdcall DragQueryFileW
(long long ptr long
)
284 @ stdcall DragQueryPoint
(long ptr
)
285 @ stdcall DuplicateIcon
(long long
)
286 @ stdcall ExtractAssociatedIconA
(long str ptr
)
287 @ stdcall ExtractAssociatedIconExA
(long str long long
)
288 @ stdcall ExtractAssociatedIconExW
(long wstr long long
)
289 @ stdcall ExtractAssociatedIconW
(long wstr ptr
)
290 @ stdcall ExtractIconA
(long str long
)
291 @ stdcall ExtractIconEx
(ptr long ptr ptr long
) ExtractIconExA
292 @ stdcall ExtractIconExA
(str long ptr ptr long
)
293 @ stdcall ExtractIconExW
(wstr long ptr ptr long
)
294 @ stub ExtractIconResInfoA
295 @ stub ExtractIconResInfoW
296 @ stdcall ExtractIconW
(long wstr long
)
297 @ stub ExtractVersionResource16W
298 @ stub FindExeDlgProc
299 @ stdcall FindExecutableA
(str str ptr
)
300 @ stdcall FindExecutableW
(wstr wstr ptr
)
301 @ stub FixupOptionalComponents
302 @ stdcall FreeIconList
(long
)
303 @ stub InternalExtractIconListA
304 @ stub InternalExtractIconListW
306 @ stdcall OpenAs_RunDLL
(long long str long
) OpenAs_RunDLLA
307 @ stdcall OpenAs_RunDLLA
(long long str long
)
308 @ stdcall OpenAs_RunDLLW
(long long wstr long
)
309 @ stub PrintersGetCommand_RunDLL
310 @ stub PrintersGetCommand_RunDLLA
311 @ stub PrintersGetCommand_RunDLLW
312 @ stub RealShellExecuteA
313 @ stub RealShellExecuteExA
314 @ stub RealShellExecuteExW
315 @ stub RealShellExecuteW
316 @ stub RegenerateUserEnvironment
317 @ stdcall SHAddToRecentDocs
(long ptr
)
318 @ stdcall SHAppBarMessage
(long ptr
)
319 @ stdcall SHBindToParent
(ptr ptr ptr ptr
)
320 @ stdcall SHBrowseForFolder
(ptr
) SHBrowseForFolderA
321 @ stdcall SHBrowseForFolderA
(ptr
)
322 @ stdcall SHBrowseForFolderW
(ptr
)
323 @ stdcall SHChangeNotify
(long long ptr ptr
)
324 @ stub SHChangeNotifySuspendResume
325 @ stdcall SHCreateDirectoryExA
(long str ptr
)
326 @ stdcall SHCreateDirectoryExW
(long wstr ptr
)
327 @ stub SHCreateProcessAsUserW
328 @ stdcall SHEmptyRecycleBinA
(long str long
)
329 @ stdcall SHEmptyRecycleBinW
(long wstr long
)
330 @ stub SHExtractIconsW
331 @ stdcall SHFileOperation
(ptr
) SHFileOperationA
332 @ stdcall SHFileOperationA
(ptr
)
333 @ stdcall SHFileOperationW
(ptr
)
334 @ stdcall SHFormatDrive
(long long long long
)
335 @ stdcall SHFreeNameMappings
(ptr
)
336 @ stdcall SHGetDataFromIDListA
(ptr ptr long ptr long
)
337 @ stdcall SHGetDataFromIDListW
(ptr ptr long ptr long
)
338 @ stdcall SHGetDesktopFolder
(ptr
)
339 @ stdcall SHGetDiskFreeSpaceA
(str ptr ptr ptr
) kernel32.GetDiskFreeSpaceExA
340 @ stdcall SHGetDiskFreeSpaceExA
(str ptr ptr ptr
) kernel32.GetDiskFreeSpaceExA
341 @ stdcall SHGetDiskFreeSpaceExW
(wstr ptr ptr ptr
) kernel32.GetDiskFreeSpaceExW
342 @ stdcall SHGetFileInfo
(ptr long ptr long long
) SHGetFileInfoA
343 @ stdcall SHGetFileInfoA
(ptr long ptr long long
)
344 @ stdcall SHGetFileInfoW
(ptr long ptr long long
)
345 @ stdcall SHGetFolderLocation
(long long long long ptr
)
346 @ stdcall SHGetFolderPathA
(long long long long ptr
)
347 @ stdcall SHGetFolderPathAndSubDirA
(long long long long str ptr
)
348 @ stdcall SHGetFolderPathAndSubDirW
(long long long long wstr ptr
)
349 @ stdcall SHGetFolderPathW
(long long long long ptr
)
350 @ stub SHGetFreeDiskSpace
351 @ stub SHGetIconOverlayIndexA
352 @ stub SHGetIconOverlayIndexW
353 @ stdcall SHGetInstanceExplorer
(long
)
354 @ stdcall SHGetMalloc
(ptr
)
355 @ stdcall SHGetNewLinkInfo
(str str ptr long long
) SHGetNewLinkInfoA
356 @ stdcall SHGetPathFromIDList
(ptr ptr
) SHGetPathFromIDListA
357 @ stdcall SHGetPathFromIDListA
(ptr ptr
)
358 @ stdcall SHGetPathFromIDListW
(ptr ptr
)
359 @ stdcall SHGetSettings
(ptr long
)
360 @ stdcall SHGetSpecialFolderLocation
(long long ptr
)
361 @ stdcall SHGetSpecialFolderPathA
(long ptr long long
)
362 @ stdcall SHGetSpecialFolderPathW
(long ptr long long
)
363 @ stdcall SHHelpShortcuts_RunDLL
(long long long long
) SHHelpShortcuts_RunDLLA
364 @ stdcall SHHelpShortcuts_RunDLLA
(long long long long
)
365 @ stdcall SHHelpShortcuts_RunDLLW
(long long long long
)
366 @ stub SHInvokePrinterCommandA
367 @ stub SHInvokePrinterCommandW
368 @ stdcall SHIsFileAvailableOffline
(wstr ptr
)
369 @ stdcall SHLoadInProc
(long
)
370 @ stdcall SHLoadNonloadedIconOverlayIdentifiers
()
371 @ stdcall SHPathPrepareForWriteA
(long ptr str long
)
372 @ stdcall SHPathPrepareForWriteW
(long ptr wstr long
)
373 @ stdcall SHQueryRecycleBinA
(str ptr
)
374 @ stdcall SHQueryRecycleBinW
(wstr ptr
)
375 @ stdcall SHSetLocalizedName
(wstr wstr long
)
376 @ stdcall SHUpdateRecycleBinIcon
()
377 @ stdcall SheChangeDirA
(str
)
378 @ stub SheChangeDirExA
379 @ stub SheChangeDirExW
380 @ stdcall SheChangeDirW
(wstr
)
381 @ stub SheConvertPathW
384 @ stub SheGetCurDrive
385 @ stdcall SheGetDirA
(long long
)
387 @ stdcall SheGetDirW
(long long
)
388 @ stub SheGetPathOffsetW
389 @ stub SheRemoveQuotesA
390 @ stub SheRemoveQuotesW
391 @ stub SheSetCurDrive
392 @ stub SheShortenPathA
393 @ stub SheShortenPathW
394 @ stdcall ShellAboutA
(long str str long
)
395 @ stdcall ShellAboutW
(long wstr wstr long
)
396 @ stub ShellExec_RunDLL
397 @ stub ShellExec_RunDLLA
398 @ stub ShellExec_RunDLLW
399 @ stdcall ShellExecuteA
(long str str str str long
)
400 @ stdcall ShellExecuteEx
(long
) ShellExecuteExA
401 @ stdcall ShellExecuteExA
(long
)
402 @ stdcall ShellExecuteExW
(long
)
403 @ stdcall ShellExecuteW
(long wstr wstr wstr wstr long
)
405 @ stdcall Shell_NotifyIcon
(long ptr
) Shell_NotifyIconA
406 @ stdcall Shell_NotifyIconA
(long ptr
)
407 @ stdcall Shell_NotifyIconW
(long ptr
)
408 @ stdcall StrChrA
(str long
) shlwapi.StrChrA
409 @ stdcall StrChrIA
(str long
) shlwapi.StrChrIA
410 @ stdcall StrChrIW
(wstr long
) shlwapi.StrChrIW
411 @ stdcall StrChrW
(wstr long
) shlwapi.StrChrW
412 @ stdcall StrCmpNA
(str str long
) shlwapi.StrCmpNA
413 @ stdcall StrCmpNIA
(str str long
) shlwapi.StrCmpNIA
414 @ stdcall StrCmpNIW
(wstr wstr long
) shlwapi.StrCmpNIW
415 @ stdcall StrCmpNW
(wstr wstr long
) shlwapi.StrCmpNW
416 @ stdcall StrCpyNA
(ptr str long
) kernel32.lstrcpynA
417 @ stdcall StrCpyNW
(wstr wstr long
) shlwapi.StrCpyNW
418 @ stdcall StrNCmpA
(str str long
) shlwapi.StrCmpNA
419 @ stdcall StrNCmpIA
(str str long
) shlwapi.StrCmpNIA
420 @ stdcall StrNCmpIW
(wstr wstr long
) shlwapi.StrCmpNIW
421 @ stdcall StrNCmpW
(wstr wstr long
) shlwapi.StrCmpNW
422 @ stdcall StrNCpyA
(ptr str long
) kernel32.lstrcpynA
423 @ stdcall StrNCpyW
(wstr wstr long
) shlwapi.StrCpyNW
424 @ stdcall StrRChrA
(str str long
) shlwapi.StrRChrA
425 @ stdcall StrRChrIA
(str str long
) shlwapi.StrRChrIA
426 @ stdcall StrRChrIW
(str str long
) shlwapi.StrRChrIW
427 @ stdcall StrRChrW
(wstr wstr long
) shlwapi.StrRChrW
429 @ stdcall StrRStrIA
(str str str
) shlwapi.StrRStrIA
430 @ stdcall StrRStrIW
(wstr wstr wstr
) shlwapi.StrRStrIW
432 @ stdcall StrStrA
(str str
) shlwapi.StrStrA
433 @ stdcall StrStrIA
(str str
) shlwapi.StrStrIA
434 @ stdcall StrStrIW
(wstr wstr
) shlwapi.StrStrIW
435 @ stdcall StrStrW
(wstr wstr
) shlwapi.StrStrW
436 @ stub WOWShellExecute