hid: Rewrite HidP_SetUsageValue using enum_value_caps.
[wine.git] / dlls / crtdll / crtdll.spec
blob022893a5978edb274f9cbe22524d36194a6def80
1 # Old C runtime library. All functions provided by msvcrt
3 @ cdecl -arch=win32 ??2@YAPAXI@Z(long) operator_new
4 @ cdecl -arch=win64 ??2@YAPEAX_K@Z(long) operator_new
5 @ cdecl -arch=win32 ??3@YAXPAX@Z(ptr) operator_delete
6 @ cdecl -arch=win64 ??3@YAXPEAX@Z(ptr) operator_delete
7 @ cdecl -arch=win32 ?_set_new_handler@@YAP6AHI@ZP6AHI@Z@Z(ptr) _set_new_handler
8 @ cdecl -arch=win64 ?_set_new_handler@@YAP6AH_K@ZP6AH0@Z@Z(ptr) _set_new_handler
9 @ cdecl -arch=i386 _CIacos()
10 @ cdecl -arch=i386 _CIasin()
11 @ cdecl -arch=i386 _CIatan()
12 @ cdecl -arch=i386 _CIatan2()
13 @ cdecl -arch=i386 _CIcos()
14 @ cdecl -arch=i386 _CIcosh()
15 @ cdecl -arch=i386 _CIexp()
16 @ cdecl -arch=i386 _CIfmod()
17 @ cdecl -arch=i386 _CIlog()
18 @ cdecl -arch=i386 _CIlog10()
19 @ cdecl -arch=i386 _CIpow()
20 @ cdecl -arch=i386 _CIsin()
21 @ cdecl -arch=i386 _CIsinh()
22 @ cdecl -arch=i386 _CIsqrt()
23 @ cdecl -arch=i386 _CItan()
24 @ cdecl -arch=i386 _CItanh()
25 @ extern _HUGE_dll MSVCRT__HUGE
26 @ cdecl _XcptFilter(long ptr)
27 @ cdecl __GetMainArgs(ptr ptr ptr long)
28 @ extern __argc_dll MSVCRT___argc
29 @ extern __argv_dll MSVCRT___argv
30 @ cdecl __dllonexit(ptr ptr ptr)
31 @ cdecl __doserrno()
32 @ cdecl __fpecode()
33 @ cdecl __isascii(long)
34 @ cdecl __iscsym(long)
35 @ cdecl __iscsymf(long)
36 @ extern __mb_cur_max_dll MSVCRT___mb_cur_max
37 @ cdecl __pxcptinfoptrs()
38 @ cdecl __threadhandle() kernel32.GetCurrentThread
39 @ cdecl __threadid() kernel32.GetCurrentThreadId
40 @ cdecl __toascii(long)
41 @ cdecl _abnormal_termination() __intrinsic_abnormal_termination
42 @ cdecl _access(str long)
43 @ extern _acmdln_dll MSVCRT__acmdln
44 @ extern _aexit_rtn_dll _aexit_rtn
45 @ cdecl _amsg_exit(long)
46 @ cdecl _assert(str str long)
47 @ extern _basemajor_dll CRTDLL__basemajor_dll
48 @ extern _baseminor_dll CRTDLL__baseminor_dll
49 @ extern _baseversion_dll MSVCRT__osver
50 @ cdecl _beep(long long)
51 @ cdecl _beginthread(ptr long ptr)
52 @ cdecl _c_exit()
53 @ cdecl _cabs(long)
54 @ cdecl _cexit()
55 @ cdecl _cgets(ptr)
56 @ cdecl _chdir(str)
57 @ cdecl _chdrive(long)
58 @ cdecl _chgsign(double)
59 @ cdecl _chmod(str long)
60 @ cdecl _chsize(long long)
61 @ cdecl _clearfp()
62 @ cdecl _close(long)
63 @ cdecl _commit(long)
64 @ extern _commode_dll MSVCRT__commode
65 @ cdecl _control87(long long)
66 @ cdecl _controlfp(long long)
67 @ cdecl _copysign(double double)
68 @ varargs _cprintf(str)
69 @ extern _cpumode_dll CRTDLL__cpumode_dll
70 @ cdecl _cputs(str)
71 @ cdecl _creat(str long)
72 @ varargs _cscanf(str)
73 @ extern _ctype MSVCRT__ctype
74 @ cdecl _cwait(ptr long long)
75 @ extern _daylight_dll MSVCRT___daylight
76 @ cdecl _dup(long)
77 @ cdecl _dup2(long long)
78 @ cdecl _ecvt(double long ptr ptr)
79 @ cdecl _endthread()
80 @ extern _environ_dll MSVCRT__environ
81 @ cdecl _eof(long)
82 @ cdecl _errno()
83 @ cdecl -arch=i386 _except_handler2(ptr ptr ptr ptr)
84 @ varargs _execl(str str)
85 @ varargs _execle(str str)
86 @ varargs _execlp(str str)
87 @ varargs _execlpe(str str)
88 @ cdecl _execv(str ptr)
89 @ cdecl _execve(str ptr ptr)
90 @ cdecl _execvp(str ptr)
91 @ cdecl _execvpe(str ptr ptr)
92 @ cdecl _exit(long)
93 @ cdecl _expand(ptr long)
94 @ cdecl _fcloseall()
95 @ cdecl _fcvt(double long ptr ptr)
96 @ cdecl _fdopen(long str)
97 @ cdecl _fgetchar()
98 @ cdecl _fgetwchar()
99 @ cdecl _filbuf(ptr)
100 # extern _fileinfo_dll
101 @ cdecl _filelength(long)
102 @ cdecl _fileno(ptr)
103 @ cdecl _findclose(long)
104 @ cdecl _findfirst(str ptr)
105 @ cdecl _findnext(long ptr)
106 @ cdecl _finite(double)
107 @ cdecl _flsbuf(long ptr)
108 @ cdecl _flushall()
109 @ extern _fmode_dll MSVCRT__fmode
110 @ cdecl _fpclass(double)
111 @ cdecl -arch=i386,x86_64,arm,arm64 _fpieee_flt(long ptr ptr)
112 @ cdecl _fpreset()
113 @ cdecl _fputchar(long)
114 @ cdecl _fputwchar(long)
115 @ cdecl _fsopen(str str long)
116 @ cdecl _fstat(long ptr)
117 @ cdecl -arch=win32 _ftime(ptr) _ftime32
118 @ cdecl -arch=win64 _ftime(ptr) _ftime64
119 @ cdecl -arch=i386 -ret64 _ftol()
120 @ cdecl _fullpath(ptr str long)
121 @ cdecl -arch=win32 _futime(long ptr) _futime32
122 @ cdecl -arch=win64 _futime(long ptr) _futime64
123 @ cdecl _gcvt(double long str)
124 @ cdecl _get_osfhandle(long)
125 @ cdecl _getch()
126 @ cdecl _getche()
127 @ cdecl _getcwd(str long)
128 @ cdecl _getdcwd(long str long)
129 @ cdecl _getdiskfree(long ptr)
130 @ cdecl _getdllprocaddr(long str long)
131 @ cdecl _getdrive()
132 @ cdecl _getdrives() kernel32.GetLogicalDrives
133 @ cdecl _getpid()
134 @ stub _getsystime(ptr)
135 @ cdecl _getw(ptr)
136 @ cdecl -arch=i386 _global_unwind2(ptr)
137 @ cdecl _heapchk()
138 @ cdecl _heapmin()
139 @ cdecl _heapset(long)
140 @ cdecl _heapwalk(ptr)
141 @ cdecl _hypot(double double)
142 @ cdecl _initterm(ptr ptr)
143 @ extern _iob MSVCRT__iob
144 @ cdecl _isatty(long)
145 @ cdecl _isctype(long long)
146 @ stub _ismbbalnum(long)
147 @ stub _ismbbalpha(long)
148 @ stub _ismbbgraph(long)
149 @ stub _ismbbkalnum(long)
150 @ cdecl _ismbbkana(long)
151 @ stub _ismbbkpunct(long)
152 @ cdecl _ismbblead(long)
153 @ stub _ismbbprint(long)
154 @ stub _ismbbpunct(long)
155 @ cdecl _ismbbtrail(long)
156 @ cdecl _ismbcalpha(long)
157 @ cdecl _ismbcdigit(long)
158 @ cdecl _ismbchira(long)
159 @ cdecl _ismbckata(long)
160 @ cdecl _ismbcl0(long)
161 @ cdecl _ismbcl1(long)
162 @ cdecl _ismbcl2(long)
163 @ cdecl _ismbclegal(long)
164 @ cdecl _ismbclower(long)
165 @ cdecl _ismbcprint(long)
166 @ cdecl _ismbcspace(long)
167 @ cdecl _ismbcsymbol(long)
168 @ cdecl _ismbcupper(long)
169 @ cdecl _ismbslead(ptr ptr)
170 @ cdecl _ismbstrail(ptr ptr)
171 @ cdecl _isnan(double)
172 @ cdecl _itoa(long ptr long)
173 @ cdecl _itow(long ptr long) ntdll._itow
174 @ cdecl _j0(double)
175 @ cdecl _j1(double)
176 @ cdecl _jn(long double)
177 @ cdecl _kbhit()
178 @ cdecl _lfind(ptr ptr ptr long ptr)
179 @ cdecl _loaddll(str)
180 @ cdecl -arch=i386 _local_unwind2(ptr long)
181 @ cdecl _locking(long long long)
182 @ cdecl _logb(double)
183 @ cdecl _lrotl(long long) MSVCRT__lrotl
184 @ cdecl _lrotr(long long) MSVCRT__lrotr
185 @ cdecl _lsearch(ptr ptr ptr long ptr)
186 @ cdecl _lseek(long long long)
187 @ cdecl _ltoa(long ptr long) ntdll._ltoa
188 @ cdecl _ltow(long ptr long) ntdll._ltow
189 @ cdecl _makepath(ptr str str str str)
190 @ cdecl _matherr(ptr)
191 @ cdecl _mbbtombc(long)
192 @ cdecl _mbbtype(long long)
193 @ cdecl _mbccpy(ptr ptr)
194 @ cdecl _mbcjistojms(long)
195 @ cdecl _mbcjmstojis(long)
196 @ cdecl _mbclen(ptr)
197 @ cdecl _mbctohira(long)
198 @ cdecl _mbctokata(long)
199 @ cdecl _mbctolower(long)
200 @ cdecl _mbctombb(long)
201 @ cdecl _mbctoupper(long)
202 @ extern _mbctype MSVCRT_mbctype
203 @ cdecl _mbsbtype(str long)
204 @ cdecl _mbscat(str str)
205 @ cdecl _mbschr(str long)
206 @ cdecl _mbscmp(str str)
207 @ cdecl _mbscpy(ptr str)
208 @ cdecl _mbscspn(str str)
209 @ cdecl _mbsdec(ptr ptr)
210 @ cdecl _mbsdup(str) _strdup
211 @ cdecl _mbsicmp(str str)
212 @ cdecl _mbsinc(str)
213 @ cdecl _mbslen(str)
214 @ cdecl _mbslwr(str)
215 @ cdecl _mbsnbcat(str str long)
216 @ cdecl _mbsnbcmp(str str long)
217 @ cdecl _mbsnbcnt(ptr long)
218 @ cdecl _mbsnbcpy(ptr str long)
219 @ cdecl _mbsnbicmp(str str long)
220 @ cdecl _mbsnbset(ptr long long)
221 @ cdecl _mbsncat(str str long)
222 @ cdecl _mbsnccnt(str long)
223 @ cdecl _mbsncmp(str str long)
224 @ cdecl _mbsncpy(ptr str long)
225 @ cdecl _mbsnextc(str)
226 @ cdecl _mbsnicmp(str str long)
227 @ cdecl _mbsninc(str long)
228 @ cdecl _mbsnset(ptr long long)
229 @ cdecl _mbspbrk(str str)
230 @ cdecl _mbsrchr(str long)
231 @ cdecl _mbsrev(str)
232 @ cdecl _mbsset(ptr long)
233 @ cdecl _mbsspn(str str)
234 @ cdecl _mbsspnp(str str)
235 @ cdecl _mbsstr(str str)
236 @ cdecl _mbstok(str str)
237 @ cdecl _mbstrlen(str)
238 @ cdecl _mbsupr(str)
239 @ cdecl _memccpy(ptr ptr long long) ntdll._memccpy
240 @ cdecl _memicmp(str str long)
241 @ cdecl _mkdir(str)
242 @ cdecl _mktemp(str)
243 @ cdecl _msize(ptr)
244 @ cdecl _nextafter(double double)
245 @ cdecl _onexit(ptr)
246 @ varargs _open(str long)
247 @ cdecl _open_osfhandle(long long)
248 @ extern _osmajor_dll MSVCRT__winmajor
249 @ extern _osminor_dll MSVCRT__winminor
250 @ extern _osmode_dll CRTDLL__osmode_dll
251 @ extern _osver_dll MSVCRT__osver
252 @ extern _osversion_dll MSVCRT__winver
253 @ cdecl _pclose(ptr)
254 @ extern _pctype_dll MSVCRT__pctype
255 @ extern _pgmptr_dll MSVCRT__pgmptr
256 @ cdecl _pipe(ptr long long)
257 @ cdecl _popen(str str)
258 @ cdecl _purecall()
259 @ cdecl _putch(long)
260 @ cdecl _putenv(str)
261 @ cdecl _putw(long ptr)
262 # extern _pwctype_dll
263 @ cdecl _read(long ptr long)
264 @ cdecl _rmdir(str)
265 @ cdecl _rmtmp()
266 @ cdecl _rotl(long long) MSVCRT__rotl
267 @ cdecl _rotr(long long) MSVCRT__rotr
268 @ cdecl _scalb(double long)
269 @ cdecl _searchenv(str str ptr)
270 @ cdecl _seterrormode(long)
271 @ cdecl -arch=i386,x86_64,arm,arm64 -norelay _setjmp(ptr) MSVCRT__setjmp
272 @ cdecl _setmode(long long)
273 @ stub _setsystime(ptr long)
274 @ cdecl _sleep(long)
275 @ varargs _snprintf(ptr long str)
276 @ varargs _snwprintf(ptr long wstr)
277 @ varargs _sopen(str long long)
278 @ varargs _spawnl(long str str)
279 @ varargs _spawnle(long str str)
280 @ varargs _spawnlp(long str str)
281 @ varargs _spawnlpe(long str str)
282 @ cdecl _spawnv(long str ptr)
283 @ cdecl _spawnve(long str ptr ptr)
284 @ cdecl _spawnvp(long str ptr)
285 @ cdecl _spawnvpe(long str ptr ptr)
286 @ cdecl _splitpath(str ptr ptr ptr ptr)
287 @ cdecl _stat(str ptr)
288 @ cdecl _statusfp()
289 @ cdecl _strcmpi(str str) _stricmp
290 @ cdecl _strdate(ptr)
291 @ cdecl _strdec(str str)
292 @ cdecl _strdup(str)
293 @ cdecl _strerror(long)
294 @ cdecl _stricmp(str str)
295 @ cdecl _stricoll(str str)
296 @ cdecl _strinc(str)
297 @ cdecl _strlwr(str)
298 @ cdecl _strncnt(str long) __strncnt
299 @ cdecl _strnextc(str)
300 @ cdecl _strnicmp(str str long)
301 @ cdecl _strninc(str long)
302 @ cdecl _strnset(str long long)
303 @ cdecl _strrev(str)
304 @ cdecl _strset(str long)
305 @ cdecl _strspnp(str str)
306 @ cdecl _strtime(ptr)
307 @ cdecl _strupr(str)
308 @ cdecl _swab(str str long)
309 @ extern _sys_errlist MSVCRT__sys_errlist
310 @ extern _sys_nerr_dll MSVCRT__sys_nerr
311 @ cdecl _tell(long)
312 @ cdecl _tempnam(str str)
313 @ extern _timezone_dll MSVCRT___timezone
314 @ cdecl _tolower(long)
315 @ cdecl _toupper(long)
316 @ extern _tzname MSVCRT__tzname
317 @ cdecl _tzset()
318 @ cdecl _ultoa(long ptr long) ntdll._ultoa
319 @ cdecl _umask(long)
320 @ cdecl _ungetch(long)
321 @ cdecl _unlink(str)
322 @ cdecl _unloaddll(long)
323 @ cdecl -arch=win32 _utime(str ptr) _utime32
324 @ cdecl -arch=win64 _utime(str ptr) _utime64
325 @ cdecl _vsnprintf(ptr long str ptr)
326 @ cdecl _vsnwprintf(ptr long wstr ptr)
327 @ cdecl _wcsdup(wstr)
328 @ cdecl _wcsicmp(wstr wstr)
329 @ cdecl _wcsicoll(wstr wstr)
330 @ cdecl _wcslwr(wstr)
331 @ cdecl _wcsnicmp(wstr wstr long)
332 @ cdecl _wcsnset(wstr long long)
333 @ cdecl _wcsrev(wstr)
334 @ cdecl _wcsset(wstr long)
335 @ cdecl _wcsupr(wstr)
336 @ extern _winmajor_dll MSVCRT__winmajor
337 @ extern _winminor_dll MSVCRT__winminor
338 @ extern _winver_dll MSVCRT__winver
339 @ cdecl _write(long ptr long)
340 @ cdecl _wtoi(wstr)
341 @ cdecl _wtol(wstr)
342 @ cdecl _y0(double)
343 @ cdecl _y1(double)
344 @ cdecl _yn(long double)
345 @ cdecl abort()
346 @ cdecl abs(long)
347 @ cdecl acos(double)
348 @ cdecl asctime(ptr)
349 @ cdecl asin(double)
350 @ cdecl atan(double)
351 @ cdecl atan2(double double)
352 @ cdecl -private atexit(ptr) MSVCRT_atexit
353 @ cdecl atof(str)
354 @ cdecl atoi(str)
355 @ cdecl atol(str)
356 @ cdecl bsearch(ptr ptr long long ptr)
357 @ cdecl calloc(long long)
358 @ cdecl ceil(double)
359 @ cdecl clearerr(ptr)
360 @ cdecl clock()
361 @ cdecl cos(double)
362 @ cdecl cosh(double)
363 @ cdecl -arch=win32 ctime(ptr) _ctime32
364 @ cdecl -arch=win64 ctime(ptr) _ctime64
365 @ cdecl -arch=win32 difftime(long long) _difftime32
366 @ cdecl -arch=win64 difftime(long long) _difftime64
367 @ cdecl -ret64 div(long long)
368 @ cdecl exit(long)
369 @ cdecl exp(double)
370 @ cdecl fabs(double)
371 @ cdecl fclose(ptr)
372 @ cdecl feof(ptr)
373 @ cdecl ferror(ptr)
374 @ cdecl fflush(ptr)
375 @ cdecl fgetc(ptr)
376 @ cdecl fgetpos(ptr ptr)
377 @ cdecl fgets(ptr long ptr)
378 @ cdecl fgetwc(ptr)
379 @ cdecl floor(double)
380 @ cdecl fmod(double double)
381 @ cdecl fopen(str str)
382 @ varargs fprintf(ptr str)
383 @ cdecl fputc(long ptr)
384 @ cdecl fputs(str ptr)
385 @ cdecl fputwc(long ptr)
386 @ cdecl fread(ptr long long ptr)
387 @ cdecl free(ptr)
388 @ cdecl freopen(str str ptr)
389 @ cdecl frexp(double ptr)
390 @ varargs fscanf(ptr str)
391 @ cdecl fseek(ptr long long)
392 @ cdecl fsetpos(ptr ptr)
393 @ cdecl ftell(ptr)
394 @ varargs fwprintf(ptr wstr)
395 @ cdecl fwrite(ptr long long ptr)
396 @ varargs fwscanf(ptr wstr)
397 @ cdecl getc(ptr)
398 @ cdecl getchar()
399 @ cdecl getenv(str)
400 @ cdecl gets(str)
401 @ cdecl -arch=win32 gmtime(ptr) _gmtime32
402 @ cdecl -arch=win64 gmtime(ptr) _gmtime64
403 @ cdecl is_wctype(long long) iswctype
404 @ cdecl isalnum(long)
405 @ cdecl isalpha(long)
406 @ cdecl iscntrl(long)
407 @ cdecl isdigit(long)
408 @ cdecl isgraph(long)
409 @ cdecl isleadbyte(long)
410 @ cdecl islower(long)
411 @ cdecl isprint(long)
412 @ cdecl ispunct(long)
413 @ cdecl isspace(long)
414 @ cdecl isupper(long)
415 @ cdecl iswalnum(long)
416 @ cdecl iswalpha(long)
417 @ cdecl iswascii(long)
418 @ cdecl iswcntrl(long)
419 @ cdecl iswctype(long long)
420 @ cdecl iswdigit(long)
421 @ cdecl iswgraph(long)
422 @ cdecl iswlower(long)
423 @ cdecl iswprint(long)
424 @ cdecl iswpunct(long)
425 @ cdecl iswspace(long)
426 @ cdecl iswupper(long)
427 @ cdecl iswxdigit(long)
428 @ cdecl isxdigit(long)
429 @ cdecl labs(long)
430 @ cdecl ldexp(double long)
431 @ cdecl -ret64 ldiv(long long)
432 @ cdecl localeconv()
433 @ cdecl -arch=win32 localtime(ptr) _localtime32
434 @ cdecl -arch=win64 localtime(ptr) _localtime64
435 @ cdecl log(double)
436 @ cdecl log10(double)
437 @ cdecl -arch=i386,x86_64,arm,arm64 longjmp(ptr long) MSVCRT_longjmp
438 @ cdecl malloc(long)
439 @ cdecl mblen(ptr long)
440 @ cdecl mbstowcs(ptr str long)
441 @ cdecl mbtowc(ptr str long)
442 @ cdecl memchr(ptr long long)
443 @ cdecl memcmp(ptr ptr long)
444 @ cdecl memcpy(ptr ptr long)
445 @ cdecl memmove(ptr ptr long)
446 @ cdecl memset(ptr long long)
447 @ cdecl -arch=win32 mktime(ptr) _mktime32
448 @ cdecl -arch=win64 mktime(ptr) _mktime64
449 @ cdecl modf(double ptr)
450 @ cdecl perror(str)
451 @ cdecl pow(double double)
452 @ varargs printf(str)
453 @ cdecl putc(long ptr)
454 @ cdecl putchar(long)
455 @ cdecl puts(str)
456 @ cdecl qsort(ptr long long ptr)
457 @ cdecl raise(long)
458 @ cdecl rand()
459 @ cdecl realloc(ptr long)
460 @ cdecl remove(str)
461 @ cdecl rename(str str)
462 @ cdecl rewind(ptr)
463 @ varargs scanf(str)
464 @ cdecl setbuf(ptr ptr)
465 @ cdecl setlocale(long str)
466 @ cdecl setvbuf(ptr str long long)
467 @ cdecl signal(long long)
468 @ cdecl sin(double)
469 @ cdecl sinh(double)
470 @ varargs sprintf(ptr str)
471 @ cdecl sqrt(double)
472 @ cdecl srand(long)
473 @ varargs sscanf(str str)
474 @ cdecl strcat(str str)
475 @ cdecl strchr(str long)
476 @ cdecl strcmp(str str)
477 @ cdecl strcoll(str str)
478 @ cdecl strcpy(ptr str)
479 @ cdecl strcspn(str str)
480 @ cdecl strerror(long)
481 @ cdecl strftime(ptr long str ptr)
482 @ cdecl strlen(str)
483 @ cdecl strncat(str str long)
484 @ cdecl strncmp(str str long)
485 @ cdecl strncpy(ptr str long)
486 @ cdecl strpbrk(str str)
487 @ cdecl strrchr(str long)
488 @ cdecl strspn(str str) ntdll.strspn
489 @ cdecl strstr(str str)
490 @ cdecl strtod(str ptr)
491 @ cdecl strtok(str str)
492 @ cdecl strtol(str ptr long)
493 @ cdecl strtoul(str ptr long)
494 @ cdecl strxfrm(ptr str long)
495 @ varargs swprintf(ptr wstr) _swprintf
496 @ varargs swscanf(wstr wstr)
497 @ cdecl system(str)
498 @ cdecl tan(double)
499 @ cdecl tanh(double)
500 @ cdecl -arch=win32 time(ptr) _time32
501 @ cdecl -arch=win64 time(ptr) _time64
502 @ cdecl tmpfile()
503 @ cdecl tmpnam(ptr)
504 @ cdecl tolower(long)
505 @ cdecl toupper(long)
506 @ cdecl towlower(long)
507 @ cdecl towupper(long)
508 @ cdecl ungetc(long ptr)
509 @ cdecl ungetwc(long ptr)
510 @ cdecl vfprintf(ptr str ptr)
511 @ cdecl vfwprintf(ptr wstr ptr)
512 @ cdecl vprintf(str ptr)
513 @ cdecl vsprintf(ptr str ptr)
514 @ cdecl vswprintf(ptr wstr ptr) _vswprintf
515 @ cdecl vwprintf(wstr ptr)
516 @ cdecl wcscat(wstr wstr)
517 @ cdecl wcschr(wstr long)
518 @ cdecl wcscmp(wstr wstr)
519 @ cdecl wcscoll(wstr wstr)
520 @ cdecl wcscpy(ptr wstr)
521 @ cdecl wcscspn(wstr wstr) ntdll.wcscspn
522 @ cdecl wcsftime(ptr long wstr ptr)
523 @ cdecl wcslen(wstr)
524 @ cdecl wcsncat(wstr wstr long) ntdll.wcsncat
525 @ cdecl wcsncmp(wstr wstr long)
526 @ cdecl wcsncpy(ptr wstr long)
527 @ cdecl wcspbrk(wstr wstr)
528 @ cdecl wcsrchr(wstr long)
529 @ cdecl wcsspn(wstr wstr) ntdll.wcsspn
530 @ cdecl wcsstr(wstr wstr)
531 @ cdecl wcstod(wstr ptr)
532 @ cdecl wcstok(wstr wstr)
533 @ cdecl wcstol(wstr ptr long)
534 @ cdecl wcstombs(ptr ptr long)
535 @ cdecl wcstoul(wstr ptr long)
536 @ cdecl wcsxfrm(ptr wstr long)
537 @ cdecl wctomb(ptr long)
538 @ varargs wprintf(wstr)
539 @ varargs wscanf(wstr)