1 @ stdcall AddIPAddress
( long long long ptr ptr
)
2 @ stub AllocateAndGetArpEntTableFromStack
3 @ stdcall AllocateAndGetIfTableFromStack
( ptr long long long
)
4 #@ stub AllocateAndGetInterfaceInfoFromStack
5 @ stdcall AllocateAndGetIpAddrTableFromStack
( ptr long long long
)
6 @ stdcall AllocateAndGetIpForwardTableFromStack
( ptr long long long
)
7 @ stdcall AllocateAndGetIpNetTableFromStack
( ptr long long long
)
8 @ stdcall AllocateAndGetTcpExTableFromStack
( ptr long long long long
)
9 @ stdcall AllocateAndGetTcpTableFromStack
( ptr long long long
)
10 @ stdcall AllocateAndGetUdpTableFromStack
( ptr long long long
)
11 @ stdcall CancelIPChangeNotify
( ptr
)
12 @ stdcall CancelMibChangeNotify2
( ptr
)
13 @ stdcall ConvertGuidToStringA
( ptr ptr long
)
14 @ stdcall ConvertGuidToStringW
( ptr ptr long
)
15 @ stdcall ConvertInterfaceAliasToLuid
( wstr ptr
)
16 @ stdcall ConvertInterfaceGuidToLuid
( ptr ptr
)
17 @ stdcall ConvertInterfaceIndexToLuid
( long ptr
)
18 @ stdcall ConvertInterfaceLuidToAlias
( ptr ptr long
)
19 @ stdcall ConvertInterfaceLuidToGuid
( ptr ptr
)
20 @ stdcall ConvertInterfaceLuidToIndex
( ptr ptr
)
21 @ stdcall ConvertInterfaceLuidToNameA
( ptr ptr long
)
22 @ stdcall ConvertInterfaceLuidToNameW
( ptr ptr long
)
23 @ stdcall ConvertInterfaceNameToLuidA
( str ptr
)
24 @ stdcall ConvertInterfaceNameToLuidW
( wstr ptr
)
25 #@ stub ConvertInterfacePhysicalAddressToLuid
26 #@ stub ConvertIpv4MaskToLength
27 @ stdcall ConvertLengthToIpv4Mask
( long ptr
)
28 #@ stub ConvertRemoteInterfaceAliasToLuid
29 #@ stub ConvertRemoteInterfaceGuidToLuid
30 #@ stub ConvertRemoteInterfaceIndexToLuid
31 #@ stub ConvertRemoteInterfaceLuidToAlias
32 #@ stub ConvertRemoteInterfaceLuidToGuid
33 #@ stub ConvertRemoteInterfaceLuidToIndex
34 #@ stub ConvertStringToGuidA
35 @ stdcall ConvertStringToGuidW
( wstr ptr
)
36 #@ stub ConvertStringToInterfacePhysicalAddress
37 #@ stub CPNatfwtCreateProviderInstance
38 #@ stub CPNatfwtDeregisterProviderInstance
39 #@ stub CPNatfwtDestroyProviderInstance
40 #@ stub CPNatfwtIndicateReceivedBuffers
41 #@ stub CPNatfwtRegisterProviderInstance
42 #@ stub CreateAnycastIpAddressEntry
43 #@ stub CreateIpForwardEntry2
44 @ stdcall CreateIpForwardEntry
( ptr
)
45 #@ stub CreateIpNetEntry2
46 @ stdcall CreateIpNetEntry
( ptr
)
47 #@ stub CreatePersistentTcpPortReservation
48 #@ stub CreatePersistentUdpPortReservation
49 @ stdcall CreateProxyArpEntry
( long long long
)
50 @ stdcall CreateSortedAddressPairs
( ptr long ptr long long ptr ptr
)
51 #@ stub CreateUnicastIpAddressEntry
52 #@ stub DeleteAnycastIpAddressEntry
53 @ stdcall DeleteIPAddress
( long
)
54 #@ stub DeleteIpForwardEntry2
55 @ stdcall DeleteIpForwardEntry
( ptr
)
56 #@ stub DeleteIpNetEntry2
57 @ stdcall DeleteIpNetEntry
( ptr
)
58 #@ stub DeletePersistentTcpPortReservation
59 #@ stub DeletePersistentUdpPortReservation
60 @ stdcall DeleteProxyArpEntry
( long long long
)
61 #@ stub DeleteUnicastIpAddressEntry
62 #@ stub DisableMediaSense
65 @ stdcall EnableRouter
( ptr ptr
)
66 @ stdcall FlushIpNetTable
( long
)
67 #@ stub FlushIpNetTable2
68 @ stub FlushIpNetTableFromStack
69 #@ stub FlushIpPathTable
70 @ stdcall FreeMibTable
( ptr
)
71 @ stdcall GetAdapterIndex
( wstr ptr
)
72 @ stub GetAdapterOrderMap
73 @ stdcall GetAdaptersAddresses
( long long ptr ptr ptr
)
74 @ stdcall GetAdaptersInfo
( ptr ptr
)
75 #@ stub GetAnycastIpAddressEntry
76 #@ stub GetAnycastIpAddressTable
77 @ stdcall GetBestInterface
( long ptr
)
78 @ stdcall GetBestInterfaceEx
( ptr ptr
)
79 @ stub GetBestInterfaceFromStack
80 @ stdcall GetBestRoute
( long long ptr
)
81 @ stdcall GetBestRoute2
( ptr long ptr ptr long ptr ptr
)
82 @ stub GetBestRouteFromStack
83 @ stdcall GetCurrentThreadCompartmentId
()
84 @ stdcall GetExtendedTcpTable
( ptr ptr long long long long
)
85 @ stdcall GetExtendedUdpTable
( ptr ptr long long long long
)
86 @ stdcall GetFriendlyIfIndex
( long
)
87 @ stdcall GetIcmpStatisticsEx
( ptr long
)
88 @ stdcall GetIcmpStatistics
( ptr
)
89 @ stub GetIcmpStatsFromStack
90 @ stdcall GetIfEntry
( ptr
)
91 @ stdcall GetIfEntry2
( ptr
)
92 @ stdcall GetIfEntry2Ex
( long ptr
)
93 @ stub GetIfEntryFromStack
94 #@ stub GetIfStackTable
95 @ stdcall GetIfTable
( ptr ptr long
)
96 @ stdcall GetIfTable2
( ptr
)
97 @ stdcall GetIfTable2Ex
( long ptr
)
98 @ stub GetIfTableFromStack
100 @ stdcall GetInterfaceInfo
( ptr ptr
)
101 #@ stub GetInvertedIfStackTable
102 @ stdcall GetIpAddrTable
( ptr ptr long
)
103 @ stub GetIpAddrTableFromStack
104 #@ stub GetIpErrorString
105 #@ stub GetIpForwardEntry2
106 @ stdcall GetIpForwardTable
( ptr ptr long
)
107 @ stdcall GetIpForwardTable2
( long ptr
)
108 @ stub GetIpForwardTableFromStack
109 #@ stub GetIpInterfaceEntry
110 @ stdcall GetIpInterfaceTable
( long ptr
)
111 #@ stub GetIpNetEntry2
112 @ stdcall GetIpNetTable
( ptr ptr long
)
113 @ stdcall GetIpNetTable2
( long ptr
)
114 @ stub GetIpNetTableFromStack
115 #@ stub GetIpPathEntry
116 #@ stub GetIpPathTable
117 @ stdcall GetIpStatisticsEx
( ptr long
)
118 @ stdcall GetIpStatistics
( ptr
)
119 @ stub GetIpStatsFromStack
120 #@ stub GetMulticastIpAddressEntry
121 #@ stub GetMulticastIpAddressTable
122 #@ stub GetNetworkInformation
123 @ stdcall GetNetworkParams
( ptr ptr
)
124 @ stdcall GetNumberOfInterfaces
( ptr
)
125 #@ stub GetOwnerModuleFromPidAndInfo
126 #@ stub GetOwnerModuleFromTcp6Entry
127 #@ stub GetOwnerModuleFromTcpEntry
128 #@ stub GetOwnerModuleFromUdp6Entry
129 #@ stub GetOwnerModuleFromUdpEntry
130 @ stdcall GetPerAdapterInfo
( long ptr ptr
)
131 #@ stub GetPerTcp6ConnectionEStats
132 #@ stub GetPerTcp6ConnectionStats
133 @ stdcall GetPerTcpConnectionEStats
( ptr long ptr long long ptr long long ptr long long
)
134 #@ stub GetPerTcpConnectionStats
135 @ stdcall GetRTTAndHopCount
( long ptr long ptr
)
136 #@ stub GetSessionCompartmentId
137 @ stdcall GetTcp6Table
( ptr ptr long
)
138 @ stdcall GetTcp6Table2
( ptr ptr long
)
139 @ stdcall GetTcpStatisticsEx
( ptr long
)
140 @ stdcall GetTcpStatistics
( ptr
)
141 @ stub GetTcpStatsFromStack
142 @ stdcall GetTcpTable
( ptr ptr long
)
143 @ stdcall GetTcpTable2
( ptr ptr long
)
144 @ stub GetTcpTableFromStack
145 #@ stub GetTeredoPort
146 @ stdcall GetUdp6Table
( ptr ptr long
)
147 @ stdcall GetUdpStatisticsEx
( ptr long
)
148 @ stdcall GetUdpStatistics
( ptr
)
149 @ stub GetUdpStatsFromStack
150 @ stdcall GetUdpTable
( ptr ptr long
)
151 @ stub GetUdpTableFromStack
152 @ stdcall GetUnicastIpAddressEntry
( ptr
)
153 @ stdcall GetUnicastIpAddressTable
(long ptr
)
154 @ stdcall GetUniDirectionalAdapterInfo
( ptr ptr
)
155 @ stdcall Icmp6CreateFile
()
156 #@ stub Icmp6ParseReplies
157 @ stdcall Icmp6SendEcho2
(ptr ptr ptr ptr ptr ptr ptr long ptr ptr long long
)
158 @ stdcall IcmpCloseHandle
(ptr
)
159 @ stdcall IcmpCreateFile
()
160 @ stdcall IcmpParseReplies
(ptr long
)
161 @ stdcall IcmpSendEcho2Ex
(ptr ptr ptr ptr long long ptr long ptr ptr long long
)
162 @ stdcall IcmpSendEcho2
(ptr ptr ptr ptr long ptr long ptr ptr long long
)
163 @ stdcall IcmpSendEcho
(ptr long ptr long ptr ptr long long
)
164 @ stdcall if_indextoname
(long ptr
) IPHLP_if_indextoname
165 @ stdcall if_nametoindex
(str
) IPHLP_if_nametoindex
166 #@ stub InitializeIpForwardEntry
167 #@ stub InitializeIpInterfaceEntry
168 #@ stub InitializeUnicastIpAddressEntry
169 #@ stub InternalCleanupPersistentStore
170 #@ stub InternalCreateAnycastIpAddressEntry
171 @ stub InternalCreateIpForwardEntry
172 #@ stub InternalCreateIpForwardEntry2
173 @ stub InternalCreateIpNetEntry
174 #@ stub InternalCreateIpNetEntry2
175 #@ stub InternalCreateUnicastIpAddressEntry
176 #@ stub InternalDeleteAnycastIpAddressEntry
177 @ stub InternalDeleteIpForwardEntry
178 #@ stub InternalDeleteIpForwardEntry2
179 @ stub InternalDeleteIpNetEntry
180 #@ stub InternalDeleteIpNetEntry2
181 #@ stub InternalDeleteUnicastIpAddressEntry
182 #@ stub InternalFindInterfaceByAddress
183 #@ stub InternalGetAnycastIpAddressEntry
184 #@ stub InternalGetAnycastIpAddressTable
185 #@ stub InternalGetForwardIpTable2
186 #@ stub InternalGetIfEntry2
187 @ stub InternalGetIfTable
188 #@ stub InternalGetIfTable2
189 @ stub InternalGetIpAddrTable
190 #@ stub InternalGetIpForwardEntry2
191 @ stub InternalGetIpForwardTable
192 #@ stub InternalGetIpInterfaceEntry
193 #@ stub InternalGetIpInterfaceTable
194 #@ stub InternalGetIpNetEntry2
195 @ stub InternalGetIpNetTable
196 #@ stub InternalGetIpNetTable2
197 #@ stub InternalGetMulticastIpAddressEntry
198 #@ stub InternalGetMulticastIpAddressTable
199 #@ stub InternalGetTcp6Table2
200 #@ stub InternalGetTcp6TableWithOwnerModule
201 #@ stub InternalGetTcp6TableWithOwnerPid
202 @ stub InternalGetTcpTable
203 #@ stub InternalGetTcpTable2
204 #@ stub InternalGetTcpTableEx
205 #@ stub InternalGetTcpTableWithOwnerModule
206 #@ stub InternalGetTcpTableWithOwnerPid
207 #@ stub InternalGetTunnelPhysicalAdapter
208 #@ stub InternalGetUdp6TableWithOwnerModule
209 #@ stub InternalGetUdp6TableWithOwnerPid
210 @ stub InternalGetUdpTable
211 #@ stub InternalGetUdpTableEx
212 #@ stub InternalGetUdpTableWithOwnerModule
213 #@ stub InternalGetUdpTableWithOwnerPid
214 #@ stub InternalGetUnicastIpAddressEntry
215 #@ stub InternalGetUnicastIpAddressTable
216 @ stub InternalSetIfEntry
217 @ stub InternalSetIpForwardEntry
218 #@ stub InternalSetIpForwardEntry2
219 #@ stub InternalSetIpInterfaceEntry
220 @ stub InternalSetIpNetEntry
221 #@ stub InternalSetIpNetEntry2
222 @ stub InternalSetIpStats
223 @ stub InternalSetTcpEntry
224 #@ stub InternalSetTeredoPort
225 #@ stub InternalSetUnicastIpAddressEntry
226 @ stdcall IpReleaseAddress
( ptr
)
227 @ stdcall IpRenewAddress
( ptr
)
228 @ stub IsLocalAddress
229 #@ stub LookupPersistentTcpPortReservation
230 #@ stub LookupPersistentUdpPortReservation
231 @ stub NhGetGuidFromInterfaceName
232 #@ stub NhGetInterfaceDescriptionFromGuid
233 #@ stub NhGetInterfaceNameFromDeviceGuid
234 @ stub NhGetInterfaceNameFromGuid
235 @ stub NhpAllocateAndGetInterfaceInfoFromStack
236 @ stub NhpGetInterfaceIndexFromStack
237 @ stdcall NotifyAddrChange
( ptr ptr
)
238 @ stdcall NotifyIpInterfaceChange
( long ptr ptr long ptr
)
239 @ stdcall NotifyRouteChange
( ptr ptr
)
240 @ stdcall NotifyRouteChange2
( long ptr ptr long ptr
)
241 @ stub NotifyRouteChangeEx
242 #@ stub NotifyStableUnicastIpAddressTable
243 #@ stub NotifyTeredoPortChange
244 @ stdcall NotifyUnicastIpAddressChange
(long ptr ptr long ptr
)
245 #@ stub NTPTimeToNTFileTime
246 #@ stub NTTimeToNTPTime
247 @ stdcall ParseNetworkString
(wstr long ptr ptr ptr
)
248 @ stub _PfAddFiltersToInterface@
24
249 @ stub _PfAddGlobalFilterToInterface@
8
250 @ stdcall _PfBindInterfaceToIPAddress@
12(long long ptr
) PfBindInterfaceToIPAddress
251 @ stub _PfBindInterfaceToIndex@
16
252 @ stdcall _PfCreateInterface@
24(long long long long long ptr
) PfCreateInterface
253 @ stdcall _PfDeleteInterface@
4(long
) PfDeleteInterface
254 @ stub _PfDeleteLog@
0
255 @ stub _PfGetInterfaceStatistics@
16
257 @ stub _PfRebindFilters@
8
258 @ stub _PfRemoveFilterHandles@
12
259 @ stub _PfRemoveFiltersFromInterface@
20
260 @ stub _PfRemoveGlobalFilterFromInterface@
8
261 @ stub _PfSetLogBuffer@
28
262 @ stub _PfTestPacket@
20
263 @ stdcall _PfUnBindInterface@
4(long
) PfUnBindInterface
264 #@ stub register_icmp
265 #@ stub ResolveIpNetEntry2
266 #@ stub ResolveNeighbor
267 #@ stub RestoreMediaSense
268 @ stdcall SendARP
( long long ptr ptr
)
269 @ stub SetAdapterIpAddress
270 @ stub SetBlockRoutes
271 #@ stub SetCurrentThreadCompartmentId
272 @ stdcall SetIfEntry
( ptr
)
273 @ stub SetIfEntryToStack
274 #@ stub SetIpForwardEntry2
275 @ stdcall SetIpForwardEntry
( ptr
)
276 @ stub SetIpForwardEntryToStack
277 #@ stub SetIpInterfaceEntry
278 @ stub SetIpMultihopRouteEntryToStack
279 #@ stub SetIpNetEntry2
280 @ stdcall SetIpNetEntry
( ptr
)
281 @ stub SetIpNetEntryToStack
282 @ stub SetIpRouteEntryToStack
283 #@ stub SetIpStatisticsEx
284 @ stdcall SetIpStatistics
( ptr
)
285 @ stub SetIpStatsToStack
286 @ stdcall SetIpTTL
( long
)
287 #@ stub SetNetworkInformation
288 #@ stub SetPerTcp6ConnectionEStats
289 #@ stub SetPerTcp6ConnectionStats
290 @ stdcall SetPerTcpConnectionEStats
( ptr long ptr long long long
)
291 #@ stub SetPerTcpConnectionStats
292 @ stub SetProxyArpEntryToStack
293 @ stub SetRouteWithRef
294 #@ stub SetSessionCompartmentId
295 @ stdcall SetTcpEntry
( ptr
)
296 @ stub SetTcpEntryToStack
297 #@ stub SetUnicastIpAddressEntry
298 @ stdcall UnenableRouter
( ptr ptr
)