combase: Add CoDecodeProxy stub.
[wine.git] / dlls / combase / combase.spec
blob7343da6a0ef384fbbd6050326dc87f1384b48303
1 @ stub ObjectStublessClient3
2 @ stub ObjectStublessClient4
3 @ stub ObjectStublessClient5
4 @ stub ObjectStublessClient6
5 @ stub ObjectStublessClient7
6 @ stub ObjectStublessClient8
7 @ stub ObjectStublessClient9
8 @ stub ObjectStublessClient10
9 @ stub ObjectStublessClient11
10 @ stub ObjectStublessClient12
11 @ stub ObjectStublessClient13
12 @ stub ObjectStublessClient14
13 @ stub ObjectStublessClient15
14 @ stub ObjectStublessClient16
15 @ stub ObjectStublessClient17
16 @ stub ObjectStublessClient18
17 @ stub ObjectStublessClient19
18 @ stub ObjectStublessClient20
19 @ stub ObjectStublessClient21
20 @ stub ObjectStublessClient22
21 @ stub ObjectStublessClient23
22 @ stub ObjectStublessClient24
23 @ stub ObjectStublessClient25
24 @ stub ObjectStublessClient26
25 @ stub ObjectStublessClient27
26 @ stub ObjectStublessClient28
27 @ stub ObjectStublessClient29
28 @ stub ObjectStublessClient30
29 @ stub ObjectStublessClient31
30 @ stub ObjectStublessClient32
31 @ stub NdrProxyForwardingFunction3
32 @ stub NdrProxyForwardingFunction4
33 @ stub NdrProxyForwardingFunction5
34 @ stub NdrProxyForwardingFunction6
35 @ stub NdrProxyForwardingFunction7
36 @ stub NdrProxyForwardingFunction8
37 @ stub NdrProxyForwardingFunction9
38 @ stub NdrProxyForwardingFunction10
39 @ stub NdrProxyForwardingFunction11
40 @ stub NdrProxyForwardingFunction12
41 @ stub NdrProxyForwardingFunction13
42 @ stub NdrProxyForwardingFunction14
43 @ stub NdrProxyForwardingFunction15
44 @ stub NdrProxyForwardingFunction16
45 @ stub NdrProxyForwardingFunction17
46 @ stub NdrProxyForwardingFunction18
47 @ stub NdrProxyForwardingFunction19
48 @ stub NdrProxyForwardingFunction20
49 @ stub NdrProxyForwardingFunction21
50 @ stub NdrProxyForwardingFunction22
51 @ stub NdrProxyForwardingFunction23
52 @ stub NdrProxyForwardingFunction24
53 @ stub NdrProxyForwardingFunction25
54 @ stub NdrProxyForwardingFunction26
55 @ stub NdrProxyForwardingFunction27
56 @ stub NdrProxyForwardingFunction28
57 @ stub NdrProxyForwardingFunction29
58 @ stub NdrProxyForwardingFunction30
59 @ stub NdrProxyForwardingFunction31
60 @ stub NdrProxyForwardingFunction32
61 @ stub NdrOleInitializeExtension
62 @ stub RoFailFastWithErrorContextInternal2
63 @ stub RoFailFastWithErrorContextInternal
64 @ stub UpdateProcessTracing
65 @ stdcall CLIPFORMAT_UserFree(ptr ptr)
66 @ stdcall CLIPFORMAT_UserMarshal(ptr ptr ptr)
67 @ stdcall CLIPFORMAT_UserSize(ptr long ptr)
68 @ stdcall CLIPFORMAT_UserUnmarshal(ptr ptr ptr)
69 @ stub CLSIDFromOle1Class
70 @ stdcall CLSIDFromProgID(wstr ptr)
71 @ stdcall CLSIDFromProgIDEx(wstr ptr)
72 @ stdcall CLSIDFromString(wstr ptr)
73 @ stub CleanupOleStateInAllTls
74 @ stdcall CleanupTlsOleState(ptr)
75 @ stub ClearCleanupFlag
76 @ stdcall CoAddRefServerProcess()
77 @ stub CoAllowUnmarshalerCLSID
78 @ stub CoCancelCall
79 @ stdcall CoCopyProxy(ptr ptr)
80 @ stdcall CoCreateErrorInfo(ptr) CreateErrorInfo
81 @ stdcall CoCreateFreeThreadedMarshaler(ptr ptr)
82 @ stdcall CoCreateGuid(ptr)
83 @ stdcall CoCreateInstance(ptr ptr long ptr ptr)
84 @ stdcall CoCreateInstanceEx(ptr ptr long ptr long ptr)
85 @ stdcall CoCreateInstanceFromApp(ptr ptr long ptr long ptr)
86 @ stub CoCreateObjectInContext
87 @ stub CoDeactivateObject
88 @ stdcall CoDecodeProxy(long int64 ptr)
89 @ stdcall CoDecrementMTAUsage(ptr)
90 @ stdcall CoDisableCallCancellation(ptr)
91 @ stub CoDisconnectContext
92 @ stdcall CoDisconnectObject(ptr long)
93 @ stdcall CoEnableCallCancellation(ptr)
94 @ stdcall CoFileTimeNow(ptr)
95 @ stdcall CoFreeUnusedLibraries()
96 @ stdcall CoFreeUnusedLibrariesEx(long long)
97 @ stdcall CoGetActivationState(int128 long ptr)
98 @ stub CoGetApartmentID
99 @ stdcall CoGetApartmentType(ptr ptr)
100 @ stdcall CoGetCallContext(ptr ptr)
101 @ stdcall CoGetCallState(long ptr)
102 @ stdcall CoGetCallerTID(ptr)
103 @ stub CoGetCancelObject
104 @ stdcall CoGetClassObject(ptr long ptr ptr ptr)
105 @ stub CoGetClassVersion
106 @ stdcall CoGetContextToken(ptr)
107 @ stdcall CoGetCurrentLogicalThreadId(ptr)
108 @ stdcall CoGetCurrentProcess()
109 @ stdcall CoGetDefaultContext(long ptr ptr)
110 @ stdcall CoGetErrorInfo(long ptr) GetErrorInfo
111 @ stdcall CoGetInstanceFromFile(ptr ptr ptr long long wstr long ptr)
112 @ stdcall CoGetInstanceFromIStorage(ptr ptr ptr long ptr long ptr)
113 @ stdcall CoGetInterfaceAndReleaseStream(ptr ptr ptr)
114 @ stdcall CoGetMalloc(long ptr)
115 @ stdcall CoGetMarshalSizeMax(ptr ptr ptr long ptr long)
116 @ stub CoGetModuleType
117 @ stdcall CoGetObjectContext(ptr ptr)
118 @ stdcall CoGetPSClsid(ptr ptr)
119 @ stub CoGetProcessIdentifier
120 @ stdcall CoGetStandardMarshal(ptr ptr long ptr long ptr)
121 @ stub CoGetStdMarshalEx
122 @ stub CoGetSystemSecurityPermissions
123 @ stdcall CoGetTreatAsClass(ptr ptr)
124 @ stdcall CoImpersonateClient()
125 @ stdcall CoIncrementMTAUsage(ptr)
126 @ stdcall CoInitializeEx(ptr long)
127 @ stdcall CoInitializeSecurity(ptr long ptr ptr long long ptr long ptr)
128 @ stdcall CoInitializeWOW(long long)
129 @ stub CoInvalidateRemoteMachineBindings
130 @ stdcall CoIsHandlerConnected(ptr)
131 @ stdcall CoLockObjectExternal(ptr long long)
132 @ stdcall CoMarshalHresult(ptr long)
133 @ stdcall CoMarshalInterThreadInterfaceInStream(ptr ptr ptr)
134 @ stdcall CoMarshalInterface(ptr ptr ptr long ptr long)
135 @ stub CoPopServiceDomain
136 @ stub CoPushServiceDomain
137 @ stub CoQueryAuthenticationServices
138 @ stdcall CoQueryClientBlanket(ptr ptr ptr ptr ptr ptr ptr)
139 @ stdcall CoQueryProxyBlanket(ptr ptr ptr ptr ptr ptr ptr ptr)
140 @ stub CoReactivateObject
141 @ stub CoRegisterActivationFilter
142 @ stdcall CoRegisterChannelHook(ptr ptr)
143 @ stdcall CoRegisterClassObject(ptr ptr long long ptr)
144 @ stdcall CoRegisterInitializeSpy(ptr ptr)
145 @ stdcall CoRegisterMallocSpy(ptr)
146 @ stdcall CoRegisterMessageFilter(ptr ptr)
147 @ stdcall CoRegisterPSClsid(ptr ptr)
148 @ stdcall CoRegisterSurrogate(ptr)
149 @ stdcall CoRegisterSurrogateEx(ptr ptr)
150 @ stdcall CoReleaseMarshalData(ptr)
151 @ stdcall CoReleaseServerProcess()
152 @ stdcall CoResumeClassObjects()
153 @ stub CoRetireServer
154 @ stdcall CoRevertToSelf()
155 @ stdcall CoRevokeClassObject(long)
156 @ stdcall CoRevokeInitializeSpy(int64)
157 @ stdcall CoRevokeMallocSpy()
158 @ stub CoSetCancelObject
159 @ stdcall CoSetErrorInfo(long ptr) SetErrorInfo
160 @ stdcall CoSetProxyBlanket(ptr long long ptr long long ptr long)
161 @ stdcall CoSuspendClassObjects()
162 @ stdcall CoSwitchCallContext(ptr ptr)
163 @ stdcall CoTaskMemAlloc(long)
164 @ stdcall CoTaskMemFree(ptr)
165 @ stdcall CoTaskMemRealloc(ptr long)
166 @ stub CoTestCancel
167 @ stdcall CoUninitialize()
168 @ stub CoUnloadingWOW
169 @ stdcall CoUnmarshalHresult(ptr ptr)
170 @ stdcall CoUnmarshalInterface(ptr ptr ptr)
171 @ stub CoVrfCheckThreadState
172 @ stub CoVrfGetThreadState
173 @ stub CoVrfReleaseThreadState
174 @ stdcall CoWaitForMultipleHandles(long long long ptr ptr)
175 @ stub CoWaitForMultipleObjects
176 @ stdcall CreateErrorInfo(ptr)
177 @ stdcall CreateStreamOnHGlobal(ptr long ptr)
178 @ stub DcomChannelSetHResult
179 @ stdcall DllDebugObjectRPCHook(long ptr)
180 @ stdcall DllGetActivationFactory(ptr ptr)
181 @ stdcall -private DllGetClassObject(ptr ptr ptr)
182 @ stub EnableHookObject
183 @ stdcall FreePropVariantArray(long ptr)
184 @ stub FreePropVariantArrayWorker
185 @ stub GetCatalogHelper
186 @ stdcall GetErrorInfo(long ptr)
187 @ stub GetFuncDescs
188 @ stdcall GetHGlobalFromStream(ptr ptr)
189 @ stub GetHookInterface
190 @ stdcall GetRestrictedErrorInfo(ptr)
191 @ stdcall HACCEL_UserFree(ptr ptr)
192 @ stdcall HACCEL_UserMarshal(ptr ptr ptr)
193 @ stdcall HACCEL_UserSize(ptr long ptr)
194 @ stdcall HACCEL_UserUnmarshal(ptr ptr ptr)
195 @ stdcall HBITMAP_UserFree(ptr ptr)
196 @ stdcall HBITMAP_UserMarshal(ptr ptr ptr)
197 @ stdcall HBITMAP_UserSize(ptr long ptr)
198 @ stdcall HBITMAP_UserUnmarshal(ptr ptr ptr)
199 @ stdcall HBRUSH_UserFree(ptr ptr)
200 @ stdcall HBRUSH_UserMarshal(ptr ptr ptr)
201 @ stdcall HBRUSH_UserSize(ptr long ptr)
202 @ stdcall HBRUSH_UserUnmarshal(ptr ptr ptr)
203 @ stdcall HDC_UserFree(ptr ptr)
204 @ stdcall HDC_UserMarshal(ptr ptr ptr)
205 @ stdcall HDC_UserSize(ptr long ptr)
206 @ stdcall HDC_UserUnmarshal(ptr ptr ptr)
207 @ stdcall HGLOBAL_UserFree(ptr ptr)
208 @ stdcall HGLOBAL_UserMarshal(ptr ptr ptr)
209 @ stdcall HGLOBAL_UserSize(ptr long ptr)
210 @ stdcall HGLOBAL_UserUnmarshal(ptr ptr ptr)
211 @ stdcall HICON_UserFree(ptr ptr)
212 @ stdcall HICON_UserMarshal(ptr ptr ptr)
213 @ stdcall HICON_UserSize(ptr long ptr)
214 @ stdcall HICON_UserUnmarshal(ptr ptr ptr)
215 @ stdcall HMENU_UserFree(ptr ptr)
216 @ stdcall HMENU_UserMarshal(ptr ptr ptr)
217 @ stdcall HMENU_UserSize(ptr long ptr)
218 @ stdcall HMENU_UserUnmarshal(ptr ptr ptr)
219 @ stdcall HPALETTE_UserFree(ptr ptr)
220 @ stdcall HPALETTE_UserMarshal(ptr ptr ptr)
221 @ stdcall HPALETTE_UserSize(ptr long ptr)
222 @ stdcall HPALETTE_UserUnmarshal(ptr ptr ptr)
223 @ stub HSTRING_UserFree
224 @ stub -arch=win64 HSTRING_UserFree64
225 @ stub HSTRING_UserMarshal
226 @ stub -arch=win64 HSTRING_UserMarshal64
227 @ stub HSTRING_UserSize
228 @ stub -arch=win64 HSTRING_UserSize64
229 @ stub HSTRING_UserUnmarshal
230 @ stub -arch=win64 HSTRING_UserUnmarshal64
231 @ stdcall HWND_UserFree(ptr ptr)
232 @ stdcall HWND_UserMarshal(ptr ptr ptr)
233 @ stdcall HWND_UserSize(ptr long ptr)
234 @ stdcall HWND_UserUnmarshal(ptr ptr ptr)
235 @ stub HkOleRegisterObject
236 @ stdcall IIDFromString(wstr ptr)
237 @ stub InternalAppInvokeExceptionFilter
238 @ stub InternalCCFreeUnused
239 @ stub InternalCCGetClassInformationForDde
240 @ stub InternalCCGetClassInformationFromKey
241 @ stub InternalCCSetDdeServerWindow
242 @ stub InternalCMLSendReceive
243 @ stub InternalCallAsProxyExceptionFilter
244 @ stub InternalCallFrameExceptionFilter
245 @ stub InternalCallerIsAppContainer
246 @ stub InternalCanMakeOutCall
247 @ stub InternalCoIsSurrogateProcess
248 @ stub InternalCoRegisterDisconnectCallback
249 @ stub InternalCoRegisterSurrogatedObject
250 @ stdcall InternalCoStdMarshalObject(ptr long ptr ptr)
251 @ stub InternalCoUnregisterDisconnectCallback
252 @ stub InternalCompleteObjRef
253 @ stub InternalCreateCAggId
254 @ stub InternalCreateIdentityHandler
255 @ stub InternalDoATClassCreate
256 @ stub InternalFillLocalOXIDInfo
257 @ stub InternalFreeObjRef
258 @ stub InternalGetWindowPropInterface
259 @ stdcall InternalIrotEnumRunning(ptr)
260 @ stdcall InternalIrotGetObject(ptr ptr ptr)
261 @ stdcall InternalIrotGetTimeOfLastChange(ptr ptr)
262 @ stdcall InternalIrotIsRunning(ptr)
263 @ stdcall InternalIrotNoteChangeTime(long ptr)
264 @ stdcall InternalIrotRegister(ptr ptr ptr ptr long ptr ptr)
265 @ stdcall InternalIrotRevoke(long ptr ptr ptr)
266 @ stub InternalIsApartmentInitialized
267 @ stdcall InternalIsProcessInitialized()
268 @ stub InternalMarshalObjRef
269 @ stub InternalNotifyDDStartOrStop
270 @ stub InternalOleModalLoopBlockFn
271 @ stub InternalRegisterWindowPropInterface
272 @ stub InternalReleaseMarshalObjRef
273 @ stub InternalSTAInvoke
274 @ stub InternalServerExceptionFilter
275 @ stub InternalSetAptCallCtrlOnTlsIfRequired
276 @ stub InternalSetOleThunkWowPtr
277 @ stub InternalStubInvoke
278 @ stdcall InternalTlsAllocData(ptr)
279 @ stub InternalUnmarshalObjRef
280 @ stub IsErrorPropagationEnabled
281 @ stub NdrExtStubInitialize
282 @ stub NdrOleDllGetClassObject
283 @ stub NdrpFindInterface
284 @ stdcall ProgIDFromCLSID(ptr ptr)
285 @ stdcall PropVariantClear(ptr)
286 @ stdcall PropVariantCopy(ptr ptr)
287 @ stub ReleaseFuncDescs
288 @ stdcall RoActivateInstance(ptr ptr)
289 @ stub RoCaptureErrorContext
290 @ stub RoClearError
291 @ stub RoFailFastWithErrorContext
292 @ stub RoFreeParameterizedTypeExtra
293 @ stub RoGetActivatableClassRegistration
294 @ stdcall RoGetActivationFactory(ptr ptr ptr)
295 @ stub RoGetAgileReference
296 @ stdcall RoGetApartmentIdentifier(ptr)
297 @ stub RoGetErrorReportingFlags
298 @ stub RoGetMatchingRestrictedErrorInfo
299 @ stdcall RoGetParameterizedTypeInstanceIID(long ptr ptr ptr ptr)
300 @ stdcall RoGetServerActivatableClasses(ptr ptr ptr)
301 @ stdcall RoInitialize(long)
302 @ stub RoInspectCapturedStackBackTrace
303 @ stub RoInspectThreadErrorInfo
304 @ stub RoOriginateError
305 @ stub RoOriginateErrorW
306 @ stdcall RoOriginateLanguageException(long ptr ptr)
307 @ stub RoParameterizedTypeExtraGetTypeSignature
308 @ stdcall RoRegisterActivationFactories(ptr ptr long ptr)
309 @ stdcall RoRegisterForApartmentShutdown(ptr ptr ptr)
310 @ stub RoReportCapabilityCheckFailure
311 @ stub RoReportFailedDelegate
312 @ stub RoReportUnhandledError
313 @ stub RoResolveRestrictedErrorInfoReference
314 @ stub RoRevokeActivationFactories
315 @ stub RoSetErrorReportingFlags
316 @ stub RoTransformError
317 @ stub RoTransformErrorW
318 @ stdcall RoUninitialize()
319 @ stub RoUnregisterForApartmentShutdown
320 @ stub SetCleanupFlag
321 @ stdcall SetErrorInfo(long ptr)
322 @ stub SetRestrictedErrorInfo
323 @ stdcall StringFromCLSID(ptr ptr)
324 @ stdcall StringFromGUID2(ptr ptr long)
325 @ stdcall StringFromIID(ptr ptr) StringFromCLSID
326 @ stub UpdateDCOMSettings
327 @ stdcall WdtpInterfacePointer_UserFree(ptr)
328 @ stub -arch=win64 WdtpInterfacePointer_UserFree64
329 @ stdcall WdtpInterfacePointer_UserMarshal(ptr long ptr ptr ptr)
330 @ stub -arch=win64 WdtpInterfacePointer_UserMarshal64
331 @ stdcall WdtpInterfacePointer_UserSize(ptr long long ptr ptr)
332 @ stub -arch=win64 WdtpInterfacePointer_UserSize64
333 @ stdcall WdtpInterfacePointer_UserUnmarshal(ptr ptr ptr ptr)
334 @ stub -arch=win64 WdtpInterfacePointer_UserUnmarshal64
335 @ stdcall WindowsCompareStringOrdinal(ptr ptr ptr)
336 @ stdcall WindowsConcatString(ptr ptr ptr)
337 @ stdcall WindowsCreateString(wstr long ptr)
338 @ stdcall WindowsCreateStringReference(wstr long ptr ptr)
339 @ stdcall WindowsDeleteString(ptr)
340 @ stdcall WindowsDeleteStringBuffer(ptr)
341 @ stdcall WindowsDuplicateString(ptr ptr)
342 @ stdcall WindowsGetStringLen(ptr)
343 @ stdcall WindowsGetStringRawBuffer(ptr ptr)
344 @ stub WindowsInspectString
345 @ stdcall WindowsIsStringEmpty(ptr)
346 @ stdcall WindowsPreallocateStringBuffer(long ptr ptr)
347 @ stdcall WindowsPromoteStringBuffer(ptr ptr)
348 @ stub WindowsReplaceString
349 @ stdcall WindowsStringHasEmbeddedNull(ptr ptr)
350 @ stdcall WindowsSubstring(ptr long ptr)
351 @ stdcall WindowsSubstringWithSpecifiedLength(ptr long long ptr)
352 @ stdcall WindowsTrimStringEnd(ptr ptr ptr)
353 @ stdcall WindowsTrimStringStart(ptr ptr ptr)