- implement some more virtcopy (VCP) stuff
[wine.git] / dlls / setupapi / setupx.spec
blob8a848166f6eadb1d842324e31db00ae69864840c
1 name setupx
2 type win16
3 owner setupapi
5 1 stub WEP
6 2 pascal16 IpOpen(str ptr) IpOpen16
7 3 stub IpOpenAppend #(str word)
8 4 pascal16 IpClose(word) IpClose16
9 5 stub IpGetLongField #(word ptr word ptr)
10 6 stub IpGetStringField #(word ptr word ptr word ptr)
11 7 stub IpFindFirstLine #(word str str ptr)
12 8 stub IpGetLineCount #(word str ptr)
13 9 stub IpGetFieldCount #(word ptr ptr)
14 10 stub IpGetIntField #(word ptr word ptr)
15 11 stub IpFindNextLine #(word ptr)
16 12 stub IpGetFileName #(word ptr word)
17 13 pascal16 VcpQueueCopy(str str str str word word ptr word long) VcpQueueCopy16
18 14 stub NOAUTORUNWNDPROC
19 15 stub __DEBUGMSG
20 16 stub __ASSERTMSG
21 17 pascal16 VcpQueueDelete(str str word long) VcpQueueDelete16
22 18 stub TpOpenFile #(str ptr word)
23 19 stub TpCloseFile #(word)
24 20 stub TpOpenSection #(word ptr str word)
25 21 stub TpCloseSection #(word)
26 22 stub TpCommitSection #(word word str word)
27 23 stub TpGetLine #(word str str word word ptr)
28 24 stub TpGetNextLine #(word str str ptr)
29 25 stub TpInsertLine #(word str str word word word)
30 26 stub TpReplaceLine #(word str str word word word)
31 27 stub TpDeleteLine #(word word word word)
32 28 stub TpMoveLine #(word word word word word word)
33 29 stub TpGetLineContents #(word ptr word ptr word word word)
34 30 stub TpGetPrivateProfileString #(str str str ptr word str)
35 31 stub TpWritePrivateProfileString #(str str str str)
36 32 stub TpGetProfileString #(str str str ptr word)
37 33 pascal16 CtlSetLdd(ptr) CtlSetLdd16
38 34 pascal16 CtlGetLdd(ptr) CtlGetLdd16
39 35 pascal16 CtlFindLdd(ptr) CtlFindLdd16
40 36 pascal16 CtlAddLdd(ptr) CtlAddLdd16
41 37 pascal16 CtlDelLdd(word) CtlDelLdd16
42 38 pascal16 CtlGetLddPath(word ptr) CtlGetLddPath16
43 39 stub SURegCloseKey #(word)
44 40 stub SURegCreateKey #(word)
45 41 stub SURegDeleteKey #(word str)
46 42 stub SURegDeleteValue #(word str)
47 43 stub SURegEnumKey #(word long ptr long)
48 44 stub SURegEnumValue #(word long str ptr ptr ptr ptr ptr)
49 45 stub SURegFlush #()
50 46 stub SURegInit #()
51 47 pascal SURegOpenKey(word str ptr) SURegOpenKey
52 48 stub SURegQueryValue
53 49 stub SURegQueryValue16 #(word str ptr ptr)
54 50 pascal SURegQueryValueEx(long str ptr ptr ptr ptr) SURegQueryValueEx
55 51 stub SURegSetValue
56 52 stub SURegSetValue16 #(word str long ptr long)
57 53 stub SURegSetValueEx #(word str long long ptr long)
58 54 stub SURegSaveKey #(word str ptr)
59 55 stub SURegLoadKey #(word str str)
60 56 stub SURegUnLoadKey #(word str)
61 60 stub DiskInfoFromLdid #(word ptr)
62 61 stub suErrorToIds #(word word)
63 62 stub TPWriteProfileString #(str str str)
64 63 stub SURPLSETUP
65 # does SUSTORELDIDPATH set the path of an LDID in the registry ?
66 64 stub SUSTORELDIDPATH
67 65 stub WILDCARDSTRCMPI
68 101 pascal16 GenInstall(word str word) GenInstall16
69 102 stub GenWinInitRename #(str str word)
70 103 pascal GenFormStrWithoutPlaceHolders(str str word) GenFormStrWithoutPlaceHolders16
71 104 stub SETUPX
72 105 stub CfgSetupMerge #(word)
73 106 stub INITDEPENDANTLDIDS
74 107 stub CFGOBJFINDKEYCMD
75 108 stub GenSURegSetValueEx
76 109 stub GENINSTALLWITHQUEUE
77 110 stub GenInstallEx #(word str word word ptr long)
78 111 stub GenCopyLogConfig2Reg #(word word str)
79 112 stub SUGetSetSetupFlags #(ptr word)
80 114 stub CFGPARSELINE # returns array
81 115 stub CFGSETAUTOPROCESS
82 116 stub CFGOBJTOSTR
83 117 stub CFGLNTOOBJ
84 118 stub MATCHCMDEXT
85 119 stub IpFindNextMatchLine #(word str ptr)
86 120 stub P_SETDEFAULTOPTION
87 121 stub CFGCLEANBOOT
88 122 stub CFGMATCHCMDEXT
89 123 stub CFGWASFILEUPDATED
90 124 stub AUTOMATCHCMDEXT
91 125 stub P_VALIDATEOC
92 126 stub GENMAPROOTREGSTR2KEY
93 127 stub P_CDROMOC
94 128 stub P_MEDIAOC
95 129 stub CFGCLEAN1STBOOT
96 130 stub suFormatMessage
97 131 stub suvFormatMessage #(word str str word ptr)
98 132 stub suFormatMessageBox
99 #133 stub suHelp # W98SE conflict !!
100 135 stub suHelp #(word word)
101 #135 stub P_WEBTVOC # W98SE conflict !!
102 136 stub P_WBEMOC
103 137 stub P_THEMESOC
104 138 stub P_IMAGINGOC
105 139 stub P_SCHEMESOC
106 140 stub suVerConflict #(word ptr word ptr)
107 141 stub suVerConflictInit #(word)
108 142 stub suVerConflictTerm #(ptr)
109 # Emergency Boot Disk
110 143 stub suCreateEBD #(word ptr long)
111 144 stub suCopyToEBD
112 145 stub sxIsMSDOS7Running #()
113 150 stub DS_INIT
114 151 stub DS_DESTROY
115 152 stub DS_SSYNCDRIVES
116 153 stub DS_GETDRIVEDATA
117 154 stub DS_ADDSECTION
118 155 stub DS_ENABLESECTION
119 156 stub DS_DISABLESECTION
120 157 stub DS_SETSWAPSIZE
121 158 stub DS_SETREQUIREDPAD
122 159 stub DS_SETAVAILABLEPAD
123 160 stub SXUPDATEDS
124 170 stub SUSETMEM
125 171 stub WriteDMFBootData #(word ptr word)
126 200 pascal VcpOpen(segptr ptr) VcpOpen16
127 201 pascal VcpClose(word str) VcpClose16
128 202 pascal16 vcpDefCallbackProc(ptr word word long long) vcpDefCallbackProc16
129 203 stub vcpEnumFiles #(ptr long)
130 204 pascal16 VcpQueueRename(str str str str word word long) VcpQueueRename16
131 205 pascal16 vsmGetStringName(word ptr word) vsmGetStringName16
132 206 pascal16 vsmStringDelete(word) vsmStringDelete16
133 207 pascal16 vsmStringAdd(str) vsmStringAdd16
134 208 pascal vsmGetStringRawName(word) vsmGetStringRawName16
135 209 stub IpSaveRestorePosition #(word word)
136 210 pascal16 IpGetProfileString(word str str ptr word) IpGetProfileString16
137 211 stub IpOpenEx #(str ptr word)
138 212 stub IpOpenAppendEx #(str word word)
139 213 pascal16 vcpUICallbackProc(ptr word word long long) vcpUICallbackProc16
140 214 stub VcpAddMRUPath #(str)
141 300 stub DiBuildCompatDrvList #(ptr)
142 301 stub DiBuildClassDrvList #(ptr)
143 302 stub DiDestroyDriverNodeList #(ptr)
144 303 stub DiCreateDeviceInfo #(ptr str long str str word)
145 304 pascal16 DiGetClassDevs(ptr str word word) DiGetClassDevs16
146 305 stub DiDestroyDeviceInfoList #(ptr)
147 306 stub DiRemoveDevice #(ptr)
148 308 stub DiCallClassInstaller #(word ptr)
149 309 stub DiCreateDriverNode #(ptr word word word str str str str str str long)
150 310 stub DiDrawMiniIcon
151 311 stub DiGetClassBitmapIndex #(str ptr)
152 312 stub DiSelectDevice #(ptr)
153 313 stub DiInstallDevice #(ptr)
154 314 stub DiLoadClassIcon #(str ptr ptr)
155 315 stub DiAskForOEMDisk #(ptr)
156 316 stub Display_SetMode #(ptr word word word)
157 317 stub Display_ClassInstaller #(word ptr)
158 318 stub DiCreateDevRegKey #(ptr ptr word str word)
159 319 stub DiOpenDevRegKey #(ptr ptr word)
160 320 stub DiInstallDrvSection #(str str str str long)
161 321 stub DiInstallClass #(str long)
162 322 stub DiOpenClassRegKey #(ptr str)
163 323 stub Display_SetFontSize #(str)
164 324 stub Display_OpenFontSizeKey #(ptr)
165 325 stub DiBuildClassDrvListFromOldInf #(ptr str ptr long)
166 326 stub DiIsThereNeedToCopy #(word long)
167 333 stub DiChangeState #(ptr long long long)
168 334 stub WALKSUBTREE
169 340 stub GetFctn #(word str str ptr ptr)
170 341 stub DiBuildClassInfoList #(ptr)
171 342 stub DiDestroyClassInfoList #(ptr)
172 343 stub DiGetDeviceClassInfo #(ptr ptr)
173 344 stub DiDeleteDevRegKey #(ptr word)
174 350 stub DiSelectOEMDrv #(word ptr)
175 351 stub DiGetINFClass #(str word str long)
176 353 stub DIPICKBESTDRIVER
177 355 stub COPYINFFILE
178 360 stub GenInfLCToDevNode #(word str word word long)
179 361 stub GETDOSMESSAGE
180 362 stub Mouse_ClassInstaller #(word ptr)
181 363 stub sxCompareDosAppVer #(str str)
182 364 stub MONITOR_CLASSINSTALLER
183 365 stub FCEGETRESDESOFFSET
184 366 stub FCEGETALLOCVALUE
185 367 stub FCEADDRESDES
186 368 stub FCEDELETERESDES
187 369 stub FCEINIT
188 370 stub FCEGETRESDES
189 371 stub FCEGETFIRSTVALUE
190 372 stub FCEGETOTHERVALUE
191 373 stub FCEGETVALIDATEVALUE
192 374 stub FCEWRITETHISFORCEDCONFIGNOW
193 375 stub SUCreatePropertySheetPage #(ptr)
194 376 stub SUDestroyPropertySheetPage #(word)
195 377 stub SUPropertySheet #(ptr)
196 380 stub DiReadRegLogConf #(ptr str ptr ptr)
197 381 stub DiReadRegConf #(ptr ptr ptr long)
198 390 stub DiBuildPotentialDuplicatesList #(ptr ptr long ptr ptr)
199 395 stub InitSubstrData #(ptr str)
200 396 stub GetFirstSubstr #(ptr)
201 397 stub GetNextSubstr #(ptr)
202 398 stub INITSUBSTRDATAEX
203 400 stub bIsFileInVMM32 #(str)
204 401 stub DiInstallDriverFiles #(ptr)
205 405 stub DiBuildClassInfoListEx #(ptr long)
206 406 stub DiGetClassDevsEx #(ptr str str word word)
207 407 stub DiCopyRegSubKeyValue #(word str str str)
208 408 stub IPGETDRIVERDATE
209 409 stub IPGETDRIVERVERSION
210 410 stub IpGetVersionString #(str str ptr word str)
211 411 stub VcpExplain #(ptr long)
212 412 stub DiBuildDriverIndex #(word)
213 413 stub DiAddSingleInfToDrvIdx #(str word word)
214 414 stub FCEGETFLAGS
215 450 stub UiMakeDlgNonBold #(word)
216 451 stub UiDeleteNonBoldFont #(word)
217 500 stub SUEBDPAGE
218 501 stub SUOCPAGE
219 502 stub SXLISTSUBPROC
220 503 stub SXFILLLB
221 504 stub SXOCPAGEDLG
222 506 stub SXOCBATCHSETTINGS
223 507 stub SXOCFIXNEEDS
224 508 pascal16 CtlSetLddPath(word str) CtlSetLddPath16
225 509 stub SXCALLOCPROC
226 510 stub BUILDINFOCS
227 511 stub BUILDREGOCS
228 512 stub DELETEOCS
229 520 stub DiBuildClassDrvInfoList #(ptr)
230 521 stub DiBuildCompatDrvInfoList #(ptr)
231 522 stub DiDestroyDrvInfoList #(ptr)
232 523 stub DiConvertDriverInfoToDriverNode #(ptr ptr)
233 524 stub DISELECTBESTCOMPATDRV
234 525 stub FirstBootMoveToDOSSTART #(str word)
235 526 stub DOSOptEnableCurCfg #(str)
236 527 pascal16 InstallHinfSection(word word str word) InstallHinfSection16
237 528 stub SXMAKEUNCPATH
238 529 stub SXISSBSSERVERFILE
239 530 stub SXFINDBATCHFILES
240 531 stub ISPANEUROPEAN
241 532 stub UPGRADENIGGLINGS
242 533 stub DISPLAY_ISSECONDDISPLAY
243 534 stub ISWINDOWSFILE
244 540 stub VERIFYSELECTEDDRIVER
245 575 stub SXCALLMIGRATIONDLLS
246 576 stub SXCALLMIGRATIONDLLS_RUNDLL
247 600 stub PidConstruct #(str str str word)
248 601 stub PidValidate #(str str)
249 602 stub GETJAPANESEKEYBOARDTYPE
250 610 stub CRC32COMPUTE
251 621 stub SXSAVEINFO
252 622 stub SXADDPAGEEX
253 623 stub OPKREMOVEINSTALLEDNETDEVICE
254 640 stub DOFIRSTRUNSCREENS
255 700 stub SXSHOWREBOOTDLG
256 701 stub SXSHOWREBOOTDLG_RUNDLL
257 750 stub UIPOSITIONDIALOG
258 775 stub ASPICLEAN
259 800 stub EXTRACTCABFILE
260 825 stub PIDGEN3
261 826 stub GETSETUPINFO
262 827 stub SETSETUPINFO
263 828 stub GETKEYBOARDOPTIONS
264 829 stub GETLOCALEOPTIONS
265 830 stub SETINTLOPTIONS
266 831 stub GETPRODUCTTYPE
267 832 stub ISOPKMODE
268 833 stub AUDITONETIMEINSTALL
269 834 stub DISKDUP
270 835 stub OPKPREINSTALL
271 836 stub ISAUDITMODE
272 837 stub ISAUDITAUTO
273 838 stub GETVALIDEULA