msvcrt: Don't include MSVC 7.0+ exception functions in SOs for older DLLs.
[wine.git] / dlls / netapi32 / netapi32.spec
blob8dbd3785217522aaa2b1cc8b7621ae4cc12bac54
1 @ stdcall DavGetHTTPFromUNCPath(wstr ptr ptr)
2 @ stdcall DavGetUNCFromHTTPPath(wstr ptr ptr)
3 @ stub DsAddressToSiteNames
4 @ stub DsAddressToSiteNamesEx
5 @ stub DsDeregisterDnsHostRecords
6 @ stub DsEnumerateDomainTrusts
7 @ stub DsGetDcClose
8 @ stdcall DsGetDcNameA(str str ptr str long ptr)
9 @ stdcall DsGetDcNameW(wstr wstr ptr wstr long ptr)
10 @ stub DsGetDcNext
11 @ stub DsGetDcOpen
12 @ stub DsGetDcSiteCoverage
13 @ stub DsGetForestTrustInformationW
14 @ stdcall DsGetSiteNameA(str ptr)
15 @ stdcall DsGetSiteNameW(wstr ptr)
16 @ stub DsMergeForestTrustInformationW
17 @ stdcall DsRoleFreeMemory(ptr)
18 @ stdcall DsRoleGetPrimaryDomainInformation(wstr long ptr)
19 @ stub DsValidateSubnetName
20 @ stub I_BrowserDebugCall
21 @ stub I_BrowserDebugTrace
22 @ stdcall I_BrowserQueryEmulatedDomains(wstr ptr ptr)
23 @ stub I_BrowserQueryOtherDomains
24 @ stub I_BrowserQueryStatistics
25 @ stub I_BrowserResetNetlogonState
26 @ stub I_BrowserResetStatistics
27 @ stub I_BrowserServerEnum
28 @ stdcall I_BrowserSetNetlogonState(wstr wstr wstr long)
29 @ stub I_NetAccountDeltas
30 @ stub I_NetAccountSync
31 @ stub I_NetDatabaseDeltas
32 @ stub I_NetDatabaseRedo
33 @ stub I_NetDatabaseSync2
34 @ stub I_NetDatabaseSync
35 @ stub I_NetDfsCreateExitPoint
36 @ stub I_NetDfsCreateLocalPartition
37 @ stub I_NetDfsDeleteExitPoint
38 @ stub I_NetDfsDeleteLocalPartition
39 @ stub I_NetDfsFixLocalVolume
40 @ stub I_NetDfsGetVersion
41 @ stub I_NetDfsIsThisADomainName
42 @ stub I_NetDfsModifyPrefix
43 @ stub I_NetDfsSetLocalVolumeState
44 @ stub I_NetDfsSetServerInfo
45 @ stub I_NetGetDCList
46 @ stub I_NetListCanonicalize
47 @ stub I_NetListTraverse
48 @ stub I_NetLogonControl2
49 @ stub I_NetLogonControl
50 @ stub I_NetLogonSamLogoff
51 @ stub I_NetLogonSamLogon
52 @ stub I_NetLogonUasLogoff
53 @ stub I_NetLogonUasLogon
54 @ stub I_NetNameCanonicalize
55 @ stdcall I_NetNameCompare(ptr wstr wstr ptr ptr)
56 @ stdcall I_NetNameValidate(ptr wstr ptr ptr)
57 @ stub I_NetPathCanonicalize
58 @ stub I_NetPathCompare
59 @ stub I_NetPathType
60 @ stub I_NetServerAuthenticate2
61 @ stub I_NetServerAuthenticate
62 @ stub I_NetServerPasswordSet
63 @ stub I_NetServerReqChallenge
64 @ stub I_NetServerSetServiceBits
65 @ stub I_NetServerSetServiceBitsEx
66 @ stub NetAlertRaise
67 @ stub NetAlertRaiseEx
68 @ stdcall NetApiBufferAllocate(long ptr)
69 @ stdcall NetApiBufferFree(ptr)
70 @ stdcall NetApiBufferReallocate(ptr long ptr)
71 @ stdcall NetApiBufferSize(ptr ptr)
72 @ stub NetAuditClear
73 @ stub NetAuditRead
74 @ stub NetAuditWrite
75 @ stub NetBrowserStatisticsGet
76 @ stub NetConfigGet
77 @ stub NetConfigGetAll
78 @ stub NetConfigSet
79 @ stub NetConnectionEnum
80 @ stub NetDfsAdd
81 @ stub NetDfsEnum
82 @ stub NetDfsGetInfo
83 @ stub NetDfsManagerGetConfigInfo
84 @ stub NetDfsMove
85 @ stub NetDfsRemove
86 @ stub NetDfsRename
87 @ stub NetDfsSetInfo
88 @ stub NetEnumerateTrustedDomains
89 @ stub NetErrorLogClear
90 @ stub NetErrorLogRead
91 @ stub NetErrorLogWrite
92 @ stub NetFileClose
93 @ stdcall NetFileEnum(wstr wstr wstr long ptr long ptr ptr ptr)
94 @ stub NetFileGetInfo
95 @ stdcall NetGetAnyDCName(wstr wstr ptr)
96 @ stdcall NetGetDCName(wstr wstr ptr)
97 @ stub NetGetDisplayInformationIndex
98 @ stdcall NetGetJoinInformation(wstr ptr ptr)
99 @ stub NetGroupAdd
100 @ stdcall NetGroupAddUser(wstr wstr wstr)
101 @ stub NetGroupDel
102 @ stub NetGroupDelUser
103 @ stdcall NetGroupEnum(wstr long ptr long ptr ptr ptr)
104 @ stdcall NetGroupGetInfo(wstr wstr long ptr)
105 @ stub NetGroupGetUsers
106 @ stub NetGroupSetInfo
107 @ stub NetGroupSetUsers
108 @ stdcall NetLocalGroupAdd(wstr long ptr ptr)
109 @ stdcall NetLocalGroupAddMember(wstr wstr ptr)
110 @ stdcall NetLocalGroupAddMembers(wstr wstr long ptr long)
111 @ stdcall NetLocalGroupDel(wstr wstr)
112 @ stdcall NetLocalGroupDelMember(wstr wstr ptr)
113 @ stdcall NetLocalGroupDelMembers(wstr wstr long ptr long)
114 @ stdcall NetLocalGroupEnum(wstr long ptr long ptr ptr ptr)
115 @ stdcall NetLocalGroupGetInfo(wstr wstr long ptr)
116 @ stdcall NetLocalGroupGetMembers(wstr wstr long ptr long ptr ptr ptr)
117 @ stdcall NetLocalGroupSetInfo(wstr wstr long ptr ptr)
118 @ stdcall NetLocalGroupSetMembers(wstr wstr long ptr long)
119 @ stub NetMessageBufferSend
120 @ stub NetMessageNameAdd
121 @ stub NetMessageNameDel
122 @ stub NetMessageNameEnum
123 @ stub NetMessageNameGetInfo
124 @ stdcall NetQueryDisplayInformation(wstr long long long long ptr ptr)
125 @ stub NetRemoteComputerSupports
126 @ stub NetRemoteTOD
127 @ stub NetReplExportDirAdd
128 @ stub NetReplExportDirDel
129 @ stub NetReplExportDirEnum
130 @ stub NetReplExportDirGetInfo
131 @ stub NetReplExportDirLock
132 @ stub NetReplExportDirSetInfo
133 @ stub NetReplExportDirUnlock
134 @ stub NetReplGetInfo
135 @ stub NetReplImportDirAdd
136 @ stub NetReplImportDirDel
137 @ stub NetReplImportDirEnum
138 @ stub NetReplImportDirGetInfo
139 @ stub NetReplImportDirLock
140 @ stub NetReplImportDirUnlock
141 @ stub NetReplSetInfo
142 @ stub NetRplAdapterAdd
143 @ stub NetRplAdapterDel
144 @ stub NetRplAdapterEnum
145 @ stub NetRplBootAdd
146 @ stub NetRplBootDel
147 @ stub NetRplBootEnum
148 @ stub NetRplClose
149 @ stub NetRplConfigAdd
150 @ stub NetRplConfigDel
151 @ stub NetRplConfigEnum
152 @ stub NetRplGetInfo
153 @ stub NetRplOpen
154 @ stub NetRplProfileAdd
155 @ stub NetRplProfileClone
156 @ stub NetRplProfileDel
157 @ stub NetRplProfileEnum
158 @ stub NetRplProfileGetInfo
159 @ stub NetRplProfileSetInfo
160 @ stub NetRplSetInfo
161 @ stub NetRplSetSecurity
162 @ stub NetRplVendorAdd
163 @ stub NetRplVendorDel
164 @ stub NetRplVendorEnum
165 @ stub NetRplWkstaAdd
166 @ stub NetRplWkstaClone
167 @ stub NetRplWkstaDel
168 @ stub NetRplWkstaEnum
169 @ stub NetRplWkstaGetInfo
170 @ stub NetRplWkstaSetInfo
171 @ stdcall NetScheduleJobAdd(wstr ptr ptr)
172 @ stdcall NetScheduleJobDel(wstr long long)
173 @ stdcall NetScheduleJobEnum(wstr ptr long ptr ptr ptr)
174 @ stub NetScheduleJobGetInfo
175 @ stub NetServerComputerNameAdd
176 @ stub NetServerComputerNameDel
177 @ stdcall NetServerDiskEnum(wstr long ptr long ptr ptr ptr)
178 @ stdcall NetServerEnum(wstr long ptr long ptr ptr long wstr ptr)
179 @ stdcall NetServerEnumEx(wstr long ptr long ptr ptr long wstr wstr)
180 @ stdcall NetServerGetInfo(wstr long ptr)
181 @ stub NetServerSetInfo
182 @ stub NetServerTransportAdd
183 @ stub NetServerTransportAddEx
184 @ stub NetServerTransportDel
185 @ stub NetServerTransportEnum
186 @ stub NetServiceControl
187 @ stub NetServiceEnum
188 @ stub NetServiceGetInfo
189 @ stub NetServiceInstall
190 @ stub NetSessionDel
191 @ stdcall NetSessionEnum(wstr wstr wstr long ptr long ptr ptr ptr)
192 @ stub NetSessionGetInfo
193 @ stdcall NetShareAdd(wstr long ptr ptr)
194 @ stub NetShareCheck
195 @ stdcall NetShareDel(wstr wstr long)
196 @ stub NetShareDelSticky
197 @ stdcall NetShareEnum(wstr long ptr long ptr ptr ptr)
198 @ stub NetShareEnumSticky
199 @ stdcall NetShareGetInfo(wstr wstr long ptr)
200 @ stub NetShareSetInfo
201 @ stdcall NetStatisticsGet(wstr wstr long long ptr)
202 @ stdcall NetUseAdd(wstr long ptr ptr)
203 @ stdcall NetUseDel(wstr wstr long)
204 @ stdcall NetUseEnum(wstr long ptr long ptr ptr ptr)
205 @ stdcall NetUseGetInfo(ptr ptr long ptr)
206 @ stdcall NetUserAdd(wstr long ptr ptr)
207 @ stdcall NetUserChangePassword(wstr wstr wstr wstr)
208 @ stdcall NetUserDel(wstr wstr)
209 @ stdcall NetUserEnum(wstr long long ptr long ptr ptr ptr)
210 @ stdcall NetUserGetGroups(wstr wstr long ptr long ptr ptr)
211 @ stdcall NetUserGetInfo(wstr wstr long ptr)
212 @ stdcall NetUserGetLocalGroups(wstr wstr long long ptr long ptr ptr)
213 @ stdcall NetUserModalsGet(wstr long ptr)
214 @ stub NetUserModalsSet
215 @ stub NetUserSetGroups
216 @ stub NetUserSetInfo
217 @ stdcall NetWkstaGetInfo(wstr long ptr)
218 @ stub NetWkstaSetInfo
219 @ stub NetWkstaTransportAdd
220 @ stub NetWkstaTransportDel
221 @ stdcall NetWkstaTransportEnum (wstr long ptr long ptr ptr ptr)
222 @ stdcall NetWkstaUserEnum(wstr long ptr long ptr ptr ptr)
223 @ stdcall NetWkstaUserGetInfo(wstr long ptr)
224 @ stub NetWkstaUserSetInfo
225 @ stdcall NetapipBufferAllocate(long ptr) NetApiBufferAllocate
226 @ stdcall Netbios(ptr)
227 @ stub NetpAccessCheck
228 @ stub NetpAccessCheckAndAudit
229 @ stub NetpAllocConfigName
230 @ stub NetpAllocStrFromStr
231 @ stub NetpAllocStrFromWStr
232 @ stub NetpAllocTStrFromString
233 @ stub NetpAllocWStrFromStr
234 @ stub NetpAllocWStrFromWStr
235 @ stub NetpApiStatusToNtStatus
236 @ stub NetpAssertFailed
237 @ stub NetpCloseConfigData
238 @ stub NetpCopyStringToBuffer
239 @ stub NetpCreateSecurityObject
240 @ stub NetpDbgDisplayServerInfo
241 @ stub NetpDbgPrint
242 @ stdcall NetpDeleteSecurityObject(long) ntdll.RtlDeleteSecurityObject
243 @ stdcall NetpGetComputerName(ptr)
244 @ stub NetpGetConfigBool
245 @ stub NetpGetConfigDword
246 @ stub NetpGetConfigTStrArray
247 @ stub NetpGetConfigValue
248 @ stub NetpGetDomainName
249 @ stub NetpGetFileSecurity
250 @ stub NetpGetPrivilege
251 @ stub NetpHexDump
252 @ stdcall NetpInitOemString(ptr str) ntdll.RtlInitAnsiString
253 @ stub NetpIsRemote
254 @ stub NetpIsUncComputerNameValid
255 @ stub NetpLocalTimeZoneOffset
256 @ stub NetpLogonPutUnicodeString
257 @ stub NetpNetBiosAddName
258 @ stub NetpNetBiosCall
259 @ stub NetpNetBiosDelName
260 @ stub NetpNetBiosGetAdapterNumbers
261 @ stub NetpNetBiosHangup
262 @ stub NetpNetBiosReceive
263 @ stub NetpNetBiosReset
264 @ stub NetpNetBiosSend
265 @ stdcall NetpNetBiosStatusToApiStatus(long)
266 @ stub NetpNtStatusToApiStatus
267 @ stub NetpOpenConfigData
268 @ stub NetpPackString
269 @ stub NetpReleasePrivilege
270 @ stub NetpSetConfigBool
271 @ stub NetpSetConfigDword
272 @ stub NetpSetConfigTStrArray
273 @ stub NetpSetFileSecurity
274 @ stub NetpSmbCheck
275 @ stub NetpStringToNetBiosName
276 @ stub NetpTStrArrayEntryCount
277 @ stub NetpwNameCanonicalize
278 @ stub NetpwNameCompare
279 @ stub NetpwNameValidate
280 @ stub NetpwPathCanonicalize
281 @ stub NetpwPathCompare
282 @ stub NetpwPathType
283 @ stub NlBindingAddServerToCache
284 @ stub NlBindingRemoveServerFromCache
285 @ stub NlBindingSetAuthInfo
286 @ stub RxNetAccessAdd
287 @ stub RxNetAccessDel
288 @ stub RxNetAccessEnum
289 @ stub RxNetAccessGetInfo
290 @ stub RxNetAccessGetUserPerms
291 @ stub RxNetAccessSetInfo
292 @ stub RxNetServerEnum
293 @ stub RxNetUserPasswordSet
294 @ stub RxRemoteApi