msi: Add more tests for MsiSourceListGetInfo.
[wine.git] / dlls / iphlpapi / iphlpapi.spec
blob5ea43c5636a0ab16c63013f802f4981119293e01
1 @ stdcall AddIPAddress( long long long ptr ptr )
2 @ stub AllocateAndGetArpEntTableFromStack
3 @ stdcall AllocateAndGetIfTableFromStack( ptr long long long )
4 @ stdcall AllocateAndGetIpAddrTableFromStack( ptr long long long )
5 @ stdcall AllocateAndGetIpForwardTableFromStack( ptr long long long )
6 @ stdcall AllocateAndGetIpNetTableFromStack( ptr long long long )
7 @ stdcall AllocateAndGetTcpTableFromStack( ptr long long long )
8 @ stdcall AllocateAndGetUdpTableFromStack( ptr long long long )
9 @ stdcall CreateIpForwardEntry( ptr )
10 @ stdcall CreateIpNetEntry( ptr )
11 @ stdcall CreateProxyArpEntry( long long long )
12 @ stdcall DeleteIPAddress( long )
13 @ stdcall DeleteIpForwardEntry( ptr )
14 @ stdcall DeleteIpNetEntry( ptr )
15 @ stdcall DeleteProxyArpEntry( long long long )
16 @ stdcall EnableRouter( ptr ptr )
17 @ stdcall FlushIpNetTable( long )
18 @ stub FlushIpNetTableFromStack
19 @ stdcall GetAdapterIndex( wstr ptr )
20 @ stub GetAdapterOrderMap
21 @ stdcall GetAdaptersInfo( ptr ptr )
22 @ stdcall GetBestInterface( long ptr )
23 @ stdcall GetBestInterfaceEx( ptr ptr )
24 @ stub GetBestInterfaceFromStack
25 @ stdcall GetBestRoute( long long long )
26 @ stub GetBestRouteFromStack
27 @ stdcall GetFriendlyIfIndex( long )
28 @ stdcall GetIcmpStatistics( ptr )
29 @ stub GetIcmpStatsFromStack
30 @ stdcall GetIfEntry( ptr )
31 @ stub GetIfEntryFromStack
32 @ stdcall GetIfTable( ptr ptr long )
33 @ stub GetIfTableFromStack
34 @ stub GetIgmpList
35 @ stdcall GetInterfaceInfo( ptr ptr )
36 @ stdcall GetIpAddrTable( ptr ptr long )
37 @ stub GetIpAddrTableFromStack
38 @ stdcall GetIpForwardTable( ptr ptr long )
39 @ stub GetIpForwardTableFromStack
40 @ stdcall GetIpNetTable( ptr ptr long )
41 @ stub GetIpNetTableFromStack
42 @ stdcall GetIpStatistics( ptr )
43 @ stub GetIpStatsFromStack
44 @ stdcall GetNetworkParams( ptr ptr )
45 @ stdcall GetNumberOfInterfaces( ptr )
46 @ stdcall GetPerAdapterInfo( long ptr ptr )
47 @ stdcall GetRTTAndHopCount( long ptr long ptr )
48 @ stdcall GetTcpStatistics( ptr )
49 @ stub GetTcpStatsFromStack
50 @ stdcall GetTcpTable( ptr ptr long )
51 @ stub GetTcpTableFromStack
52 @ stdcall GetUdpStatistics( ptr )
53 @ stub GetUdpStatsFromStack
54 @ stdcall GetUdpTable( ptr ptr long )
55 @ stub GetUdpTableFromStack
56 @ stdcall GetUniDirectionalAdapterInfo( ptr ptr )
57 @ stub InternalCreateIpForwardEntry
58 @ stub InternalCreateIpNetEntry
59 @ stub InternalDeleteIpForwardEntry
60 @ stub InternalDeleteIpNetEntry
61 @ stub InternalGetIfTable
62 @ stub InternalGetIpAddrTable
63 @ stub InternalGetIpForwardTable
64 @ stub InternalGetIpNetTable
65 @ stub InternalGetTcpTable
66 @ stub InternalGetUdpTable
67 @ stub InternalSetIfEntry
68 @ stub InternalSetIpForwardEntry
69 @ stub InternalSetIpNetEntry
70 @ stub InternalSetIpStats
71 @ stub InternalSetTcpEntry
72 @ stdcall IpReleaseAddress( ptr )
73 @ stdcall IpRenewAddress( ptr )
74 @ stub IsLocalAddress
75 @ stub NTPTimeToNTFileTime
76 @ stub NTTimeToNTPTime
77 @ stub NhGetGuidFromInterfaceName
78 @ stub NhGetInterfaceNameFromGuid
79 @ stub NhpAllocateAndGetInterfaceInfoFromStack
80 @ stub NhpGetInterfaceIndexFromStack
81 @ stdcall NotifyAddrChange( ptr ptr )
82 @ stdcall NotifyRouteChange( ptr ptr )
83 @ stub NotifyRouteChangeEx
84 @ stub _PfAddFiltersToInterface@24
85 @ stub _PfAddGlobalFilterToInterface@8
86 @ stub _PfBindInterfaceToIPAddress@12
87 @ stub _PfBindInterfaceToIndex@16
88 @ stub _PfCreateInterface@24
89 @ stub _PfDeleteInterface@4
90 @ stub _PfDeleteLog@0
91 @ stub _PfGetInterfaceStatistics@16
92 @ stub _PfMakeLog@4
93 @ stub _PfRebindFilters@8
94 @ stub _PfRemoveFilterHandles@12
95 @ stub _PfRemoveFiltersFromInterface@20
96 @ stub _PfRemoveGlobalFilterFromInterface@8
97 @ stub _PfSetLogBuffer@28
98 @ stub _PfTestPacket@20
99 @ stub _PfUnBindInterface@4
100 @ stdcall SendARP( long long ptr ptr )
101 @ stub SetAdapterIpAddress
102 @ stub SetBlockRoutes
103 @ stdcall SetIfEntry( ptr )
104 @ stub SetIfEntryToStack
105 @ stdcall SetIpForwardEntry( ptr )
106 @ stub SetIpForwardEntryToStack
107 @ stub SetIpMultihopRouteEntryToStack
108 @ stdcall SetIpNetEntry( ptr )
109 @ stub SetIpNetEntryToStack
110 @ stub SetIpRouteEntryToStack
111 @ stdcall SetIpStatistics( ptr )
112 @ stub SetIpStatsToStack
113 @ stdcall SetIpTTL( long )
114 @ stub SetProxyArpEntryToStack
115 @ stub SetRouteWithRef
116 @ stdcall SetTcpEntry( ptr )
117 @ stub SetTcpEntryToStack
118 @ stdcall UnenableRouter( ptr ptr )