1 @ stdcall BCryptAddContextFunction
(long wstr long wstr long
)
2 @ stdcall BCryptAddContextFunctionProvider
(long wstr long wstr wstr long
)
3 @ stdcall BCryptCloseAlgorithmProvider
(ptr long
)
4 @ stub BCryptConfigureContext
5 @ stub BCryptConfigureContextFunction
6 @ stub BCryptCreateContext
7 @ stdcall BCryptCreateHash
(ptr ptr ptr long ptr long long
)
8 @ stdcall BCryptDecrypt
(ptr ptr long ptr ptr long ptr long ptr long
)
9 @ stub BCryptDeleteContext
10 @ stdcall BCryptDeriveKey
(ptr wstr ptr ptr long ptr long
)
11 @ stdcall BCryptDeriveKeyCapi
(ptr ptr ptr long long
)
12 @ stdcall BCryptDeriveKeyPBKDF2
(ptr ptr long ptr long int64 ptr long long
)
13 @ stdcall BCryptDestroyHash
(ptr
)
14 @ stdcall BCryptDestroyKey
(ptr
)
15 @ stdcall BCryptDestroySecret
(ptr
)
16 @ stdcall BCryptDuplicateHash
(ptr ptr ptr long long
)
17 @ stdcall BCryptDuplicateKey
(ptr ptr ptr long long
)
18 @ stdcall BCryptEncrypt
(ptr ptr long ptr ptr long ptr long ptr long
)
19 @ stdcall BCryptEnumAlgorithms
(long ptr ptr long
)
20 @ stub BCryptEnumContextFunctionProviders
21 @ stdcall BCryptEnumContextFunctions
(long wstr long ptr ptr
)
22 @ stub BCryptEnumContexts
23 @ stub BCryptEnumProviders
24 @ stub BCryptEnumRegisteredProviders
25 @ stdcall BCryptExportKey
(ptr ptr wstr ptr long ptr long
)
26 @ stdcall BCryptFinalizeKeyPair
(ptr long
)
27 @ stdcall BCryptFinishHash
(ptr ptr long long
)
28 @ stdcall BCryptFreeBuffer
(ptr
)
29 @ stdcall BCryptGenRandom
(ptr ptr long long
)
30 @ stdcall BCryptGenerateKeyPair
(ptr ptr long long
)
31 @ stdcall BCryptGenerateSymmetricKey
(ptr ptr ptr long ptr long long
)
32 @ stdcall BCryptGetFipsAlgorithmMode
(ptr
)
33 @ stdcall BCryptGetProperty
(ptr wstr ptr long ptr long
)
34 @ stdcall BCryptHash
(ptr ptr long ptr long ptr long
)
35 @ stdcall BCryptHashData
(ptr ptr long long
)
36 @ stdcall BCryptImportKey
(ptr ptr wstr ptr ptr long ptr long long
)
37 @ stdcall BCryptImportKeyPair
(ptr ptr wstr ptr ptr long long
)
38 @ stdcall BCryptOpenAlgorithmProvider
(ptr wstr wstr long
)
39 @ stub BCryptQueryContextConfiguration
40 @ stub BCryptQueryContextFunctionConfiguration
41 @ stub BCryptQueryContextFunctionProperty
42 @ stub BCryptQueryProviderRegistration
43 @ stub BCryptRegisterConfigChangeNotify
44 @ stdcall BCryptRegisterProvider
(wstr long ptr
)
45 @ stdcall BCryptRemoveContextFunction
(long wstr long wstr
)
46 @ stdcall BCryptRemoveContextFunctionProvider
(long wstr long wstr wstr
)
47 @ stub BCryptResolveProviders
48 @ stdcall BCryptSecretAgreement
(ptr ptr ptr long
)
49 @ stub BCryptSetAuditingInterface
50 @ stub BCryptSetContextFunctionProperty
51 @ stdcall BCryptSetProperty
(ptr wstr ptr long long
)
52 @ stdcall BCryptSignHash
(ptr ptr ptr long ptr long ptr long
)
53 @ stub BCryptUnregisterConfigChangeNotify
54 @ stdcall BCryptUnregisterProvider
(wstr
)
55 @ stdcall BCryptVerifySignature
(ptr ptr ptr long ptr long long
)
56 @ stub GetAsymmetricEncryptionInterface
57 @ stub GetCipherInterface
58 @ stub GetHashInterface
59 @ stub GetRngInterface
60 @ stub GetSecretAgreementInterface
61 @ stub GetSignatureInterface