sspicli: Implement SspiZeroAuthIdentity.
[wine.git] / dlls / sspicli / sspicli.spec
blob2a78cff909c20a9ad8ded6243e14e806c06a3679
1 @ stub AcceptSecurityContext
2 @ stub AcquireCredentialsHandleA
3 @ stub AcquireCredentialsHandleW
4 @ stub AddCredentialsA
5 @ stub AddCredentialsW
6 @ stub AddSecurityPackageA
7 @ stub AddSecurityPackageW
8 @ stub ApplyControlToken
9 @ stub ChangeAccountPasswordA
10 @ stub ChangeAccountPasswordW
11 @ stub CompleteAuthToken
12 @ stub CredMarshalTargetInfo
13 @ stub CredUnmarshalTargetInfo
14 @ stub DecryptMessage
15 @ stub DeleteSecurityContext
16 @ stub DeleteSecurityPackageA
17 @ stub DeleteSecurityPackageW
18 @ stub EncryptMessage
19 @ stub EnumerateSecurityPackagesA
20 @ stub EnumerateSecurityPackagesW
21 @ stub ExportSecurityContext
22 @ stub FreeContextBuffer
23 @ stub FreeCredentialsHandle
24 @ stub GetSecurityUserInfo
25 @ stub GetUserNameExA
26 @ stub GetUserNameExW
27 @ stub ImpersonateSecurityContext
28 @ stub ImportSecurityContextA
29 @ stub ImportSecurityContextW
30 @ stub InitializeSecurityContextA
31 @ stub InitializeSecurityContextW
32 @ stub InitSecurityInterfaceA
33 @ stub InitSecurityInterfaceW
34 @ stub LogonUserExExW
35 @ stub LsaCallAuthenticationPackage
36 @ stub LsaConnectUntrusted
37 @ stub LsaDeregisterLogonProcess
38 @ stub LsaEnumerateLogonSessions
39 @ stub LsaFreeReturnBuffer
40 @ stub LsaGetLogonSessionData
41 @ stub LsaLogonUser
42 @ stub LsaLookupAuthenticationPackage
43 @ stub LsaRegisterLogonProcess
44 @ stub LsaRegisterPolicyChangeNotification
45 @ stub LsaUnregisterPolicyChangeNotification
46 @ stub MakeSignature
47 @ stub QueryContextAttributesA
48 @ stub QueryContextAttributesExA
49 @ stub QueryContextAttributesExW
50 @ stub QueryContextAttributesW
51 @ stub QueryCredentialsAttributesA
52 @ stub QueryCredentialsAttributesExA
53 @ stub QueryCredentialsAttributesExW
54 @ stub QueryCredentialsAttributesW
55 @ stub QuerySecurityContextToken
56 @ stub QuerySecurityPackageInfoA
57 @ stub QuerySecurityPackageInfoW
58 @ stub RevertSecurityContext
59 @ stub SaslAcceptSecurityContext
60 @ stub SaslEnumerateProfilesA
61 @ stub SaslEnumerateProfilesW
62 @ stub SaslGetContextOption
63 @ stub SaslGetProfilePackageA
64 @ stub SaslGetProfilePackageW
65 @ stub SaslIdentifyPackageA
66 @ stub SaslIdentifyPackageW
67 @ stub SaslInitializeSecurityContextA
68 @ stub SaslInitializeSecurityContextW
69 @ stub SaslSetContextOption
70 @ stub SealMessage
71 @ stub SecCacheSspiPackages
72 @ stub SecDeleteUserModeContext
73 @ stub SeciAllocateAndSetCallFlags
74 @ stub SeciAllocateAndSetIPAddress
75 @ stub SeciFreeCallContext
76 @ stub SeciIsProtectedUser
77 @ stub SecInitUserModeContext
78 @ stub SetContextAttributesA
79 @ stub SetContextAttributesW
80 @ stub SetCredentialsAttributesA
81 @ stub SetCredentialsAttributesW
82 @ stub SspiCompareAuthIdentities
83 @ stub SspiCopyAuthIdentity
84 @ stub SspiDecryptAuthIdentity
85 @ stub SspiDecryptAuthIdentityEx
86 @ stub SspiEncodeAuthIdentityAsStrings
87 @ stdcall SspiEncodeStringsAsAuthIdentity(wstr wstr wstr ptr)
88 @ stub SspiEncryptAuthIdentity
89 @ stub SspiEncryptAuthIdentityEx
90 @ stub SspiExcludePackage
91 @ stub SspiFreeAuthIdentity
92 @ stub SspiGetComputerNameForSPN
93 @ stub SspiGetTargetHostName
94 @ stub SspiIsAuthIdentityEncrypted
95 @ stub SspiLocalFree
96 @ stub SspiMarshalAuthIdentity
97 @ stub SspiPrepareForCredRead
98 @ stub SspiPrepareForCredWrite
99 @ stub SspiUnmarshalAuthIdentity
100 @ stub SspiUnmarshalAuthIdentityInternal
101 @ stub SspiValidateAuthIdentity
102 @ stdcall SspiZeroAuthIdentity(ptr)
103 @ stub UnsealMessage
104 @ stub VerifySignature