iphlpapi: Added PfCreateInterface stub implementation.
[wine.git] / dlls / iphlpapi / iphlpapi.spec
blobe53a64140e22135a2c6715f1d45d3599af394294
1 @ stdcall AddIPAddress( long long long ptr ptr )
2 @ stub AllocateAndGetArpEntTableFromStack
3 @ stdcall AllocateAndGetIfTableFromStack( ptr long long long )
4 @ stdcall AllocateAndGetIpAddrTableFromStack( ptr long long long )
5 @ stdcall AllocateAndGetIpForwardTableFromStack( ptr long long long )
6 @ stdcall AllocateAndGetIpNetTableFromStack( ptr long long long )
7 @ stdcall AllocateAndGetTcpTableFromStack( ptr long long long )
8 @ stdcall AllocateAndGetUdpTableFromStack( ptr long long long )
9 @ stdcall CancelIPChangeNotify( ptr )
10 @ stdcall CreateIpForwardEntry( ptr )
11 @ stdcall CreateIpNetEntry( ptr )
12 @ stdcall CreateProxyArpEntry( long long long )
13 @ stdcall DeleteIPAddress( long )
14 @ stdcall DeleteIpForwardEntry( ptr )
15 @ stdcall DeleteIpNetEntry( ptr )
16 @ stdcall DeleteProxyArpEntry( long long long )
17 @ stdcall EnableRouter( ptr ptr )
18 @ stdcall FlushIpNetTable( long )
19 @ stub FlushIpNetTableFromStack
20 @ stdcall GetAdapterIndex( wstr ptr )
21 @ stub GetAdapterOrderMap
22 @ stdcall GetAdaptersAddresses( long long ptr ptr ptr )
23 @ stdcall GetAdaptersInfo( ptr ptr )
24 @ stdcall GetBestInterface( long ptr )
25 @ stdcall GetBestInterfaceEx( ptr ptr )
26 @ stub GetBestInterfaceFromStack
27 @ stdcall GetBestRoute( long long long )
28 @ stub GetBestRouteFromStack
29 @ stdcall GetFriendlyIfIndex( long )
30 @ stdcall GetIcmpStatistics( ptr )
31 @ stub GetIcmpStatsFromStack
32 @ stdcall GetIfEntry( ptr )
33 @ stub GetIfEntryFromStack
34 @ stdcall GetIfTable( ptr ptr long )
35 @ stub GetIfTableFromStack
36 @ stub GetIgmpList
37 @ stdcall GetInterfaceInfo( ptr ptr )
38 @ stdcall GetIpAddrTable( ptr ptr long )
39 @ stub GetIpAddrTableFromStack
40 @ stdcall GetIpForwardTable( ptr ptr long )
41 @ stub GetIpForwardTableFromStack
42 @ stdcall GetIpNetTable( ptr ptr long )
43 @ stub GetIpNetTableFromStack
44 @ stdcall GetIpStatistics( ptr )
45 @ stub GetIpStatsFromStack
46 @ stdcall GetNetworkParams( ptr ptr )
47 @ stdcall GetNumberOfInterfaces( ptr )
48 @ stdcall GetPerAdapterInfo( long ptr ptr )
49 @ stdcall GetRTTAndHopCount( long ptr long ptr )
50 @ stdcall GetTcpStatistics( ptr )
51 @ stub GetTcpStatsFromStack
52 @ stdcall GetTcpTable( ptr ptr long )
53 @ stub GetTcpTableFromStack
54 @ stdcall GetUdpStatistics( ptr )
55 @ stub GetUdpStatsFromStack
56 @ stdcall GetUdpTable( ptr ptr long )
57 @ stub GetUdpTableFromStack
58 @ stdcall GetUniDirectionalAdapterInfo( ptr ptr )
59 @ stdcall IcmpCloseHandle(ptr)
60 @ stdcall IcmpCreateFile()
61 @ stub IcmpParseReplies
62 @ stdcall IcmpSendEcho2(ptr ptr ptr ptr long ptr long ptr ptr long long)
63 @ stdcall IcmpSendEcho(ptr long ptr long ptr ptr long long)
64 @ stub InternalCreateIpForwardEntry
65 @ stub InternalCreateIpNetEntry
66 @ stub InternalDeleteIpForwardEntry
67 @ stub InternalDeleteIpNetEntry
68 @ stub InternalGetIfTable
69 @ stub InternalGetIpAddrTable
70 @ stub InternalGetIpForwardTable
71 @ stub InternalGetIpNetTable
72 @ stub InternalGetTcpTable
73 @ stub InternalGetUdpTable
74 @ stub InternalSetIfEntry
75 @ stub InternalSetIpForwardEntry
76 @ stub InternalSetIpNetEntry
77 @ stub InternalSetIpStats
78 @ stub InternalSetTcpEntry
79 @ stdcall IpReleaseAddress( ptr )
80 @ stdcall IpRenewAddress( ptr )
81 @ stub IsLocalAddress
82 @ stub NTPTimeToNTFileTime
83 @ stub NTTimeToNTPTime
84 @ stub NhGetGuidFromInterfaceName
85 @ stub NhGetInterfaceNameFromGuid
86 @ stub NhpAllocateAndGetInterfaceInfoFromStack
87 @ stub NhpGetInterfaceIndexFromStack
88 @ stdcall NotifyAddrChange( ptr ptr )
89 @ stdcall NotifyRouteChange( ptr ptr )
90 @ stub NotifyRouteChangeEx
91 @ stub _PfAddFiltersToInterface@24
92 @ stub _PfAddGlobalFilterToInterface@8
93 @ stub _PfBindInterfaceToIPAddress@12
94 @ stub _PfBindInterfaceToIndex@16
95 @ stdcall _PfCreateInterface@24(long long long long long ptr) PfCreateInterface
96 @ stub _PfDeleteInterface@4
97 @ stub _PfDeleteLog@0
98 @ stub _PfGetInterfaceStatistics@16
99 @ stub _PfMakeLog@4
100 @ stub _PfRebindFilters@8
101 @ stub _PfRemoveFilterHandles@12
102 @ stub _PfRemoveFiltersFromInterface@20
103 @ stub _PfRemoveGlobalFilterFromInterface@8
104 @ stub _PfSetLogBuffer@28
105 @ stub _PfTestPacket@20
106 @ stub _PfUnBindInterface@4
107 @ stdcall SendARP( long long ptr ptr )
108 @ stub SetAdapterIpAddress
109 @ stub SetBlockRoutes
110 @ stdcall SetIfEntry( ptr )
111 @ stub SetIfEntryToStack
112 @ stdcall SetIpForwardEntry( ptr )
113 @ stub SetIpForwardEntryToStack
114 @ stub SetIpMultihopRouteEntryToStack
115 @ stdcall SetIpNetEntry( ptr )
116 @ stub SetIpNetEntryToStack
117 @ stub SetIpRouteEntryToStack
118 @ stdcall SetIpStatistics( ptr )
119 @ stub SetIpStatsToStack
120 @ stdcall SetIpTTL( long )
121 @ stub SetProxyArpEntryToStack
122 @ stub SetRouteWithRef
123 @ stdcall SetTcpEntry( ptr )
124 @ stub SetTcpEntryToStack
125 @ stdcall UnenableRouter( ptr ptr )