Fixed issues found by winapi_check.
[wine.git] / dlls / shell32 / shell32.spec
blob44e546ed2eb41de339ae1d7daea082a16eab4605
1 name shell32
2 type win32
3 init Shell32LibMain
4 rsrc shell32
6 import ole32.dll
7 import comctl32.dll
9 # Functions exported by the Win95 shell32.dll
10 # (these need to have these exact ordinals, for some
11 # win95 and winNT dlls import shell32.dll by ordinal)
12 # This list was updated to dll version 4.72
14 2 stdcall SHChangeNotifyRegister(long long long long long long) SHChangeNotifyRegister
15 3 stub CheckEscapesA@8
16 4 stdcall SHChangeNotifyDeregister (long) SHChangeNotifyDeregister
17 5 stub SHChangeNotifyUpdateEntryList@16
18 6 stub CheckEscapesW@8
19 7 stdcall CommandLineToArgvW(wstr ptr) CommandLineToArgvW
20 8 stdcall Control_FillCache_RunDLL (long long long long) Control_FillCache_RunDLL
21 9 stub PifMgr_OpenProperties@16
22 10 stub PifMgr_GetProperties@20
23 11 stub PifMgr_SetProperties@20
24 12 stub Control_FillCache_RunDLLA@16
25 13 stub PifMgr_CloseProperties@8
26 14 stub Control_FillCache_RunDLLW@16
27 15 stdcall ILGetDisplayName(ptr ptr) ILGetDisplayName
28 16 stdcall ILFindLastID(ptr) ILFindLastID
29 17 stdcall ILRemoveLastID(ptr) ILRemoveLastID
30 18 stdcall ILClone(ptr) ILClone
31 19 stdcall ILCloneFirst (ptr) ILCloneFirst
32 20 stdcall ILGlobalClone (ptr) ILGlobalClone
33 21 stdcall ILIsEqual (ptr ptr) ILIsEqual
34 22 stdcall Control_RunDLL(long long long long) Control_RunDLL # exported by name
35 23 stdcall ILIsParent (long long long) ILIsParent
36 24 stdcall ILFindChild (long long) ILFindChild
37 25 stdcall ILCombine(ptr ptr) ILCombine
38 26 stdcall ILLoadFromStream (long long) ILLoadFromStream
39 27 stub ILSaveToStream@8
40 28 stdcall SHILCreateFromPath (long long long) SHILCreateFromPathAW
41 29 stdcall PathIsRoot(ptr) PathIsRootAW
42 30 stdcall PathBuildRoot(ptr long) PathBuildRootA
43 31 stdcall PathFindExtension(ptr) PathFindExtensionAW
44 32 stdcall PathAddBackslash(ptr) PathAddBackslashAW
45 33 stdcall PathRemoveBlanks(str) PathRemoveBlanksAW
46 34 stdcall PathFindFilename(ptr) PathFindFilenameAW
47 35 stdcall PathRemoveFileSpec(str) PathRemoveFileSpecA
48 36 stdcall PathAppend(str str) PathAppendA
49 37 stdcall PathCombine(ptr ptr ptr) PathCombineAW
50 38 stub PathStripPath
51 39 stdcall PathIsUNC (ptr) PathIsUNCAW
52 40 stdcall PathIsRelative (ptr) PathIsRelativeAW
53 41 stub Control_RunDLLA@16
54 42 stub Control_RunDLLW@16
55 43 stdcall PathIsExe (ptr) PathIsExeAW
56 44 stub DoEnvironmentSubstA@8
57 45 stdcall PathFileExists(str) PathFileExistsA
58 46 stdcall PathMatchSpec (str str) PathMatchSpecAW
59 47 stub PathMakeUniqueName@20
60 48 stdcall PathSetDlgItemPath (long long ptr) PathSetDlgItemPathAW
61 49 stdcall PathQualify (ptr) PathQualifyAW
62 50 stub PathStripToRoot@4
63 51 stdcall PathResolve(str long long) PathResolve
64 52 stdcall PathGetArgs(str) PathGetArgsAW
65 53 stdcall DoEnvironmentSubst (long long) DoEnvironmentSubstAW
66 54 stdcall DragAcceptFiles(long long) DragAcceptFiles
67 55 stdcall PathQuoteSpaces (ptr) PathQuoteSpacesAW
68 56 stdcall PathUnquoteSpaces(str) PathUnquoteSpacesAW
69 57 stdcall PathGetDriveNumber(str) PathGetDriveNumberAW
70 58 stdcall ParseField(str long ptr long) ParseFieldA
71 59 stub RestartDialog@12
72 60 stdcall ExitWindowsDialog(long) ExitWindowsDialog
73 61 stdcall RunFileDlg(long long long str str long) RunFileDlg
74 62 stdcall PickIconDlg(long long long long) PickIconDlg
75 63 stdcall GetFileNameFromBrowse(long long long long str str str) GetFileNameFromBrowse
76 64 stdcall DriveType (long) DriveType
77 65 stub InvalidateDriveType
78 66 stub IsNetDrive
79 67 stdcall Shell_MergeMenus (long long long long long long) Shell_MergeMenus
80 68 stdcall SHGetSettings(ptr long long) SHGetSettings
81 69 stub SHGetNetResource
82 70 stdcall SHCreateDefClassObject(long long long long long)SHCreateDefClassObject
83 71 stdcall Shell_GetImageList(ptr ptr) Shell_GetImageList
84 72 stdcall Shell_GetCachedImageIndex(ptr ptr long) Shell_GetCachedImageIndexAW
85 73 stdcall SHShellFolderView_Message(long long long) SHShellFolderView_Message
86 74 stub SHCreateStdEnumFmtEtc
87 75 stdcall PathYetAnotherMakeUniqueName(ptr ptr) PathYetAnotherMakeUniqueNameA
88 76 stub DragQueryInfo
89 77 stdcall SHMapPIDLToSystemImageListIndex(long long long) SHMapPIDLToSystemImageListIndex
90 78 stdcall OleStrToStrN(str long wstr long) OleStrToStrNAW
91 79 stdcall StrToOleStrN(wstr long str long) StrToOleStrNAW
92 80 stdcall DragFinish(long) DragFinish
93 81 stdcall DragQueryFile(long long ptr long) DragQueryFileA
94 82 stdcall DragQueryFileA(long long ptr long) DragQueryFileA
95 83 stub CIDLData_CreateFromIDArray
96 84 stub SHIsBadInterfacePtr
97 85 stdcall OpenRegStream(long long long long) OpenRegStream
98 86 stdcall SHRegisterDragDrop(long ptr) SHRegisterDragDrop
99 87 stdcall SHRevokeDragDrop(long) SHRevokeDragDrop
100 88 stdcall SHDoDragDrop(long long long long long long) SHDoDragDrop
101 89 stdcall SHCloneSpecialIDList(long long long) SHCloneSpecialIDList
102 90 stub SHFindFiles
103 91 stub SHFindComputer
104 92 stub PathGetShortPath
105 93 stub Win32CreateDirectory
106 94 stub Win32RemoveDirectory
107 95 stdcall SHLogILFromFSIL (ptr) SHLogILFromFSIL
108 96 stdcall StrRetToStrN (long long long long) StrRetToStrNAW
109 97 stdcall SHWaitForFileToOpen (long long long) SHWaitForFileToOpen
110 98 stdcall SHGetRealIDL (long long long) SHGetRealIDL
111 99 stdcall SetAppStartingCursor (long long) SetAppStartingCursor
112 100 stdcall SHRestricted(long) SHRestricted
113 101 stub DragQueryFileAorW # exported by name
114 102 stdcall SHCoCreateInstance(ptr ptr long ptr ptr) SHCoCreateInstance
115 103 stdcall SignalFileOpen(long) SignalFileOpen
116 104 stdcall FileMenu_DeleteAllItems(long)FileMenu_DeleteAllItems
117 105 stdcall FileMenu_DrawItem(long ptr)FileMenu_DrawItem
118 106 stdcall FileMenu_FindSubMenuByPidl(long ptr)FileMenu_FindSubMenuByPidl
119 107 stdcall FileMenu_GetLastSelectedItemPidls(long ptr ptr)FileMenu_GetLastSelectedItemPidls
120 108 stdcall FileMenu_HandleMenuChar(long long)FileMenu_HandleMenuChar
121 109 stdcall FileMenu_InitMenuPopup (long) FileMenu_InitMenuPopup
122 110 stdcall FileMenu_InsertUsingPidl (long long ptr long long ptr) FileMenu_InsertUsingPidl
123 111 stdcall FileMenu_Invalidate (long) FileMenu_Invalidate
124 112 stdcall FileMenu_MeasureItem(long ptr)FileMenu_MeasureItem
125 113 stdcall FileMenu_ReplaceUsingPidl (long long ptr long ptr) FileMenu_ReplaceUsingPidl
126 114 stdcall FileMenu_Create (long long long long long) FileMenu_Create
127 115 stdcall FileMenu_AppendItem (long ptr long long long long) FileMenu_AppendItemAW
128 116 stdcall FileMenu_TrackPopupMenuEx (long long long long long long) FileMenu_TrackPopupMenuEx
129 117 stdcall FileMenu_DeleteItemByCmd(long long)FileMenu_DeleteItemByCmd
130 118 stdcall FileMenu_Destroy (long) FileMenu_Destroy
131 119 stdcall IsLFNDrive(str) IsLFNDriveA
132 120 stdcall FileMenu_AbortInitMenu () FileMenu_AbortInitMenu
133 121 stdcall SHFlushClipboard () SHFlushClipboard
134 122 stdcall RunDLL_CallEntry16 (long long long long long) RunDLL_CallEntry16 #name wrong?
135 123 stdcall SHFreeUnusedLibraries () SHFreeUnusedLibraries
136 124 stdcall FileMenu_AppendFilesForPidl(long ptr long)FileMenu_AppendFilesForPidl
137 125 stdcall FileMenu_AddFilesForPidl(long long long ptr long long ptr)FileMenu_AddFilesForPidl
138 126 stdcall SHOutOfMemoryMessageBox (long long long) SHOutOfMemoryMessageBox
139 127 stdcall SHWinHelp (long long long long) SHWinHelp
140 128 stdcall DllGetClassObject(long long ptr) SHELL32_DllGetClassObject
141 129 stub DAD_AutoScroll
142 130 stub DAD_DragEnter
143 131 stub DAD_DragEnterEx
144 132 stub DAD_DragLeave
145 133 stdcall DragQueryFileW(long long ptr long) DragQueryFileW
146 134 stub DAD_DragMove
147 135 stdcall DragQueryPoint(long ptr) DragQueryPoint
148 136 stdcall DAD_SetDragImage(long long) DAD_SetDragImage
149 137 stdcall DAD_ShowDragImage (long) DAD_ShowDragImage
150 138 stub DuplicateIcon # exported by name
151 139 stub Desktop_UpdateBriefcaseOnEvent
152 140 stdcall FileMenu_DeleteItemByIndex(long long) FileMenu_DeleteItemByIndex
153 141 stdcall FileMenu_DeleteItemByFirstID(long long)FileMenu_DeleteItemByFirstID
154 142 stdcall FileMenu_DeleteSeparator(long)FileMenu_DeleteSeparator
155 143 stdcall FileMenu_EnableItemByCmd(long long long)FileMenu_EnableItemByCmd
156 144 stdcall FileMenu_GetItemExtent (long long) FileMenu_GetItemExtent
157 145 stdcall PathFindOnPath (ptr ptr) PathFindOnPathAW
158 146 stdcall RLBuildListOfPaths()RLBuildListOfPaths
159 147 stdcall SHCLSIDFromString(long long) SHCLSIDFromStringAW
160 148 stdcall ExtractAssociatedIconA(long ptr long) ExtractAssociatedIconA # exported by name
161 149 stdcall SHFind_InitMenuPopup(long long long long) SHFind_InitMenuPopup
162 150 stub ExtractAssociatedIconExA # exported by name
163 151 stdcall SHLoadOLE (long) SHLoadOLE
164 152 stdcall ILGetSize(ptr) ILGetSize
165 153 stdcall ILGetNext(ptr) ILGetNext
166 154 stdcall ILAppend (long long long) ILAppend
167 155 stdcall ILFree (ptr) ILFree
168 156 stdcall ILGlobalFree (ptr) ILGlobalFree
169 157 stdcall ILCreateFromPath (ptr) ILCreateFromPathAW
170 158 stdcall PathGetExtension(str long long) PathGetExtensionAW
171 159 stdcall PathIsDirectory(ptr)PathIsDirectoryAW
172 160 stub SHNetConnectionDialog
173 161 stdcall SHRunControlPanel (long long) SHRunControlPanel
174 162 stdcall SHSimpleIDListFromPath (ptr) SHSimpleIDListFromPathAW
175 163 stdcall StrToOleStr (wstr str) StrToOleStrAW
176 164 stdcall Win32DeleteFile(str) Win32DeleteFile
177 165 stdcall SHCreateDirectory(long long) SHCreateDirectory
178 166 stub CallCPLEntry16
179 167 stub SHAddFromPropSheetExtArray
180 168 stub SHCreatePropSheetExtArray
181 169 stub SHDestroyPropSheetExtArray
182 170 stub SHReplaceFromPropSheetExtArray
183 171 stdcall PathCleanupSpec(ptr ptr) PathCleanupSpecAW
184 172 stub SHCreateLinks
185 173 stdcall SHValidateUNC(long long long)SHValidateUNC
186 174 stdcall SHCreateShellFolderViewEx (ptr ptr) SHCreateShellFolderViewEx
187 175 stdcall SHGetSpecialFolderPath(long long long long) SHGetSpecialFolderPathAW
188 176 stdcall SHSetInstanceExplorer (long) SHSetInstanceExplorer
189 177 stub DAD_SetDragImageFromListView
190 178 stub SHObjectProperties
191 179 stub SHGetNewLinkInfoA
192 180 stub SHGetNewLinkInfoW
193 181 stdcall RegisterShellHook(long long) RegisterShellHook
194 182 cdecl ShellMessageBoxW(long long long str long long) ShellMessageBoxW
195 183 cdecl ShellMessageBoxA(long long long str long long) ShellMessageBoxA
196 184 stdcall ArrangeWindows(long long long long long) ArrangeWindows
197 185 stub SHHandleDiskFull
198 186 stub ExtractAssociatedIconExW # exported by name
199 187 stub ExtractAssociatedIconW # exported by name
200 188 stdcall ExtractIconA(long str long) ExtractIconA # exported by name
201 189 stdcall ExtractIconEx(ptr long ptr ptr long) ExtractIconExAW
202 190 stdcall ExtractIconExA(str long ptr ptr long) ExtractIconExA
203 191 stdcall ExtractIconExW(wstr long ptr ptr long) ExtractIconExW
204 192 stub ExtractIconResInfoA # exported by name
205 193 stub ExtractIconResInfoW # exported by name
206 194 stdcall ExtractIconW(long wstr long) ExtractIconW # exported by name
207 195 stdcall SHFree(ptr) SHFree
208 196 stdcall SHAlloc(long) SHAlloc
209 197 stub SHGlobalDefect
210 198 stdcall SHAbortInvokeCommand () SHAbortInvokeCommand
211 199 stub SHGetFileIcon
212 200 stub SHLocalAlloc
213 201 stub SHLocalFree
214 202 stub SHLocalReAlloc
215 203 stub AddCommasW
216 204 stub ShortSizeFormatW
217 205 stub Printer_LoadIconsW
218 206 stub Link_AddExtraDataSection
219 207 stub Link_ReadExtraDataSection
220 208 stub Link_RemoveExtraDataSection
221 209 stub Int64ToString
222 210 stub LargeIntegerToString
223 211 stub Printers_GetPidl
224 212 stub Printer_AddPrinterPropPages
225 213 stub Printers_RegisterWindowW
226 214 stub Printers_UnregisterWindow
227 215 stub SHStartNetConnectionDialog@12
228 216 stub ExtractVersionResource16W # exported by name
229 217 stub FindExeDlgProc # exported by name
230 218 stdcall FindExecutableA(ptr ptr ptr) FindExecutableA # exported by name
231 219 stdcall FindExecutableW(wstr wstr wstr) FindExecutableW # exported by name
232 220 stdcall FreeIconList(long) FreeIconList # exported by name
233 221 stub InternalExtractIconListA # exported by name
234 222 stub InternalExtractIconListW # exported by name
235 223 stub OpenAs_RunDLL # exported by name
236 224 stub OpenAs_RunDLLA # exported by name
237 225 stub OpenAs_RunDLLW # exported by name
238 226 stub PrintersGetCommand_RunDLL # exported by name
239 227 stub PrintersGetCommand_RunDLLA # exported by name
240 228 stub PrintersGetCommand_RunDLLW # exported by name
241 229 stub RealShellExecuteA # exported by name
242 230 stub RealShellExecuteExA # exported by name
243 231 stub RealShellExecuteExW # exported by name
244 232 stub RealShellExecuteW # exported by name
245 233 stub RegenerateUserEnvironment # exported by name
246 234 stdcall SHAddToRecentDocs (long ptr) SHAddToRecentDocs # exported by name
247 235 stdcall SHAppBarMessage(long ptr) SHAppBarMessage # exported by name
248 236 stdcall SHBrowseForFolder(ptr) SHBrowseForFolderA # exported by name
249 237 stdcall SHBrowseForFolderA(ptr) SHBrowseForFolderA # exported by name
250 238 stub SHBrowseForFolderW@4 # exported by name
251 239 stdcall SHChangeNotify (long long ptr ptr) SHChangeNotifyAW # exported by name
252 240 stub SHEmptyRecycleBinA@12 # exported by name
253 241 stub SHEmptyRecycleBinW@12 # exported by name
254 242 stdcall SHFileOperation (ptr) SHFileOperationAW # exported by name
255 243 stdcall shell32_243(long long) shell32_243
256 244 stdcall SHInitRestricted(ptr ptr) SHInitRestricted # win98+ only, by ordinal
257 245 stub SHFormatDrive@16 # exported by name
258 246 stub SHFreeNameMappings@4 # exported by name
259 247 stdcall SHGetDataFromIDListA (ptr ptr long ptr long) SHGetDataFromIDListA
260 248 stdcall SHGetDataFromIDListW (ptr ptr long ptr long) SHGetDataFromIDListW
261 249 stub PathParseIconLocation@4
262 250 stub PathRemoveExtension@4
263 251 stub PathRemoveArgs@4
264 252 stdcall SHGetDesktopFolder(ptr) SHGetDesktopFolder # exported by name
265 253 stdcall SHGetFileInfo(ptr long ptr long long) SHGetFileInfoA # exported by name
266 254 stdcall SHGetFileInfoA(ptr long ptr long long) SHGetFileInfoA # exported by name
267 255 stdcall SHGetFileInfoW(ptr long ptr long long) SHGetFileInfoW # exported by name
268 256 stdcall SHGetInstanceExplorer (long) SHGetInstanceExplorer
269 257 stdcall SHGetMalloc(ptr) SHGetMalloc # exported by name
270 258 stub SHGetNewLinkInfo@20 # exported by name
271 259 stdcall SHGetPathFromIDList(ptr ptr) SHGetPathFromIDListAW # exported by name
272 260 stub SHGetPathFromIDList@8 # exported by name
273 261 stdcall SHGetPathFromIDListA (long long) SHGetPathFromIDListA # exported by name
274 262 stdcall SHGetPathFromIDListW (long long) SHGetPathFromIDListW # exported by name
275 263 stdcall SHGetSpecialFolderLocation(long long ptr) SHGetSpecialFolderLocation # exported by name
276 264 stdcall SHHelpShortcuts_RunDLL(long long long long) SHHelpShortcuts_RunDLL # exported by name
277 265 stub SHHelpShortcuts_RunDLLA@16 # exported by name
278 266 stub SHHelpShortcuts_RunDLLW@16 # exported by name
279 267 stdcall SHLoadInProc(long) SHLoadInProc # exported by name
280 268 stub SHQueryRecycleBinA@8 # exported by name
281 269 stub SHQueryRecycleBinW@8 # exported by name
282 270 stub SHUpdateRecycleBinIcon@0 # exported by name
284 271 stub SheChangeDirA
285 272 stub SheChangeDirExA
286 273 stub SheChangeDirExW
287 274 stdcall SheChangeDirW(wstr) SheChangeDirW
288 275 stub SheConvertPathW
289 276 stub SheFullPathA
290 277 stub SheFullPathW
291 278 stub SheGetCurDrive
292 279 stub SheGetDirA@8
293 280 stub SheGetDirExW@12
294 281 stdcall SheGetDirW (long long) SheGetDirW
295 282 stub SheGetPathOffsetW
296 283 stub SheRemoveQuotesA
297 284 stub SheRemoveQuotesW
298 285 stub SheSetCurDrive
299 286 stub SheShortenPathA
300 287 stub SheShortenPathW
301 288 stdcall ShellAboutA(long str str long) ShellAboutA
302 289 stdcall ShellAboutW(long wstr wstr long) ShellAboutW
303 290 stdcall ShellExecuteA(long str str str str long) ShellExecuteA
304 291 stdcall ShellExecuteEx (long) ShellExecuteExAW
305 292 stdcall ShellExecuteExA (long) ShellExecuteExA
306 293 stdcall ShellExecuteExW (long) ShellExecuteExW
307 294 stdcall ShellExecuteW (long wstr wstr wstr wstr long) ShellExecuteW
308 295 stub ShellHookProc # exported by name
309 296 stdcall Shell_NotifyIcon(long ptr) Shell_NotifyIcon
310 297 stdcall Shell_NotifyIconA(long ptr) Shell_NotifyIconA
311 298 stdcall Shell_NotifyIconW(long ptr) Shell_NotifyIconW
312 299 stub Shl1632_ThunkData32
313 300 stub Shl3216_ThunkData32
314 301 stub StrChrA
315 302 stub StrChrIA
316 303 stub StrChrIW
317 304 stdcall StrChrW (wstr long) StrChrW
318 305 stub StrCmpNA
319 306 stub StrCmpNIA
320 307 stdcall StrCmpNIW (wstr wstr long) StrCmpNIW
321 308 stub StrCmpNW
322 309 stdcall StrCpyNA (ptr str long) lstrcpynA
323 310 stdcall StrCpyNW (ptr wstr long)lstrcpynW
324 311 stub StrNCmpA
325 312 stub StrNCmpIA
326 313 stub StrNCmpIW
327 314 stub StrNCmpW
328 315 stdcall StrNCpyA (ptr str long) lstrcpynA
329 316 stdcall StrNCpyW (ptr wstr long)lstrcpynW
330 317 stdcall StrRChrA (str str long) lstrrchr
331 318 stub StrRChrIA
332 319 stub StrRChrIW
333 320 stdcall StrRChrW (wstr wstr long) lstrrchrw
334 321 stub StrRStrA
335 322 stub StrRStrIA
336 323 stub StrRStrIW
337 324 stub StrRStrW
338 325 stub StrStrA
339 326 stub StrStrIA
340 327 stub StrStrIW
341 328 stub StrStrW
342 329 stub WOWShellExecute # proper ordinal unknown
344 505 stdcall SHRegCloseKey (long) SHRegCloseKey
345 506 stdcall SHRegOpenKeyA (long str long) SHRegOpenKeyA
346 507 stdcall SHRegOpenKeyW (long wstr long) SHRegOpenKeyW
347 508 stub SHRegQueryValueA@16
348 509 stdcall SHRegQueryValueExA(long str ptr ptr ptr ptr) SHRegQueryValueExA
349 510 stdcall SHRegQueryValueW (long long long long) SHRegQueryValueW
350 511 stdcall SHRegQueryValueExW (long wstr ptr ptr ptr ptr) SHRegQueryValueExW
351 512 stdcall SHRegDeleteKeyW (long wstr) SHRegDeleteKeyW
353 520 stdcall SHAllocShared (long long long) SHAllocShared
354 521 stdcall SHLockShared (long long) SHLockShared
355 522 stdcall SHUnlockShared (long) SHUnlockShared
356 523 stdcall SHFreeShared (long long) SHFreeShared
357 524 stub RealDriveType@8
358 525 stub RealDriveTypeFlags@8
360 640 stdcall NTSHChangeNotifyRegister (long long long long long long) NTSHChangeNotifyRegister
361 641 stdcall NTSHChangeNotifyDeregister (long) NTSHChangeNotifyDeregister
363 643 stub SHChangeNotifyReceive@16
364 644 stub SHChangeNotification_Lock@16
365 645 stub SHChangeNotification_Unlock@4
366 646 stub SHChangeRegistrationReceive@8
367 647 stub ReceiveAddToRecentDocs@8
368 648 stub SHWaitOp_Operate@8
370 650 stub PathIsSameRoot@8
372 # nt40/win98
373 651 stdcall ReadCabinetState (long long) ReadCabinetState
374 652 stdcall WriteCabinetState (long) WriteCabinetState
375 653 stdcall PathProcessCommand (long long long long) PathProcessCommandAW
377 # win98
378 654 stdcall shell32_654 (long long) shell32_654
380 660 stdcall FileIconInit (long) FileIconInit
382 680 stdcall IsUserAdmin () IsUserAdmin
384 1217 stub FOOBAR1217 # no joke! This is the real name!!
386 # later additions ... FIXME: incorrect ordinals
387 # win 98 uses 2...330, 505..511, 520..526, 640..654, 660, 680, 700..707, 711
390 1220 stdcall DllGetVersion (ptr) SHELL32_DllGetVersion # win98:201
391 1221 stdcall SHGetSpecialFolderPathA(long ptr long long) SHGetSpecialFolderPathA # win98:292
392 1222 stdcall DoEnvironmentSubstA (str str) DoEnvironmentSubstA # win98:293
393 1223 stdcall DoEnvironmentSubstW (wstr wstr) DoEnvironmentSubstW # win98:204
395 # by-name routines relocated in win98
397 1224 stdcall SHFileOperationA (ptr) SHFileOperationA # exported by name
398 1225 stdcall SHFileOperationW (ptr) SHFileOperationW # exported by name
399 1226 stdcall DllInstall (long wstr) SHELL32_DllInstall # win98:202