1 @ stdcall AddIPAddress
( long long long ptr ptr
)
2 @ stub AllocateAndGetArpEntTableFromStack
3 @ stdcall AllocateAndGetIfTableFromStack
( ptr long long long
)
4 #@ stub AllocateAndGetInterfaceInfoFromStack
5 @ stdcall AllocateAndGetIpAddrTableFromStack
( ptr long long long
)
6 @ stdcall AllocateAndGetIpForwardTableFromStack
( ptr long long long
)
7 @ stdcall AllocateAndGetIpNetTableFromStack
( ptr long long long
)
8 @ stdcall AllocateAndGetTcpExTableFromStack
( ptr long long long long
)
9 @ stdcall AllocateAndGetTcpTableFromStack
( ptr long long long
)
10 @ stdcall AllocateAndGetUdpTableFromStack
( ptr long long long
)
11 @ stdcall CancelIPChangeNotify
( ptr
)
12 @ stdcall CancelMibChangeNotify2
( ptr
)
13 #@ stub ConvertGuidToStringA
14 #@ stub ConvertGuidToStringW
15 #@ stub ConvertInterfaceAliasToLuid
16 @ stdcall ConvertInterfaceGuidToLuid
( ptr ptr
)
17 @ stdcall ConvertInterfaceIndexToLuid
( long ptr
)
18 #@ stub ConvertInterfaceLuidToAlias
19 @ stdcall ConvertInterfaceLuidToGuid
( ptr ptr
)
20 @ stdcall ConvertInterfaceLuidToIndex
( ptr ptr
)
21 @ stdcall ConvertInterfaceLuidToNameA
( ptr ptr long
)
22 @ stdcall ConvertInterfaceLuidToNameW
( ptr ptr long
)
23 @ stdcall ConvertInterfaceNameToLuidA
( str ptr
)
24 @ stdcall ConvertInterfaceNameToLuidW
( wstr ptr
)
25 #@ stub ConvertInterfacePhysicalAddressToLuid
26 #@ stub ConvertIpv4MaskToLength
27 @ stdcall ConvertLengthToIpv4Mask
( long ptr
)
28 #@ stub ConvertRemoteInterfaceAliasToLuid
29 #@ stub ConvertRemoteInterfaceGuidToLuid
30 #@ stub ConvertRemoteInterfaceIndexToLuid
31 #@ stub ConvertRemoteInterfaceLuidToAlias
32 #@ stub ConvertRemoteInterfaceLuidToGuid
33 #@ stub ConvertRemoteInterfaceLuidToIndex
34 #@ stub ConvertStringToGuidA
35 #@ stub ConvertStringToGuidW
36 #@ stub ConvertStringToInterfacePhysicalAddress
37 #@ stub CPNatfwtCreateProviderInstance
38 #@ stub CPNatfwtDeregisterProviderInstance
39 #@ stub CPNatfwtDestroyProviderInstance
40 #@ stub CPNatfwtIndicateReceivedBuffers
41 #@ stub CPNatfwtRegisterProviderInstance
42 #@ stub CreateAnycastIpAddressEntry
43 #@ stub CreateIpForwardEntry2
44 @ stdcall CreateIpForwardEntry
( ptr
)
45 #@ stub CreateIpNetEntry2
46 @ stdcall CreateIpNetEntry
( ptr
)
47 #@ stub CreatePersistentTcpPortReservation
48 #@ stub CreatePersistentUdpPortReservation
49 @ stdcall CreateProxyArpEntry
( long long long
)
50 @ stdcall CreateSortedAddressPairs
( ptr long ptr long long ptr ptr
)
51 #@ stub CreateUnicastIpAddressEntry
52 #@ stub DeleteAnycastIpAddressEntry
53 @ stdcall DeleteIPAddress
( long
)
54 #@ stub DeleteIpForwardEntry2
55 @ stdcall DeleteIpForwardEntry
( ptr
)
56 #@ stub DeleteIpNetEntry2
57 @ stdcall DeleteIpNetEntry
( ptr
)
58 #@ stub DeletePersistentTcpPortReservation
59 #@ stub DeletePersistentUdpPortReservation
60 @ stdcall DeleteProxyArpEntry
( long long long
)
61 #@ stub DeleteUnicastIpAddressEntry
62 #@ stub DisableMediaSense
65 @ stdcall EnableRouter
( ptr ptr
)
66 @ stdcall FlushIpNetTable
( long
)
67 #@ stub FlushIpNetTable2
68 @ stub FlushIpNetTableFromStack
69 #@ stub FlushIpPathTable
70 @ stdcall FreeMibTable
( ptr
)
71 @ stdcall GetAdapterIndex
( wstr ptr
)
72 @ stub GetAdapterOrderMap
73 @ stdcall GetAdaptersAddresses
( long long ptr ptr ptr
)
74 @ stdcall GetAdaptersInfo
( ptr ptr
)
75 #@ stub GetAnycastIpAddressEntry
76 #@ stub GetAnycastIpAddressTable
77 @ stdcall GetBestInterface
( long ptr
)
78 @ stdcall GetBestInterfaceEx
( ptr ptr
)
79 @ stub GetBestInterfaceFromStack
80 @ stdcall GetBestRoute
( long long ptr
)
81 @ stdcall GetBestRoute2
( ptr long ptr ptr long ptr ptr
)
82 @ stub GetBestRouteFromStack
83 #@ stub GetCurrentThreadCompartmentId
84 @ stdcall GetExtendedTcpTable
( ptr ptr long long long long
)
85 @ stdcall GetExtendedUdpTable
( ptr ptr long long long long
)
86 @ stdcall GetFriendlyIfIndex
( long
)
87 @ stdcall GetIcmpStatisticsEx
( ptr long
)
88 @ stdcall GetIcmpStatistics
( ptr
)
89 @ stub GetIcmpStatsFromStack
90 @ stdcall GetIfEntry
( ptr
)
91 @ stdcall GetIfEntry2
( ptr
)
92 @ stub GetIfEntryFromStack
93 #@ stub GetIfStackTable
94 @ stdcall GetIfTable
( ptr ptr long
)
95 @ stdcall GetIfTable2
( ptr
)
96 @ stdcall GetIfTable2Ex
( long ptr
)
97 @ stub GetIfTableFromStack
99 @ stdcall GetInterfaceInfo
( ptr ptr
)
100 #@ stub GetInvertedIfStackTable
101 @ stdcall GetIpAddrTable
( ptr ptr long
)
102 @ stub GetIpAddrTableFromStack
103 #@ stub GetIpErrorString
104 #@ stub GetIpForwardEntry2
105 @ stdcall GetIpForwardTable
( ptr ptr long
)
106 @ stdcall GetIpForwardTable2
( long ptr
)
107 @ stub GetIpForwardTableFromStack
108 #@ stub GetIpInterfaceEntry
109 @ stdcall GetIpInterfaceTable
( long ptr
)
110 #@ stub GetIpNetEntry2
111 @ stdcall GetIpNetTable
( ptr ptr long
)
112 @ stdcall GetIpNetTable2
( long ptr
)
113 @ stub GetIpNetTableFromStack
114 #@ stub GetIpPathEntry
115 #@ stub GetIpPathTable
116 @ stdcall GetIpStatisticsEx
( ptr long
)
117 @ stdcall GetIpStatistics
( ptr
)
118 @ stub GetIpStatsFromStack
119 #@ stub GetMulticastIpAddressEntry
120 #@ stub GetMulticastIpAddressTable
121 #@ stub GetNetworkInformation
122 @ stdcall GetNetworkParams
( ptr ptr
)
123 @ stdcall GetNumberOfInterfaces
( ptr
)
124 #@ stub GetOwnerModuleFromPidAndInfo
125 #@ stub GetOwnerModuleFromTcp6Entry
126 #@ stub GetOwnerModuleFromTcpEntry
127 #@ stub GetOwnerModuleFromUdp6Entry
128 #@ stub GetOwnerModuleFromUdpEntry
129 @ stdcall GetPerAdapterInfo
( long ptr ptr
)
130 #@ stub GetPerTcp6ConnectionEStats
131 #@ stub GetPerTcp6ConnectionStats
132 #@ stub GetPerTcpConnectionEStats
133 #@ stub GetPerTcpConnectionStats
134 @ stdcall GetRTTAndHopCount
( long ptr long ptr
)
135 #@ stub GetSessionCompartmentId
136 @ stdcall GetTcp6Table
( ptr ptr long
)
137 @ stdcall GetTcp6Table2
( ptr ptr long
)
138 @ stdcall GetTcpStatisticsEx
( ptr long
)
139 @ stdcall GetTcpStatistics
( ptr
)
140 @ stub GetTcpStatsFromStack
141 @ stdcall GetTcpTable
( ptr ptr long
)
142 @ stdcall GetTcpTable2
( ptr ptr long
)
143 @ stub GetTcpTableFromStack
144 #@ stub GetTeredoPort
145 @ stdcall GetUdp6Table
( ptr ptr long
)
146 @ stdcall GetUdpStatisticsEx
( ptr long
)
147 @ stdcall GetUdpStatistics
( ptr
)
148 @ stub GetUdpStatsFromStack
149 @ stdcall GetUdpTable
( ptr ptr long
)
150 @ stub GetUdpTableFromStack
151 @ stdcall GetUnicastIpAddressEntry
( ptr
)
152 @ stdcall GetUnicastIpAddressTable
(long ptr
)
153 @ stdcall GetUniDirectionalAdapterInfo
( ptr ptr
)
154 @ stdcall Icmp6CreateFile
()
155 #@ stub Icmp6ParseReplies
156 @ stdcall Icmp6SendEcho2
(ptr ptr ptr ptr ptr ptr ptr long ptr ptr long long
)
157 @ stdcall IcmpCloseHandle
(ptr
)
158 @ stdcall IcmpCreateFile
()
159 @ stub IcmpParseReplies
160 @ stdcall IcmpSendEcho2Ex
(ptr ptr ptr ptr long long ptr long ptr ptr long long
)
161 @ stdcall IcmpSendEcho2
(ptr ptr ptr ptr long ptr long ptr ptr long long
)
162 @ stdcall IcmpSendEcho
(ptr long ptr long ptr ptr long long
)
163 @ stdcall if_indextoname
(long ptr
) IPHLP_if_indextoname
164 @ stdcall if_nametoindex
(str
) IPHLP_if_nametoindex
165 #@ stub InitializeIpForwardEntry
166 #@ stub InitializeIpInterfaceEntry
167 #@ stub InitializeUnicastIpAddressEntry
168 #@ stub InternalCleanupPersistentStore
169 #@ stub InternalCreateAnycastIpAddressEntry
170 @ stub InternalCreateIpForwardEntry
171 #@ stub InternalCreateIpForwardEntry2
172 @ stub InternalCreateIpNetEntry
173 #@ stub InternalCreateIpNetEntry2
174 #@ stub InternalCreateUnicastIpAddressEntry
175 #@ stub InternalDeleteAnycastIpAddressEntry
176 @ stub InternalDeleteIpForwardEntry
177 #@ stub InternalDeleteIpForwardEntry2
178 @ stub InternalDeleteIpNetEntry
179 #@ stub InternalDeleteIpNetEntry2
180 #@ stub InternalDeleteUnicastIpAddressEntry
181 #@ stub InternalFindInterfaceByAddress
182 #@ stub InternalGetAnycastIpAddressEntry
183 #@ stub InternalGetAnycastIpAddressTable
184 #@ stub InternalGetForwardIpTable2
185 #@ stub InternalGetIfEntry2
186 @ stub InternalGetIfTable
187 #@ stub InternalGetIfTable2
188 @ stub InternalGetIpAddrTable
189 #@ stub InternalGetIpForwardEntry2
190 @ stub InternalGetIpForwardTable
191 #@ stub InternalGetIpInterfaceEntry
192 #@ stub InternalGetIpInterfaceTable
193 #@ stub InternalGetIpNetEntry2
194 @ stub InternalGetIpNetTable
195 #@ stub InternalGetIpNetTable2
196 #@ stub InternalGetMulticastIpAddressEntry
197 #@ stub InternalGetMulticastIpAddressTable
198 #@ stub InternalGetTcp6Table2
199 #@ stub InternalGetTcp6TableWithOwnerModule
200 #@ stub InternalGetTcp6TableWithOwnerPid
201 @ stub InternalGetTcpTable
202 #@ stub InternalGetTcpTable2
203 #@ stub InternalGetTcpTableEx
204 #@ stub InternalGetTcpTableWithOwnerModule
205 #@ stub InternalGetTcpTableWithOwnerPid
206 #@ stub InternalGetTunnelPhysicalAdapter
207 #@ stub InternalGetUdp6TableWithOwnerModule
208 #@ stub InternalGetUdp6TableWithOwnerPid
209 @ stub InternalGetUdpTable
210 #@ stub InternalGetUdpTableEx
211 #@ stub InternalGetUdpTableWithOwnerModule
212 #@ stub InternalGetUdpTableWithOwnerPid
213 #@ stub InternalGetUnicastIpAddressEntry
214 #@ stub InternalGetUnicastIpAddressTable
215 @ stub InternalSetIfEntry
216 @ stub InternalSetIpForwardEntry
217 #@ stub InternalSetIpForwardEntry2
218 #@ stub InternalSetIpInterfaceEntry
219 @ stub InternalSetIpNetEntry
220 #@ stub InternalSetIpNetEntry2
221 @ stub InternalSetIpStats
222 @ stub InternalSetTcpEntry
223 #@ stub InternalSetTeredoPort
224 #@ stub InternalSetUnicastIpAddressEntry
225 @ stdcall IpReleaseAddress
( ptr
)
226 @ stdcall IpRenewAddress
( ptr
)
227 @ stub IsLocalAddress
228 #@ stub LookupPersistentTcpPortReservation
229 #@ stub LookupPersistentUdpPortReservation
230 @ stub NhGetGuidFromInterfaceName
231 #@ stub NhGetInterfaceDescriptionFromGuid
232 #@ stub NhGetInterfaceNameFromDeviceGuid
233 @ stub NhGetInterfaceNameFromGuid
234 @ stub NhpAllocateAndGetInterfaceInfoFromStack
235 @ stub NhpGetInterfaceIndexFromStack
236 @ stdcall NotifyAddrChange
( ptr ptr
)
237 @ stdcall NotifyIpInterfaceChange
( long ptr ptr long ptr
)
238 @ stdcall NotifyRouteChange
( ptr ptr
)
239 #@ stub NotifyRouteChange2
240 @ stub NotifyRouteChangeEx
241 #@ stub NotifyStableUnicastIpAddressTable
242 #@ stub NotifyTeredoPortChange
243 @ stdcall NotifyUnicastIpAddressChange
(long ptr ptr long ptr
)
244 #@ stub NTPTimeToNTFileTime
245 #@ stub NTTimeToNTPTime
246 @ stdcall ParseNetworkString
(wstr long ptr ptr ptr
)
247 @ stub _PfAddFiltersToInterface@
24
248 @ stub _PfAddGlobalFilterToInterface@
8
249 @ stdcall _PfBindInterfaceToIPAddress@
12(long long ptr
) PfBindInterfaceToIPAddress
250 @ stub _PfBindInterfaceToIndex@
16
251 @ stdcall _PfCreateInterface@
24(long long long long long ptr
) PfCreateInterface
252 @ stdcall _PfDeleteInterface@
4(long
) PfDeleteInterface
253 @ stub _PfDeleteLog@
0
254 @ stub _PfGetInterfaceStatistics@
16
256 @ stub _PfRebindFilters@
8
257 @ stub _PfRemoveFilterHandles@
12
258 @ stub _PfRemoveFiltersFromInterface@
20
259 @ stub _PfRemoveGlobalFilterFromInterface@
8
260 @ stub _PfSetLogBuffer@
28
261 @ stub _PfTestPacket@
20
262 @ stdcall _PfUnBindInterface@
4(long
) PfUnBindInterface
263 #@ stub register_icmp
264 #@ stub ResolveIpNetEntry2
265 #@ stub ResolveNeighbor
266 #@ stub RestoreMediaSense
267 @ stdcall SendARP
( long long ptr ptr
)
268 @ stub SetAdapterIpAddress
269 @ stub SetBlockRoutes
270 #@ stub SetCurrentThreadCompartmentId
271 @ stdcall SetIfEntry
( ptr
)
272 @ stub SetIfEntryToStack
273 #@ stub SetIpForwardEntry2
274 @ stdcall SetIpForwardEntry
( ptr
)
275 @ stub SetIpForwardEntryToStack
276 #@ stub SetIpInterfaceEntry
277 @ stub SetIpMultihopRouteEntryToStack
278 #@ stub SetIpNetEntry2
279 @ stdcall SetIpNetEntry
( ptr
)
280 @ stub SetIpNetEntryToStack
281 @ stub SetIpRouteEntryToStack
282 #@ stub SetIpStatisticsEx
283 @ stdcall SetIpStatistics
( ptr
)
284 @ stub SetIpStatsToStack
285 @ stdcall SetIpTTL
( long
)
286 #@ stub SetNetworkInformation
287 #@ stub SetPerTcp6ConnectionEStats
288 #@ stub SetPerTcp6ConnectionStats
289 @ stdcall SetPerTcpConnectionEStats
( ptr long ptr long long long
)
290 #@ stub SetPerTcpConnectionStats
291 @ stub SetProxyArpEntryToStack
292 @ stub SetRouteWithRef
293 #@ stub SetSessionCompartmentId
294 @ stdcall SetTcpEntry
( ptr
)
295 @ stub SetTcpEntryToStack
296 #@ stub SetUnicastIpAddressEntry
297 @ stdcall UnenableRouter
( ptr ptr
)