gphoto2.ds: Set supported groups.
[wine.git] / dlls / api-ms-win-crt-math-l1-1-0 / api-ms-win-crt-math-l1-1-0.spec
blob7bae4ff11e36304291a79f68b48c6052c3727735
1 @ cdecl -arch=i386 _CIacos() ucrtbase._CIacos
2 @ cdecl -arch=i386 _CIasin() ucrtbase._CIasin
3 @ cdecl -arch=i386 _CIatan() ucrtbase._CIatan
4 @ cdecl -arch=i386 _CIatan2() ucrtbase._CIatan2
5 @ cdecl -arch=i386 _CIcos() ucrtbase._CIcos
6 @ cdecl -arch=i386 _CIcosh() ucrtbase._CIcosh
7 @ cdecl -arch=i386 _CIexp() ucrtbase._CIexp
8 @ cdecl -arch=i386 _CIfmod() ucrtbase._CIfmod
9 @ cdecl -arch=i386 _CIlog() ucrtbase._CIlog
10 @ cdecl -arch=i386 _CIlog10() ucrtbase._CIlog10
11 @ cdecl -arch=i386 _CIpow() ucrtbase._CIpow
12 @ cdecl -arch=i386 _CIsin() ucrtbase._CIsin
13 @ cdecl -arch=i386 _CIsinh() ucrtbase._CIsinh
14 @ cdecl -arch=i386 _CIsqrt() ucrtbase._CIsqrt
15 @ cdecl -arch=i386 _CItan() ucrtbase._CItan
16 @ cdecl -arch=i386 _CItanh() ucrtbase._CItanh
17 @ stub _Cbuild
18 @ stub _Cmulcc
19 @ stub _Cmulcr
20 @ stub _FCbuild
21 @ stub _FCmulcc
22 @ stub _FCmulcr
23 @ stub _LCbuild
24 @ stub _LCmulcc
25 @ stub _LCmulcr
26 @ cdecl -arch=i386 -norelay __libm_sse2_acos() ucrtbase.__libm_sse2_acos
27 @ cdecl -arch=i386 -norelay __libm_sse2_acosf() ucrtbase.__libm_sse2_acosf
28 @ cdecl -arch=i386 -norelay __libm_sse2_asin() ucrtbase.__libm_sse2_asin
29 @ cdecl -arch=i386 -norelay __libm_sse2_asinf() ucrtbase.__libm_sse2_asinf
30 @ cdecl -arch=i386 -norelay __libm_sse2_atan() ucrtbase.__libm_sse2_atan
31 @ cdecl -arch=i386 -norelay __libm_sse2_atan2() ucrtbase.__libm_sse2_atan2
32 @ cdecl -arch=i386 -norelay __libm_sse2_atanf() ucrtbase.__libm_sse2_atanf
33 @ cdecl -arch=i386 -norelay __libm_sse2_cos() ucrtbase.__libm_sse2_cos
34 @ cdecl -arch=i386 -norelay __libm_sse2_cosf() ucrtbase.__libm_sse2_cosf
35 @ cdecl -arch=i386 -norelay __libm_sse2_exp() ucrtbase.__libm_sse2_exp
36 @ cdecl -arch=i386 -norelay __libm_sse2_expf() ucrtbase.__libm_sse2_expf
37 @ cdecl -arch=i386 -norelay __libm_sse2_log() ucrtbase.__libm_sse2_log
38 @ cdecl -arch=i386 -norelay __libm_sse2_log10() ucrtbase.__libm_sse2_log10
39 @ cdecl -arch=i386 -norelay __libm_sse2_log10f() ucrtbase.__libm_sse2_log10f
40 @ cdecl -arch=i386 -norelay __libm_sse2_logf() ucrtbase.__libm_sse2_logf
41 @ cdecl -arch=i386 -norelay __libm_sse2_pow() ucrtbase.__libm_sse2_pow
42 @ cdecl -arch=i386 -norelay __libm_sse2_powf() ucrtbase.__libm_sse2_powf
43 @ cdecl -arch=i386 -norelay __libm_sse2_sin() ucrtbase.__libm_sse2_sin
44 @ cdecl -arch=i386 -norelay __libm_sse2_sinf() ucrtbase.__libm_sse2_sinf
45 @ cdecl -arch=i386 -norelay __libm_sse2_tan() ucrtbase.__libm_sse2_tan
46 @ cdecl -arch=i386 -norelay __libm_sse2_tanf() ucrtbase.__libm_sse2_tanf
47 @ cdecl __setusermatherr(ptr) ucrtbase.__setusermatherr
48 @ cdecl _cabs(long) ucrtbase._cabs
49 @ cdecl _chgsign(double) ucrtbase._chgsign
50 @ cdecl _chgsignf(float) ucrtbase._chgsignf
51 @ cdecl _copysign(double double) ucrtbase._copysign
52 @ cdecl _copysignf(float float) ucrtbase._copysignf
53 @ stub _d_int
54 @ cdecl _dclass(double) ucrtbase._dclass
55 @ stub _dexp
56 @ stub _dlog
57 @ stub _dnorm
58 @ cdecl _dpcomp(double double) ucrtbase._dpcomp
59 @ stub _dpoly
60 @ stub _dscale
61 @ cdecl _dsign(double) ucrtbase._dsign
62 @ stub _dsin
63 @ cdecl _dtest(ptr) ucrtbase._dtest
64 @ stub _dunscale
65 @ cdecl _except1(long long double double long ptr) ucrtbase._except1
66 @ stub _fd_int
67 @ cdecl _fdclass(float) ucrtbase._fdclass
68 @ stub _fdexp
69 @ stub _fdlog
70 @ stub _fdnorm
71 @ cdecl _fdopen(long str) ucrtbase._fdopen
72 @ cdecl _fdpcomp(float float) ucrtbase._fdpcomp
73 @ stub _fdpoly
74 @ stub _fdscale
75 @ cdecl _fdsign(float) ucrtbase._fdsign
76 @ stub _fdsin
77 @ cdecl _fdtest(ptr) ucrtbase._fdtest
78 @ stub _fdunscale
79 @ cdecl _finite(double) ucrtbase._finite
80 @ cdecl -arch=arm,x86_64,arm64 _finitef(float) ucrtbase._finitef
81 @ cdecl _fpclass(double) ucrtbase._fpclass
82 @ stub _fpclassf
83 @ cdecl -arch=i386 -ret64 _ftol() ucrtbase._ftol
84 @ stub _get_FMA3_enable
85 @ cdecl _hypot(double double) ucrtbase._hypot
86 @ cdecl _hypotf(float float) ucrtbase._hypotf
87 @ cdecl _isnan(double) ucrtbase._isnan
88 @ cdecl -arch=x86_64 _isnanf(float) ucrtbase._isnanf
89 @ cdecl _j0(double) ucrtbase._j0
90 @ cdecl _j1(double) ucrtbase._j1
91 @ cdecl _jn(long double) ucrtbase._jn
92 @ stub _ld_int
93 @ cdecl _ldclass(double) ucrtbase._ldclass
94 @ stub _ldexp
95 @ stub _ldlog
96 @ cdecl _ldpcomp(double double) ucrtbase._ldpcomp
97 @ stub _ldpoly
98 @ stub _ldscale
99 @ cdecl _ldsign(double) ucrtbase._ldsign
100 @ stub _ldsin
101 @ cdecl _ldtest(ptr) ucrtbase._ldtest
102 @ stub _ldunscale
103 @ cdecl -arch=i386 -norelay _libm_sse2_acos_precise() ucrtbase._libm_sse2_acos_precise
104 @ cdecl -arch=i386 -norelay _libm_sse2_asin_precise() ucrtbase._libm_sse2_asin_precise
105 @ cdecl -arch=i386 -norelay _libm_sse2_atan_precise() ucrtbase._libm_sse2_atan_precise
106 @ cdecl -arch=i386 -norelay _libm_sse2_cos_precise() ucrtbase._libm_sse2_cos_precise
107 @ cdecl -arch=i386 -norelay _libm_sse2_exp_precise() ucrtbase._libm_sse2_exp_precise
108 @ cdecl -arch=i386 -norelay _libm_sse2_log10_precise() ucrtbase._libm_sse2_log10_precise
109 @ cdecl -arch=i386 -norelay _libm_sse2_log_precise() ucrtbase._libm_sse2_log_precise
110 @ cdecl -arch=i386 -norelay _libm_sse2_pow_precise() ucrtbase._libm_sse2_pow_precise
111 @ cdecl -arch=i386 -norelay _libm_sse2_sin_precise() ucrtbase._libm_sse2_sin_precise
112 @ cdecl -arch=i386 -norelay _libm_sse2_sqrt_precise() ucrtbase._libm_sse2_sqrt_precise
113 @ cdecl -arch=i386 -norelay _libm_sse2_tan_precise() ucrtbase._libm_sse2_tan_precise
114 @ cdecl _logb(double) ucrtbase._logb
115 @ cdecl -arch=arm,x86_64,arm64 _logbf(float) ucrtbase._logbf
116 @ cdecl _nextafter(double double) ucrtbase._nextafter
117 @ cdecl -arch=x86_64 _nextafterf(float float) ucrtbase._nextafterf
118 @ cdecl _scalb(double long) ucrtbase._scalb
119 @ cdecl -arch=x86_64 _scalbf(float long) ucrtbase._scalbf
120 @ cdecl -arch=win64 _set_FMA3_enable(long) ucrtbase._set_FMA3_enable
121 @ cdecl -arch=i386 _set_SSE2_enable(long) ucrtbase._set_SSE2_enable
122 @ cdecl _y0(double) ucrtbase._y0
123 @ cdecl _y1(double) ucrtbase._y1
124 @ cdecl _yn(long double) ucrtbase._yn
125 @ cdecl acos(double) ucrtbase.acos
126 @ cdecl -arch=arm,x86_64,arm64 acosf(float) ucrtbase.acosf
127 @ cdecl acosh(double) ucrtbase.acosh
128 @ cdecl acoshf(float) ucrtbase.acoshf
129 @ cdecl acoshl(double) ucrtbase.acoshl
130 @ cdecl asin(double) ucrtbase.asin
131 @ cdecl -arch=arm,x86_64,arm64 asinf(float) ucrtbase.asinf
132 @ cdecl asinh(double) ucrtbase.asinh
133 @ cdecl asinhf(float) ucrtbase.asinhf
134 @ cdecl asinhl(double) ucrtbase.asinhl
135 @ cdecl atan(double) ucrtbase.atan
136 @ cdecl atan2(double double) ucrtbase.atan2
137 @ cdecl -arch=arm,x86_64,arm64 atan2f(float float) ucrtbase.atan2f
138 @ cdecl -arch=arm,x86_64,arm64 atanf(float) ucrtbase.atanf
139 @ cdecl atanh(double) ucrtbase.atanh
140 @ cdecl atanhf(float) ucrtbase.atanhf
141 @ cdecl atanhl(double) ucrtbase.atanhl
142 @ stub cabs
143 @ stub cabsf
144 @ stub cabsl
145 @ stub cacos
146 @ stub cacosf
147 @ stub cacosh
148 @ stub cacoshf
149 @ stub cacoshl
150 @ stub cacosl
151 @ stub carg
152 @ stub cargf
153 @ stub cargl
154 @ stub casin
155 @ stub casinf
156 @ stub casinh
157 @ stub casinhf
158 @ stub casinhl
159 @ stub casinl
160 @ stub catan
161 @ stub catanf
162 @ stub catanh
163 @ stub catanhf
164 @ stub catanhl
165 @ stub catanl
166 @ cdecl cbrt(double) ucrtbase.cbrt
167 @ cdecl cbrtf(float) ucrtbase.cbrtf
168 @ cdecl cbrtl(double) ucrtbase.cbrtl
169 @ stub ccos
170 @ stub ccosf
171 @ stub ccosh
172 @ stub ccoshf
173 @ stub ccoshl
174 @ stub ccosl
175 @ cdecl ceil(double) ucrtbase.ceil
176 @ cdecl -arch=arm,x86_64,arm64 ceilf(float) ucrtbase.ceilf
177 @ stub cexp
178 @ stub cexpf
179 @ stub cexpl
180 @ stub cimag
181 @ stub cimagf
182 @ stub cimagl
183 @ stub clog
184 @ stub clog10
185 @ stub clog10f
186 @ stub clog10l
187 @ stub clogf
188 @ stub clogl
189 @ stub conj
190 @ stub conjf
191 @ stub conjl
192 @ cdecl copysign(double double) ucrtbase.copysign
193 @ cdecl copysignf(float float) ucrtbase.copysignf
194 @ cdecl copysignl(double double) ucrtbase.copysignl
195 @ cdecl cos(double) ucrtbase.cos
196 @ cdecl -arch=arm,x86_64,arm64 cosf(float) ucrtbase.cosf
197 @ cdecl cosh(double) ucrtbase.cosh
198 @ cdecl -arch=arm,x86_64,arm64 coshf(float) ucrtbase.coshf
199 @ stub cpow
200 @ stub cpowf
201 @ stub cpowl
202 @ stub cproj
203 @ stub cprojf
204 @ stub cprojl
205 @ stub creal
206 @ stub crealf
207 @ stub creall
208 @ stub csin
209 @ stub csinf
210 @ stub csinh
211 @ stub csinhf
212 @ stub csinhl
213 @ stub csinl
214 @ stub csqrt
215 @ stub csqrtf
216 @ stub csqrtl
217 @ stub ctan
218 @ stub ctanf
219 @ stub ctanh
220 @ stub ctanhf
221 @ stub ctanhl
222 @ stub ctanl
223 @ cdecl erf(double) ucrtbase.erf
224 @ cdecl erfc(double) ucrtbase.erfc
225 @ cdecl erfcf(float) ucrtbase.erfcf
226 @ cdecl erfcl(double) ucrtbase.erfcl
227 @ cdecl erff(float) ucrtbase.erff
228 @ cdecl erfl(double) ucrtbase.erfl
229 @ cdecl exp(double) ucrtbase.exp
230 @ cdecl exp2(double) ucrtbase.exp2
231 @ cdecl exp2f(float) ucrtbase.exp2f
232 @ cdecl exp2l(double) ucrtbase.exp2l
233 @ cdecl -arch=arm,x86_64,arm64 expf(float) ucrtbase.expf
234 @ cdecl expm1(double) ucrtbase.expm1
235 @ cdecl expm1f(float) ucrtbase.expm1f
236 @ cdecl expm1l(double) ucrtbase.expm1l
237 @ cdecl fabs(double) ucrtbase.fabs
238 @ cdecl -arch=arm,arm64 fabsf(float) ucrtbase.fabsf
239 @ stub fdim
240 @ stub fdimf
241 @ stub fdiml
242 @ cdecl floor(double) ucrtbase.floor
243 @ cdecl -arch=arm,x86_64,arm64 floorf(float) ucrtbase.floorf
244 @ stub fma
245 @ stub fmaf
246 @ stub fmal
247 @ cdecl fmax(double double) ucrtbase.fmax
248 @ cdecl fmaxf(float float) ucrtbase.fmaxf
249 @ cdecl fmaxl(double double) ucrtbase.fmaxl
250 @ cdecl fmin(double double) ucrtbase.fmin
251 @ cdecl fminf(float float) ucrtbase.fminf
252 @ cdecl fminl(double double) ucrtbase.fminl
253 @ cdecl fmod(double double) ucrtbase.fmod
254 @ cdecl -arch=arm,x86_64,arm64 fmodf(float float) ucrtbase.fmodf
255 @ cdecl frexp(double ptr) ucrtbase.frexp
256 @ cdecl hypot(double double) ucrtbase.hypot
257 @ stub ilogb
258 @ stub ilogbf
259 @ stub ilogbl
260 @ cdecl ldexp(double long) ucrtbase.ldexp
261 @ cdecl lgamma(double) ucrtbase.lgamma
262 @ cdecl lgammaf(float) ucrtbase.lgammaf
263 @ cdecl lgammal(double) ucrtbase.lgammal
264 @ cdecl -ret64 llrint(double) ucrtbase.llrint
265 @ cdecl -ret64 llrintf(float) ucrtbase.llrintf
266 @ cdecl -ret64 llrintl(double) ucrtbase.llrintl
267 @ cdecl -ret64 llround(double) ucrtbase.llround
268 @ cdecl -ret64 llroundf(float) ucrtbase.llroundf
269 @ cdecl -ret64 llroundl(double) ucrtbase.llroundl
270 @ cdecl log(double) ucrtbase.log
271 @ cdecl log10(double) ucrtbase.log10
272 @ cdecl -arch=arm,x86_64,arm64 log10f(float) ucrtbase.log10f
273 @ cdecl log1p(double) ucrtbase.log1p
274 @ cdecl log1pf(float) ucrtbase.log1pf
275 @ cdecl log1pl(double) ucrtbase.log1pl
276 @ cdecl log2(double) ucrtbase.log2
277 @ cdecl log2f(float) ucrtbase.log2f
278 @ cdecl log2l(double) ucrtbase.log2l
279 @ stub logb
280 @ stub logbf
281 @ stub logbl
282 @ cdecl -arch=arm,x86_64,arm64 logf(float) ucrtbase.logf
283 @ cdecl lrint(double) ucrtbase.lrint
284 @ cdecl lrintf(float) ucrtbase.lrintf
285 @ cdecl lrintl(double) ucrtbase.lrintl
286 @ cdecl lround(double) ucrtbase.lround
287 @ cdecl lroundf(float) ucrtbase.lroundf
288 @ cdecl lroundl(double) ucrtbase.lroundl
289 @ cdecl modf(double ptr) ucrtbase.modf
290 @ cdecl -arch=arm,x86_64,arm64 modff(float ptr) ucrtbase.modff
291 @ cdecl nan(str) ucrtbase.nan
292 @ cdecl nanf(str) ucrtbase.nanf
293 @ cdecl nanl(str) ucrtbase.nanl
294 @ cdecl nearbyint(double) ucrtbase.nearbyint
295 @ cdecl nearbyintf(float) ucrtbase.nearbyintf
296 @ cdecl nearbyintl(double) ucrtbase.nearbyintl
297 @ cdecl nextafter(double double) ucrtbase.nextafter
298 @ cdecl nextafterf(float float) ucrtbase.nextafterf
299 @ cdecl nextafterl(double double) ucrtbase.nextafterl
300 @ stub nexttoward
301 @ stub nexttowardf
302 @ stub nexttowardl
303 @ stub norm
304 @ stub normf
305 @ stub norml
306 @ cdecl pow(double double) ucrtbase.pow
307 @ cdecl -arch=arm,x86_64,arm64 powf(float float) ucrtbase.powf
308 @ cdecl remainder(double double) ucrtbase.remainder
309 @ cdecl remainderf(float float) ucrtbase.remainderf
310 @ cdecl remainderl(double double) ucrtbase.remainderl
311 @ stub remquo
312 @ stub remquof
313 @ stub remquol
314 @ cdecl rint(double) ucrtbase.rint
315 @ cdecl rintf(float) ucrtbase.rintf
316 @ cdecl rintl(double) ucrtbase.rintl
317 @ cdecl round(double) ucrtbase.round
318 @ cdecl roundf(float) ucrtbase.roundf
319 @ cdecl roundl(double) ucrtbase.roundl
320 @ cdecl scalbln(double long) ucrtbase.scalbln
321 @ cdecl scalblnf(float long) ucrtbase.scalblnf
322 @ cdecl scalblnl(double long) ucrtbase.scalblnl
323 @ cdecl scalbn(double long) ucrtbase.scalbn
324 @ cdecl scalbnf(float long) ucrtbase.scalbnf
325 @ cdecl scalbnl(double long) ucrtbase.scalbnl
326 @ cdecl sin(double) ucrtbase.sin
327 @ cdecl -arch=arm,x86_64,arm64 sinf(float) ucrtbase.sinf
328 @ cdecl sinh(double) ucrtbase.sinh
329 @ cdecl -arch=arm,x86_64,arm64 sinhf(float) ucrtbase.sinhf
330 @ cdecl sqrt(double) ucrtbase.sqrt
331 @ cdecl -arch=arm,x86_64,arm64 sqrtf(float) ucrtbase.sqrtf
332 @ cdecl tan(double) ucrtbase.tan
333 @ cdecl -arch=arm,x86_64,arm64 tanf(float) ucrtbase.tanf
334 @ cdecl tanh(double) ucrtbase.tanh
335 @ cdecl -arch=arm,x86_64,arm64 tanhf(float) ucrtbase.tanhf
336 @ stub tgamma
337 @ stub tgammaf
338 @ stub tgammal
339 @ cdecl trunc(double) ucrtbase.trunc
340 @ cdecl truncf(float) ucrtbase.truncf
341 @ cdecl truncl(double) ucrtbase.truncl