shcore: Implement semi-stub for GetDpiForMonitor.
[wine.git] / dlls / shcore / shcore.spec
blob958c91f88de846fda9afb06effe19498df32c8f2
1 1 stub @
2 @ stdcall CommandLineToArgvW(wstr ptr) shell32.CommandLineToArgvW
3 @ stub CreateRandomAccessStreamOnFile
4 @ stub CreateRandomAccessStreamOverStream
5 @ stub CreateStreamOverRandomAccessStream
6 @ stdcall -private DllCanUnloadNow() shell32.DllCanUnloadNow
7 @ stub DllGetActivationFactory
8 @ stdcall -private DllGetClassObject(ptr ptr ptr) shell32.DllGetClassObject
9 @ stdcall GetCurrentProcessExplicitAppUserModelID(ptr) shell32.GetCurrentProcessExplicitAppUserModelID
10 @ stdcall GetDpiForMonitor(long long ptr ptr)
11 @ stub GetDpiForShellUIComponent
12 @ stdcall GetProcessDpiAwareness(long ptr)
13 @ stub GetProcessReference
14 @ stub GetScaleFactorForDevice
15 @ stub GetScaleFactorForMonitor
16 @ stub IStream_Copy
17 @ stdcall IStream_Read(ptr ptr long) shlwapi.IStream_Read
18 @ stub IStream_ReadStr
19 @ stdcall IStream_Reset(ptr) shlwapi.IStream_Reset
20 @ stdcall IStream_Size(ptr ptr) shlwapi.IStream_Size
21 @ stdcall IStream_Write(ptr ptr long) shlwapi.IStream_Write
22 @ stub IStream_WriteStr
23 @ stdcall IUnknown_AtomicRelease(long) shlwapi.IUnknown_AtomicRelease
24 @ stdcall IUnknown_GetSite(ptr ptr ptr) shlwapi.IUnknown_GetSite
25 @ stdcall IUnknown_QueryService(ptr ptr ptr ptr) shlwapi.IUnknown_QueryService
26 @ stdcall IUnknown_Set(ptr ptr) shlwapi.IUnknown_Set
27 @ stdcall IUnknown_SetSite(ptr ptr) shlwapi.IUnknown_SetSite
28 @ stdcall IsOS(long) shlwapi.IsOS
29 @ stub RegisterScaleChangeEvent
30 @ stub RegisterScaleChangeNotifications
31 @ stub RevokeScaleChangeNotifications
32 @ stdcall SHAnsiToAnsi(str ptr long) shlwapi.SHAnsiToAnsi
33 @ stdcall SHAnsiToUnicode(str ptr long) shlwapi.SHAnsiToUnicode
34 @ stdcall SHCopyKeyA(long str long long) shlwapi.SHCopyKeyA
35 @ stdcall SHCopyKeyW(long wstr long long) shlwapi.SHCopyKeyW
36 @ stdcall SHCreateMemStream(ptr long) shlwapi.SHCreateMemStream
37 @ stdcall SHCreateStreamOnFileA(str long ptr) shlwapi.SHCreateStreamOnFileA
38 @ stdcall SHCreateStreamOnFileEx(wstr long long long ptr ptr) shlwapi.SHCreateStreamOnFileEx
39 @ stdcall SHCreateStreamOnFileW(wstr long ptr) shlwapi.SHCreateStreamOnFileW
40 @ stdcall SHCreateThread(ptr ptr long ptr) shlwapi.SHCreateThread
41 @ stdcall SHCreateThreadRef(ptr ptr) shlwapi.SHCreateThreadRef
42 @ stub SHCreateThreadWithHandle
43 @ stdcall SHDeleteEmptyKeyA(long ptr) shlwapi.SHDeleteEmptyKeyA
44 @ stdcall SHDeleteEmptyKeyW(long ptr) shlwapi.SHDeleteEmptyKeyW
45 @ stdcall SHDeleteKeyA(long str) shlwapi.SHDeleteKeyA
46 @ stdcall SHDeleteKeyW(long wstr) shlwapi.SHDeleteKeyW
47 @ stdcall SHDeleteValueA(long str str) shlwapi.SHDeleteValueA
48 @ stdcall SHDeleteValueW(long wstr wstr) shlwapi.SHDeleteValueW
49 @ stdcall SHEnumKeyExA(long long str ptr) shlwapi.SHEnumKeyExA
50 @ stdcall SHEnumKeyExW(long long wstr ptr) shlwapi.SHEnumKeyExW
51 @ stdcall SHEnumValueA(long long str ptr ptr ptr ptr) shlwapi.SHEnumValueA
52 @ stdcall SHEnumValueW(long long wstr ptr ptr ptr ptr) shlwapi.SHEnumValueW
53 @ stdcall SHGetThreadRef(ptr) shlwapi.SHGetThreadRef
54 @ stdcall SHGetValueA( long str str ptr ptr ptr ) shlwapi.SHGetValueA
55 @ stdcall SHGetValueW( long wstr wstr ptr ptr ptr ) shlwapi.SHGetValueW
56 @ stdcall SHOpenRegStream2A(long str str long) shlwapi.SHOpenRegStream2A
57 @ stdcall SHOpenRegStream2W(long wstr wstr long) shlwapi.SHOpenRegStream2W
58 @ stdcall SHOpenRegStreamA(long str str long) shlwapi.SHOpenRegStreamA
59 @ stdcall SHOpenRegStreamW(long wstr wstr long) shlwapi.SHOpenRegStreamW
60 @ stdcall SHQueryInfoKeyA(long ptr ptr ptr ptr) shlwapi.SHQueryInfoKeyA
61 @ stdcall SHQueryInfoKeyW(long ptr ptr ptr ptr) shlwapi.SHQueryInfoKeyW
62 @ stdcall SHQueryValueExA(long str ptr ptr ptr ptr) shlwapi.SHQueryValueExA
63 @ stdcall SHQueryValueExW(long wstr ptr ptr ptr ptr) shlwapi.SHQueryValueExW
64 @ stdcall SHRegDuplicateHKey(long) shlwapi.SHRegDuplicateHKey
65 @ stdcall SHRegGetIntW(ptr wstr long) shlwapi.SHRegGetIntW
66 @ stdcall SHRegGetPathA(long str str ptr long) shlwapi.SHRegGetPathA
67 @ stdcall SHRegGetPathW(long wstr wstr ptr long) shlwapi.SHRegGetPathW
68 @ stdcall SHRegGetValueA( long str str long ptr ptr ptr ) shlwapi.SHRegGetValueA
69 @ stdcall SHRegGetValueW( long wstr wstr long ptr ptr ptr ) shlwapi.SHRegGetValueW
70 @ stdcall SHRegSetPathA(long str str str long) shlwapi.SHRegSetPathA
71 @ stdcall SHRegSetPathW(long wstr wstr wstr long) shlwapi.SHRegSetPathW
72 @ stdcall SHReleaseThreadRef() shlwapi.SHReleaseThreadRef
73 @ stdcall SHSetThreadRef(ptr) shlwapi.SHSetThreadRef
74 @ stdcall SHSetValueA(long str str long ptr long) shlwapi.SHSetValueA
75 @ stdcall SHSetValueW(long wstr wstr long ptr long) shlwapi.SHSetValueW
76 @ stdcall SHStrDupA(str ptr) shlwapi.SHStrDupA
77 @ stdcall SHStrDupW(wstr ptr) shlwapi.SHStrDupW
78 @ stdcall SHUnicodeToAnsi(wstr ptr ptr) shlwapi.SHUnicodeToAnsi
79 @ stdcall SHUnicodeToUnicode(wstr ptr long) shlwapi.SHUnicodeToUnicode
80 @ stdcall SetCurrentProcessExplicitAppUserModelID(wstr) shell32.SetCurrentProcessExplicitAppUserModelID
81 @ stub SetProcessDpiAwareness
82 @ stub SetProcessReference
83 @ stub UnregisterScaleChangeEvent
85 100 stub @
86 101 stub @
87 102 stub @
88 103 stub @
89 104 stub @
90 105 stub @
91 106 stub @
92 107 stub @
93 108 stub @
94 109 stub @
95 110 stub @
96 111 stub @
97 115 stub @
98 116 stub @
99 117 stub @
100 120 stub @
101 121 stub @
102 122 stub SHRegGetValueFromHKCUHKLM
103 123 stub @
104 124 stub @
105 125 stub @
106 126 stub @
107 127 stub @
108 130 stub @
109 131 stub @
110 132 stub @
111 133 stub @
112 140 stub @
113 141 stub @
114 142 stub @
115 143 stub @
116 144 stub @
117 145 stub @
118 150 stub @
119 151 stub @
120 152 stub @
121 153 stub @
122 160 stub @
123 161 stub @
124 162 stub @
125 170 stub @
126 171 stub @
127 172 stub @
128 173 stub @
129 181 stub @
130 182 stub @
131 183 stub @
132 184 stub @
133 185 stub @
134 186 stub @
135 187 stub @
136 188 stub @
137 190 stub @
138 191 stub @
139 192 stub @
140 193 stub @
141 200 stub @
142 220 stub @
143 221 stub @
144 222 stub @
145 223 stub @
146 224 stub @
147 225 stub @
148 226 stub @
149 227 stub @
150 228 stub @
151 230 stub @
152 231 stub @
153 232 stub @
154 233 stub @
155 234 stub @
156 240 stub @
157 241 stub @
158 242 stub @
159 243 stub @
160 244 stub @
161 245 stub @
162 246 stub @
163 247 stub @
164 248 stub @
165 250 stub @
166 251 stub @
167 252 stub @
168 253 stub @
169 254 stub @
170 255 stub @
171 260 stub @
172 261 stub @
173 270 stub @
174 280 stub @
175 281 stub @
176 282 stub @
177 283 stub @
178 284 stub @
179 290 stub @
180 291 stub @
181 292 stub @