Release 950522
[wine.git] / if1632 / shell.spec
blobb00a5c4ac5dd6ac94572b59d538c71d0296da5d2
1 name shell
2 id 5
5 # WARNING ! These functions are not documented, so I didn't look for
6 # proper parameters. It's just to have stub for PROGMAN.EXE ...
9 1 pascal RegOpenKey(word ptr ptr) RegOpenKey
10 2 pascal RegCreateKey(word ptr ptr) RegCreateKey
11 3 pascal RegCloseKey(word) RegCloseKey
12 4 pascal RegDeleteKey(word ptr) RegDeleteKey
13 5 pascal RegSetValue(word ptr long ptr long) RegSetValue
14 6 pascal RegQueryValue(word ptr ptr ptr) RegQueryValue
15 7 pascal RegEnumKey(word long ptr long) RegEnumKey
16 9 pascal DragAcceptFiles(word word) DragAcceptFiles
17 11 pascal DragQueryFile(word s_word ptr s_word) DragQueryFile
18 12 pascal DragFinish(word) DragFinish
19 13 pascal DragQueryPoint(word ptr) DragQueryPoint
20 20 pascal ShellExecute(word ptr ptr ptr ptr s_word) ShellExecute
21 21 pascal FindExecutable(ptr ptr ptr) FindExecutable
22 22 pascal ShellAbout(word ptr ptr word) ShellAbout
23 33 pascal AboutDlgProc(word word word long) AboutDlgProc
24 34 pascal ExtractIcon(word ptr s_word) ExtractIcon
25 36 pascal ExtractAssociatedIcon(word ptr ptr) ExtractAssociatedIcon
26 37 pascal DoEnvironmentSubst(ptr word word) DoEnvironmentSubst
27 39 stub InternalExtractIcon
28 102 pascal RegisterShellHook(ptr) RegisterShellHook
29 103 pascal ShellHookProc() ShellHookProc
31 # 8 7 0000 WEP exported, shared data
32 #100 4 0550 HERETHARBETYGARS exported, shared data
33 # 38 5 0000 FINDENVIRONMENTSTRING exported, shared data
34 # 37 5 00ae DOENVIRONMENTSUBST exported, shared data
35 # 20 4 110a SHELLEXECUTE exported, shared data
36 #101 8 010e FINDEXEDLGPROC exported, shared data
37 # 39 10 026e INTERNALEXTRACTICON exported, shared data
38 # 32 9 0829 WCI exported, shared data
39 # 36 10 08dc EXTRACTASSOCIATEDICON exported, shared data