msvcrt: Remove MSVCRT_ prefix from string.c functions.
[wine.git] / dlls / crtdll / crtdll.spec
blob5a4d4707b88fbdd728de6247039bcd6913b5a088
1 # Old C runtime library. All functions provided by msvcrt
3 @ cdecl -arch=win32 ??2@YAPAXI@Z(long) operator_new
4 @ cdecl -arch=win64 ??2@YAPEAX_K@Z(long) operator_new
5 @ cdecl -arch=win32 ??3@YAXPAX@Z(ptr) operator_delete
6 @ cdecl -arch=win64 ??3@YAXPEAX@Z(ptr) operator_delete
7 @ cdecl -arch=win32 ?_set_new_handler@@YAP6AHI@ZP6AHI@Z@Z(ptr) _set_new_handler
8 @ cdecl -arch=win64 ?_set_new_handler@@YAP6AH_K@ZP6AH0@Z@Z(ptr) _set_new_handler
9 @ cdecl -arch=i386 _CIacos()
10 @ cdecl -arch=i386 _CIasin()
11 @ cdecl -arch=i386 _CIatan()
12 @ cdecl -arch=i386 _CIatan2()
13 @ cdecl -arch=i386 _CIcos()
14 @ cdecl -arch=i386 _CIcosh()
15 @ cdecl -arch=i386 _CIexp()
16 @ cdecl -arch=i386 _CIfmod()
17 @ cdecl -arch=i386 _CIlog()
18 @ cdecl -arch=i386 _CIlog10()
19 @ cdecl -arch=i386 _CIpow()
20 @ cdecl -arch=i386 _CIsin()
21 @ cdecl -arch=i386 _CIsinh()
22 @ cdecl -arch=i386 _CIsqrt()
23 @ cdecl -arch=i386 _CItan()
24 @ cdecl -arch=i386 _CItanh()
25 @ extern _HUGE_dll MSVCRT__HUGE
26 @ cdecl _XcptFilter(long ptr)
27 @ cdecl __GetMainArgs(ptr ptr ptr long)
28 @ extern __argc_dll MSVCRT___argc
29 @ extern __argv_dll MSVCRT___argv
30 @ cdecl __dllonexit(ptr ptr ptr)
31 @ cdecl __doserrno()
32 @ cdecl __fpecode()
33 @ cdecl __isascii(long)
34 @ cdecl __iscsym(long)
35 @ cdecl __iscsymf(long)
36 @ extern __mb_cur_max_dll MSVCRT___mb_cur_max
37 @ cdecl __pxcptinfoptrs()
38 @ cdecl __threadhandle() kernel32.GetCurrentThread
39 @ cdecl __threadid() kernel32.GetCurrentThreadId
40 @ cdecl __toascii(long)
41 @ cdecl _abnormal_termination()
42 @ cdecl _access(str long) MSVCRT__access
43 @ extern _acmdln_dll MSVCRT__acmdln
44 @ extern _aexit_rtn_dll _aexit_rtn
45 @ cdecl _amsg_exit(long)
46 @ cdecl _assert(str str long)
47 @ extern _basemajor_dll CRTDLL__basemajor_dll
48 @ extern _baseminor_dll CRTDLL__baseminor_dll
49 @ extern _baseversion_dll MSVCRT__osver
50 @ cdecl _beep(long long)
51 @ cdecl _beginthread(ptr long ptr)
52 @ cdecl _c_exit()
53 @ cdecl _cabs(long) MSVCRT__cabs
54 @ cdecl _cexit()
55 @ cdecl _cgets(ptr)
56 @ cdecl _chdir(str) MSVCRT__chdir
57 @ cdecl _chdrive(long) MSVCRT__chdrive
58 @ cdecl _chgsign(double) MSVCRT__chgsign
59 @ cdecl _chmod(str long) MSVCRT__chmod
60 @ cdecl _chsize(long long) MSVCRT__chsize
61 @ cdecl _clearfp()
62 @ cdecl _close(long) MSVCRT__close
63 @ cdecl _commit(long) MSVCRT__commit
64 @ extern _commode_dll MSVCRT__commode
65 @ cdecl _control87(long long)
66 @ cdecl _controlfp(long long)
67 @ cdecl _copysign(double double) MSVCRT__copysign
68 @ varargs _cprintf(str)
69 @ extern _cpumode_dll CRTDLL__cpumode_dll
70 @ cdecl _cputs(str)
71 @ cdecl _creat(str long) MSVCRT__creat
72 @ varargs _cscanf(str)
73 @ extern _ctype MSVCRT__ctype
74 @ cdecl _cwait(ptr long long)
75 @ extern _daylight_dll MSVCRT___daylight
76 @ cdecl _dup(long) MSVCRT__dup
77 @ cdecl _dup2(long long) MSVCRT__dup2
78 @ cdecl _ecvt(double long ptr ptr) MSVCRT__ecvt
79 @ cdecl _endthread()
80 @ extern _environ_dll MSVCRT__environ
81 @ cdecl _eof(long) MSVCRT__eof
82 @ cdecl _errno()
83 @ cdecl -arch=i386 _except_handler2(ptr ptr ptr ptr)
84 @ varargs _execl(str str)
85 @ varargs _execle(str str)
86 @ varargs _execlp(str str)
87 @ varargs _execlpe(str str)
88 @ cdecl _execv(str ptr)
89 @ cdecl _execve(str ptr ptr)
90 @ cdecl _execvp(str ptr)
91 @ cdecl _execvpe(str ptr ptr)
92 @ cdecl _exit(long)
93 @ cdecl _expand(ptr long)
94 @ cdecl _fcloseall() MSVCRT__fcloseall
95 @ cdecl _fcvt(double long ptr ptr) MSVCRT__fcvt
96 @ cdecl _fdopen(long str) MSVCRT__fdopen
97 @ cdecl _fgetchar() MSVCRT__fgetchar
98 @ cdecl _fgetwchar() MSVCRT__fgetwchar
99 @ cdecl _filbuf(ptr) MSVCRT__filbuf
100 # extern _fileinfo_dll
101 @ cdecl _filelength(long) MSVCRT__filelength
102 @ cdecl _fileno(ptr) MSVCRT__fileno
103 @ cdecl _findclose(long) MSVCRT__findclose
104 @ cdecl _findfirst(str ptr) MSVCRT__findfirst
105 @ cdecl _findnext(long ptr) MSVCRT__findnext
106 @ cdecl _finite(double) MSVCRT__finite
107 @ cdecl _flsbuf(long ptr) MSVCRT__flsbuf
108 @ cdecl _flushall() MSVCRT__flushall
109 @ extern _fmode_dll MSVCRT__fmode
110 @ cdecl _fpclass(double) MSVCRT__fpclass
111 @ cdecl -arch=i386,x86_64,arm,arm64 _fpieee_flt(long ptr ptr)
112 @ cdecl _fpreset()
113 @ cdecl _fputchar(long) MSVCRT__fputchar
114 @ cdecl _fputwchar(long) MSVCRT__fputwchar
115 @ cdecl _fsopen(str str long) MSVCRT__fsopen
116 @ cdecl _fstat(long ptr) MSVCRT__fstat
117 @ cdecl _ftime(ptr) MSVCRT__ftime
118 @ cdecl -arch=i386 -ret64 _ftol() MSVCRT__ftol
119 @ cdecl _fullpath(ptr str long) MSVCRT__fullpath
120 @ cdecl -arch=win32 _futime(long ptr) _futime32
121 @ cdecl -arch=win64 _futime(long ptr) _futime64
122 @ cdecl _gcvt(double long str) MSVCRT__gcvt
123 @ cdecl _get_osfhandle(long) MSVCRT__get_osfhandle
124 @ cdecl _getch()
125 @ cdecl _getche()
126 @ cdecl _getcwd(str long) MSVCRT__getcwd
127 @ cdecl _getdcwd(long str long) MSVCRT__getdcwd
128 @ cdecl _getdiskfree(long ptr) MSVCRT__getdiskfree
129 @ cdecl _getdllprocaddr(long str long)
130 @ cdecl _getdrive() MSVCRT__getdrive
131 @ cdecl _getdrives() kernel32.GetLogicalDrives
132 @ cdecl _getpid()
133 @ stub _getsystime(ptr)
134 @ cdecl _getw(ptr) MSVCRT__getw
135 @ cdecl -arch=i386 _global_unwind2(ptr)
136 @ cdecl _heapchk()
137 @ cdecl _heapmin()
138 @ cdecl _heapset(long)
139 @ cdecl _heapwalk(ptr)
140 @ cdecl _hypot(double double)
141 @ cdecl _initterm(ptr ptr)
142 @ extern _iob MSVCRT__iob
143 @ cdecl _isatty(long) MSVCRT__isatty
144 @ cdecl _isctype(long long)
145 @ stub _ismbbalnum(long)
146 @ stub _ismbbalpha(long)
147 @ stub _ismbbgraph(long)
148 @ stub _ismbbkalnum(long)
149 @ cdecl _ismbbkana(long)
150 @ stub _ismbbkpunct(long)
151 @ cdecl _ismbblead(long)
152 @ stub _ismbbprint(long)
153 @ stub _ismbbpunct(long)
154 @ cdecl _ismbbtrail(long)
155 @ cdecl _ismbcalpha(long)
156 @ cdecl _ismbcdigit(long)
157 @ cdecl _ismbchira(long)
158 @ cdecl _ismbckata(long)
159 @ cdecl _ismbcl0(long)
160 @ cdecl _ismbcl1(long)
161 @ cdecl _ismbcl2(long)
162 @ cdecl _ismbclegal(long)
163 @ cdecl _ismbclower(long)
164 @ cdecl _ismbcprint(long)
165 @ cdecl _ismbcspace(long)
166 @ cdecl _ismbcsymbol(long)
167 @ cdecl _ismbcupper(long)
168 @ cdecl _ismbslead(ptr ptr)
169 @ cdecl _ismbstrail(ptr ptr)
170 @ cdecl _isnan(double) MSVCRT__isnan
171 @ cdecl _itoa(long ptr long)
172 @ cdecl _itow(long ptr long) ntdll._itow
173 @ cdecl _j0(double) MSVCRT__j0
174 @ cdecl _j1(double) MSVCRT__j1
175 @ cdecl _jn(long double) MSVCRT__jn
176 @ cdecl _kbhit()
177 @ cdecl _lfind(ptr ptr ptr long ptr)
178 @ cdecl _loaddll(str)
179 @ cdecl -arch=i386 _local_unwind2(ptr long)
180 @ cdecl _locking(long long long) MSVCRT__locking
181 @ cdecl _logb(double) MSVCRT__logb
182 @ cdecl _lrotl(long long) MSVCRT__lrotl
183 @ cdecl _lrotr(long long) MSVCRT__lrotr
184 @ cdecl _lsearch(ptr ptr ptr long ptr)
185 @ cdecl _lseek(long long long) MSVCRT__lseek
186 @ cdecl _ltoa(long ptr long) ntdll._ltoa
187 @ cdecl _ltow(long ptr long) ntdll._ltow
188 @ cdecl _makepath(ptr str str str str) MSVCRT__makepath
189 @ cdecl _matherr(ptr) MSVCRT__matherr
190 @ cdecl _mbbtombc(long)
191 @ cdecl _mbbtype(long long)
192 @ cdecl _mbccpy(ptr ptr)
193 @ cdecl _mbcjistojms(long)
194 @ cdecl _mbcjmstojis(long)
195 @ cdecl _mbclen(ptr)
196 @ cdecl _mbctohira(long)
197 @ cdecl _mbctokata(long)
198 @ cdecl _mbctolower(long)
199 @ cdecl _mbctombb(long)
200 @ cdecl _mbctoupper(long)
201 @ extern _mbctype MSVCRT_mbctype
202 @ cdecl _mbsbtype(str long)
203 @ cdecl _mbscat(str str)
204 @ cdecl _mbschr(str long)
205 @ cdecl _mbscmp(str str)
206 @ cdecl _mbscpy(ptr str)
207 @ cdecl _mbscspn(str str)
208 @ cdecl _mbsdec(ptr ptr)
209 @ cdecl _mbsdup(str) _strdup
210 @ cdecl _mbsicmp(str str)
211 @ cdecl _mbsinc(str)
212 @ cdecl _mbslen(str)
213 @ cdecl _mbslwr(str)
214 @ cdecl _mbsnbcat(str str long)
215 @ cdecl _mbsnbcmp(str str long)
216 @ cdecl _mbsnbcnt(ptr long)
217 @ cdecl _mbsnbcpy(ptr str long)
218 @ cdecl _mbsnbicmp(str str long)
219 @ cdecl _mbsnbset(ptr long long)
220 @ cdecl _mbsncat(str str long)
221 @ cdecl _mbsnccnt(str long)
222 @ cdecl _mbsncmp(str str long)
223 @ cdecl _mbsncpy(ptr str long)
224 @ cdecl _mbsnextc(str)
225 @ cdecl _mbsnicmp(str str long)
226 @ cdecl _mbsninc(str long)
227 @ cdecl _mbsnset(ptr long long)
228 @ cdecl _mbspbrk(str str)
229 @ cdecl _mbsrchr(str long)
230 @ cdecl _mbsrev(str)
231 @ cdecl _mbsset(ptr long)
232 @ cdecl _mbsspn(str str)
233 @ cdecl _mbsspnp(str str)
234 @ cdecl _mbsstr(str str)
235 @ cdecl _mbstok(str str)
236 @ cdecl _mbstrlen(str)
237 @ cdecl _mbsupr(str)
238 @ cdecl _memccpy(ptr ptr long long) ntdll._memccpy
239 @ cdecl _memicmp(str str long)
240 @ cdecl _mkdir(str) MSVCRT__mkdir
241 @ cdecl _mktemp(str) MSVCRT__mktemp
242 @ cdecl _msize(ptr)
243 @ cdecl _nextafter(double double) MSVCRT__nextafter
244 @ cdecl _onexit(ptr)
245 @ varargs _open(str long) MSVCRT__open
246 @ cdecl _open_osfhandle(long long) MSVCRT__open_osfhandle
247 @ extern _osmajor_dll MSVCRT__winmajor
248 @ extern _osminor_dll MSVCRT__winminor
249 @ extern _osmode_dll CRTDLL__osmode_dll
250 @ extern _osver_dll MSVCRT__osver
251 @ extern _osversion_dll MSVCRT__winver
252 @ cdecl _pclose(ptr)
253 @ extern _pctype_dll MSVCRT__pctype
254 @ extern _pgmptr_dll MSVCRT__pgmptr
255 @ cdecl _pipe(ptr long long) MSVCRT__pipe
256 @ cdecl _popen(str str)
257 @ cdecl _purecall()
258 @ cdecl _putch(long)
259 @ cdecl _putenv(str)
260 @ cdecl _putw(long ptr) MSVCRT__putw
261 # extern _pwctype_dll
262 @ cdecl _read(long ptr long) MSVCRT__read
263 @ cdecl _rmdir(str) MSVCRT__rmdir
264 @ cdecl _rmtmp() MSVCRT__rmtmp
265 @ cdecl _rotl(long long)
266 @ cdecl _rotr(long long)
267 @ cdecl _scalb(double long) MSVCRT__scalb
268 @ cdecl _searchenv(str str ptr) MSVCRT__searchenv
269 @ cdecl _seterrormode(long)
270 @ cdecl -arch=i386,x86_64,arm,arm64 -norelay _setjmp(ptr) MSVCRT__setjmp
271 @ cdecl _setmode(long long) MSVCRT__setmode
272 @ stub _setsystime(ptr long)
273 @ cdecl _sleep(long)
274 @ varargs _snprintf(ptr long str) MSVCRT__snprintf
275 @ varargs _snwprintf(ptr long wstr) MSVCRT__snwprintf
276 @ varargs _sopen(str long long) MSVCRT__sopen
277 @ varargs _spawnl(long str str)
278 @ varargs _spawnle(long str str)
279 @ varargs _spawnlp(long str str)
280 @ varargs _spawnlpe(long str str)
281 @ cdecl _spawnv(long str ptr)
282 @ cdecl _spawnve(long str ptr ptr)
283 @ cdecl _spawnvp(long str ptr)
284 @ cdecl _spawnvpe(long str ptr ptr)
285 @ cdecl _splitpath(str ptr ptr ptr ptr) MSVCRT__splitpath
286 @ cdecl _stat(str ptr) MSVCRT_stat
287 @ cdecl _statusfp()
288 @ cdecl _strcmpi(str str) _stricmp
289 @ cdecl _strdate(ptr) MSVCRT__strdate
290 @ cdecl _strdec(str str)
291 @ cdecl _strdup(str)
292 @ cdecl _strerror(long)
293 @ cdecl _stricmp(str str)
294 @ cdecl _stricoll(str str)
295 @ cdecl _strinc(str)
296 @ cdecl _strlwr(str)
297 @ cdecl _strncnt(str long) __strncnt
298 @ cdecl _strnextc(str)
299 @ cdecl _strnicmp(str str long)
300 @ cdecl _strninc(str long)
301 @ cdecl _strnset(str long long)
302 @ cdecl _strrev(str)
303 @ cdecl _strset(str long)
304 @ cdecl _strspnp(str str)
305 @ cdecl _strtime(ptr) MSVCRT__strtime
306 @ cdecl _strupr(str)
307 @ cdecl _swab(str str long)
308 @ extern _sys_errlist MSVCRT__sys_errlist
309 @ extern _sys_nerr_dll MSVCRT__sys_nerr
310 @ cdecl _tell(long) MSVCRT__tell
311 @ cdecl _tempnam(str str) MSVCRT__tempnam
312 @ extern _timezone_dll MSVCRT___timezone
313 @ cdecl _tolower(long)
314 @ cdecl _toupper(long)
315 @ extern _tzname MSVCRT__tzname
316 @ cdecl _tzset() MSVCRT__tzset
317 @ cdecl _ultoa(long ptr long) ntdll._ultoa
318 @ cdecl _umask(long) MSVCRT__umask
319 @ cdecl _ungetch(long)
320 @ cdecl _unlink(str) MSVCRT__unlink
321 @ cdecl _unloaddll(long)
322 @ cdecl -arch=win32 _utime(str ptr) _utime32
323 @ cdecl -arch=win64 _utime(str ptr) _utime64
324 @ cdecl _vsnprintf(ptr long str ptr)
325 @ cdecl _vsnwprintf(ptr long wstr ptr) MSVCRT_vsnwprintf
326 @ cdecl _wcsdup(wstr) MSVCRT__wcsdup
327 @ cdecl _wcsicmp(wstr wstr) MSVCRT__wcsicmp
328 @ cdecl _wcsicoll(wstr wstr) MSVCRT__wcsicoll
329 @ cdecl _wcslwr(wstr) MSVCRT__wcslwr
330 @ cdecl _wcsnicmp(wstr wstr long) MSVCRT__wcsnicmp
331 @ cdecl _wcsnset(wstr long long) MSVCRT__wcsnset
332 @ cdecl _wcsrev(wstr) MSVCRT__wcsrev
333 @ cdecl _wcsset(wstr long) MSVCRT__wcsset
334 @ cdecl _wcsupr(wstr) MSVCRT__wcsupr
335 @ extern _winmajor_dll MSVCRT__winmajor
336 @ extern _winminor_dll MSVCRT__winminor
337 @ extern _winver_dll MSVCRT__winver
338 @ cdecl _write(long ptr long) MSVCRT__write
339 @ cdecl _wtoi(wstr) MSVCRT__wtoi
340 @ cdecl _wtol(wstr) MSVCRT__wtol
341 @ cdecl _y0(double) MSVCRT__y0
342 @ cdecl _y1(double) MSVCRT__y1
343 @ cdecl _yn(long double) MSVCRT__yn
344 @ cdecl abort()
345 @ cdecl abs(long) MSVCRT_abs
346 @ cdecl acos(double) MSVCRT_acos
347 @ cdecl asctime(ptr) MSVCRT_asctime
348 @ cdecl asin(double) MSVCRT_asin
349 @ cdecl atan(double) MSVCRT_atan
350 @ cdecl atan2(double double) MSVCRT_atan2
351 @ cdecl -private atexit(ptr) MSVCRT_atexit
352 @ cdecl atof(str)
353 @ cdecl atoi(str)
354 @ cdecl atol(str)
355 @ cdecl bsearch(ptr ptr long long ptr)
356 @ cdecl calloc(long long)
357 @ cdecl ceil(double) MSVCRT_ceil
358 @ cdecl clearerr(ptr) MSVCRT_clearerr
359 @ cdecl clock() MSVCRT_clock
360 @ cdecl cos(double) MSVCRT_cos
361 @ cdecl cosh(double) MSVCRT_cosh
362 @ cdecl ctime(ptr) MSVCRT_ctime
363 @ cdecl difftime(long long) MSVCRT_difftime
364 @ cdecl -ret64 div(long long) MSVCRT_div
365 @ cdecl exit(long)
366 @ cdecl exp(double) MSVCRT_exp
367 @ cdecl fabs(double) MSVCRT_fabs
368 @ cdecl fclose(ptr) MSVCRT_fclose
369 @ cdecl feof(ptr) MSVCRT_feof
370 @ cdecl ferror(ptr) MSVCRT_ferror
371 @ cdecl fflush(ptr) MSVCRT_fflush
372 @ cdecl fgetc(ptr) MSVCRT_fgetc
373 @ cdecl fgetpos(ptr ptr) MSVCRT_fgetpos
374 @ cdecl fgets(ptr long ptr) MSVCRT_fgets
375 @ cdecl fgetwc(ptr) MSVCRT_fgetwc
376 @ cdecl floor(double) MSVCRT_floor
377 @ cdecl fmod(double double) MSVCRT_fmod
378 @ cdecl fopen(str str) MSVCRT_fopen
379 @ varargs fprintf(ptr str) MSVCRT_fprintf
380 @ cdecl fputc(long ptr) MSVCRT_fputc
381 @ cdecl fputs(str ptr) MSVCRT_fputs
382 @ cdecl fputwc(long ptr) MSVCRT_fputwc
383 @ cdecl fread(ptr long long ptr) MSVCRT_fread
384 @ cdecl free(ptr)
385 @ cdecl freopen(str str ptr) MSVCRT_freopen
386 @ cdecl frexp(double ptr) MSVCRT_frexp
387 @ varargs fscanf(ptr str)
388 @ cdecl fseek(ptr long long) MSVCRT_fseek
389 @ cdecl fsetpos(ptr ptr) MSVCRT_fsetpos
390 @ cdecl ftell(ptr) MSVCRT_ftell
391 @ varargs fwprintf(ptr wstr) MSVCRT_fwprintf
392 @ cdecl fwrite(ptr long long ptr) MSVCRT_fwrite
393 @ varargs fwscanf(ptr wstr)
394 @ cdecl getc(ptr) MSVCRT_getc
395 @ cdecl getchar() MSVCRT_getchar
396 @ cdecl getenv(str)
397 @ cdecl gets(str) MSVCRT_gets
398 @ cdecl gmtime(ptr) MSVCRT_gmtime
399 @ cdecl is_wctype(long long) MSVCRT_iswctype
400 @ cdecl isalnum(long)
401 @ cdecl isalpha(long)
402 @ cdecl iscntrl(long)
403 @ cdecl isdigit(long)
404 @ cdecl isgraph(long)
405 @ cdecl isleadbyte(long)
406 @ cdecl islower(long)
407 @ cdecl isprint(long)
408 @ cdecl ispunct(long)
409 @ cdecl isspace(long)
410 @ cdecl isupper(long)
411 @ cdecl iswalnum(long) MSVCRT_iswalnum
412 @ cdecl iswalpha(long) MSVCRT_iswalpha
413 @ cdecl iswascii(long)
414 @ cdecl iswcntrl(long) MSVCRT_iswcntrl
415 @ cdecl iswctype(long long) MSVCRT_iswctype
416 @ cdecl iswdigit(long) MSVCRT_iswdigit
417 @ cdecl iswgraph(long) MSVCRT_iswgraph
418 @ cdecl iswlower(long) MSVCRT_iswlower
419 @ cdecl iswprint(long) MSVCRT_iswprint
420 @ cdecl iswpunct(long) MSVCRT_iswpunct
421 @ cdecl iswspace(long) MSVCRT_iswspace
422 @ cdecl iswupper(long) MSVCRT_iswupper
423 @ cdecl iswxdigit(long) MSVCRT_iswxdigit
424 @ cdecl isxdigit(long)
425 @ cdecl labs(long) MSVCRT_labs
426 @ cdecl ldexp(double long) MSVCRT_ldexp
427 @ cdecl -ret64 ldiv(long long) MSVCRT_ldiv
428 @ cdecl localeconv()
429 @ cdecl localtime(ptr) MSVCRT_localtime
430 @ cdecl log(double) MSVCRT_log
431 @ cdecl log10(double) MSVCRT_log10
432 @ cdecl -arch=i386,x86_64,arm,arm64 longjmp(ptr long) MSVCRT_longjmp
433 @ cdecl malloc(long)
434 @ cdecl mblen(ptr long)
435 @ cdecl mbstowcs(ptr str long)
436 @ cdecl mbtowc(ptr str long)
437 @ cdecl memchr(ptr long long)
438 @ cdecl memcmp(ptr ptr long)
439 @ cdecl memcpy(ptr ptr long)
440 @ cdecl memmove(ptr ptr long)
441 @ cdecl memset(ptr long long)
442 @ cdecl mktime(ptr) MSVCRT_mktime
443 @ cdecl modf(double ptr) MSVCRT_modf
444 @ cdecl perror(str)
445 @ cdecl pow(double double) MSVCRT_pow
446 @ varargs printf(str) MSVCRT_printf
447 @ cdecl putc(long ptr) MSVCRT_putc
448 @ cdecl putchar(long) MSVCRT_putchar
449 @ cdecl puts(str) MSVCRT_puts
450 @ cdecl qsort(ptr long long ptr)
451 @ cdecl raise(long)
452 @ cdecl rand()
453 @ cdecl realloc(ptr long)
454 @ cdecl remove(str) MSVCRT_remove
455 @ cdecl rename(str str) MSVCRT_rename
456 @ cdecl rewind(ptr) MSVCRT_rewind
457 @ varargs scanf(str)
458 @ cdecl setbuf(ptr ptr) MSVCRT_setbuf
459 @ cdecl setlocale(long str)
460 @ cdecl setvbuf(ptr str long long) MSVCRT_setvbuf
461 @ cdecl signal(long long)
462 @ cdecl sin(double) MSVCRT_sin
463 @ cdecl sinh(double) MSVCRT_sinh
464 @ varargs sprintf(ptr str) MSVCRT_sprintf
465 @ cdecl sqrt(double) MSVCRT_sqrt
466 @ cdecl srand(long)
467 @ varargs sscanf(str str)
468 @ cdecl strcat(str str)
469 @ cdecl strchr(str long)
470 @ cdecl strcmp(str str)
471 @ cdecl strcoll(str str)
472 @ cdecl strcpy(ptr str)
473 @ cdecl strcspn(str str)
474 @ cdecl strerror(long)
475 @ cdecl strftime(ptr long str ptr) MSVCRT_strftime
476 @ cdecl strlen(str)
477 @ cdecl strncat(str str long)
478 @ cdecl strncmp(str str long)
479 @ cdecl strncpy(ptr str long)
480 @ cdecl strpbrk(str str)
481 @ cdecl strrchr(str long)
482 @ cdecl strspn(str str) ntdll.strspn
483 @ cdecl strstr(str str)
484 @ cdecl strtod(str ptr)
485 @ cdecl strtok(str str)
486 @ cdecl strtol(str ptr long)
487 @ cdecl strtoul(str ptr long)
488 @ cdecl strxfrm(ptr str long)
489 @ varargs swprintf(ptr wstr) MSVCRT_swprintf
490 @ varargs swscanf(wstr wstr)
491 @ cdecl system(str)
492 @ cdecl tan(double) MSVCRT_tan
493 @ cdecl tanh(double) MSVCRT_tanh
494 @ cdecl time(ptr) MSVCRT_time
495 @ cdecl tmpfile() MSVCRT_tmpfile
496 @ cdecl tmpnam(ptr) MSVCRT_tmpnam
497 @ cdecl tolower(long)
498 @ cdecl toupper(long)
499 @ cdecl towlower(long) MSVCRT_towlower
500 @ cdecl towupper(long) MSVCRT_towupper
501 @ cdecl ungetc(long ptr) MSVCRT_ungetc
502 @ cdecl ungetwc(long ptr) MSVCRT_ungetwc
503 @ cdecl vfprintf(ptr str ptr) MSVCRT_vfprintf
504 @ cdecl vfwprintf(ptr wstr ptr) MSVCRT_vfwprintf
505 @ cdecl vprintf(str ptr) MSVCRT_vprintf
506 @ cdecl vsprintf(ptr str ptr) MSVCRT_vsprintf
507 @ cdecl vswprintf(ptr wstr ptr) MSVCRT_vswprintf
508 @ cdecl vwprintf(wstr ptr) MSVCRT_vwprintf
509 @ cdecl wcscat(wstr wstr) MSVCRT_wcscat
510 @ cdecl wcschr(wstr long) MSVCRT_wcschr
511 @ cdecl wcscmp(wstr wstr) MSVCRT_wcscmp
512 @ cdecl wcscoll(wstr wstr) MSVCRT_wcscoll
513 @ cdecl wcscpy(ptr wstr) MSVCRT_wcscpy
514 @ cdecl wcscspn(wstr wstr) ntdll.wcscspn
515 @ cdecl wcsftime(ptr long wstr ptr) MSVCRT_wcsftime
516 @ cdecl wcslen(wstr) MSVCRT_wcslen
517 @ cdecl wcsncat(wstr wstr long) ntdll.wcsncat
518 @ cdecl wcsncmp(wstr wstr long) MSVCRT_wcsncmp
519 @ cdecl wcsncpy(ptr wstr long) MSVCRT_wcsncpy
520 @ cdecl wcspbrk(wstr wstr) MSVCRT_wcspbrk
521 @ cdecl wcsrchr(wstr long) MSVCRT_wcsrchr
522 @ cdecl wcsspn(wstr wstr) ntdll.wcsspn
523 @ cdecl wcsstr(wstr wstr) MSVCRT_wcsstr
524 @ cdecl wcstod(wstr ptr) MSVCRT_wcstod
525 @ cdecl wcstok(wstr wstr) MSVCRT_wcstok
526 @ cdecl wcstol(wstr ptr long) MSVCRT_wcstol
527 @ cdecl wcstombs(ptr ptr long) MSVCRT_wcstombs
528 @ cdecl wcstoul(wstr ptr long) MSVCRT_wcstoul
529 @ cdecl wcsxfrm(ptr wstr long) MSVCRT_wcsxfrm
530 @ cdecl wctomb(ptr long) MSVCRT_wctomb
531 @ varargs wprintf(wstr) MSVCRT_wprintf
532 @ varargs wscanf(wstr)