conhost: Fix ctrl-c handling.
[wine.git] / dlls / shcore / shcore.spec
blob9ed7c87b0fe5e678e849af6cd6bcdd73183df28b
1 1 stub -noname SHCreateReadOnlySharedMemoryStream
2 @ stdcall CommandLineToArgvW(wstr ptr)
3 @ stub CreateRandomAccessStreamOnFile
4 @ stub CreateRandomAccessStreamOverStream
5 @ stub CreateStreamOverRandomAccessStream
6 @ stdcall -private DllCanUnloadNow()
7 @ stub DllGetActivationFactory
8 @ stub DllGetClassObject
9 @ stdcall GetCurrentProcessExplicitAppUserModelID(ptr)
10 @ stdcall GetDpiForMonitor(long long ptr ptr)
11 @ stub GetDpiForShellUIComponent
12 @ stdcall GetFeatureEnabledState(long long)
13 # @ stub GetFeatureVariant
14 @ stdcall GetProcessDpiAwareness(long ptr)
15 @ stdcall GetProcessReference(ptr)
16 @ stdcall GetScaleFactorForDevice(long)
17 @ stdcall GetScaleFactorForMonitor(long ptr)
18 @ stub IStream_Copy
19 @ stdcall IStream_Read(ptr ptr long) _IStream_Read
20 @ stub IStream_ReadStr
21 @ stdcall IStream_Reset(ptr)
22 @ stdcall IStream_Size(ptr ptr)
23 @ stdcall IStream_Write(ptr ptr long) _IStream_Write
24 @ stub IStream_WriteStr
25 @ stdcall IUnknown_AtomicRelease(ptr)
26 @ stdcall IUnknown_GetSite(ptr ptr ptr)
27 @ stdcall IUnknown_QueryService(ptr ptr ptr ptr)
28 @ stdcall IUnknown_Set(ptr ptr)
29 @ stdcall IUnknown_SetSite(ptr ptr)
30 @ stdcall IsOS(long)
31 # @ stub IsProcessInIsolatedContainer
32 # @ stub IsProcessInWDAGContainer
33 # @ stub RecordFeatureError
34 # @ stub RecordFeatureUsage
35 @ stub RegisterScaleChangeEvent
36 @ stub RegisterScaleChangeNotifications
37 @ stub RevokeScaleChangeNotifications
38 @ stdcall SHAnsiToAnsi(str ptr long)
39 @ stdcall SHAnsiToUnicode(str ptr long)
40 @ stdcall SHCopyKeyA(long str long long)
41 @ stdcall SHCopyKeyW(long wstr long long)
42 @ stdcall SHCreateMemStream(ptr long)
43 @ stdcall SHCreateStreamOnFileA(str long ptr)
44 @ stdcall SHCreateStreamOnFileEx(wstr long long long ptr ptr)
45 @ stdcall SHCreateStreamOnFileW(wstr long ptr)
46 @ stdcall SHCreateThread(ptr ptr long ptr)
47 @ stdcall SHCreateThreadRef(ptr ptr)
48 @ stub SHCreateThreadWithHandle
49 @ stdcall SHDeleteEmptyKeyA(long str)
50 @ stdcall SHDeleteEmptyKeyW(long wstr)
51 @ stdcall SHDeleteKeyA(long str)
52 @ stdcall SHDeleteKeyW(long wstr)
53 @ stdcall SHDeleteValueA(long str str)
54 @ stdcall SHDeleteValueW(long wstr wstr)
55 @ stdcall SHEnumKeyExA(long long str ptr)
56 @ stdcall SHEnumKeyExW(long long wstr ptr)
57 @ stdcall SHEnumValueA(long long str ptr ptr ptr ptr)
58 @ stdcall SHEnumValueW(long long wstr ptr ptr ptr ptr)
59 @ stdcall SHGetThreadRef(ptr)
60 @ stdcall SHGetValueA(long str str ptr ptr ptr)
61 @ stdcall SHGetValueW(long wstr wstr ptr ptr ptr)
62 @ stdcall SHOpenRegStream2A(long str str long)
63 @ stdcall SHOpenRegStream2W(long wstr wstr long)
64 @ stdcall SHOpenRegStreamA(long str str long)
65 @ stdcall SHOpenRegStreamW(long wstr wstr long)
66 @ stdcall SHQueryInfoKeyA(long ptr ptr ptr ptr)
67 @ stdcall SHQueryInfoKeyW(long ptr ptr ptr ptr)
68 @ stdcall SHQueryValueExA(long str ptr ptr ptr ptr)
69 @ stdcall SHQueryValueExW(long wstr ptr ptr ptr ptr)
70 @ stdcall SHRegDuplicateHKey(long)
71 @ stdcall SHRegGetIntW(ptr wstr long)
72 @ stdcall SHRegGetPathA(long str str ptr long)
73 @ stdcall SHRegGetPathW(long wstr wstr ptr long)
74 @ stdcall SHRegGetValueA(long str str long ptr ptr ptr) advapi32.RegGetValueA
75 @ stdcall SHRegGetValueW(long wstr wstr long ptr ptr ptr) advapi32.RegGetValueW
76 @ stdcall SHRegSetPathA(long str str str long)
77 @ stdcall SHRegSetPathW(long wstr wstr wstr long)
78 @ stdcall SHReleaseThreadRef()
79 @ stdcall SHSetThreadRef(ptr)
80 @ stdcall SHSetValueA(long str str long ptr long)
81 @ stdcall SHSetValueW(long wstr wstr long ptr long)
82 @ stdcall SHStrDupA(str ptr)
83 @ stdcall SHStrDupW(wstr ptr)
84 # @ stub SHTaskPoolAllowThreadReuse
85 # @ stub SHTaskPoolDoNotWaitForMoreTasks
86 # @ stub SHTaskPoolGetCurrentThreadLifetime
87 # @ stub SHTaskPoolGetUniqueContext
88 # @ stub SHTaskPoolQueueTask
89 # @ stub SHTaskPoolSetThreadReuseAllowed
90 @ stdcall SHUnicodeToAnsi(wstr ptr ptr)
91 @ stdcall SHUnicodeToUnicode(wstr ptr long)
92 @ stdcall SetCurrentProcessExplicitAppUserModelID(wstr)
93 @ stdcall SetProcessDpiAwareness(long)
94 @ stdcall SetProcessReference(ptr)
95 @ stdcall SubscribeFeatureStateChangeNotification(ptr ptr ptr)
96 @ stub UnregisterScaleChangeEvent
97 # @ stub UnsubscribeFeatureStateChangeNotification
99 100 stub -noname SHManagedCreateStreamOnFile
100 101 stub -noname SHManagedCreateFile
101 102 stub -noname SHIsEmptyStream
102 103 stub -noname MapWin32ErrorToSTG
103 104 stub -noname ModeToCreateFileFlags
104 105 stub -noname CreateTempStreamName
105 106 stub -noname StreamCopyTo
106 107 stub -noname IStream_ReadStrLong
107 108 stub -noname IStream_WriteStrLong
108 109 stub -noname SHCreateStreamOnModuleResourceW
109 110 stub -noname SHCreateStreamOnDllResourceW
110 111 stub -noname CreateWritableSharedMemoryStream
111 115 stub -noname CreateRandomAccessStreamOnFileWithOptions
112 116 stub -noname RandomAccessStreamCopyAsync
113 117 stub -noname CreateRandomAccessStreamOnPlaceholderFile
114 120 stub -noname SHRegGetCLSIDKey
115 121 stub -noname SHRegSetValue
116 122 stub SHRegGetValueFromHKCUHKLM
117 123 stub -noname SHRegGetBoolValueFromHKCUHKLM
118 124 stub -noname SHGetValueGoodBootA
119 125 stub -noname SHGetValueGoodBootW
120 126 stub -noname SHLoadRegUIStringW
121 127 stub -noname QuerySourceCreateFromKeyEx
122 130 stub -noname SHGlobalCounterGetValue
123 131 stub -noname SHGlobalCounterIncrement
124 132 stub -noname SHGlobalCounterDecrement
125 133 stub -noname SHGlobalCounterSetValue
126 140 stub -noname IUnknown_ProfferService
127 141 stub -noname IUnknown_RemoveBackReferences
128 142 stub -noname IUnknown_GetClassID
129 143 stub -noname StrRetToStrW
130 144 stub -noname StrRetToBSTR
131 145 stub -noname StrRetToBufW
132 150 stub -noname SHAnsiToUnicodeCP
133 151 stub -noname SHUnicodeToAnsiCP
134 152 stub -noname SHUnicodeToAnsiCPAlloc
135 153 stub -noname SHAnsiToUnicodeCPAlloc
136 160 stub -noname SHWaitForSendMessageThread
137 161 stub -noname SHWaitForThreadWithWakeMask
138 162 stub -noname SHQueueUserWorkItem
139 170 stub -noname PathIsNetworkPathW
140 171 stub -noname PathIsNetworkPathA
141 172 stub -noname PathBuildRootW
142 173 stub -noname PathBuildRootA
143 174 stub -noname DriveType
144 175 stub -noname IsNetDrive
145 181 stub -noname SHMapHandle
146 182 stub -noname SHAllocShared
147 183 stub -noname SHLockSharedEx
148 184 stub -noname SHLockShared
149 185 stub -noname SHGetSizeShared
150 186 stub -noname SHUnlockShared
151 187 stub -noname SHFreeShared
152 188 stub -noname SHCreateWorkerWindowW
153 189 stub -noname SHCreateOplockProvider
154 190 stub -noname SHWindowsPolicy
155 191 stub -noname SHWindowsPolicyGetValue
156 192 stub -noname IsAppCompatModeEnabled
157 193 stub -noname SHGetObjectCompatFlags
158 200 stub -noname GUIDFromStringW
159 220 stub -noname GetPhysicalDpiForDevice
160 222 stub -noname ScaleRelativePixelsForDevice
161 223 stub -noname PhysicalRectFromScaledRect
162 224 stub -noname ScaleAndMapRelativeRectForDevice
163 225 stub -noname CanOverrideScaleFactor
164 226 stub -noname GetScalingOverride
165 227 stub -noname RegisterScaleChangeSink
166 228 stub -noname SetDesignModeScaleFactor
167 229 stub -noname GetProposedScaleFactorForWindow
168 230 stub -noname SHSetWindowSubclass
169 231 stub -noname SHGetWindowSubclassData
170 232 stub -noname SHRemoveWindowSubclass
171 233 stub -noname SHDefSubclassProc
172 234 stub -noname SHRegisterClassW
173 240 stub -noname RegisterScaleChangeSinkForWindow
174 241 stub -noname ScaleAndMapRelativeRect
175 242 stub -noname RelativeRectFromPhysicalRectWithScale
176 244 stub -noname GetScaleFactorForWindow
177 245 stub -noname RegisterScaleChangeNotificationsForWindow
178 246 stub -noname RevokeScaleChangeNotificationsForWindow
179 247 stub -noname GetOverrideScaleFactorForWindow
180 248 stub -noname GetSystemScaleFactorForWindow
181 249 stub -noname UpdateScalingInfoCache
182 250 stub -noname RegisterCurrentWindowChangeListener
183 251 stub -noname RegisterWindowMonitorChangeListener
184 252 stub -noname UnregisterCurrentWindowChangeListener
185 253 stub -noname UnregisterWindowMonitorChangeListener
186 254 stub -noname AddCurrentWindowCandidate
187 255 stub -noname GetCurrentWindow
188 260 stub -noname PhysicalRectFromRelativeRectWithScales
189 261 stub -noname RelativeRectFromPhysicalRectWithScales
190 270 stub -noname SHCreateMemoryStreamOnSharedBuffer
191 280 stub -noname _CreateDirectoryHelper
192 281 stub -noname Win32CreateDirectory
193 282 stub -noname SuspendSHNotify
194 283 stub -noname ResumeSHNotify
195 284 stub -noname IsNotifySuspended
196 290 stub -noname SHCreateDirectoryExW
197 291 stub -noname SHCreateDirectoryExA
198 292 stub -noname SHCreateDirectory