Move configuration file reading to wifiradar module
[wifi-radar.git] / debian / rules
blob376a84428b3a7558713877cd2ea249513330aad5
1 #!/usr/bin/make -f
2 # -*- makefile -*-
3 # Sample debian/rules that uses debhelper.
4 # This file was originally written by Joey Hess and Craig Small.
5 # As a special exception, when this file is copied by dh-make into a
6 # dh-make output file, you may use that output file without restriction.
7 # This special exception was added by Craig Small in version 0.37 of dh-make.
9 # Uncomment this to turn on verbose mode.
10 #export DH_VERBOSE=1
12 include /usr/share/dpatch/dpatch.make
14 configure: configure-stamp
15 configure-stamp:
16 dh_testdir
17 touch configure-stamp
20 build: build-stamp
22 build-stamp: configure-stamp patch-stamp
23 dh_testdir
24 touch build-stamp
26 clean: unpatch clean1
28 clean1:
29 dh_testdir
30 dh_testroot
31 rm -f build-stamp configure-stamp
32 dh_clean
34 install: build
35 dh_testdir
36 dh_testroot
37 dh_clean -k
38 dh_installdirs
39 dh_install wifi-radar /usr/sbin/
40 dh_install pixmaps/wifi-radar.svg /usr/share/pixmaps/
41 dh_install pixmaps/wifi-radar.png /usr/share/pixmaps/
42 dh_install wifi-radar.desktop /usr/share/applications/
45 # Build architecture-independent files here.
46 binary-indep: build install
47 # We have nothing to do by default.
49 # Build architecture-dependent files here.
50 binary-arch: build install
51 dh_testdir
52 dh_testroot
53 dh_installchangelogs ChangeLog
54 dh_installdocs
55 dh_installman
56 dh_installinit -n -r --no-start -- defaults
57 dh_link
58 dh_strip
59 dh_compress
60 dh_fixperms
61 dh_installdeb
62 dh_shlibdeps
63 dh_gencontrol
64 dh_md5sums
65 dh_builddeb
67 binary: binary-indep binary-arch
68 .PHONY: build clean binary-indep binary-arch binary install configure