Merging with Ralf debianization
[viking/gosmore.git] / debian / rules
blob32af9ff4c68f41fbbf48a65851832d80421ed6e0
1 #!/usr/bin/make -f
2 # -*- makefile -*-
3 # Sample debian/rules that uses debhelper.
4 # This file was originally written by Joey Hess and Craig Small.
5 # As a special exception, when this file is copied by dh-make into a
6 # dh-make output file, you may use that output file without restriction.
7 # This special exception was added by Craig Small in version 0.37 of dh-make.
9 # Uncomment this to turn on verbose mode.
10 #export DH_VERBOSE=1
13 # These are used for cross-compiling and for saving the configure script
14 # from having to guess our platform (since we know it already)
15 DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
16 DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
19 CFLAGS = -Wall -g
21 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
22 CFLAGS += -O0
23 else
24 CFLAGS += -O2
25 endif
27 config.status: configure
28 dh_testdir
29 # Add here commands to configure the package.
30 ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info CFLAGS="$(CFLAGS)" LDFLAGS="-Wl,-z,defs"
32 configure:
33 cp -f /usr/share/misc/config.sub config.sub
34 cp -f /usr/share/misc/config.guess config.guess
36 build: build-stamp
38 build-stamp: config.status
39 dh_testdir
41 # Add here commands to compile the package.
42 $(MAKE)
43 docbook-to-man debian/viking.sgml > debian/viking.1
44 docbook-to-man debian/viking-remote.sgml > debian/viking-remote.1
46 touch $@
48 clean:
49 dh_testdir
50 dh_testroot
51 rm -f build-stamp
53 # Add here commands to clean up after the build process.
54 -$(MAKE) distclean
55 ifneq "$(wildcard /usr/share/misc/config.sub)" ""
56 cp -f /usr/share/misc/config.sub config.sub
57 endif
58 ifneq "$(wildcard /usr/share/misc/config.guess)" ""
59 cp -f /usr/share/misc/config.guess config.guess
60 endif
63 dh_clean
65 install: build
66 dh_testdir
67 dh_testroot
68 dh_clean -k
69 dh_installdirs
71 # Add here commands to install the package into debian/viking.
72 $(MAKE) DESTDIR=$(CURDIR)/debian/viking install
74 mkdir -p $(CURDIR)/debian/viking/usr/share/viking
75 convert -resize 32x32 src/icons/viking_18.png $(CURDIR)/debian/viking/usr/share/viking/viking.xpm
77 install -m 644 debian/viking.desktop \
78 $(CURDIR)/debian/viking/usr/share/applications/
81 # Build architecture-independent files here.
82 binary-indep: build install
83 # We have nothing to do by default.
85 # Build architecture-dependent files here.
86 binary-arch: build install
87 dh_testdir
88 dh_testroot
89 dh_installchangelogs ChangeLog
90 dh_installdocs
91 # dh_installexamples
92 # dh_install
93 dh_installmenu
94 # dh_installdebconf
95 # dh_installlogrotate
96 # dh_installemacsen
97 # dh_installpam
98 # dh_installmime
99 # dh_python
100 # dh_installinit
101 # dh_installcron
102 # dh_installinfo
103 dh_installman debian/viking.1 debian/viking-remote.1
104 dh_link
105 dh_strip
106 dh_compress
107 dh_desktop viking
108 dh_fixperms
109 # dh_perl
110 # dh_makeshlibs
111 dh_installdeb
112 dh_shlibdeps
113 dh_gencontrol
114 dh_md5sums
115 dh_builddeb
117 binary: binary-indep binary-arch
118 .PHONY: build clean binary-indep binary-arch binary install