Bump media-video/smplayer && x11-themes/smplayer-themes.
[underlay.git] / app-crypt / qca / qca-2.0.0.ebuild
blob177648947db6a4509b2344e50fbab010a6b32f11
1 # Copyright 1999-2007 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 EAPI=1
6 inherit eutils qt4
8 DESCRIPTION="Qt Cryptographic Architecture (QCA)"
9 HOMEPAGE="http://delta.affinix.com/qca/"
10 SRC_URI="http://delta.affinix.com/download/qca/${PV%.*}/${P}.tar.bz2"
12 LICENSE="LGPL-2"
13 SLOT="2"
14 KEYWORDS="~alpha amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc x86 ~x86-fbsd"
15 IUSE="debug doc examples"
16 RESTRICT="mirror test"
18 DEPEND="$(qt4_min_version 4.2.0)"
19 RDEPEND="${DEPEND}"
21 pkg_setup() {
22 if use debug && ! built_with_use x11-libs/qt:4 debug; then
23 eerror
24 eerror "You are trying to compile ${PN} package with USE=\"debug\""
25 eerror "while qt4 is built without this particular flag: it will"
26 eerror "not work."
27 eerror
28 eerror "Possible solutions to this problem are:"
29 eerror "a) install package ${PN} without debug USE flag"
30 eerror "b) re-emerge qt4 with debug USE flag"
31 eerror
32 die "can't emerge ${PN} with debug USE flag"
36 src_compile() {
37 local myconf=
38 if use debug; then
39 myconf="--debug"
40 else
41 myconf="--release"
44 ./configure \
45 --prefix=/usr \
46 --qtdir=/usr \
47 --includedir="/usr/include/qca2" \
48 --libdir="/usr/$(get_libdir)/qca2" \
49 ${myconf} \
50 --no-separate-debug-info \
51 --disable-tests \
52 || die "configure failed"
54 eqmake4 ${PN}.pro
55 emake || die "emake failed"
58 src_install() {
59 emake INSTALL_ROOT="${D}" install || die "emake install failed"
60 dodoc README TODO
62 cat > "${T}"/44qca2 << EOF
63 LDPATH=/usr/$(get_libdir)/qca2
64 EOF
65 doenvd "${T}"/44qca2
67 if use doc; then
68 dohtml "${S}"/apidocs/html/* || die "failed to install documentation"
71 if use examples; then
72 insinto /usr/share/doc/${PF}/
73 doins -r "${S}"/examples || die "failed to install examples"