Added new ebuilds app-crypt/qca-{cyrus-sasl,pkcs11}.
[underlay.git] / app-crypt / qca-pkcs11 / qca-pkcs11-0.1_p20070829.ebuild
blob6b2c225c74ad573a23e468dc429a368fd83f6fc3
1 # Copyright 1999-2006 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header:
5 inherit eutils qt4
7 QCA_VER="2.0-test2"
8 MY_PV="${PV/_p/-}"
9 MY_P="${PN}-${MY_PV}"
11 DESCRIPTION="PKCS#11 (smartcard) plugin for QCA"
12 HOMEPAGE="http://delta.affinix.com/qca/"
13 SRC_URI="http://delta.affinix.com/download/qca/${QCA_VER/-*/}/${QCA_VER/*-/}/${MY_P}.tar.bz2"
15 LICENSE="LGPL-2"
16 SLOT="2"
17 KEYWORDS="~amd64 ~x86"
18 IUSE="debug"
19 RESTRICT="strip"
21 RDEPEND=">=app-crypt/qca-2.0.0_rc2
22 app-crypt/qca-ossl
23 dev-libs/pkcs11-helper"
24 DEPEND="${RDEPEND}"
26 S="${WORKDIR}/${MY_P}"
28 pkg_setup() {
29 if use debug && ! built_with_use '>=app-crypt/qca-2.0.0_rc' debug; then
30 einfo
31 einfo "You are trying to compile ${PN} package with active USE=\"debug\""
32 einfo "while qca is build without this particular flag. It will not"
33 einfo "work."
34 einfo
35 einfo "Possible solutions to this problem are:"
36 einfo "a) install package ${PN} without debug USE flag"
37 einfo "b) re-emerge qca with debug USE flag"
38 einfo
39 die "can't emerge ${PN} with debug USE flag"
43 src_unpack() {
44 unpack ${A}
45 cd "${S}"
47 epatch "${FILESDIR}"/${PN}-configure.patch
50 src_compile() {
51 local myconf=
53 if use debug; then
54 myconf="--debug-and-release"
55 else
56 myconf="--release"
59 ./configure \
60 --qtdir=/usr \
61 --no-separate-debug-info \
62 ${myconf} || die "configure failed"
64 eqmake4 ${PN}.pro
65 emake || die "make failed"
68 src_install() {
69 emake INSTALL_ROOT="${D}" install || die "make install failed"
70 dodoc README