Stop using qt4_min_version() as it's deprecated.
[underlay.git] / net-im / psi / psi-9999.ebuild
blobc151169b128ef6938bba22575ff0bf9981aa3844
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 EAPI="1"
7 inherit eutils qt4 multilib subversion
9 ESVN_REPO_URI="http://svn.psi-im.org/psi/trunk"
11 DESCRIPTION="Qt4 Jabber client, with Licq-like interface"
12 HOMEPAGE="http://psi-im.org/"
13 LICENSE="GPL-2"
15 IUSE="crypt dbus debug doc kernel_linux spell ssl xscreensaver"
16 SLOT="0"
17 KEYWORDS=""
18 RESTRICT="test"
20 COMMON_DEPEND="|| ( x11-libs/qt-gui:4 =x11-libs/qt-4.3* )
21 =app-crypt/qca-2*
22 spell? ( app-text/aspell )
23 xscreensaver? ( x11-libs/libXScrnSaver )"
25 DEPEND="${COMMON_DEPEND}
26 doc? ( app-doc/doxygen )"
28 RDEPEND="${COMMON_DEPEND}
29 crypt? ( >=app-crypt/qca-gnupg-2.0.0_beta2 )
30 ssl? ( >=app-crypt/qca-ossl-2.0.0_beta2 )"
32 S="${WORKDIR}/${PN}"
34 QT4_BUILT_WITH_USE_CHECK="qt3support png"
35 QT4_OPTIONAL_BUILT_WITH_USE_CHECK="dbus"
37 src_compile() {
38 # disable growl as it is a MacOS X extension only
39 local myconf="--prefix=/usr --qtdir=/usr"
40 myconf="${myconf} --disable-growl --disable-bundled-qca"
41 use debug && myconf="${myconf} --enable-debug"
42 use dbus || myconf="${myconf} --disable-qdbus"
43 use kernel_linux || myconf="${myconf} --disable-dnotify"
44 use spell || myconf="${myconf} --disable-aspell"
45 use xscreensaver || myconf="${myconf} --disable-xss"
47 # cannot use econf because of non-standard configure script
48 ./configure ${myconf} || die "configure failed"
50 eqmake4 ${PN}.pro
52 SUBLIBS="-L/usr/${get_libdir}/qca2" emake || die "emake failed"
54 if use doc; then
55 cd doc
56 make api_public || die "make api_public failed"
60 src_install() {
61 emake INSTALL_ROOT="${D}" install || die "emake install failed"
63 # this way the docs will be installed in the standard gentoo dir
64 newdoc iconsets/roster/README README.roster
65 newdoc iconsets/system/README README.system
66 newdoc certs/README README.certs
67 dodoc README
69 if use doc; then
70 cd doc
71 dohtml -r api || die "dohtml failed"