Stop using qt4_min_version() as it's deprecated.
[underlay.git] / games-board / pokerth / pokerth-0.6.1.ebuild
blob70b6dcc69d4fb7d536d28fc558335ab67b7bdc9c
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 EAPI="1"
6 inherit eutils games qt4
8 MY_P="PokerTH-${PV}"
10 DESCRIPTION="Texas Hold'em poker game."
11 HOMEPAGE="http://www.pokerth.net/"
12 SRC_URI="mirror://sourceforge/${PN}/${MY_P}.src.tar.bz2"
13 RESTRICT="mirror"
15 LICENSE="GPL-2"
16 SLOT="0"
17 KEYWORDS="~amd64 ~x86"
18 IUSE="dedicated"
20 DEPEND=">=x11-libs/qt-4.3.2:4
21 >=dev-libs/boost-1.34.1
22 >=dev-libs/openssl-0.9.7
23 media-libs/libmikmod
24 media-libs/libsdl
25 media-libs/sdl-mixer"
26 RDEPEND="${DEPEND}"
28 S="${WORKDIR}/${MY_P}-src"
30 pkg_setup() {
31 if ! built_with_use "media-libs/sdl-mixer" mikmod ; then
32 eerror
33 eerror "media-libs/sdl-mixer has to be compiled with USE=\"mikmod\""
34 eerror
35 die "Needed USE flag for sdl-mixer not found."
38 games_pkg_setup
41 src_compile() {
42 if ! use dedicated ; then
43 sed -i -e '/SUBDIRS/s/pokerth_server\.pro//' pokerth.pro || die
46 eqmake4
47 emake || die "emake failed"
50 src_install() {
51 dogamesbin ${PN} || die "failed to install pokerth binary"
53 insinto "${GAMES_DATADIR}/${PN}"
54 doins -r data || die "doins failed"
55 dodoc ChangeLog TODO docs/{net_protocol,server_setup_howto}.txt
57 doicon ${PN}.png
58 make_desktop_entry ${PN} "PokerTH"
60 if use dedicated ; then
61 dogamesbin bin/pokerth_server || die "failed to install pokerth_server binary"
64 prepgamesdirs