app-crypt/qca-2.0.0-r1: revision bump.
[underlay.git] / app-crypt / qca / qca-2.0.0-r1.ebuild
blobaa0b48197e5daed0b0c5ec5bbff94db83a729844
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 inherit eutils multilib qt4
7 DESCRIPTION="Qt Cryptographic Architecture (QCA)"
8 HOMEPAGE="http://delta.affinix.com/qca/"
9 SRC_URI="http://delta.affinix.com/download/qca/${PV%.*}/${P}.tar.bz2"
11 LICENSE="LGPL-2"
12 SLOT="2"
13 KEYWORDS="~alpha amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc x86 ~x86-fbsd"
14 IUSE="debug doc examples"
15 RESTRICT="mirror test"
17 DEPEND="$(qt4_min_version 4.2.0)
18 !<app-crypt/qca-1.0-r3"
19 RDEPEND="${DEPEND}"
21 QT4_OPTIONAL_BUILT_WITH_USE_CHECK="debug"
23 src_unpack() {
24 unpack ${A}
25 cd "${S}"
27 epatch "${FILESDIR}"/${P}-debug-same-pkgconfig-file.patch
30 src_compile() {
31 local myconf=
32 use debug && myconf="--debug" || myconf="--release"
34 # Multilib fix
35 local _libdir=$(get_libdir)
36 sed -i -e "/pcfiles\.path/s:lib:${_libdir}:" "${S}"/configure \
37 || die "Multilib fix failed."
39 ./configure \
40 --prefix=/usr \
41 --qtdir=/usr \
42 --includedir="/usr/include/qca2" \
43 --libdir="/usr/${_libdir}/qca2" \
44 --no-separate-debug-info \
45 --disable-tests \
46 ${myconf} \
47 || die "configure failed"
49 eqmake4 ${PN}.pro
50 emake || die "emake failed"
53 src_install() {
54 emake INSTALL_ROOT="${D}" install || die "emake install failed"
55 dodoc README TODO
57 cat <<-EOF > "${T}"/44qca2
58 LDPATH=/usr/$(get_libdir)/qca2
59 EOF
60 doenvd "${T}"/44qca2
62 if use doc; then
63 dohtml "${S}"/apidocs/html/* || die "Failed to install documentation"
66 if use examples; then
67 insinto /usr/share/doc/${PF}/
68 doins -r "${S}"/examples || die "Failed to install examples"