Bump to net-im/psi-0.12_rc2.
[underlay.git] / net-im / psi / psi-0.12_rc2.ebuild
blob55032b1fd03d568334a6d8f3e4dd647779f37e4d
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 inherit eutils qt4 multilib
7 MY_P=${P/_rc/-RC}
9 DESCRIPTION="Qt4 Jabber client, with Licq-like interface"
10 HOMEPAGE="http://psi-im.org/"
11 SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
12 RESTRICT="mirror"
14 IUSE="crypt dbus debug doc kernel_linux spell ssl xscreensaver"
15 SLOT="0"
16 LICENSE="GPL-2"
17 KEYWORDS="~amd64 ~x86"
19 COMMON_DEPEND="$(qt4_min_version 4.2.0)
20 =app-crypt/qca-2*
21 spell? ( app-text/aspell )
22 xscreensaver? ( x11-libs/libXScrnSaver )"
24 DEPEND="${COMMON_DEPEND}
25 doc? ( app-doc/doxygen )"
27 RDEPEND="${COMMON_DEPEND}
28 crypt? ( >=app-crypt/qca-gnupg-2.0.0_beta2 )
29 ssl? ( >=app-crypt/qca-ossl-2.0.0_beta2 )"
31 S="${WORKDIR}/${MY_P}"
33 QT4_BUILT_WITH_USE_CHECK="qt3support png"
34 QT4_OPTIONAL_BUILT_WITH_USE_CHECK="dbus"
36 src_compile() {
37 # disable growl as it is a MacOS X extension only
38 local myconf="--prefix=/usr --qtdir=/usr"
39 myconf="${myconf} --disable-growl --disable-bundled-qca"
40 use debug && myconf="${myconf} --enable-debug"
41 use dbus || myconf="${myconf} --disable-qdbus"
42 use kernel_linux || myconf="${myconf} --disable-dnotify"
43 use spell || myconf="${myconf} --disable-aspell"
44 use xscreensaver || myconf="${myconf} --disable-xss"
46 # cannot use econf because of non-standard configure script
47 ./configure ${myconf} || die "configure failed"
49 eqmake4 ${PN}.pro
51 SUBLIBS="-L/usr/${get_libdir}/qca2" emake || die "emake failed"
53 if use doc; then
54 cd doc
55 make api_public || die "make api_public failed"
59 src_install() {
60 emake INSTALL_ROOT="${D}" install || die "emake install failed"
62 # this way the docs will be installed in the standard gentoo dir
63 newdoc iconsets/roster/README README.roster
64 newdoc iconsets/system/README README.system
65 newdoc certs/README README.certs
66 dodoc README
68 if use doc; then
69 cd doc
70 dohtml -r api || die "dohtml failed"