Fixed dependency atoms wrt split Qt 4.4 ebuilds.
[underlay.git] / media-libs / SoQt / SoQt-1.4.1-r1.ebuild
blob71a1093b1218c1dd825d502dc6c37bb2a8be841f
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/media-libs/SoQt/SoQt-1.4.1.ebuild,v 1.1 2007/10/21 13:19:51 carlo Exp $
5 EAPI=1
7 inherit flag-o-matic eutils
9 DESCRIPTION="SoQt provides the glue between Coin high-level 3D visualization library and Qt 2D GUI library"
10 SRC_URI="ftp://ftp.coin3d.org/pub/coin/src/all/${P}.tar.gz"
11 HOMEPAGE="http://www.coin3d.org/"
13 SLOT="0"
14 LICENSE="|| ( GPL-2 PEL )"
15 KEYWORDS="~amd64 ~x86"
16 IUSE="doc qt4"
18 RDEPEND="qt4? ( ||
20 ( x11-libs/qt-gui:4 x11-libs/qt-qt3support:4 )
21 <x11-libs/qt-4.4:4
24 !qt4? ( x11-libs/qt:3 )
25 >=media-libs/coin-2.4.4"
26 DEPEND="${RDEPEND}
27 doc? ( app-doc/doxygen )"
29 use qt4 && QT4_BUILT_WITH_USE_CHECK="qt3support"
31 src_compile() {
32 if use qt4; then
33 export QTDIR="/usr"
34 export PATH="/usr/bin/:${PATH}"
35 append-ldflags $(pkg-config --libs QtCore QtGui)
36 else
37 export QTDIR="/usr/qt/3"
40 filter-ldflags -Wl,--as-needed
42 econf --with-coin \
43 --disable-html-help \
44 $(use_enable doc html) \
45 htmldir="${ROOT}"usr/share/doc/${PF}/html \
46 || die "configure failed"
48 emake || die "emake failed"
51 src_install() {
52 emake DESTDIR="${D}" install || die "installation failed"
53 dodoc AUTHORS BUGS.txt ChangeLog FAQ NEWS README