Fixed dependency atoms wrt split Qt 4.4 ebuilds.
[underlay.git] / games-board / pokerth / pokerth-0.6.2.ebuild
blob252e8a60e66caed5819c5f6da06bd5ed6be20d41
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 EAPI="1"
6 inherit eutils games qt4
8 MY_P="PokerTH-${PV}"
10 DESCRIPTION="Texas Hold'em poker game."
11 HOMEPAGE="http://www.pokerth.net/"
12 SRC_URI="mirror://sourceforge/${PN}/${MY_P}-src.tar.bz2"
13 RESTRICT="mirror"
15 LICENSE="GPL-2"
16 SLOT="0"
17 KEYWORDS="~amd64 ~x86"
18 IUSE="dedicated"
20 DEPEND="|| ( x11-libs/qt-gui:4 =x11-libs/qt-4.3* )
21 >=dev-libs/boost-1.34.1
22 >=net-libs/gnutls-2.2.2
23 >=net-misc/curl-7.16
24 media-libs/libmikmod
25 media-libs/libsdl
26 media-libs/sdl-mixer
27 sys-libs/zlib"
28 RDEPEND="${DEPEND}"
30 S="${WORKDIR}/${MY_P}-src"
32 pkg_setup() {
33 if ! built_with_use "media-libs/sdl-mixer" mikmod ; then
34 eerror
35 eerror "media-libs/sdl-mixer has to be compiled with USE=\"mikmod\""
36 eerror
37 die "Needed USE flag for sdl-mixer not found."
40 games_pkg_setup
43 src_compile() {
44 if ! use dedicated ; then
45 sed -i -e '/SUBDIRS/s/pokerth_server\.pro//' pokerth.pro || die
48 eqmake4
49 emake || die "emake failed"
52 src_install() {
53 dogamesbin ${PN} || die "failed to install pokerth binary"
55 insinto "${GAMES_DATADIR}/${PN}"
56 doins -r data || die "doins failed"
57 dodoc ChangeLog TODO docs/{net_protocol,server_setup_howto}.txt
59 doicon ${PN}.png
60 make_desktop_entry ${PN} "PokerTH"
62 if use dedicated ; then
63 dogamesbin bin/pokerth_server || die "failed to install pokerth_server binary"
66 prepgamesdirs