Bump all QCA2 plugins to version 2.0.0_beta1.
[underlay.git] / app-crypt / qca-pkcs11 / qca-pkcs11-2.0.0_beta1.ebuild
blob98617ff366744c03b4de4d2e30c9bd8a4a4a357b
1 # Copyright 1999-2007 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 inherit eutils qt4
7 MY_P="${P/_/-}"
8 QCA_VER="${PV%.*}"
10 DESCRIPTION="PKCS#11 (smartcard) plugin for QCA"
11 HOMEPAGE="http://delta.affinix.com/qca/"
12 SRC_URI="http://delta.affinix.com/download/qca/${QCA_VER}/plugins/${MY_P}.tar.bz2"
13 RESTRICT="mirror"
15 LICENSE="LGPL-2"
16 SLOT="2"
17 KEYWORDS="~amd64 ~x86"
18 IUSE="debug"
20 DEPEND=">=app-crypt/qca-${QCA_VER}
21 >=dev-libs/pkcs11-helper-1.02"
22 RDEPEND="${DEPEND}"
24 S="${WORKDIR}/${MY_P}"
26 pkg_setup() {
27 if use debug && ! built_with_use ">=app-crypt/qca-${QCA_VER}" debug; then
28 eerror
29 eerror "You are trying to compile ${PN} with USE=\"debug\""
30 eerror "while qca is built without this flag. It will not work."
31 eerror
32 eerror "Possible solutions to this problem are:"
33 eerror "a) install ${PN} without debug USE flag"
34 eerror "b) re-emerge qca with debug USE flag"
35 eerror
36 die "can't emerge ${PN} with debug USE flag"
40 src_compile() {
41 # cannot use econf because of non-standard configure script
42 ./configure \
43 --qtdir=/usr \
44 $(use debug && echo "--debug" || echo "--release") \
45 --no-separate-debug-info \
46 || die "configure failed"
48 eqmake4 ${PN}.pro
49 emake || die "make failed"
52 src_install() {
53 emake INSTALL_ROOT="${D}" install || die "make install failed"
54 dodoc README