1 # Copyright 1999-2007 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
10 DESCRIPTION
="TLS, S/MIME, PKCS#12, crypto algorithms plugin for QCA"
11 HOMEPAGE
="http://delta.affinix.com/qca/"
12 SRC_URI
="http://delta.affinix.com/download/qca/${QCA_VER}/plugins/${MY_P}.tar.bz2"
17 KEYWORDS
="~amd64 ~x86"
20 DEPEND
=">=app-crypt/qca-${QCA_VER}
21 >=dev-libs/openssl-0.9.6"
24 S
="${WORKDIR}/${MY_P}"
27 if use debug
&& ! built_with_use
">=app-crypt/qca-${QCA_VER}" debug
; then
29 eerror
"You are trying to compile ${PN} with USE=\"debug\""
30 eerror
"while qca is built without this flag. It will not work."
32 eerror
"Possible solutions to this problem are:"
33 eerror
"a) install ${PN} without debug USE flag"
34 eerror
"b) re-emerge qca with debug USE flag"
36 die
"can't emerge ${PN} with debug USE flag"
41 # cannot use econf because of non-standard configure script
44 $
(use debug
&& echo "--debug" ||
echo "--release") \
45 --no-separate-debug-info \
46 || die
"configure failed"
49 emake || die
"emake failed"
53 emake INSTALL_ROOT
="${D}" install || die
"emake install failed"