Added new ebuild media-video/smplayer.
[underlay.git] / app-crypt / qca-pkcs11 / qca-pkcs11-0.1_p20070829.ebuild
blob57f19f010afddc9cc6c1e3456a21a7783fabb7d5
1 # Copyright 1999-2007 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 inherit eutils qt4
7 QCA_VER="2.0-test4"
8 MY_P="${P/_p/-}"
10 DESCRIPTION="PKCS#11 (smartcard) plugin for QCA"
11 HOMEPAGE="http://delta.affinix.com/qca/"
12 SRC_URI="http://delta.affinix.com/download/qca/${QCA_VER/-*/}/${QCA_VER/*-/}/${MY_P}.tar.bz2"
14 LICENSE="LGPL-2"
15 SLOT="2"
16 KEYWORDS="~amd64 ~x86"
17 IUSE="debug"
19 RDEPEND="=app-crypt/qca-2*
20 app-crypt/qca-ossl
21 dev-libs/pkcs11-helper"
22 DEPEND="${RDEPEND}"
24 S="${WORKDIR}/${MY_P}"
26 pkg_setup() {
27 if use debug && ! built_with_use '=app-crypt/qca-2*' debug; then
28 einfo
29 einfo "You are trying to compile ${PN} package with active USE=\"debug\""
30 einfo "while qca is build without this particular flag. It will not"
31 einfo "work."
32 einfo
33 einfo "Possible solutions to this problem are:"
34 einfo "a) install package ${PN} without debug USE flag"
35 einfo "b) re-emerge qca with debug USE flag"
36 einfo
37 die "can't emerge ${PN} with debug USE flag"
41 src_compile() {
42 local myconf="--release"
43 use debug && myconf="--debug"
45 ./configure \
46 --qtdir=/usr \
47 --no-separate-debug-info \
48 ${myconf} || die "configure failed"
50 eqmake4 ${PN}.pro
51 emake || die "make failed"
54 src_install() {
55 emake INSTALL_ROOT="${D}" install || die "make install failed"
56 dodoc README