Added new ebuild media-video/smplayer.
[underlay.git] / app-crypt / qca-logger / qca-logger-0.1_p20070829.ebuild
blob8660f9eb2802025586505e2e1cc9b516a37afe93
1 # Copyright 1999-2007 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 inherit eutils qt4
7 QCA_VER="2.0-test4"
8 MY_P="${P/_p/-}"
10 DESCRIPTION="Logger plugin for QCA"
11 HOMEPAGE="http://delta.affinix.com/qca/"
12 SRC_URI="http://delta.affinix.com/download/qca/${QCA_VER/-*/}/${QCA_VER/*-/}/${MY_P}.tar.bz2"
14 LICENSE="LGPL-2"
15 SLOT="2"
16 KEYWORDS="~amd64 ~x86"
17 IUSE="debug"
19 RDEPEND="=app-crypt/qca-2*"
20 DEPEND="${RDEPEND}"
22 S="${WORKDIR}/${MY_P}"
24 pkg_setup() {
25 if use debug && ! built_with_use '=app-crypt/qca-2*' debug; then
26 einfo
27 einfo "You are trying to compile ${PN} package with active USE=\"debug\""
28 einfo "while qca is build without this particular flag. It will not"
29 einfo "work."
30 einfo
31 einfo "Possible solutions to this problem are:"
32 einfo "a) install package ${PN} without debug USE flag"
33 einfo "b) re-emerge qca with debug USE flag"
34 einfo
35 die "can't emerge ${PN} with debug USE flag"
39 src_compile() {
40 local myconf="--release"
41 use debug && myconf="--debug"
43 ./configure \
44 --qtdir=/usr \
45 --no-separate-debug-info \
46 ${myconf} || die "configure failed"
48 eqmake4 ${PN}.pro
49 emake || die "make failed"
52 src_install() {
53 emake INSTALL_ROOT="${D}" install || die "make install failed"
54 dodoc README