Fixed building of qca and qca-plugins with USE="debug".
[underlay.git] / app-crypt / qca-logger / qca-logger-0.1_p20070829.ebuild
blob431229e2dba77de93366e264ea981948307e369e
1 # Copyright 1999-2007 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header:
5 inherit eutils qt4
7 QCA_VER="2.0-test3"
8 MY_PV="${PV/_p/-}"
9 MY_P="${PN}-${MY_PV}"
11 DESCRIPTION="Logger plugin for QCA"
12 HOMEPAGE="http://delta.affinix.com/qca/"
13 SRC_URI="http://delta.affinix.com/download/qca/${QCA_VER/-*/}/${QCA_VER/*-/}/${MY_P}.tar.bz2"
15 LICENSE="LGPL-2"
16 SLOT="2"
17 KEYWORDS="~amd64 ~x86"
18 IUSE="debug"
20 RDEPEND=">=app-crypt/qca-2.0.0_rc2"
21 DEPEND="${RDEPEND}"
23 S="${WORKDIR}/${MY_P}"
25 pkg_setup() {
26 if use debug && ! built_with_use '>=app-crypt/qca-2.0.0_rc' debug; then
27 einfo
28 einfo "You are trying to compile ${PN} package with active USE=\"debug\""
29 einfo "while qca is build without this particular flag. It will not"
30 einfo "work."
31 einfo
32 einfo "Possible solutions to this problem are:"
33 einfo "a) install package ${PN} without debug USE flag"
34 einfo "b) re-emerge qca with debug USE flag"
35 einfo
36 die "can't emerge ${PN} with debug USE flag"
40 src_compile() {
41 local myconf="--release"
42 use debug && myconf="--debug"
44 ./configure \
45 --qtdir=/usr \
46 --no-separate-debug-info \
47 ${myconf} || die "configure failed"
49 eqmake4 ${PN}.pro
50 emake || die "make failed"
53 src_install() {
54 emake INSTALL_ROOT="${D}" install || die "make install failed"
55 dodoc README