Bump to QCA 2.0.1 final.
[underlay.git] / net-wireless / madwifi-ng / madwifi-ng-0.9.4_pre20070801.ebuild
blob8bc2a4d2d2bbe2841f915fb8bb9b2930d4b1a881
1 # Copyright 1999-2007 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 inherit linux-mod
7 MY_REV="2628"
8 MY_P=${PN}-r${MY_REV}-${PV##*_pre}
9 S=${WORKDIR}/${MY_P}
11 DESCRIPTION="Next Generation driver for Atheros based IEEE 802.11a/b/g wireless LAN cards"
12 HOMEPAGE="http://www.madwifi.org/"
13 SRC_URI="http://snapshots.madwifi.org/${PN}/${MY_P}.tar.gz"
14 RESTRICT="mirror"
16 LICENSE="atheros-hal
17 || ( BSD GPL-2 )"
18 SLOT="0"
19 KEYWORDS="~amd64 ~x86"
20 IUSE=""
22 DEPEND="app-arch/sharutils"
23 RDEPEND="!net-wireless/madwifi-old
24 net-wireless/wireless-tools
25 ~net-wireless/madwifi-ng-tools-${PV}"
27 CONFIG_CHECK="CRYPTO WIRELESS_EXT SYSCTL"
28 ERROR_CRYPTO="${P} requires Cryptographic API support (CONFIG_CRYPTO)."
29 ERROR_NET_RADIO="${P} requires CONFIG_WIRELESS_EXT selected by Wireless LAN drivers (non-hamradio) & Wireless Extensions"
30 ERROR_SYSCTL="${P} requires Sysctl support (CONFIG_SYSCTL)."
31 BUILD_TARGETS="all"
32 MODULESD_ATH_PCI_DOCS="README"
34 pkg_setup() {
35 linux-mod_pkg_setup
37 MODULE_NAMES="ath_hal(net:${S}/ath_hal)
38 wlan(net:${S}/net80211)
39 wlan_acl(net:${S}/net80211)
40 wlan_ccmp(net:${S}/net80211)
41 wlan_tkip(net:${S}/net80211)
42 wlan_wep(net:${S}/net80211)
43 wlan_xauth(net:${S}/net80211)
44 wlan_scan_sta(net:${S}/net80211)
45 wlan_scan_ap(net:${S}/net80211)
46 ath_rate_amrr(net:${S}/ath_rate/amrr)
47 ath_rate_minstrel(net:${S}/ath_rate/minstrel)
48 ath_rate_onoe(net:${S}/ath_rate/onoe)
49 ath_rate_sample(net:${S}/ath_rate/sample)
50 ath_pci(net:${S}/ath)"
52 BUILD_PARAMS="KERNELPATH=${KV_OUT_DIR}"
55 src_unpack() {
56 unpack ${A}
57 cd ${S}
59 epatch ${FILESDIR}/${PN}-0.9.3-uudecode-gcda-fix.patch
61 for dir in ath ath_hal net80211 ath_rate ath_rate/amrr ath_rate/minstrel ath_rate/onoe ath_rate/sample; do
62 convert_to_m ${S}/${dir}/Makefile
63 done
65 local version=$(sed -e '/^Revision: */!d;s///;q' SNAPSHOT)
66 echo "#define SVNVERSION \"svn r${version}\"" > svnversion.h
69 src_install() {
70 linux-mod_src_install
72 dodoc README THANKS
75 pkg_postinst() {
76 local moddir="${ROOT}/lib/modules/${KV_FULL}/net/"
78 linux-mod_pkg_postinst
80 einfo
81 einfo "Interfaces (athX) are now automatically created upon loading the ath_pci"
82 einfo "module."
83 einfo
84 einfo "The type of the created interface can be controlled through the 'autocreate'"
85 einfo "module parameter."
86 einfo
87 einfo "As of net-wireless/madwifi-ng-0.9.3 rate control module selection is done at"
88 einfo "module load time via the 'ratectl' module parameter. USE flags amrr and onoe"
89 einfo "no longer serve any purpose."